[PATCH 1/4] staging: unisys: visorbus: 'unsigned' --> 'unsigned int'

2016-04-04 Thread David Kershner
From: Tim Sell Fix as recommended by checkpatch. Signed-off-by: Tim Sell Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorchipset.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

[PATCH 3/3] staging: unisys: visorbus: make bus_epilog match device_epilog

2016-04-04 Thread David Kershner
The paths in bus_epilog should match device_epilog. Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorchipset.c | 19 +++ 1 file changed, 3 insertions(+), 16 deletions(-) diff --git a/drivers/staging/unisys/visorbus/visorchipset.c

[PATCH 0/3] staging: unisys: clean gotos in visorchipset

2016-04-04 Thread David Kershner
This series cleans up some more gotos in the the visorbus driver. David Kershner (3): staging: unisys: visorbus: visorchipset_init clean up gotos staging: unisys: visorbus: device_epilog: clean up gotos staging: unisys: visorbus: make bus_epilog match device_epilog

[PATCH] staging: unisys: visorchannel: remove redundant member size

2016-04-04 Thread David Kershner
From: David Binder Removes size member from the visorchannel struct, since it was a duplicate of the nbytes member. Signed-off-by: David Binder Signed-off-by: David Kershner ---

[PATCH 3/4] staging: unisys: visornic: CHECK: Alignment should match open parenthesis

2016-04-04 Thread David Kershner
From: Tim Sell Fix 'CHECK: Alignment should match open parenthesis' as recommended by checkpatch. Signed-off-by: Tim Sell Signed-off-by: David Kershner --- drivers/staging/unisys/visornic/visornic_main.c | 13

[PATCH 0/4] staging: unisys: fix checkpatch warnings

2016-04-04 Thread David Kershner
This series fixes checkpatch warnings in the unisys visorbus and visornic drivers. Tim Sell (4): staging: unisys: visorbus: 'unsigned' --> 'unsigned int' staging: unisys: visorbus: CHECK: Alignment should match open parenthesis staging: unisys: visornic: CHECK: Alignment should match

[PATCH 2/4] staging: unisys: visorbus: CHECK: Alignment should match open parenthesis

2016-04-04 Thread David Kershner
From: Tim Sell Fix 'CHECK: Alignment should match open parenthesis' as recommended by checkpatch. Signed-off-by: Tim Sell Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorchipset.c | 80

[PATCH 1/3] staging: unisys: visorbus: visorchipset_init clean up gotos

2016-04-04 Thread David Kershner
Several error paths were not logging a message to s-Par during failure. Error paths in visorchipset_init() were corrected so that they now all do proper clean-ups. This made it necessary to move the function visorchipset_file_cleanup() above visorchipset_init so it can be referenced.

[PATCH 2/3] staging: unisys: visorbus: device_epilog: clean up gotos

2016-04-04 Thread David Kershner
The away flag is ambiguous, rename it to out and appropriately call the correct goto. Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorchipset.c | 36 ++ 1 file changed, 13 insertions(+), 23 deletions(-) diff --git

[PATCH 4/4] staging: unisys: visornic: convert BUG_ON to dev_err() message

2016-04-04 Thread David Kershner
From: Tim Sell The caller of visor_copy_fragsinfo_from_skb() is prepared to log a dev_err() message if it fails (by returning a negative value), so we now just fail in the one occasion where visor_copy_fragsinfo_from_skb() was doing a BUG_ON. There was also a problem

[PATCH 4/4] staging: skein: cleanup: align parentheses

2016-04-04 Thread Manu Kumar
Aligned parentheses to conform to the coding style. Signed-off-by: Manu Kumar --- drivers/staging/skein/skein_base.c| 14 +++--- drivers/staging/skein/skein_generic.c | 6 +++--- 2 files changed, 10 insertions(+), 10 deletions(-) diff --git

[PATCH 3/4] staging: skein: cleanup: remove white space after casts

2016-04-04 Thread Manu Kumar
Clean skein files so that there is no white space after casts. Signed-off-by: Manu Kumar --- drivers/staging/skein/skein_api.c | 2 +- drivers/staging/skein/skein_base.c | 12 ++-- drivers/staging/skein/skein_base.h | 12 ++--

[PATCH 2/4] staging: skein: cleanup: fixed blank lines

2016-04-04 Thread Manu Kumar
Added a blank line between functions in skein_block.c and removed unneeded blank lines in skein_api.c and threefish_block.c Signed-off-by: Manu Kumar --- drivers/staging/skein/skein_api.c | 1 - drivers/staging/skein/skein_block.c | 4 +++-

[PATCH] staging: rtl8712: use container_of() instead of LIST_CONTAINOR()

2016-04-04 Thread Geliang Tang
This patch drops the local definition of LIST_CONTAINOR(), and uses container_of() instead of it. Signed-off-by: Geliang Tang --- drivers/staging/rtl8712/osdep_service.h | 3 --- drivers/staging/rtl8712/rtl8712_recv.c| 10 +-

[PATCH 05/18] staging: lustre: libcfs: make D_HSM a unique value

2016-04-04 Thread James Simmons
From: Jinshan Xiong Redefine D_HSM. It was defined to D_TRACE. Signed-off-by: Jinshan Xiong Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-3647 Reviewed-on: http://review.whamcloud.com/7243 Reviewed-by: John L. Hammond

[PATCH 14/18] staging: lustre: fix 'NULL pointer dereference' errors

2016-04-04 Thread James Simmons
From: Sebastien Buisson Fix 'NULL pointer dereference' defects found by Coverity version 6.5.0: Dereference after null check (FORWARD_NULL) For instance, Passing null pointer to a function which dereferences it. Dereference before null check (REVERSE_INULL) Null-checking

[PATCH 11/18] staging: lustre: llite: Delaying creation of client side proc entries.

2016-04-04 Thread James Simmons
From: Gaurav Mahajan In client_common_fill_super() proc entries are created before before cl_sb_init() and therefore lu_site is not allocated resulting in client crash when tried reading lu_site stats. Delaying creation of proc entries after creation of all required data

[PATCH 15/18] staging: lustre: llite: cancel open lock before closing file

2016-04-04 Thread James Simmons
From: Jinshan Xiong In error handling path of ll_lease_open(), och has already been freed in ll_close_inode_openhandle() so the sequence of cancel open lock and close open handle need adjusting. Signed-off-by: Jinshan Xiong Intel-bug-id:

[PATCH 02/18] staging: lustre: llite: use 64bits flags in ll_lov_setea()

2016-04-04 Thread James Simmons
From: Niu Yawei In ll_lov_setea(), setting MDS_OPEN_HAS_OBJS to an int flags will result in the flags being overflowed. Signed-off-by: Niu Yawei Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-3744 Reviewed-on: http://review.whamcloud.com/7312

[PATCH 03/18] staging: lustre: libcfs: remove userland comments in libcfs_debug.h

2016-04-04 Thread James Simmons
From: Jinshan Xiong Remove comments about userland use. Signed-off-by: Jinshan Xiong Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-3647 Reviewed-on: http://review.whamcloud.com/7243 Reviewed-by: John L. Hammond

[PATCH 18/18] staging: lustre: osc: Lustre returns EINTR from writes when SA_RESTART is set

2016-04-04 Thread James Simmons
When Lustre is in a read or write system call and receives a SIGALRM, it will return EINTR if interrupted in osc_enter_cache. This prevents the system call from being restarted if SA_RESTART is set in the handler. This patch changes behavior in this location to return ERESTARTSYS when a signal

[PATCH 04/18] staging: lustre: libcfs: create array of debug names

2016-04-04 Thread James Simmons
From: Jinshan Xiong Instead of a using a growing case statement to handle more debugging options create a array to map debug flags to string names. Signed-off-by: Jinshan Xiong Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-3647

[PATCH 07/18] staging: lustre: hsm: rename hai_zero() HSM function

2016-04-04 Thread James Simmons
From: JC Lafoucriere rename hai_zero() to hai_first(). Use a better name for hai helper Signed-off-by: JC Lafoucriere Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-3709 Reviewed-on: http://review.whamcloud.com/7254

[PATCH 08/18] staging: lustre: hsm: copy start error should set HP_FLAG_COMPLETED

2016-04-04 Thread James Simmons
From: Aurelien Degremont If an error occurs when initializing a HSM request, in ll_ioc_copy_start(), the PROGRESS message, sent to coordinator, should carry the error code but also HP_FLAG_COMPLETED to mark the request as finished (with error). If not, the Coordinator

[PATCH 00/18] fill in missing patches present in 2.4.92 version

2016-04-04 Thread James Simmons
After the lustre client code was merged patches continued to land but gaps did happen were several patches were missed. This batch of patches are bug fixes that happened after the upstream client merger and before the creation of lustre version 2.4.92 tag. Aurelien Degremont (1): staging:

[PATCH 17/18] staging: lustre: fix 'no effect' errors

2016-04-04 Thread James Simmons
From: Sebastien Buisson Fix 'no effect' issues found by Coverity version 6.5.1: Unsigned compared against 0 (NO_EFFECT) This greater-than-or-equal-to-zero comparison of an unsigned value is always true. Remove useless cast. Signed-off-by: Sebastien Buisson

[PATCH 16/18] staging: lustre: hsm: Add support to drop all pages for ll_data_version

2016-04-04 Thread James Simmons
From: Jinshan Xiong This will be used by HSM release to get data version and drop all caching pages from all clients, before sending IT_RELEASE close REQ to MDT. Signed-off-by: Jinshan Xiong Intel-bug-id:

[PATCH 06/18] staging: lustre: hsm: Fix lu_ref for lease handle

2016-04-04 Thread James Simmons
From: Jinshan Xiong The lu_ref was not being decremented when releasing the lease handle. Signed-off-by: Jinshan Xiong Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-3647 Reviewed-on: http://review.whamcloud.com/7243 Reviewed-by: John L.

[PATCH 10/18] staging: lustre: llite: reset writeback index in ll_writepages

2016-04-04 Thread James Simmons
From: Jinshan Xiong Otherwise after one round the writeback index will become beyond the file size and ->writepages() turns into an empty operation. Also, a safety guard is added to limit the wait time for grant to 10 minutes(take recovery into consideration) at maximum

[PATCH 09/18] staging: lustre: lov: Get the correct address of lmm_objects

2016-04-04 Thread James Simmons
From: Swapnil Pimpale The introduction of lmm_layout_gen makes the assumption that lmm_objects is present after lmm_stripe_count incorrect. Fixed this to get the correct address of lmm_objects when lmmk is cast to lov_mds_md_v1. Signed-off-by: Swapnil Pimpale

[PATCH 13/18] staging: lustre: hsm: Add CLF_RENAME_LAST flag

2016-04-04 Thread James Simmons
From: JC Lafoucriere Create a special flag for the last rename event. Signed-off-by: JC Lafoucriere Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-3718 Reviewed-on: http://review.whamcloud.com/7260 Reviewed-by:

[PATCH 01/18] staging: lustre: ldlm: fix 'deadcode' errors

2016-04-04 Thread James Simmons
From: Sebastien Buisson Fix 'deadcode' issues found by Coverity version 6.5.1: Logically dead code (DEADCODE) Execution cannot reach this statement. Signed-off-by: Sebastien Buisson Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-3097 Reviewed-on:

[PATCH 12/18] staging: lustre: mdc: document mdc_rpc_lock

2016-04-04 Thread James Simmons
From: Ned Bass As this lock can be a bottleneck, clarifying why it is needed may be helpful to those working on client performance. Signed-off-by: Ned Bass Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-3443 Reviewed-on: http://review.whamcloud.com/6593

[PATCH 1/4] staging: skein: cleanup: add operator white space

2016-04-04 Thread Manu Kumar
Added white space between operators and operands. Because this sometimes maxed out the column width, some expressions were broken up into multiple lines, and comments were moved appropriately. Signed-off-by: Manu Kumar --- drivers/staging/skein/skein_base.c| 66

Re: [PATCH 4/7] Trivial: Fixed cast and operator whitespace in

2016-04-04 Thread Greg KH
On Mon, Apr 04, 2016 at 03:09:26PM -0700, Manu Kumar wrote: > skein_block.c > Reply-To: Really? Please be more careful. greg k-h ___ devel mailing list de...@linuxdriverproject.org

Re: [PATCH 1/7] Trivial: Fixed cast and operator white space in skein_api.c

2016-04-04 Thread Greg KH
On Mon, Apr 04, 2016 at 02:57:01PM -0700, Greg KH wrote: > On Mon, Apr 04, 2016 at 02:52:28PM -0700, Manu Kumar wrote: > > Signed-off-by: Manu Kumar > > I can't take patches without any changelog text, sorry. > > Also, only do one-thing-per-patch. Same goes for this whole

Re: [PATCH 1/7] Trivial: Fixed cast and operator white space in skein_api.c

2016-04-04 Thread Greg KH
On Mon, Apr 04, 2016 at 02:52:28PM -0700, Manu Kumar wrote: > Signed-off-by: Manu Kumar I can't take patches without any changelog text, sorry. Also, only do one-thing-per-patch. thanks, greg k-h ___ devel mailing list

[PATCH 6/7] Trivial: Fixed operator whitespace in threefish_api.h

2016-04-04 Thread Manu Kumar
Signed-off-by: Manu Kumar --- drivers/staging/skein/threefish_api.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/skein/threefish_api.h b/drivers/staging/skein/threefish_api.h index 8e0a0b7..615e467 100644 ---

[PATCH 5/7] Trivial: Fixed parentheses alignment in skein_generic.c

2016-04-04 Thread Manu Kumar
Signed-off-by: Manu Kumar --- drivers/staging/skein/skein_generic.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/skein/skein_generic.c b/drivers/staging/skein/skein_generic.c index e29b9ab..16cbfbf 100644 ---

[PATCH 4/7] Trivial: Fixed cast and operator whitespace in

2016-04-04 Thread Manu Kumar
skein_block.c Reply-To: Signed-off-by: Manu Kumar --- drivers/staging/skein/skein_block.c | 68 - 1 file changed, 36 insertions(+), 32 deletions(-) diff --git a/drivers/staging/skein/skein_block.c b/drivers/staging/skein/skein_block.c index

[PATCH 2/7] Trivial: Fixed cast and operator whitespace in skein_base.c

2016-04-04 Thread Manu Kumar
Signed-off-by: Manu Kumar --- drivers/staging/skein/skein_base.c | 98 +++--- 1 file changed, 49 insertions(+), 49 deletions(-) diff --git a/drivers/staging/skein/skein_base.c b/drivers/staging/skein/skein_base.c index 25a01ca..3d9c632 100644 ---

[PATCH 1/7] Trivial: Fixed cast and operator white space in skein_api.c

2016-04-04 Thread Manu Kumar
Signed-off-by: Manu Kumar --- drivers/staging/skein/skein_api.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/skein/skein_api.c b/drivers/staging/skein/skein_api.c index 36f849f..cab26e7 100644 --- a/drivers/staging/skein/skein_api.c +++

RE: Staging: unisys/verisonic: Correct double unlock

2016-04-04 Thread Sell, Timothy C
> -Original Message- > From: Neil Horman [mailto:nhor...@redhat.com] > Sent: Monday, April 04, 2016 10:35 AM > To: Sell, Timothy C > Cc: Iban Rodriguez; Kershner, David A; Greg Kroah-Hartman; Benjamin > Romer; *S-Par-Maintainer; de...@driverdev.osuosl.org; linux- > ker...@vger.kernel.org >

[PATCH] Staging: android: timed_gpio: fixed bare use of 'unsigned'

2016-04-04 Thread Shyam Saini
'unsigned int gpio' is added in place of 'unsigned gpio' Signed-off-by: Shyam Saini --- drivers/staging/android/timed_gpio.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/android/timed_gpio.c b/drivers/staging/android/timed_gpio.c

Re: Staging: unisys/verisonic: Correct double unlock

2016-04-04 Thread Neil Horman
On Sat, Apr 02, 2016 at 11:20:14PM +, Sell, Timothy C wrote: > > -Original Message- > > From: Iban Rodriguez [mailto:iban.rodrig...@ono.com] > > Sent: Saturday, April 02, 2016 1:47 PM > > To: Kershner, David A; Greg Kroah-Hartman; Benjamin Romer; Sell, Timothy > > C; Neil Horman > >

Re: [PATCH 0/6] Drivers: hv: vmbus: Cleanup and mmio management.

2016-04-04 Thread Vitaly Kuznetsov
"K. Y. Srinivasan" writes: > Cleanup and mmio management. Also included is a patch > to fix an issue in KVP. > > Jake Oshins (5): > hv: Make a function to free mmio regions through vmbus > hv: Lock access to hyperv_mmio resource tree > hv: Use new vmbus_mmio_free() from

[PATCH 1/8] staging: wilc1000: rename goto label in handle_cfg_param

2016-04-04 Thread Chaehyun Lim
This patch changes goto label from ERRORHANDLER to unlock. unlock is a more meaningful name than ERRORHANDLER. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 38 +++ 1 file changed, 19 insertions(+), 19

[PATCH 8/8] staging: wilc1000: rename pu8Buffer in handle_scan

2016-04-04 Thread Chaehyun Lim
This patch renames pu8Buffer to buffer to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c

[PATCH 6/8] staging: wilc1000: rename strWIDList in handle_scan

2016-04-04 Thread Chaehyun Lim
This patch renames strWIDList to wid_list to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 48 +++ 1 file changed, 24 insertions(+), 24 deletions(-) diff --git

[PATCH 7/8] staging: wilc1000: rename u32WidsCount in handle_scan

2016-04-04 Thread Chaehyun Lim
This patch renames u32WidsCount to index to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 58 +++ 1 file changed, 29 insertions(+), 29 deletions(-) diff --git

[PATCH 2/8] staging: wilc1000: move Handle_ScanDone function declaration

2016-04-04 Thread Chaehyun Lim
Handle_ScanDone function declaration is moved to front of host_interface.c file. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c

[PATCH 3/8] staging: wilc1000: remove block scope braces and fix indentation

2016-04-04 Thread Chaehyun Lim
This patch removes unnecessary block scope braces and fix indentation of the codes. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 12 +--- 1 file changed, 5 insertions(+), 7 deletions(-) diff --git

[PATCH 4/8] staging: wilc1000: rename Handle_Scan

2016-04-04 Thread Chaehyun Lim
This patch renames Handle_Scan to handle_scan to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.c

[PATCH 5/8] staging: wilc1000: rename pstrHostIFscanAttr in handle_scan

2016-04-04 Thread Chaehyun Lim
This patch renames pstrHostIFscanAttr to scan_info to avoid camelcase. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/host_interface.c | 55 +++ 1 file changed, 27 insertions(+), 28 deletions(-) diff --git

Re: [PATCH] android,lowmemorykiller: Don't abuse TIF_MEMDIE.

2016-04-04 Thread Tetsuo Handa
Greg KH wrote: > On Mon, Mar 21, 2016 at 08:00:49PM +0900, Tetsuo Handa wrote: > > Greg Kroah-Hartman wrote: > > > On Tue, Mar 08, 2016 at 03:18:59PM +0100, Michal Hocko wrote: > > > > On Tue 08-03-16 20:01:32, Tetsuo Handa wrote: > > > > > Currently, lowmemorykiller (LMK) is using TIF_MEMDIE for

[PATCH 2/2] staging: dgnc: remove blank line

2016-04-04 Thread Daeseok Youn
fix checkpatch.pl warning: Blank lines aren't necessary after an open brace '{' Signed-off-by: Daeseok Youn --- drivers/staging/dgnc/dgnc_neo.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/dgnc/dgnc_neo.c b/drivers/staging/dgnc/dgnc_neo.c index

[PATCH 1/2] staging: dgnc: remove parenthesis around the CONST |

2016-04-04 Thread Daeseok Youn
remove parenthesis around the CONST | CONST. Signed-off-by: Daeseok Youn --- drivers/staging/dgnc/dgnc_cls.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/dgnc/dgnc_cls.c b/drivers/staging/dgnc/dgnc_cls.c index 5e46ac8..46c050c