[PATCH v4 2/3] staging: wilc1000: Replace kthread with workqueue for host interface

2016-06-22 Thread Binoy Jayan
Deconstruct the kthread / message_queue logic, replacing it with create_singlethread_workqueue() / queue_work() setup, by adding a 'struct work_struct' to 'struct host_if_msg'. The current kthread hostIFthread() is converted to a work queue helper with the name 'host_if_work'. Signed-off-by:

[PATCH v4 3/3] staging: wilc1000: Change interface wilc_mq_send to wilc_enqueue_cmd

2016-06-22 Thread Binoy Jayan
Replace the interface 'wilc_mq_send' with 'wilc_enqueue_cmd' and remove the now unused structures 'message' and 'message_queue'. Restructure switch statement in the work queue helper function host_if_work and remove unwanted indentation. Signed-off-by: Binoy Jayan ---

[PATCH v4 0/3] *** staging: wilc1000: Replace semaphores ***

2016-06-22 Thread Binoy Jayan
Hi, Thank you Arnd for patiently reviewing this patch series multiple times and apologies to everyone for spamming you inboxes with a patch (v3) that does not even build. It was due to an uncommited change in my git repo before generating the patch. It is corrected in v4. This patchset [v4] is

[PATCH v4 1/3] staging: wilc1000: message_queue: Move code to host interface

2016-06-22 Thread Binoy Jayan
Move the contents of wilc_msgqueue.c and wilc_msgqueue.h into host_interface.c, remove 'wilc_msgqueue.c' and 'wilc_msgqueue.h'. This is done so as to restructure the implementation of the kthread 'hostIFthread' using a work queue. Signed-off-by: Binoy Jayan ---

Re: [PATCH] staging: wilc1000: fix return value check in wlan_initialize_threads()

2016-06-22 Thread Julian Calaby
Hi All, On Sat, Jun 18, 2016 at 3:34 AM, wrote: > From: Wei Yongjun > > In case of error, the function kthread_run() returns ERR_PTR() > and never returns NULL. The NULL test in the return value check > should be replaced with IS_ERR(). > >

Re: [PATCH] staging: wilc1000: fix error handling in wilc_debugfs_init()

2016-06-22 Thread Julian Calaby
Hi All, On Wed, Jun 22, 2016 at 10:39 PM, Luis de Bethencourt wrote: > The common format to check if a function returned an error pointer is to > use PTR_ERR(). Instead of ERR_PTR() which is used to return said errors. > > Also, if there was an error returning -EINVAL

Re: [PATCH 7/7] staging/android: remove sync framework TODO

2016-06-22 Thread Emil Velikov
Hi Gustavo, On 20 June 2016 at 16:53, Gustavo Padovan wrote: > - - port libsync tests to kselftest I believe the tests haven't landed yet right, so this should stay right ? -Emil ___ devel mailing list

[PATCH 11/11] staging: fsl-mc: convert mc command build/parse to use C structs

2016-06-22 Thread Stuart Yoder
From: Ioana Radulescu The layer abstracting the building of commands and extracting responses is currently based on macros that shift and mask the command fields and requires exposing offset/size values as macro parameters and makes the code harder to read. For

[PATCH 04/11] staging: fsl-mc: add support for device table matching

2016-06-22 Thread Stuart Yoder
Move the definition of fsl_mc_device_id to its proper location in mod_devicetable.h, and add fsl-mc bus support to devicetable-offsets.c and file2alias.c to enable device table matching. With this patch udev based module loading of fsl-mc drivers is supported. Signed-off-by: Stuart Yoder

[PATCH 00/11] staging: fsl-mc: module loading support, fixes, and cleanup

2016-06-22 Thread Stuart Yoder
This patch series does some cleanup and further sets the stage for additional fsl-mc device drivers. -Patches 1-4 add missing fsl-mc support for modalias and udev-based module loading of drivers. -Patch 5 exports a function some drivers rely on. -Patch 6 makes a needed helper function visible to

[PATCH 10/11] staging: fsl-mc: properly set hwirq in msi set_desc

2016-06-22 Thread Stuart Yoder
For an MSI domain the hwirq is an arbitrary but unique id to identify an interrupt. Previously the hwirq was set to the MSI index of the interrupt, but that only works if there is one DPRC. Additional DPRCs require an expanded namespace. Use both the ICID (which is unique per DPRC) and the MSI

[PATCH 08/11] staging: fsl-mc: dprc: add missing irq free

2016-06-22 Thread Stuart Yoder
add missing free of the Linux irq when tearing down interrupts Signed-off-by: Stuart Yoder --- drivers/staging/fsl-mc/bus/dprc-driver.c | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/staging/fsl-mc/bus/dprc-driver.c

[PATCH 05/11] staging: fsl-mc: export mc_get_version

2016-06-22 Thread Stuart Yoder
some drivers (built as modules) rely on mc_get_version() Signed-off-by: Stuart Yoder --- drivers/staging/fsl-mc/bus/dpmng.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/fsl-mc/bus/dpmng.c b/drivers/staging/fsl-mc/bus/dpmng.c index f633fcd..a31fa9b

[PATCH 09/11] staging: fsl-mc: dprc: fix ordering problem freeing resources in remove of dprc

2016-06-22 Thread Stuart Yoder
When unbinding a dprc from the dprc driver the cleanup of the resource pools must happen after irq pool cleanup is done. Signed-off-by: Stuart Yoder --- drivers/staging/fsl-mc/bus/dprc-driver.c | 10 ++ 1 file changed, 6 insertions(+), 4 deletions(-) diff --git

[PATCH 07/11] staging: fsl-mc: fix asymmetry in destroy of mc_io

2016-06-22 Thread Stuart Yoder
From: Bharat Bhushan An mc_io represents a mapped MC portal. Previously, an mc_io was created for the root dprc in fsl_mc_bus_probe() and for child dprcs in dprc_probe(). But the free of that data structure happened in the general bus remove callback. This asymmetry

[PATCH 02/11] staging: fsl-mc: implement uevent callback and set the modalias

2016-06-22 Thread Stuart Yoder
Replace placeholder code in the uevent callback to properly set the MODALIAS env variable. Signed-off-by: Stuart Yoder --- drivers/staging/fsl-mc/bus/mc-bus.c | 8 +++- 1 file changed, 7 insertions(+), 1 deletion(-) diff --git a/drivers/staging/fsl-mc/bus/mc-bus.c

[PATCH 03/11] staging: fsl-mc: clean up the device id struct

2016-06-22 Thread Stuart Yoder
-rename the struct used for fsl-mc device ids to be more consistent with other busses -remove the now obsolete and unused version fields Signed-off-by: Stuart Yoder --- drivers/staging/fsl-mc/bus/dprc-driver.c | 2 +- drivers/staging/fsl-mc/bus/mc-allocator.c | 2 +-

[PATCH 06/11] staging: fsl-mc: make fsl_mc_is_root_dprc() global

2016-06-22 Thread Stuart Yoder
make fsl_mc_is_root_dprc() global so that the dprc driver can use it Signed-off-by: Stuart Yoder --- drivers/staging/fsl-mc/bus/mc-bus.c | 28 +--- drivers/staging/fsl-mc/include/mc.h | 2 ++ 2 files changed, 15 insertions(+), 15 deletions(-) diff

[PATCH 01/11] staging: fsl-mc: add support for the modalias sysfs attribute

2016-06-22 Thread Stuart Yoder
In order to support uevent based module loading implement modalias support for the fsl-mc bus driver. Aliases are based on vendor and object/device id and are of the form "fsl-mc:vNdN". Signed-off-by: Stuart Yoder --- drivers/staging/fsl-mc/bus/mc-bus.c | 25

[PATCH v2] staging/android: prepare sw_sync files for de-staging

2016-06-22 Thread Gustavo Padovan
From: Gustavo Padovan remove file paths in the comments and add short description about each file. v2: remove file paths instead of just change them. Signed-off-by: Gustavo Padovan --- drivers/staging/android/sw_sync.c| 2

[RESEND PATCH v2 2/2] staging: iio: accel: add error check

2016-06-22 Thread Luis de Bethencourt
Go to error_ret if sca3000_read_ctrl_reg() failed. Signed-off-by: Luis de Bethencourt --- drivers/staging/iio/accel/sca3000_core.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/staging/iio/accel/sca3000_core.c b/drivers/staging/iio/accel/sca3000_core.c

[RESEND PATCH v2 1/2] staging: iio: accel: fix error check

2016-06-22 Thread Luis de Bethencourt
sca3000_read_ctrl_reg() returns a negative number on failure, check for this instead of zero. Signed-off-by: Luis de Bethencourt Reviewed-by: Andrew F. Davis Reviewed-by: Jonathan Cameron --- drivers/staging/iio/accel/sca3000_core.c | 2

[RESEND PATCH] staging: gdm724x: gdm_usb: Remove ignored value

2016-06-22 Thread Luis de Bethencourt
The value assigned to ret will be overwritten before it could be read in a future iteration of the loop. Removing the unnecessary assignment. Signed-off-by: Luis de Bethencourt --- drivers/staging/gdm724x/gdm_usb.c | 8 1 file changed, 4 insertions(+), 4

Re: [PATCH 1/2] [media] v4l: vsp1: Split pad operations between rpf and wpf

2016-06-22 Thread Laurent Pinchart
Hi Niklas, Thank you for the patch. On Wednesday 22 Jun 2016 02:19:24 Niklas Söderlund wrote: > This is done in preparation to move s_stream from v4l2_subdev_video_ops > to v4l2_subdev_pad_ops. Only wpf implements s_stream so it will no > longer be possible to share the v4l2_subdev_pad_ops once

[PATCH] staging: lustre: lnet: Remove old commented out code

2016-06-22 Thread James Simmons
From: Ben Evans These #if 0 blocks have been in place for years. Assume they are not used and remove them Signed-off-by: Ben Evans Intel-bug-id: https://jira.hpdd.intel.com/browse/LU-8058 Reviewed-on: http://review.whamcloud.com/20414 Reviewed-by: Andreas

[PATCH] staging: wilc1000: fix error handling in wilc_debugfs_init()

2016-06-22 Thread Luis de Bethencourt
The common format to check if a function returned an error pointer is to use PTR_ERR(). Instead of ERR_PTR() which is used to return said errors. Also, if there was an error returning -EINVAL instead of -1 is more appropriate. Signed-off-by: Luis de Bethencourt ---

[PATCH] staging: emxx_udc: allow modular build

2016-06-22 Thread Arnd Bergmann
A change to the usb gadget core allowed certain API functions to be part of a loadable module, which breaks having emxx_udc built-in: drivers/staging/built-in.o: In function `nbu2ss_drv_probe': (.text+0x2428): undefined reference to `usb_ep_set_maxpacket_limit' The original patch already fixed

Re: [PATCH v3 3/3] staging: wilc1000: Change interface wilc_mq_send to wilc_enqueue_cmd

2016-06-22 Thread kbuild test robot
Hi, [auto build test ERROR on staging/staging-testing] [also build test ERROR on v4.7-rc4 next-20160622] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/linux/commits/Binoy-Jayan/staging-wilc1000-Replace

[PATCH v3 3/3] staging: wilc1000: Change interface wilc_mq_send to wilc_enqueue_cmd

2016-06-22 Thread Binoy Jayan
Replace the interface 'wilc_mq_send' with 'wilc_enqueue_cmd' and remove the now unused structures 'message' and 'message_queue'. Restructure switch statement in the work queue helper function host_if_work and remove unwanted indentation. Signed-off-by: Binoy Jayan ---

[PATCH v3 1/3] staging: wilc1000: message_queue: Move code to host interface

2016-06-22 Thread Binoy Jayan
Move the contents of wilc_msgqueue.c and wilc_msgqueue.h into host_interface.c, remove 'wilc_msgqueue.c' and 'wilc_msgqueue.h'. This is done so as to restructure the implementation of the kthread 'hostIFthread' using a work queue. Signed-off-by: Binoy Jayan ---

[PATCH v3 2/3] staging: wilc1000: Replace kthread with workqueue for host interface

2016-06-22 Thread Binoy Jayan
Deconstruct the kthread / message_queue logic, replacing it with create_singlethread_workqueue() / queue_work() setup, by adding a 'struct work_struct' to 'struct host_if_msg'. The current kthread hostIFthread() is converted to a work queue helper with the name 'host_if_work'. Signed-off-by:

[PATCH v3 0/3] *** staging: wilc1000: Replace semaphores ***

2016-06-22 Thread Binoy Jayan
This patchset [v3] is part of the second patch series for 'wilc1000'. The original patch series consisted 7 patches of which only the first 5 are good. The patch 6 and 7 are being worked on in this series in a different way. This patch series removes the semaphore 'sem' in 'wilc1000' and also