RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

2016-09-06 Thread Dexuan Cui
> From: Bjorn Helgaas [mailto:helg...@kernel.org] > Sent: Wednesday, September 7, 2016 1:25 > To: Dexuan Cui > Cc: Bjorn Helgaas ; linux-...@vger.kernel.org; > gre...@linuxfoundation.org; KY Srinivasan ; linux- > ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de; > a...@canonica

Re: [PATCHv2 1/4] staging: android: ion: Drop heap type masks

2016-09-06 Thread Laura Abbott
On 09/05/2016 04:20 AM, Brian Starkey wrote: Hi, On Fri, Sep 02, 2016 at 12:36:25PM -0700, Laura Abbott wrote: On 09/02/2016 06:41 AM, Brian Starkey wrote: Hi Laura, On Thu, Sep 01, 2016 at 03:40:41PM -0700, Laura Abbott wrote: There is no advantage to having heap types be a mask. The ion c

[PATCH] [trivial] comedi/dt2811: fix warnings on globals

2016-09-06 Thread Elias Boutaleb
From: Elias Boutaleb This patch fixes the following two warnings on the dt2811 driver found using sparse: drivers/staging/comedi/drivers/dt2811.c:99:20: warning: symbol 'dt2811_clk_dividers' was not declared. Should it be static? drivers/staging/comedi/drivers/dt2811.c:103:20: warning: symbol

Re: [PATCH] vme: fake: fix build for 64-bit dma_addr_t

2016-09-06 Thread Arnd Bergmann
On Tuesday, September 6, 2016 10:39:25 PM CEST Dan Carpenter wrote: > On Tue, Sep 06, 2016 at 02:59:41PM +0200, Arnd Bergmann wrote: > > casting between dma_addr_t and a pointer is generally tricky, > > as they might not be the same size and almost never point into > > the same address space. With

Re: [PATCH] vme: fake: fix build for 64-bit dma_addr_t

2016-09-06 Thread Dan Carpenter
On Tue, Sep 06, 2016 at 02:59:41PM +0200, Arnd Bergmann wrote: > casting between dma_addr_t and a pointer is generally tricky, > as they might not be the same size and almost never point into > the same address space. With 32-bit ARM systems and LPAE, we > get this warning for the vme_fake driver t

[PATCH 0/3] storvsc: fixes issues on Fiber Channel

2016-09-06 Thread Long Li
From: Long Li This patch set fixes connectivity issues and improves performance for Fiber Channel disks. Long Li (3): Use tagged SRB requests if supported by the device Properly handle SRB_ERROR when sense message is present Use block layer default segment size drivers/scsi/storvsc_drv.

[PATCH 2/3] storvsc: properly handle SRB_ERROR when sense message is present

2016-09-06 Thread Long Li
From: Long Li When sense message is present on error, we should pass along to the upper layer to decide how to deal with the error. This patch fixes connectivity issues with Fiber Channel devices. --- drivers/scsi/storvsc_drv.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/sc

[PATCH 3/3] storvsc: use block layer default segment size

2016-09-06 Thread Long Li
From: Long Li We no long have the restriction of page size limit in the SG list. Remove it. The driver can properly handle default block segment size. --- drivers/scsi/storvsc_drv.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/scsi/storvsc_drv.c b/drivers/scsi/storvsc_drv.c in

[PATCH 1/3] storvsc: use tagged SRB requests if supported by the device

2016-09-06 Thread Long Li
From: Long Li Properly set SRB flags when hosting device supports tagged queuing. This patch improves the performance on Fiber Channel disks. --- drivers/scsi/storvsc_drv.c | 8 1 file changed, 8 insertions(+) diff --git a/drivers/scsi/storvsc_drv.c b/drivers/scsi/storvsc_drv.c index

[PATCH V2 1/1] Revert "Drivers: hv: ring_buffer: count on wrap around mappings in get_next_pkt_raw()"

2016-09-06 Thread kys
From: K. Y. Srinivasan To deal with the merge conflict between net-next and char-misc trees, revert commit bb08d431a914 from char-misc tree. This commit can be rebased and applied once net-next picks up char-misc changes. Here is the commit log of the reverted patch: "With wrap around mappings i

Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

2016-09-06 Thread Bjorn Helgaas
On Tue, Aug 23, 2016 at 04:42:41AM +, Dexuan Cui wrote: > > 1. use zero-length array to make the code more readable. > 2. remove an unused struct member. > 3. small error handling improvement to some error cases. > > Dexuan Cui (5): > PCI: hv: use zero-length message in struct pci_packet >

RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

2016-09-06 Thread KY Srinivasan
> -Original Message- > From: Bjorn Helgaas [mailto:helg...@kernel.org] > Sent: Tuesday, September 6, 2016 9:11 PM > To: Dexuan Cui > Cc: Bjorn Helgaas ; linux-...@vger.kernel.org; > gre...@linuxfoundation.org; KY Srinivasan ; linux- > ker...@vger.kernel.org; de...@linuxdriverproject.org;

RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

2016-09-06 Thread KY Srinivasan
> -Original Message- > From: Dexuan Cui > Sent: Tuesday, August 23, 2016 10:13 AM > To: Bjorn Helgaas ; linux-...@vger.kernel.org; > gre...@linuxfoundation.org; KY Srinivasan ; linux- > ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de; > a...@canonical.com; jasow...@re

[PATCH v3 4/6] staging: rtl8188eu: remove rtw_proc_{init,remove}_one

2016-09-06 Thread Luca Ceresoli
rtw_proc_init_one() and rtw_proc_remove_one() are two very long functions that are supposed to create a bunch of proc entries to access debugging features of the driver. But both of them are under #if 0 since their first commit three years ago (5adef66acf73705ae95ea0b1e6b5fc7f17d82d30), replaced b

[PATCH v3 6/6] staging: rtl8188eu: remove unused debugging functions

2016-09-06 Thread Luca Ceresoli
These functions were only mentioned in the rtw_proc_init_one() function in drivers/staging/rtl8188eu/os_dep/os_intfs.c, which was under #if 0 and has now been removed completely. As they are not used anywhere, and also violate the coding style rules, remove them. Signed-off-by: Luca Ceresoli Cc:

[PATCH v3 2/6] staging: rtl8188eu: remove unimplemented functions declaration

2016-09-06 Thread Luca Ceresoli
These functions have been declared without any implementation since the first commit (58c434013a22fccfdb14abc2bb8408ca29073b76) and there has been no mention of them in following commits. Signed-off-by: Luca Ceresoli Cc: Greg Kroah-Hartman Cc: Kyle Kuffermann Cc: de...@driverdev.osuosl.org Cc:

[PATCH v3 1/6] staging: rtl8723au: remove unimplemented functions declaration

2016-09-06 Thread Luca Ceresoli
These functions have been declared without any implementation since the first commit (364e30ebd2dbaccba430c603da03e68746eb932a) and there has been no mention of them in following commits. Signed-off-by: Luca Ceresoli Cc: Larry Finger Cc: Jes Sorensen Cc: Greg Kroah-Hartman Cc: linux-wirel...@v

[PATCH v3 5/6] staging: rtl8188eu: remove useless include

2016-09-06 Thread Luca Ceresoli
Since the removal of rtw_proc_init_one() the proc filesystem is not mentioned in this driver. So this include becomes useless. Signed-off-by: Luca Ceresoli Cc: Greg Kroah-Hartman Cc: Arnd Bergmann Cc: Binoy Jayan Cc: Anish Bhatt Cc: "Rémy Oudompheng" Cc: Alexey Khoroshilov Cc: Kyle Kufferma

[PATCH v3 3/6] staging: rtl8188eu: declare internal function as static

2016-09-06 Thread Luca Ceresoli
This function is only used inside rtw_recv.c. Which is quite logical, since it's a timer callback: it is passed as the _fn argument to setup_timer(). So it is internal to rtw_recv.c and should be static. Signed-off-by: Luca Ceresoli Cc: Greg Kroah-Hartman Cc: Bhaktipriya Shridhar Cc: Andy Shevc

[PATCH] Staging: wlan-ng: improve code aspect in p80211req_mibset_mibget()

2016-09-06 Thread Claudiu Beznea
This patch improves code aspect in p80211req_mibset_mibget() function by removing accolades which followed case statements. To do so, some data variable ware declared at the beginning of the function and also pstr and key variables were initialized only in the code which uses them. Signed-off-by:

Re: [PATCH 0/5] Some cleanup patches for drivers/staging/rtl8723au/core/rtw_mlme.c

2016-09-06 Thread Jes Sorensen
Joe Perches writes: > On Tue, 2016-09-06 at 12:00 -0400, Jes Sorensen wrote: > >> Nothing wrong with these patches, however I intend to post a patch to >> remove this driver soon, so it's kind of a waste of your time to spend >> too many cycles on it. > > It might be useful to mark any drivers you

Re: [PATCH 0/5] Some cleanup patches for drivers/staging/rtl8723au/core/rtw_mlme.c

2016-09-06 Thread Joe Perches
On Tue, 2016-09-06 at 12:00 -0400, Jes Sorensen wrote: > Nothing wrong with these patches, however I intend to post a patch to > remove this driver soon, so it's kind of a waste of your time to spend > too many cycles on it. It might be useful to mark any drivers you're planning on removing as "O

Re: [PATCH 0/5] Some cleanup patches for drivers/staging/rtl8723au/core/rtw_mlme.c

2016-09-06 Thread Jes Sorensen
Matthias Beyer writes: > This patchset fixes some errors and warnings reported by checkpatch.pl. > > Matthias Beyer (5): > drivers: staging: rtl8723au: core: Fix checkpatch.pl errors > drivers: staging: rtl8723au: core: simplify if-break-else > drivers: staging: rtl8723au: core: Refactor poi

Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

2016-09-06 Thread Bjorn Helgaas
On Tue, Aug 23, 2016 at 04:42:41AM +, Dexuan Cui wrote: > > 1. use zero-length array to make the code more readable. > 2. remove an unused struct member. > 3. small error handling improvement to some error cases. > > Dexuan Cui (5): > PCI: hv: use zero-length message in struct pci_packet >

RE: [PATCH] Drivers: hv: vmbus: Revert commit bb08d431a914

2016-09-06 Thread KY Srinivasan
> -Original Message- > From: Dan Carpenter [mailto:dan.carpen...@oracle.com] > Sent: Tuesday, September 6, 2016 6:34 PM > To: KY Srinivasan > Cc: gre...@linuxfoundation.org; linux-ker...@vger.kernel.org; > de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com; > vkuzn...@redha

Re: [PATCH] staging: dgnc: Fix multi line comment alignment

2016-09-06 Thread Andrey Utkin
On Tue, Sep 06, 2016 at 03:19:03PM +0200, Fernando Apesteguia wrote: > Sorry, but I fail to see how I can align all the lines by changing just the > first and last ones. Ah now I see that original version doesn't have spaces before asterisk. Sorry for noise. __

Re: [PATCH] staging: dgnc: Fix multi line comment alignment

2016-09-06 Thread Fernando Apesteguia
On Mon, Sep 05, 2016 at 11:45:30PM +0300, Andrey Utkin wrote: > On Mon, Sep 05, 2016 at 08:28:32PM +0200, Fernando Apesteguia wrote: > > Fix alignment in multi line comment block. > > > > Remove extra '*' to use the preferred comment style as in > > Documentation/CodingStyle > > > > Signed-off-b

Re: [PATCH] Drivers: hv: vmbus: Revert commit bb08d431a914

2016-09-06 Thread Dan Carpenter
Use a human readable subject. Look at the default git revert format. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

[PATCH] vme: fake: fix build for 64-bit dma_addr_t

2016-09-06 Thread Arnd Bergmann
casting between dma_addr_t and a pointer is generally tricky, as they might not be the same size and almost never point into the same address space. With 32-bit ARM systems and LPAE, we get this warning for the vme_fake driver that stores a pointer in a dma_addr_t variable: drivers/vme/bridges/vme

Re: [PATCH] Drivers: hv: vmbus: Revert commit bb08d431a914

2016-09-06 Thread Greg KH
On Tue, Sep 06, 2016 at 05:28:12AM -0700, k...@exchange.microsoft.com wrote: > From: K. Y. Srinivasan > > To deal with the merge conflict between net-next and char-misc trees, > revert commit bb08d431a914 from char-misc tree. This commit can be rebased > and applied once net-next picks up char-mi

Re: [PATCH v2] Staging: comedi: das08_cs: Fix block comments use * on subsequent lines.

2016-09-06 Thread Amit Ghadge
On Tue, Sep 6, 2016 at 4:18 PM, Ian Abbott wrote: > On 05/09/16 17:45, Amit Ghadge wrote: >> >> Fixes checkpatch warning in das08_cs.c file: >> WARNING: Block comments use * on subsequent lines >> >> Added * in blank line in comment block. >> >> Signed-off-by: Amit Ghadge >> --- >> drivers/stagi

Re: [PATCH v2] Staging: comedi: das08_cs: Fix block comments use * on subsequent lines.

2016-09-06 Thread Ian Abbott
On 05/09/16 17:45, Amit Ghadge wrote: Fixes checkpatch warning in das08_cs.c file: WARNING: Block comments use * on subsequent lines Added * in blank line in comment block. Signed-off-by: Amit Ghadge --- drivers/staging/comedi/drivers/das08_cs.c | 76 +++ 1 file ch

Re: [PATCH v3] Staging: comedi: ni_daq_dio24.c: Fix block comments use * on subsequent lines.

2016-09-06 Thread Ian Abbott
On 05/09/16 17:34, Amit Ghadge wrote: This is a patch to the ni_daq_dio24.c that fixes checkpatch warning: WARNING: Block comments use * on subsequent lines Added * in blank line in comment block. Signed-off-by: Amit Ghadge --- drivers/staging/comedi/drivers/ni_daq_dio24.c | 60 +-

[PATCH] Drivers: hv: vmbus: Revert commit bb08d431a914

2016-09-06 Thread kys
From: K. Y. Srinivasan To deal with the merge conflict between net-next and char-misc trees, revert commit bb08d431a914 from char-misc tree. This commit can be rebased and applied once net-next picks up char-misc changes. --- include/linux/hyperv.h | 32 +--- 1 file