Signed-off-by: Victor Carvajal
---
Changes in v3:
- Be consistent with spacing before text against previous patch.
Changes in v2:
- Be consistent with spacing before text.
---
drivers/staging/rtl8188eu/include/rtw_event.h | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
d
On Mon, Oct 10, 2016 at 08:50:50PM -0700, victor c wrote:
> WARNING: Block comments use * on subsequent lines.
>
> Signed-off-by: Victor Carvajal
Your "From:" line needs to match this one as well.
Also, why the "Re:" in a patch submission subject?
> ---
> Changes in v2:
> - Be consistent w
WARNING: Block comments use * on subsequent lines.
Signed-off-by: Victor Carvajal
---
Changes in v2:
- Be consistent with spacing before text.
---
drivers/staging/rtl8188eu/include/rtw_event.h | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/rtl8
From: Ming Ling
So far some ion heaps such as carveout_heap, chunk_heap,
system_heap have freed buffers asynchrounously. Freed buffers
are placed on a free list and freed from a low priority background
thread. If allocations from a particular heap fail, the free list
is drained.
But that mechani
In commit d86e64768859 ("rtlwifi: rtl818x: constify local structures"),
the configuration struct for most of the drivers was changed to be
constant. The problem is that five of the modified drivers need to be
able to update the firmware name based on the exact model of the card.
As the file names w
On 10/10/16 08:20, Brian Masney wrote:
> Add ABI documentation from the ISL29018 Data Sheet (FN6619.4, Oct 8,
> 2012) about the infrared suppression that can be controlled
> with the proximity_on_chip_ambient_infrared_suppression sysfs attribute.
>
> Signed-off-by: Brian Masney
I'm going to let t
On 10/10/16 08:19, Brian Masney wrote:
> Remove blank line between MODULE_DEVICE_TABLE() and its corresponding
> structure for consistency with the other device table entries.
>
> Signed-off-by: Brian Masney
Applied.
Thanks,
Jonathan
> ---
> drivers/staging/iio/light/isl29018.c | 1 -
> 1 file
On 10/10/16 08:20, Brian Masney wrote:
> Rename description from "ISL 29018" to "Intersil 29018" in Kconfig for
> consistency with other drivers in mainline.
>
> Signed-off-by: Brian Masney
Applied.
> ---
> drivers/staging/iio/light/Kconfig | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
On 10/10/16 08:19, Brian Masney wrote:
> Use the return value from isl29018_set_integration_time() as the return
> value for isl29018_chip_init() since this is the last piece of work
> inside that function.
>
> Signed-off-by: Brian Masney
Applied to the togreg branch of iio.git and pushed out as
On 10/10/16 08:19, Brian Masney wrote:
> Change multiline comments from:
>
> /* line1
> * line2
> * ...
> */
>
> to
>
> /*
> * line1
> * line2
> * ...
> */
>
> Signed-off-by: Brian Masney
Applied to the togreg branch of iio.git and pushed out as testing.
Thanks,
Jonathan
> ---
> driv
On Mon, 10 Oct 2016, Larry Finger wrote:
> On 10/10/2016 11:56 AM, Johannes Berg wrote:
> > On Mon, 2016-10-10 at 10:25 -0500, Larry Finger wrote:
> > > This reverts commit d86e64768859fca82c78e52877ceeba04e25d27a.
> > >
> > > For drivers rtl8188ee, rtl8192ce, rtl8192ee, rtl8723ae, and
> > > rtl
On 10/10/16 08:19, Brian Masney wrote:
> isl29035_detect() did not do chip detection. Move functionality directly
> into isl29018_chip_init() to avoid naming confusion.
It kind of does do detection (or at least verification). Key point is that
it does other things as well.
I added the word 'just'
On 10/10/16 08:19, Brian Masney wrote:
> Add newlines to improve code readability in preparation for moving the
> driver out of staging.
>
> Signed-off-by: Brian Masney
Applied to the togreg branch of iio.git and pushed out as testing for
the autobuilders to play with it.
Thanks,
Jonathan
> ---
On 10/10/2016 11:56 AM, Johannes Berg wrote:
On Mon, 2016-10-10 at 10:25 -0500, Larry Finger wrote:
This reverts commit d86e64768859fca82c78e52877ceeba04e25d27a.
For drivers rtl8188ee, rtl8192ce, rtl8192ee, rtl8723ae, and
rtl8821ae,
the Coccinelle script missed the fact that the code changes th
Fixes checkpatch warning on ks_wlan_net.c:
foo * bar should be foo *bar
Signed-off-by: Sabitha George
---
drivers/staging/ks7010/ks_wlan_net.c | 64 ++--
1 file changed, 32 insertions(+), 32 deletions(-)
diff --git a/drivers/staging/ks7010/ks_wlan_net.c
b/driver
Replaces inclusion of asm/uaccess.h with linux/uaccess.h
and asm/atomic.h with linux/atomic.h in ks_wlan_net.c
Signed-off-by: Sabitha George
---
drivers/staging/ks7010/ks_wlan_net.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ks7010/ks_wlan_net.c
b/d
On Mon, 2016-10-10 at 10:25 -0500, Larry Finger wrote:
> This reverts commit d86e64768859fca82c78e52877ceeba04e25d27a.
>
> For drivers rtl8188ee, rtl8192ce, rtl8192ee, rtl8723ae, and
> rtl8821ae,
> the Coccinelle script missed the fact that the code changes the
> firmware
> name. When that happens
I discovered that at least WS2016TP5 host has 60 seconds timeout for the
ICMSGTYPE_NEGOTIATE message so we need to lower guest's timeout a little
bit to make sure we always respond in time. Let's make it 55 seconds.
Signed-off-by: Vitaly Kuznetsov
---
drivers/hv/hyperv_vmbus.h | 2 +-
1 file cha
On 10/10/16 15:14, Spencer E. Olson wrote:
AO device arming was previously done as a part of ni_ao_inttrig which is
called as a result of the user calling comedi_internal_trigger. For
start_src == TRIG_EXT, this does not make very much sense since external
triggers should not conceptually need t
This reverts commit d86e64768859fca82c78e52877ceeba04e25d27a.
For drivers rtl8188ee, rtl8192ce, rtl8192ee, rtl8723ae, and rtl8821ae,
the Coccinelle script missed the fact that the code changes the firmware
name. When that happens, the kernel issues a BUG splat because
it is unable to overwrite the
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-testing
head: b5596d52a3715a37d6d0875791d93ae5b73c6f21
commit: 6e523414a8f7da23f59154b85544a96d5bf580f8 [189/192] staging:
vc04_services: fix dmac_map/unmap_area prototypes
config: arm64-allmodconfig (attached as
With wrap around mappings in place we can always provide drivers with
direct links to packets on the ring buffer, even when they wrap around.
Do the required updates to get_next_pkt_raw()/put_pkt_raw()
The first version of this commit was reverted (65a532f3d50a) to deal with
cross-tree merge issue
On Fri, Oct 07, 2016 at 11:12:04AM +0200, Mike Rapoport wrote:
> On Thu, Oct 06, 2016 at 09:27:36PM -0700, Edward Lipinsky wrote:
> > On Sun, Oct 02, 2016 at 08:13:01PM +0200, Greg KH wrote:
> > > On Sun, Oct 02, 2016 at 11:05:05AM -0700, Edward Lipinsky wrote:
> > > > This patch fixes the checkpat
Hi Linus,
On Mon, Oct 10, 2016 at 10:39:32AM +0200, Linus Walleij wrote:
Greybus GPIO seems to reimplement the already existing generic
gpiolib irqchip. Also use gpiochip_get_data(). Also use
devm_gpiochip_add_data().
Cc: Viresh Kumar
Cc: Axel Haslam
Cc: Johan Hovold
Cc: Sandeep Patil
Cc: Ru
AO device arming was previously done as a part of ni_ao_inttrig which is
called as a result of the user calling comedi_internal_trigger. For
start_src == TRIG_EXT, this does not make very much sense since external
triggers should not conceptually need to be software triggered also. This
patch spl
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-testing
head: b5596d52a3715a37d6d0875791d93ae5b73c6f21
commit: 6e523414a8f7da23f59154b85544a96d5bf580f8 [189/192] staging:
vc04_services: fix dmac_map/unmap_area prototypes
config: arm-multi_v7_defconfig (attache
This patch series replaces several sizeof(struct XXX) stuff in favour
of sizeof(var) which is the preferred one.
Sergio Paracuellos (5):
staging: wlan-ng: Replace data type declaration with variable of same
type in cfg80211.c
staging: wlan-ng: Replace data type declaration with variable o
sizeof(*var) instead of sizeof(struct XXX) is preferred.
Fix them in prism2sta.c file.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/wlan-ng/prism2sta.c | 7 +++
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/wlan-ng/prism2sta.c
b/drivers/staging/wlan-
sizeof(var) instead of sizeof(struct XXX) is preferred.
Fix it in hfa384x_usb.c file.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/wlan-ng/hfa384x_usb.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wlan-ng/hfa384x_usb.c
b/drivers/staging/wlan-ng/h
sizeof(var) instead of sizeof(struct XXX) is preferred.
Fix them in p80211netdev.c
Signed-off-by: Sergio Paracuellos
---
drivers/staging/wlan-ng/p80211netdev.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/wlan-ng/p80211netdev.c
b/drivers/stag
sizeof(var) instead of sizeof(struct XXX) is preferred.
Fix it in cfg80211.c file.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/wlan-ng/cfg80211.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wlan-ng/cfg80211.c
b/drivers/staging/wlan-ng/cfg80211.
sizeof(*var) instead of sizeof(struct XXX) is preferred.
Fix it in p80211conv.c file.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/wlan-ng/p80211conv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wlan-ng/p80211conv.c
b/drivers/staging/wlan-ng/p8
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-testing
head: bc1a64938434fee4cacd2d07e0d8275f17098a9a
commit: 6e523414a8f7da23f59154b85544a96d5bf580f8 [189/191] staging:
vc04_services: fix dmac_map/unmap_area prototypes
config: arm-allmodconfig (attached as .
On Mon, Oct 10, 2016 at 3:56 AM, Chase Metzger wrote:
> Added braces to else statement where checkpatch complained.
>
> Signed-off-by: Chase Metzger
> ---
> drivers/staging/greybus/audio_codec.c | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/staging/greybus/a
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-testing
head: ecbc62fd441210e54e25fa9683422bbc0143049d
commit: ecbc62fd441210e54e25fa9683422bbc0143049d [190/190] staging:
vc04_services: add CONFIG_COMPILE_TEST ability
config: ia64-allmodconfig (attached as .co
On 08/10/16 22:39, Spencer E. Olson wrote:
AO device arming was previously done as a part of ni_ao_inttrig which is
called as a result of the user calling comedi_internal_trigger. For
start_src == TRIG_EXT, this does not make very much sense since external
triggers should not conceptually need t
On 08/10/16 22:38, Spencer E. Olson wrote:
This makes INSN_CONFIG_DIO_{INPUT,OUTPUT,OPENDRAIN} simply be copies of the
already-existing constants COMEDI_INPUT, COMEDI_OUTPUT, and
COMEDI_OPENDRAIN.
This change also ensures that if a user happens to use, for example,
COMEDI_INPUT in place of where
On 08/10/16 22:37, Spencer E. Olson wrote:
Information pertaining to the NI_GPCT_ARM* registers were added to the
comedi.org version of the comedi kernel. This adds this information to
the staging-tree version of the comedi kernel. Relevant comments are also
copied over.
Signed-off-by: Spencer
On 10/07/2016 02:14 PM, Zach Brown wrote:
> From: Josh Cartwright
>
> Create an option CONFIG_LED_TRIGGER_PHY (default n), which will
> create a set of led triggers for each instantiated PHY device. There is
> one LED trigger per link-speed, per-phy.
>
> This allows for a user to configure thei
Greybus GPIO seems to reimplement the already existing generic
gpiolib irqchip. Also use gpiochip_get_data(). Also use
devm_gpiochip_add_data().
Cc: Viresh Kumar
Cc: Axel Haslam
Cc: Johan Hovold
Cc: Sandeep Patil
Cc: Rui Miguel Silva
Cc: Greg Kroah-Hartman
Signed-off-by: Linus Walleij
---
C
On Sun, Oct 09, 2016 at 09:58:45PM -0700, victor carvajal wrote:
> WARNING: Block comments use * on subsequent lines
>
> Signed-off-by: victor carvajal
> ---
> drivers/staging/rtl8188eu/include/rtw_event.h | 39
> +--
> 1 file changed, 19 insertions(+), 20 deletions(-)
>
Add ABI documentation from the ISL29018 Data Sheet (FN6619.4, Oct 8,
2012) about the infrared suppression that can be controlled
with the proximity_on_chip_ambient_infrared_suppression sysfs attribute.
Signed-off-by: Brian Masney
---
.../ABI/testing/sysfs-bus-iio-light-isl29018 | 19 +++
Remove blank line between MODULE_DEVICE_TABLE() and its corresponding
structure for consistency with the other device table entries.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/isl29018.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/iio/light/isl29018.c
b/dri
Move ISL29018/ISL29023/ISL29035 driver out of staging into mainline.
Signed-off-by: Brian Masney
---
drivers/iio/light/Kconfig| 12 +
drivers/iio/light/Makefile | 1 +
drivers/iio/light/isl29018.c | 847 +++
drivers/staging/iio/lig
Rename description from "ISL 29018" to "Intersil 29018" in Kconfig for
consistency with other drivers in mainline.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/Kconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/iio/light/Kconfig
b/drivers/st
This is a series of cleanup patches to the ISL29018/ISL29023/ISL29035
driver to move it out of staging based on feedback from Jonathan
Cameron.
Brian Masney (8):
staging: iio: isl29018: add newlines to improve readability
staging: iio: isl29018: remove poorly named function
staging: iio: isl
isl29035_detect() did not do chip detection. Move functionality directly
into isl29018_chip_init() to avoid naming confusion.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/isl29018.c | 44
1 file changed, 19 insertions(+), 25 deletions(-)
diff --
Add newlines to improve code readability in preparation for moving the
driver out of staging.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/isl29018.c | 6 ++
1 file changed, 6 insertions(+)
diff --git a/drivers/staging/iio/light/isl29018.c
b/drivers/staging/iio/light/isl29018.
Use the return value from isl29018_set_integration_time() as the return
value for isl29018_chip_init() since this is the last piece of work
inside that function.
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/isl29018.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff
Change multiline comments from:
/* line1
* line2
* ...
*/
to
/*
* line1
* line2
* ...
*/
Signed-off-by: Brian Masney
---
drivers/staging/iio/light/isl29018.c | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/iio/light/isl29018.c
b/drivers/sta
On Mon, Oct 10, 2016 at 12:42:19AM +0530, Akshay Mariyanna wrote:
> This fixes the following checkpatch warnings:
> WARNING: Block comments use * on subsequent lines
> WARNING: Block comments use a trailing */ on a separate lines
>
> Signed-off-by: Akshay Mariyanna
> ---
> drivers/staging/ks7010
51 matches
Mail list logo