Re: [PATCH] staging :rtl8712: Free memory when kmalloc fails

2016-10-26 Thread Greg KH
On Thu, Oct 27, 2016 at 11:10:09AM +0530, Souptick Joarder wrote: > There are few functions where we need to free previously allocated memory > when kmalloc fails. Else it may lead to memory leakage. > In _init_cmd_priv() and _r8712_init_xmit_priv(),in few places we are not > freeing previously

[PATCH] staging :rtl8712: Free memory when kmalloc fails

2016-10-26 Thread Souptick Joarder
There are few functions where we need to free previously allocated memory when kmalloc fails. Else it may lead to memory leakage. In _init_cmd_priv() and _r8712_init_xmit_priv(),in few places we are not freeing previously allocated memory when kmalloc fails. This patch will address it.

Re: Patchwork for this mailing list?

2016-10-26 Thread Greg KH
On Thu, Oct 27, 2016 at 08:26:20AM +0300, Dan Carpenter wrote: > On Thu, Oct 27, 2016 at 07:04:22AM +0200, Greg KH wrote: > > Also, there's no real need for the hyperv patches to be using this list > > anymore, that codebase has long since "graduated". Feel free to use > > lkml if you want

Re: Patchwork for this mailing list?

2016-10-26 Thread Dan Carpenter
On Thu, Oct 27, 2016 at 07:04:22AM +0200, Greg KH wrote: > Also, there's no real need for the hyperv patches to be using this list > anymore, that codebase has long since "graduated". Feel free to use > lkml if you want instead. Ugh... LKML is a terrible list to use unless it's a small driver

Re: [PATCH 4/5] staging: vc04_services: fix CamelCase

2016-10-26 Thread Greg Kroah-Hartman
On Wed, Oct 26, 2016 at 06:13:13PM -0700, Eric Anholt wrote: > Stefan Wahren writes: > > > This fixes the CamelCase of some variables. > > > > Signed-off-by: Stefan Wahren > > Greg, are these kinds of reformats something that you're looking for

Re: Patchwork for this mailing list?

2016-10-26 Thread Greg KH
On Wed, Oct 26, 2016 at 08:58:56PM -0700, Stephen Hemminger wrote: > Is there a patchwork project for this mailing list? Not that I know of. > If not probably it makes sense to do it. Why? I don't use it, and without the maintainer using it, it's use can be limited. But feel free to have it

Re: Patchwork for this mailing list?

2016-10-26 Thread Dan Carpenter
On Wed, Oct 26, 2016 at 08:58:56PM -0700, Stephen Hemminger wrote: > Is there a patchwork project for this mailing list? > If not probably it makes sense to do it. > I don't think there is... I've never used patch-work. I was looking at https://patchwork.kernel.org/ and most people just seem

Patchwork for this mailing list?

2016-10-26 Thread Stephen Hemminger
Is there a patchwork project for this mailing list? If not probably it makes sense to do it. ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH 4/5] staging: vc04_services: fix CamelCase

2016-10-26 Thread Dan Carpenter
On Wed, Oct 26, 2016 at 06:13:13PM -0700, Eric Anholt wrote: > Stefan Wahren writes: > > > This fixes the CamelCase of some variables. > > > > Signed-off-by: Stefan Wahren > > Greg, are these kinds of reformats something that you're looking for

Re: [PATCH 4/5] staging: vc04_services: fix CamelCase

2016-10-26 Thread Eric Anholt
Stefan Wahren writes: > This fixes the CamelCase of some variables. > > Signed-off-by: Stefan Wahren Greg, are these kinds of reformats something that you're looking for in the staging tree? I'm fine with the patch but I didn't see camel case

Re: [PATCH v2] staging: vc04_services: Replace dmac_map_area with dmac_map_sg

2016-10-26 Thread Eric Anholt
Michael Zoran writes: > The original arm implementation uses dmac_map_area which is not > portable. Replace it with an architecture neutral version > which uses dma_map_sg. > > As you can see that for larger page sizes, the dma_map_sg > implementation is faster then the

Re: [PATCH] staging: sm750fb: Refine the code and remove unused code.

2016-10-26 Thread Elise Lennion
On Wed, Oct 26, 2016 at 11:52:41AM +0300, Dan Carpenter wrote: > So, when I'm reviewing these, there are obviously a lot of patches that > go through staging and I try to do them as fast as possible and quite > often make mistakes. Feel free to speak up when that happens, I won't > be offended. >

RE: [PATCH] Drivers: hv: vmbus: Raise retry/wait limits in vmbus_post_msg()

2016-10-26 Thread KY Srinivasan
> -Original Message- > From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com] > Sent: Wednesday, October 26, 2016 4:12 AM > To: de...@linuxdriverproject.org > Cc: linux-ker...@vger.kernel.org; KY Srinivasan ; > Haiyang Zhang > Subject: [PATCH]

[PATCH 1/5] staging: vchiq_arm: add MODULE_DESCRIPTION

2016-10-26 Thread Stefan Wahren
This patch adds the missing module description for the driver. Signed-off-by: Stefan Wahren --- .../vc04_services/interface/vchiq_arm/vchiq_arm.c |1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/vc04_services/interface/vchiq_arm/vchiq_arm.c

[PATCH 3/5] staging: vchiq_shim: avoid code duplication

2016-10-26 Thread Stefan Wahren
Rearrange the polling loops in order to avoid code duplication. Btw we fix the style of the comments. Signed-off-by: Stefan Wahren --- .../vc04_services/interface/vchiq_arm/vchiq_shim.c | 56 +++- 1 file changed, 31 insertions(+), 25 deletions(-) diff

[PATCH 4/5] staging: vc04_services: fix CamelCase

2016-10-26 Thread Stefan Wahren
This fixes the CamelCase of some variables. Signed-off-by: Stefan Wahren --- .../vc04_services/interface/vchiq_arm/vchiq_core.c | 26 ++-- .../interface/vchiq_arm/vchiq_kern_lib.c |4 +-- .../interface/vchiq_arm/vchiq_memdrv.h

[PATCH 2/5] staging: vchiq_arm: Make DT firmware node mandatory

2016-10-26 Thread Stefan Wahren
In Linux Mainline there wasn't a chance to boot the RPi without DT. So we can make the firmware node mandatory. Signed-off-by: Stefan Wahren --- .../vc04_services/interface/vchiq_arm/vchiq_arm.c |3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git

[PATCH 5/5] staging: vc04_services: use bcm2835 consequently

2016-10-26 Thread Stefan Wahren
The naming bcm2708 is used only in the vendor kernel, so better replace it with bcm2835 which is used in mainline in order to avoid any confusion. Signed-off-by: Stefan Wahren --- drivers/staging/Makefile |2 +- drivers/staging/vc04_services/Kconfig |

[PATCH] vmbus: make sysfs names consistent with PCI

2016-10-26 Thread Stephen Hemminger
From: Stephen Hemminger In commit 9a56e5d6a0ba ("Drivers: hv: make VMBus bus ids persistent") the name of vmbus devices in sysfs changed to be (in 4.9-rc1): /sys/bus/vmbus/vmbus-6aebe374-9ba0-11e6-933c-00259086b36b The prefix ("vmbus-") is redundant and differs from

[PATCH v2 08/12] staging: fsl-mc: improve message clarity by adding __func__

2016-10-26 Thread Stuart Yoder
clarify some error messages by printing the actual function name involved Signed-off-by: Stuart Yoder --- -v2 -patch is result of split of original patch, updated commit messasge to reflect the change drivers/staging/fsl-mc/bus/fsl-mc-bus.c | 7 ++- 1 file

[PATCH v2 10/12] staging: fsl-mc: improve wording in comments

2016-10-26 Thread Stuart Yoder
improve and clarify miscellaneous comments in the bus driver and allocator Signed-off-by: Stuart Yoder --- -v2 -update/improve commit message drivers/staging/fsl-mc/bus/fsl-mc-allocator.c | 68 +-- drivers/staging/fsl-mc/bus/fsl-mc-bus.c |

[PATCH v2 12/12] staging: fsl-mc: uprev binary interface to match MC v10.x

2016-10-26 Thread Stuart Yoder
From: Ioana Ciornei DPAA2 will not support MC firmware versions prior to MC v10.x. Update the MC interface code and drivers to reflect this. -update the object .h files and code that builds commands to include the new command version in the command header -object

[PATCH v2 09/12] staging: fsl-mc: cleanup: improve clarity of messages

2016-10-26 Thread Stuart Yoder
improve some messages by shortening and rewording Signed-off-by: Stuart Yoder --- -v2 -patch is result of split of original patch, updated commit messasge to reflect the change drivers/staging/fsl-mc/bus/fsl-mc-allocator.c | 4 ++--

[PATCH v2 11/12] staging: fsl-mc: update copyright dates

2016-10-26 Thread Stuart Yoder
Many source files have evolved without copyright date updates. Update the dates to reflect work through 2016. Signed-off-by: Stuart Yoder --- -v2 -no changes drivers/staging/fsl-mc/bus/dpcon-cmd.h | 2 +- drivers/staging/fsl-mc/bus/dpmcp.h

[PATCH v2 06/12] staging: fsl-mc: cleanup comment style

2016-10-26 Thread Stuart Yoder
Be consistent and use kernel-preferred multi-line comment style everywhere. Signed-off-by: Stuart Yoder --- -v2 -no changes drivers/staging/fsl-mc/bus/dpbp-cmd.h | 3 ++- drivers/staging/fsl-mc/bus/dpbp.c | 3 ++- drivers/staging/fsl-mc/bus/dpcon-cmd.h | 3

[PATCH v2 03/12] staging: fsl-mc: whitespace cleanup: remove extraenous tabs

2016-10-26 Thread Stuart Yoder
use one tab to separate name and value in #define definitions Signed-off-by: Stuart Yoder --- -v2 -patch is result of split of original patch, updated commit messasge and author to reflect the change drivers/staging/fsl-mc/include/dprc.h | 10 +- 1 file

[PATCH v2 07/12] staging: fsl-mc: improve pr_* messages

2016-10-26 Thread Stuart Yoder
define pr_fmt so non dev_* messages will have an fsl-mc prefix and remove "fsl-mc" from messages where it would now be redundant Signed-off-by: Stuart Yoder --- -v2 -patch is result of split of original patch, updated commit messasge to reflect the change

[PATCH v2 05/12] staging: fsl-mc: whitespace cleanup: improve alignment in prototypes

2016-10-26 Thread Stuart Yoder
From: Ioana Ciornei To improve readability for structs and function definitions, separate type and variable name by a single space, instead of an inconsistent number of tabs. Signed-off-by: Ioana Ciornei Signed-off-by: Stuart Yoder

[PATCH v2 04/12] staging: fsl-mc: whitespace cleanup: align function args

2016-10-26 Thread Stuart Yoder
From: Ioana Ciornei align function arguments that were not aligned to the starting parenthesis Signed-off-by: Ioana Ciornei Signed-off-by: Stuart Yoder --- -v2 -patch is result of split of original patch, updated

[PATCH v2 02/12] staging: fsl-mc: whitespace cleanup: remove blank lines

2016-10-26 Thread Stuart Yoder
remove instances of multiple blank lines in comments Signed-off-by: Stuart Yoder --- -v2 -patch is result of split of original patch, updated commit messasge and author to reflect the change drivers/staging/fsl-mc/bus/dpbp-cmd.h | 1 -

[PATCH v2 00/12] staging: fsl-mc: cleanup and uprev to MC v10.x

2016-10-26 Thread Stuart Yoder
This patch does miscellaneous minor cleanup and uprevs the supported MC firmware version to 10.x. version 2 changes -move MAINTAINERS change so it's sorted properly -split whitespace cleanup into separate patches -split message cleanup into separate patches -use pr_fmt to set a message

[PATCH v2 01/12] staging: fsl-mc: update MAINTAINERS

2016-10-26 Thread Stuart Yoder
-German has moved on to other things and wished to be removed as a maintainer -cleanup the driver description to use the proper name of the driver (i.e. the fsl-mc bus driver) and remove incorrect references to Freescale Signed-off-by: Stuart Yoder Acked-by: J. German

Re: [PATCH 2/3] staging: most: hdm-usb: do h/w specific synchronization at configuration time

2016-10-26 Thread Dan Carpenter
On Tue, Oct 25, 2016 at 05:44:20PM +0200, Christian Gromm wrote: > From: Andrey Shvetsov > > This patch puts the synchronization procedure trigger for asynchronous > channels into the function hdm_configure_channel. Likewise, it removes > triggering of hardware specific

RE: [PATCH] Drivers: hv: vmbus: Raise retry/wait limits in vmbus_post_msg()

2016-10-26 Thread Haiyang Zhang
> -Original Message- > From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com] > Sent: Wednesday, October 26, 2016 7:12 AM > To: de...@linuxdriverproject.org > Cc: linux-ker...@vger.kernel.org; KY Srinivasan ; > Haiyang Zhang > Subject: [PATCH]

[PATCH] Drivers: hv: vmbus: Raise retry/wait limits in vmbus_post_msg()

2016-10-26 Thread Vitaly Kuznetsov
DoS protection conditions were altered in WS2016 and now it's easy to get -EAGAIN returned from vmbus_post_msg() (e.g. when we try changing MTU on a netvsc device in a loop). All vmbus_post_msg() callers don't retry the operation and we usually end up with a non-functional device or crash. While

Re: [PATCH] staging: iio: cdc/ad7746: fix missing return value

2016-10-26 Thread Eva Rachel Retuya
On Tue, Oct 25, 2016 at 05:27:07PM +0100, Jonathan Cameron wrote: > On 25/10/16 16:56, Arnd Bergmann wrote: > > As found by "gcc -Wmaybe-uninitialized", the latest change to the > > driver lacked an initalization for the return code in one of the > > added cases: > > > >

Re: [PATCH] staging : rtl8712: Free memory when kmalloc fails

2016-10-26 Thread Souptick Joarder
On Wed, Oct 26, 2016 at 12:39 PM, Greg KH wrote: > On Wed, Oct 26, 2016 at 12:30:26PM +0530, Souptick Joarder wrote: >> There are few functions where we need to free previously allocated memory >> when kmalloc fails. Else it may lead to memory leakage. >> In

Re: [PATCH] staging: sm750fb: Refine the code and remove unused code.

2016-10-26 Thread Dan Carpenter
So, when I'm reviewing these, there are obviously a lot of patches that go through staging and I try to do them as fast as possible and quite often make mistakes. Feel free to speak up when that happens, I won't be offended. I use a script to review them which strips our all the white space

Re: [PATCH] staging: sm750fb: Refine the code and remove unused code.

2016-10-26 Thread Dan Carpenter
No actually, what you did is fine. It all sort of hangs together... You may as well get rid of the ctrl parameter when you get rid of the macro otherwise it just creates a lot of busy work. Reviewed-by: Dan Carpenter regards, dan carpenter

Re: [PATCH] staging: sm750fb: Refine the code and remove unused code.

2016-10-26 Thread Dan Carpenter
On Wed, Oct 26, 2016 at 12:03:43AM -0200, Elise Lennion wrote: > Every call to the function waitNextVerticalSync() used the macro > primaryWaitVerticalSync(), so the macro was removed and the function > waitNextVerticalSync() renamed to primary_wait_vertical_sync(). > > With this change, an

Re: [PATCH] staging : rtl8712: Free memory when kmalloc fails

2016-10-26 Thread Greg KH
On Wed, Oct 26, 2016 at 12:30:26PM +0530, Souptick Joarder wrote: > There are few functions where we need to free previously allocated memory > when kmalloc fails. Else it may lead to memory leakage. > In _init_cmd_priv() and _r8712_init_xmit_priv(),in few places we are not > freeing previously

Re: [PATCH 0/9] staging: fsl-mc: move bus driver out of staging, add dpio

2016-10-26 Thread Alexander Graf
On 10/26/2016 04:35 AM, Stuart Yoder wrote: -Original Message- From: Alexander Graf [mailto:ag...@suse.de] Sent: Monday, October 24, 2016 9:34 AM To: Stuart Yoder ; gre...@linuxfoundation.org Cc: German Rivera ; de...@driverdev.osuosl.org;

[PATCH] staging : rtl8712: Free memory when kmalloc fails

2016-10-26 Thread Souptick Joarder
There are few functions where we need to free previously allocated memory when kmalloc fails. Else it may lead to memory leakage. In _init_cmd_priv() and _r8712_init_xmit_priv(),in few places we are not freeing previously allocated memory when kmalloc fails. This patch will address it.

Re: [PATCH] staging: rtl8712: Free memory and return failure when kmalloc fails

2016-10-26 Thread Souptick Joarder
On Tue, Oct 25, 2016 at 11:41 PM, Greg KH wrote: > On Tue, Oct 25, 2016 at 10:06:48PM +0530, Souptick Joarder wrote: >> Hi Greg, >> >> >> On Tue, Oct 25, 2016 at 2:33 PM, Greg KH wrote: >> > On Thu, Oct 20, 2016 at 12:29:33PM +0530,

Re: [PATCH v2] staging: vc04_services: Replace dmac_map_area with dmac_map_sg

2016-10-26 Thread Greg KH
On Tue, Oct 25, 2016 at 07:23:27PM -0700, Michael Zoran wrote: > The original arm implementation uses dmac_map_area which is not > portable. Replace it with an architecture neutral version > which uses dma_map_sg. > > As you can see that for larger page sizes, the dma_map_sg > implementation is