[PATCH 2/2] staging: sm750fb: Remove typedefs from enum

2017-03-21 Thread Arushi Singhal
This patch removes typedefs from enum and renames them as per kernel coding standards. Signed-off-by: Arushi Singhal --- drivers/staging/sm750fb/ddk750_mode.h | 11 +-- 1 file changed, 5 insertions(+), 6 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_mode.h b/drivers/staging/

[PATCH 1/2] staging: sm750fb: Remove typedefs from struct

2017-03-21 Thread Arushi Singhal
This patch removes typedefs from structure and renames them as per kernel coding standards. Signed-off-by: Arushi Singhal --- drivers/staging/sm750fb/ddk750_mode.c | 8 +--- drivers/staging/sm750fb/ddk750_mode.h | 8 +++- drivers/staging/sm750fb/sm750_hw.c| 2 +- 3 files changed, 9 i

[PATCH 0/2] Remove Typrdefs

2017-03-21 Thread Arushi Singhal
Typedefs are removed in sm750fb driver. Arushi Singhal (2): staging: sm750fb: Remove typedefs from struct staging: sm750fb: Remove typedefs from enum drivers/staging/sm750fb/ddk750_mode.c | 8 +--- drivers/staging/sm750fb/ddk750_mode.h | 19 --- drivers/staging/sm750fb/s

Re: [PATCH v4 14/36] [media] v4l2-mc: add a function to inherit controls from a pipeline

2017-03-21 Thread Pavel Machek
Hi! > > Making use of the full potential of the hardware requires using a more > > expressive interface. > > That's the core of the problem: most users don't need "full potential > of the hardware". It is actually worse than that: several boards > don't allow "full potential" of the SoC capabili

Re: [PATCH v5 00/39] i.MX Media Driver

2017-03-21 Thread Hans Verkuil
On 03/21/17 11:42, Niklas Söderlund wrote: > On 2017-03-20 16:57:54 +0100, Hans Verkuil wrote: >> On 03/20/2017 03:11 PM, Russell King - ARM Linux wrote: >>> On Mon, Mar 20, 2017 at 02:57:03PM +0100, Hans Verkuil wrote: On 03/20/2017 02:29 PM, Russell King - ARM Linux wrote: > It's what I

Re: [PATCH v5 00/39] i.MX Media Driver

2017-03-21 Thread Niklas Söderlund
On 2017-03-20 16:57:54 +0100, Hans Verkuil wrote: > On 03/20/2017 03:11 PM, Russell King - ARM Linux wrote: > > On Mon, Mar 20, 2017 at 02:57:03PM +0100, Hans Verkuil wrote: > >> On 03/20/2017 02:29 PM, Russell King - ARM Linux wrote: > >>> It's what I have - remember, not everyone is happy to cons

Re: [PATCH 2/5] staging: bcm2835-camera: Fix integer underrun in port_parameter_get

2017-03-21 Thread Dan Carpenter
You're fixing a bug you introduced in [PATCH 1/5]. Don't do that. Just fix Dave's patch and add a note in the commit log. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listin

[PATCH v5 6/6] staging: rtl8192e: Fix blank lines and space after a cast

2017-03-21 Thread suniel . spartan
From: Suniel Mahesh Fixed the following checkpatch.pl checks: Blank lines aren't necessary after an open brace '{' and before a close brace '}', removed No space is necessary after a cast, removed Please don't use multiple blank lines, removed Signed-off-by: Suniel Mahesh --- Changes for v5: -

[PATCH v5 5/6] staging: rtl8192e: Fix issues reported by checkpatch.pl

2017-03-21 Thread suniel . spartan
From: Suniel Mahesh Fixed the following checkpatch.pl checks: spaces preferred around that 'operator', spacing provided Logical continuations should be on the previous line, modified accordingly Unnecessary parentheses around variables, removed Please use a blank line after function/struct/union/

[PATCH v5 2/6] staging: rtl8192e: Remove unnecessary 'out of memory' message

2017-03-21 Thread suniel . spartan
From: Suniel Mahesh Fixed the following checkpatch.pl warning: Possible unnecessary 'out of memory' message If it is out of memory, function should return with an appropriate error code. Since this function is of type void, a return statement is used. Signed-off-by: Suniel Mahesh --- Changes fo

[PATCH v5 1/6] staging: rtl8192e: Fix comments as per kernel coding style

2017-03-21 Thread suniel . spartan
From: Suniel Mahesh Fixed the following checkpatch.pl warnings: Block comments should align the * on each line Block comments use * on subsequent lines Signed-off-by: Suniel Mahesh --- Changes for v5: - Changed email address from suni...@techveda.org to suniel.spar...@gmail.com, reason being

[PATCH v5 4/6] staging: rtl8192e: Pass a pointer as an argument to sizeof() instead of struct

2017-03-21 Thread suniel . spartan
From: Suniel Mahesh Replaced sizeof(struct foo) into sizeof(*ptr), found by checkpatch.pl Signed-off-by: Suniel Mahesh --- Changes for v5: - Changed email address from suni...@techveda.org to suniel.spar...@gmail.com, reason being few patches were being dropped and not getting delivered, c

[PATCH v5 0/6] staging: rtl8192e: Fix coding style, warnings and checks

2017-03-21 Thread suniel . spartan
From: Suniel Mahesh Changed email address from suni...@techveda.org to suniel.spar...@gmail.com, reason being few patches were being dropped and not getting delivered, couldn't resolve that issue. Split earlier patches into multiple commits for easy review as suggested by Dan Carpenter. Modified

[PATCH v5 3/6] staging: rtl8192e: Rectify pointer comparisions with NULL

2017-03-21 Thread suniel . spartan
From: Suniel Mahesh This patch simplifies code by replacing explicit NULL comparison with ! or unmark operator Reported by checkpatch.pl for comparison to NULL could be written '!foo' or 'foo' Signed-off-by: Suniel Mahesh --- Changes for v5: - Changed email address from suni...@techveda.org to

[PATCH 4/4] staging: speakup: Fix alignment with parenthesis.

2017-03-21 Thread Arushi Singhal
This patch fixes the warnings reported by checkpatch.pl for please use a blank line after function/struct/union/enum declarations. Signed-off-by: Arushi Singhal --- drivers/staging/speakup/speakup_apollo.c | 2 +- drivers/staging/speakup/speakup_decext.c | 4 ++-- 2 files changed, 3 insertions(+

[PATCH 3/4] staging: speakup: Match alignment with open parenthesis.

2017-03-21 Thread Arushi Singhal
Fix checkpatch issues: "CHECK: Alignment should match open parenthesis". Signed-off-by: Arushi Singhal --- drivers/staging/speakup/main.c | 2 +- drivers/staging/speakup/selection.c | 2 +- drivers/staging/speakup/serialio.c | 2 +- drivers/staging/speakup/speakup_acntpc.c |

[PATCH 1/4] staging: speakup: Removed Unnecessary parentheses.

2017-03-21 Thread Arushi Singhal
Unnecessary parentheses are removed to improve readability. Signed-off-by: Arushi Singhal --- drivers/staging/speakup/kobjects.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/speakup/kobjects.c b/drivers/staging/speakup/kobjects.c index afb61e153592..ca8547

[PATCH 2/4] staging: speakup: Simplify the NULL comparisons

2017-03-21 Thread Arushi Singhal
Fixed coding style for null comparisons in speakup driver to be more consistant with the rest of the kernel coding style. Replaced 'x != NULL' with 'x' and 'x = NULL' with '!x'. Signed-off-by: Arushi Singhal --- drivers/staging/speakup/fakekey.c | 2 +- drivers/staging/speakup/main.c| 32 ++

[PATCH 0/4] staging: speakup: Checkpatch issues.

2017-03-21 Thread Arushi Singhal
Improve readability by fixing multiple checkpatch.pl issues in speakup driver. Arushi Singhal (4): staging: speakup: Removed Unnecessary parentheses. staging: speakup: Simplify the NULL comparisons staging: speakup: Match alignment with open parenthesis. staging: speakup: Fix alignment wit

Re: [PATCH 1/5] bcm2835-camera: Correct port_parameter_get return value

2017-03-21 Thread Michael Zoran
On Tue, 2017-03-21 at 08:27 +0100, Greg KH wrote: > On Fri, Mar 17, 2017 at 02:56:42PM -0700, Michael Zoran wrote: > > From: Dave Stevenson > > > > The API for port_parameter_get() requires that the > > filled length is returned, or if insufficient space > > that the required space is returned. >

[PATCH 7/7] staging: speakup: spaces preferred around operator

2017-03-21 Thread Arushi Singhal
Fixed the checkpatch.pl issues like: CHECK: spaces preferred around that '&' (ctx:VxV) CHECK: spaces preferred around that '|' (ctx:VxV) CHECK: spaces preferred around that '-' (ctx:VxV) CHECK: spaces preferred around that '+' (ctx:VxV) etc. Signed-off-by: Arushi Singhal --- drivers/staging/spea

[PATCH 3/7] staging: speakup: Simplify "NULL" comparisons

2017-03-21 Thread Arushi Singhal
Fixed coding style for null comparisons in speakup driver to be more consistant with the rest of the kernel coding style. Replaced 'x != NULL' with 'x' and 'x = NULL' with '!x'. Signed-off-by: Arushi Singhal --- drivers/staging/speakup/selection.c | 2 +- drivers/staging/speakup/varhandlers.c

[PATCH 6/7] staging: speakup: Moved OR operator to previous line.

2017-03-21 Thread Arushi Singhal
Moved logical OR operator to previous line to fix the following checkpatch issue: CHECK: Logical continuations should be on the previous line. Signed-off-by: Arushi Singhal --- drivers/staging/speakup/main.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/sta

[PATCH 5/7] staging: speakup: Remove multiple assignments

2017-03-21 Thread Arushi Singhal
This patch fixes the checkpatch.pl warning "multiple assignments should be avoided." Signed-off-by: Arushi Singhal --- drivers/staging/speakup/main.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/speakup/main.c b/drivers/staging/speakup/main.c index 21e76b

[PATCH 2/7] staging: speakup: Remove multiple assignments

2017-03-21 Thread Arushi Singhal
This patch fixes the checkpatch.pl warning "multiple assignments should be avoided." Signed-off-by: Arushi Singhal --- drivers/staging/speakup/main.c | 18 -- 1 file changed, 12 insertions(+), 6 deletions(-) diff --git a/drivers/staging/speakup/main.c b/drivers/staging/speakup/m

[PATCH 1/7] staging: speakup: Moved logical to previous line.

2017-03-21 Thread Arushi Singhal
Moved logical AND operators to previous line to fix the following checkpatch issue: CHECK: Logical continuations should be on the previous line. Signed-off-by: Arushi Singhal --- drivers/staging/speakup/main.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/driv

[PATCH 0/7] staging: speakup: Multiple CheckPatch issues.

2017-03-21 Thread Arushi Singhal
Improve readability by fixing multiple checkpatch.pl issues in speakup driver. Arushi Singhal (7): staging: speakup: Moved logical to previous line. staging: speakup: Remove multiple assignments staging: speakup: Simplify "NULL" comparisons staging: speakup: fixes braces {} should be used

[PATCH 4/7] staging: speakup: fixes braces {} should be used on all arms of this statement

2017-03-21 Thread Arushi Singhal
This patch fixes the checks reported by checkpatch.pl for braces {} should be used on all arms of this statement. Signed-off-by: Arushi Singhal --- drivers/staging/speakup/main.c | 35 +++- drivers/staging/speakup/speakup_decext.c | 6 +++--- drivers/stagin

Re: [PATCH] Staging: ks7010 - fixed style block comments

2017-03-21 Thread Greg KH
On Sun, Mar 19, 2017 at 01:07:17PM +1300, Derek Robson wrote: > Fixed style of all block comments across whole driver > Found by checkpatch > > Signed-off-by: Derek Robson > --- > drivers/staging/ks7010/ks7010_sdio.c | 3 ++- > drivers/staging/ks7010/ks_hostif.h | 35 +

Re: [PATCH] staging: dgnc: fix printk warnings in dgnc_tty.c

2017-03-21 Thread Greg KH
On Sun, Mar 19, 2017 at 03:46:11AM -0700, absh...@gmail.com wrote: > From: Abhishek Bhardwaj > > Use __func__ to print dgnc_tty_send_xchar function name. > > Signed-off-by: Abhishek Bhardwaj > --- > drivers/staging/dgnc/dgnc_tty.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) >

Re: [PATCH] vc04_services: Fixing coding guideline error

2017-03-21 Thread Greg Kroah-Hartman
On Wed, Mar 15, 2017 at 12:01:08PM +0530, Pushkar Jambhlekar wrote: > Fixing 'if' block coding style. '{' should follow 'if' for multiline block > > Signed-off-by: Pushkar Jambhlekar > --- > drivers/staging/vc04_services/interface/vchiq_arm/vchiq_shim.c | 3 +-- > 1 file changed, 1 insertion(+),

Re: [PATCH 2/5] staging: bcm2835-camera: Fix integer underrun in port_parameter_get

2017-03-21 Thread Greg KH
On Fri, Mar 17, 2017 at 02:56:43PM -0700, Michael Zoran wrote: > Fix port_paremeter_get function blindly subtracts 8 from a reply > size without checking that the size is at lest 8 bytes. This can > casue a large buffer to be copied since the size is unsigned. > > Add a WARN_ON, and also add min a

Re: [PATCH 1/5] bcm2835-camera: Correct port_parameter_get return value

2017-03-21 Thread Greg KH
On Fri, Mar 17, 2017 at 02:56:42PM -0700, Michael Zoran wrote: > From: Dave Stevenson > > The API for port_parameter_get() requires that the > filled length is returned, or if insufficient space > that the required space is returned. > > Signed-off-by: Dave Stevenson > > Changed path: > From:

Re: [PATCH 24/29] drivers: convert iblock_req.pending from atomic_t to refcount_t

2017-03-21 Thread Nicholas A. Bellinger
Hi Elena, On Mon, 2017-03-06 at 16:21 +0200, Elena Reshetova wrote: > refcount_t type and corresponding API should be > used instead of atomic_t when the variable is used as > a reference counter. This allows to avoid accidental > refcounter overflows that might lead to use-after-free > situations

[PATCH staging/speakup v3 2/3] remove unnecessary initial allocation of vc

2017-03-21 Thread Pranay Kr. Srivastava
This patch removes the unnecessary allocation of current foreground vc during initialization. This initialization is already handled in the loop that follows it for all available virtual consoles. Signed-off-by: Pranay Kr. Srivastava Reviewed-by: Samuel Thibault --- drivers/staging/speakup/mai

[PATCH staging/speakup v3 1/3] return same error value from spk_set_key_info

2017-03-21 Thread Pranay Kr. Srivastava
This patch makes spk_set_key_info return -EINVAL in case of failure instead of returning 4 different values for the type of error that occurred. Print the offending values instead as debug message. Signed-off-by: Pranay Kr. Srivastava --- drivers/staging/speakup/main.c | 27 +++-

[PATCH staging/speakup v3 3/3] use speakup_allocate as per required context

2017-03-21 Thread Pranay Kr. Srivastava
speakup_allocate used GFP_ATOMIC for allocations even while during initialization due to it's use in notifier call. Pass GFP_ flags as well to speakup_allocate depending on the context it is called in. Signed-off-by: Pranay Kr. Srivastava --- drivers/staging/speakup/main.c | 8 1 file

[PATCH staging/speakup v3 0/3] cleanup error and initilization

2017-03-21 Thread Pranay Kr. Srivastava
Changelog from v2: Fixed the message subject line. Changelog from v1: 1. fixed kbuild warning for i386 build as reported by kbuild robot 2. split initialization code in two patches. Pranay Kr. Srivastava (3): return same error value from spk_set_key_info remove unece

Re: [PATCH 00/36] staging: unisys: additional code cleanups

2017-03-21 Thread Greg KH
On Fri, Mar 17, 2017 at 11:26:51AM -0400, David Kershner wrote: > This series cleans up several different checkpatch, sparse and other > miscellaneous code issues found throughout the Unisys s-Par driver stack. > It also cleans up the comments surrounding #defines. > > Note: Acceptence of this pat

<    1   2