Re: [PATCH 08/10] x86/hyper-v: use hypercall for remote TLB flush

2017-06-30 Thread kbuild test robot
Hi Vitaly, [auto build test WARNING on next-20170619] [cannot apply to tip/x86/core linus/master linux/master v4.12-rc6 v4.12-rc5 v4.12-rc4 v4.12-rc7] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/linux/com

[PATCH 4/4] staging: vt6656: Use variable instead of its type in sizeof(...)

2017-06-30 Thread Simon Sandström
Use sizeof(variable) instead of sizeof(type) in memory allocations to prevent problems if the variable type changes in the future. Signed-off-by: Simon Sandström --- drivers/staging/vt6656/main_usb.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/staging/vt6656/

[PATCH 3/4] staging: vt6656: Align function parameters

2017-06-30 Thread Simon Sandström
Fixes checkpatch.pl warnings "Alignment should match open parenthesis". Signed-off-by: Simon Sandström --- drivers/staging/vt6656/key.h | 2 +- drivers/staging/vt6656/rf.c | 2 +- drivers/staging/vt6656/usbpipe.c | 4 ++-- 3 files changed, 4 insertions(+), 4 deletions(-) diff --git a/d

[PATCH 2/4] staging: vt6656: Remove unnecessary blank lines

2017-06-30 Thread Simon Sandström
Fixes checkpatch.pl warning "Blank lines aren't necessary after an open brace". Also adds braces to balance if-else statement. Signed-off-by: Simon Sandström --- drivers/staging/vt6656/power.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/drivers/staging/vt6656/power.

[PATCH 0/4] staging: vt6656: Correct checkpatch.pl warnings

2017-06-30 Thread Simon Sandström
Here are some minor checkpatch.pl corrections to staging/vt6656. I was about to ask before sending these in if you rather see commits grouped on file or on type of warning, e.g. each commit fixes multiple types of warnings in a single file versus each commit fixes one type of warning in multiple f

[PATCH 1/4] staging: vt6656: Add spaces between operators

2017-06-30 Thread Simon Sandström
Fixes checkpatch.pl warnings "spaces preferred around that ". Signed-off-by: Simon Sandström --- drivers/staging/vt6656/device.h | 2 +- drivers/staging/vt6656/firmware.c | 2 +- drivers/staging/vt6656/rf.c | 4 ++-- 3 files changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/

[PATCH RESEND] staging: sm750fb: avoid conflicting vesafb

2017-06-30 Thread Sudip Mukherjee
From: Teddy Wang If vesafb is enabled in the config then /dev/fb0 is created by vesa and this sm750 driver gets fb1, fb2. But we need to be fb0 and fb1 to effectively work with xorg. So if it has been alloted fb1, then try to remove the other fb0. Cc: # v4.4+ Signed-off-by: Teddy Wang Signed-o

[PATCH 07/25] staging: unisys: visorbus: visorchipset.c: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of the lines. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorchipset.c | 10 ++ 1 file changed, 6 insertions(+), 4 deletions(-) diff --git a/drivers/staging/unisys/vi

[PATCH 25/25] staging: unisys: visorbus: fix improper bracket blocks

2017-06-30 Thread David Kershner
From: Erik Arfvidson This patch fixes visorbus_main.c improper function brackets. for the following functions: partition_handle_show partition_guid_show partition_name_show channel_addr_show channel_bytes_show channel_id_show Signed-off-by: Erik Arfvidson Signed-off-by: David Kershner --- dri

[PATCH 17/25] staging: unisys: visorhba: Fix up existing function comments

2017-06-30 Thread David Kershner
From: David Binder Refactors existing static function comments to increase code readability. Signed-off-by: David Binder Signed-off-by: David Kershner --- drivers/staging/unisys/visorhba/visorhba_main.c | 325 - 1 file changed, 170 insertions(+), 155 deletions(-) diff --git a

[PATCH 21/25] staging: unisys: visorbus: controlvmchannel.h: Adjust whitespace usage

2017-06-30 Thread David Kershner
From: David Binder Removes unnecessary blank lines to create a more uniform coding style. Signed-off-by: David Binder Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/controlvmchannel.h | 9 - 1 file changed, 9 deletions(-) diff --git a/drivers/staging/unisys/visorb

[PATCH 16/25] staging: unisys: visorbus: Rename #define to fit surrounding namespace

2017-06-30 Thread David Kershner
From: David Binder Renames MYDRVNAME to better fit with the surrounding driver namespace. Signed-off-by: David Binder Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorchannel.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/unis

[PATCH 10/25] staging: unisys: visornic: visornic_main.c: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of the lines. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/visornic/visornic_main.c | 98 +++--- 1 file changed, 61 insertions(+), 37 deletions(-) diff --git a/drivers/stagin

[PATCH 12/25] staging: unisys: visorinput: visorinput.c: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of the lines. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/visorinput/visorinput.c | 20 +++ 1 file changed, 12 insertions(+), 8 deletions(-) diff --git a/drivers/staging

[PATCH 22/25] staging: unisys: visorbus: adjust tabs in function

2017-06-30 Thread David Kershner
From: Steve Wilson Removed extra tabs in visorbus_get_device_by_id function. Signed-off-by: Steve Wilson Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorchipset.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/unisys/visorbus/v

[PATCH 11/25] staging: unisys: visorhba: visorhba_main.c: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of the lines. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/visorhba/visorhba_main.c | 33 -- 1 file changed, 22 insertions(+), 11 deletions(-) diff --git a/drivers/stagin

[PATCH 20/25] staging: unisys: include: visorbus.h: Adjust whitespace usage

2017-06-30 Thread David Kershner
From: David Binder Adjusts presence of blank lines to create a more uniform coding style. Signed-off-by: David Binder Signed-off-by: David Kershner --- drivers/staging/unisys/include/visorbus.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/unisys/include/

[PATCH 09/25] staging: unisys: include: iochannel.h: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of the lines. Added kernel-doc like comments and cleaned up the inline comments in the structures. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/include/iochannel.h | 492

[PATCH 14/25] staging: unisys: include: Fix spelling mistake

2017-06-30 Thread David Kershner
From: David Binder Fixes minor spelling mistake: stired -> stored. Signed-off-by: David Binder Signed-off-by: David Kershner --- drivers/staging/unisys/include/iochannel.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/unisys/include/iochannel.h b/drivers

[PATCH 23/25] staging: unisys: visorbus: Indent struct assignment correctly

2017-06-30 Thread David Kershner
From: Zachary Dremann Several structure initializations all had their members indented with 2 tabs instead of one. Remove the extra tabs. Signed-off-by: Zachary Dremann Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorbus_main.c | 42 +- 1 file changed, 2

[PATCH 15/25] staging: unisys: visorbus: Remove unused #define

2017-06-30 Thread David Kershner
From: David Binder Removes unused MYDRVNAME define. Signed-off-by: David Binder Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorbus_main.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/unisys/visorbus/visorbus_main.c b/drivers/staging/unisys/viso

[PATCH 18/25] staging: unisys: include: channel.h: Adjust whitespace usage

2017-06-30 Thread David Kershner
From: David Binder Adjusts spacing and removes unnecessary blank lines to create a more uniform coding style. Signed-off-by: David Binder Signed-off-by: David Kershner --- drivers/staging/unisys/include/channel.h | 7 +-- 1 file changed, 1 insertion(+), 6 deletions(-) diff --git a/driver

[PATCH 24/25] staging: unisys: visorbus: use __func__ over hardcoded name

2017-06-30 Thread David Kershner
From: Zachary Dremann As reported by checkpatch.pl, replace hardcoded uses of the current function's name in format strings with uses of __func__. Signed-off-by: Zachary Dremann Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorchipset.c | 2 +- 1 file changed, 1 insertio

[PATCH 19/25] staging: unisys: include: iochannel.h: Adjust whitespace usage

2017-06-30 Thread David Kershner
From: David Binder Adjusts spacing and removes unnecessary blank lines to create a more uniform coding style. Signed-off-by: David Binder Signed-off-by: David Kershner --- drivers/staging/unisys/include/iochannel.h | 11 ++- 1 file changed, 2 insertions(+), 9 deletions(-) diff --git

[PATCH 13/25] staging: unisys: visorinput: ultrainputreport.h: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of the lines. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/visorinput/ultrainputreport.h | 65 + 1 file changed, 28 insertions(+), 37 deletions(-) diff --git a/drivers/stagin

[PATCH 06/25] staging: unisys: visorbus: visorchannel.c: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of the lines. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorchannel.c | 22 +++ 1 file changed, 13 insertions(+), 9 deletions(-) diff --git a/drivers/staging

[PATCH 08/25] staging: unisys: include: channel.h: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of the lines. Added kernel-doc like comments and cleaned up the inline comments in the structures. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/include/channel.h | 263 +-

[PATCH 01/25] staging: unisys: visorbus: controlvmchannel.h: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of lines and fixed spacing in comments. Added kernel-doc like comments and cleaned up the inline comments in the structures. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/control

[PATCH 05/25] staging: unisys: include: remove unused macros in channel.h

2017-06-30 Thread David Kershner
Several MACROS were not in use by the code, get rid of them. Signed-off-by: David Kershner --- drivers/staging/unisys/include/channel.h | 21 - 1 file changed, 21 deletions(-) diff --git a/drivers/staging/unisys/include/channel.h b/drivers/staging/unisys/include/channel.h i

[PATCH 03/25] staging: unisys: visorbus: vmcallinterface.h: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of the lines. Added kernel-doc like comments and cleaned up the inline comments in the structures. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/vmcallinterface.h | 56 +-

[PATCH 04/25] staging: unisys: visorbus: visorbus_main.c: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of the lines. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/visorbus_main.c | 40 ++ 1 file changed, 23 insertions(+), 17 deletions(-) diff --git a/drivers/stagin

[PATCH 02/25] staging: unisys: visorbus: vbuschannel.h: fixed comment formatting issues

2017-06-30 Thread David Kershner
From: Sameer Wadgaonkar Removed comments from the right side of the lines. Added kernel-doc like comments and cleaned up the inline comments in the structures. Signed-off-by: Sameer Wadgaonkar Signed-off-by: David Kershner --- drivers/staging/unisys/visorbus/vbuschannel.h | 91 --

[PATCH 00/25] staging: unisys: Update comments and clean up whitespace

2017-06-30 Thread David Kershner
This patch series concentrates on cleaning-up comments and whitespace issues so that the code can be better examined. This series also fixes a couple checkpatch warnings. David Binder (8): staging: unisys: include: Fix spelling mistake staging: unisys: visorbus: Remove unused #define staging

Re: [PATCH] staging: ks7010: fix styling WARNINGs

2017-06-30 Thread Mark Rogers
Thank you for your feedback. I guess when making this patch I had the preferred coding style in mind, but didn't ask myself if making the code conform to it would truly improve readability. I agree with all of your comments. Do you think the best course of action is to create a new patch with this

[PATCH] staging: android: ion: statify __ion_add_cma_heaps

2017-06-30 Thread Kamal Heib
Fix the following sparse warning: symbol '__ion_add_cma_heaps' was not declared. Should it be static? Cc: Greg Kroah-Hartman Signed-off-by: Kamal Heib --- drivers/staging/android/ion/ion_cma_heap.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/android/ion/i

RE: [PATCH 0/6] staging: iio: tsl2x7x: staging cleanups

2017-06-30 Thread Jon Brenner
Hi Brian, Not sure about the DTS interrupt setting you mentioned but would like to know how you resolve - as I am planning on getting a Pi0w for some 'home personal projects'. Anyway (and I am sure you probably already know this - but just in case) WRT the device registers (on the TSL2771 for e

Re: [PATCH 0/6] staging: iio: tsl2x7x: staging cleanups

2017-06-30 Thread Brian Masney
On Thu, Jun 29, 2017 at 01:03:46PM -0400, Brian Masney wrote: > This begins my work to clean this driver up and eventually move it out > of staging. Driver changes were tested using a TSL2771 hooked up to a > Raspberry Pi 2. > > Thanks to Jon Brenner at AMS/TAOS for loaning me some hardware sample

[PATCH] staging: comedi: ni_mio_common: fix AO timer off-by-one regression

2017-06-30 Thread Ian Abbott
As reported by Éric Piel on the Comedi mailing list (see ), the analog output asynchronous commands are running too fast with a period 50 ns shorter than it should be. This affects all boards with AO command support that a

[PATCH] staging: wilc1000: fix a typo: "incative" -> "inactive"

2017-06-30 Thread Colin King
From: Colin Ian King Trivial fix to typos in netdev_err error messages. I should have spotted this in a previous round of spelling mistake checks on this driver but this one slipped through. Signed-off-by: Colin Ian King --- drivers/staging/wilc1000/host_interface.c | 4 ++-- 1 file changed, 2

RE: [PATCH] staging: fsl-dpaa2/eth: Remove dead code

2017-06-30 Thread Bogdan Purcareata
> -Original Message- > From: Ioana Radulescu [mailto:ruxandra.radule...@nxp.com] > Sent: Thursday, June 29, 2017 7:26 PM > To: gre...@linuxfoundation.org > Cc: de...@driverdev.osuosl.org; linux-ker...@vger.kernel.org; > ag...@suse.de; a...@arndb.de; linux-arm-ker...@lists.infradead.org; Bog

Re: [PATCH RESEND 0/7] Introduce MEDIA_VERSION to end KENREL_VERSION abuse in media

2017-06-30 Thread Johannes Thumshirn
On Thu, Jun 29, 2017 at 10:01:05AM -0700, Stephen Hemminger wrote: > If you read Linus's comments on version. > Driver version is meaningless and there is a desire to rip it out of all > drivers. The reason is that drivers must always behave the same, i.e you > can't use version to change API/ABI b