Re: [PATCH 6/8] staging: ccree: simplify pm manager using local var

2017-11-08 Thread Gilad Ben-Yossef
On Tue, Nov 7, 2017 at 12:43 PM, Dan Carpenter wrote: > On Tue, Nov 07, 2017 at 09:40:02AM +, Gilad Ben-Yossef wrote: >> --- a/drivers/staging/ccree/ssi_pm.c >> +++ b/drivers/staging/ccree/ssi_pm.c >> @@ -90,20 +90,24 @@ int cc_pm_resume(struct device *dev) >> int

Re: [PATCH 2/8] staging: ccree: use more readable func names

2017-11-08 Thread Gilad Ben-Yossef
Hi Dan, Thank you for reviewing the patch set. On Tue, Nov 7, 2017 at 12:30 PM, Dan Carpenter wrote: > > On Tue, Nov 07, 2017 at 09:39:58AM +, Gilad Ben-Yossef wrote: > > @@ -780,11 +766,10 @@ static inline int ssi_buffer_mgr_aead_chain_iv( > >

[PATCH v2 5/8] MIPS: Octeon: Automatically provision CVMSEG space.

2017-11-08 Thread David Daney
Remove CONFIG_CAVIUM_OCTEON_CVMSEG_SIZE and automatically calculate the amount of CVMSEG space needed. 1st 128-bytes: Use by IOBDMA 2nd 128-bytes: Reserved by kernel for scratch/TLS emulation. 3rd 128-bytes: OCTEON-III LMTLINE New config variable CONFIG_CAVIUM_OCTEON_EXTRA_CVMSEG provisions

[PATCH v2 2/8] MIPS: Octeon: Enable LMTDMA/LMTST operations.

2017-11-08 Thread David Daney
From: Carlos Munoz LMTDMA/LMTST operations move data between cores and I/O devices: * LMTST operations can send an address and a variable length (up to 128 bytes) of data to an I/O device. * LMTDMA operations can send an address and a variable length (up to 128) of data

[PATCH v2 4/8] MIPS: Octeon: Add Free Pointer Unit (FPA) support.

2017-11-08 Thread David Daney
From: Carlos Munoz >From the hardware user manual: "The FPA is a unit that maintains pools of pointers to free L2/DRAM memory. To provide QoS, the pools are referenced indirectly through 1024 auras. Both core software and hardware units allocate and free pointers."

[PATCH v2 3/8] MIPS: Octeon: Add a global resource manager.

2017-11-08 Thread David Daney
From: Carlos Munoz Add a global resource manager to manage tagged pointers within bootmem allocated memory. This is used by various functional blocks in the Octeon core like the FPA, Ethernet nexus, etc. Signed-off-by: Carlos Munoz Signed-off-by: Steven J.

[PATCH v2 6/8] staging: octeon: Remove USE_ASYNC_IOBDMA macro.

2017-11-08 Thread David Daney
Previous patch sets USE_ASYNC_IOBDMA to 1 unconditionally. Remove USE_ASYNC_IOBDMA from all if statements. Remove dead code caused by the change. Signed-off-by: David Daney --- drivers/staging/octeon/ethernet-defines.h | 6 --- drivers/staging/octeon/ethernet-rx.c

[PATCH v2 8/8] MAINTAINERS: Add entry for drivers/net/ethernet/cavium/octeon/octeon3-*

2017-11-08 Thread David Daney
Signed-off-by: David Daney --- MAINTAINERS | 6 ++ 1 file changed, 6 insertions(+) diff --git a/MAINTAINERS b/MAINTAINERS index 9a24f56e0451..142af33adc35 100644 --- a/MAINTAINERS +++ b/MAINTAINERS @@ -3212,6 +3212,12 @@ W: http://www.cavium.com S:

[PATCH v2 1/8] dt-bindings: Add Cavium Octeon Common Ethernet Interface.

2017-11-08 Thread David Daney
From: Carlos Munoz Add bindings for Common Ethernet Interface (BGX) block. Signed-off-by: Carlos Munoz Signed-off-by: Steven J. Hill Signed-off-by: David Daney ---

[PATCH v2 0/8] Cavium OCTEON-III network driver.

2017-11-08 Thread David Daney
We are adding the Cavium OCTEON-III network driver. But since interacting with the input and output queues is done via special CPU local memory, we also need to add support to the MIPS/Octeon architecture code. Aren't SoCs nice in this way? The first six patches add the SoC support needed by

Re: [PATCH 06/11] staging: lustre: add SPDX identifiers to all lustre files

2017-11-08 Thread Dilger, Andreas
On Nov 7, 2017, at 23:15, Greg Kroah-Hartman wrote: > > On Wed, Nov 08, 2017 at 12:35:43AM +, Dilger, Andreas wrote: >> On Nov 7, 2017, at 06:58, Greg Kroah-Hartman >> wrote: >>> >>> It's good to have SPDX identifiers in all files to

Re: [PATCH 9/9] staging: android: Remove redundant license text

2017-11-08 Thread Laura Abbott
On 11/07/2017 12:07 PM, Greg Kroah-Hartman wrote: Now that the SPDX tag is in all android files, that identifies the license in a specific and legally-defined manner. So the extra GPL text wording can be removed as it is no longer needed at all. This is done on a quest to remove the 700+

Re: [PATCH 6/9] staging: android: add SPDX identifiers to all android driver files

2017-11-08 Thread Laura Abbott
On 11/07/2017 12:07 PM, Greg Kroah-Hartman wrote: It's good to have SPDX identifiers in all files to make it easier to audit the kernel tree for correct licenses. Update the android driver files with the correct SPDX license identifier based on the license text in the file itself. The SPDX

RE: [Revised PATCH v2] hv: kvp: Avoid reading past allocated blocks from KVP file

2017-11-08 Thread KY Srinivasan
> -Original Message- > From: Haiyang Zhang > Sent: Wednesday, November 8, 2017 6:22 AM > To: Long Li ; KY Srinivasan ; > Stephen Hemminger ; > de...@linuxdriverproject.org; linux-ker...@vger.kernel.org > Cc: Paul Meyer

Re: Kernel Device Driver Testing

2017-11-08 Thread Greg Kroah-Hartman
On Wed, Nov 08, 2017 at 11:57:09AM -0500, tedheadster wrote: > Greg, > I had an idea about device drivers and self-tests. Create a compiler > tag called __selftest which would function similar to __init. A device > driver author could write directly into their kernel module self-test > functions

Re: [PATCH] staging: fsl-dpaa2: Fix multiple assignments should be avoided

2017-11-08 Thread Joe Perches
On Wed, 2017-11-08 at 09:16 -0800, Randy Dunlap wrote: > On 11/08/2017 03:39 AM, Joe Perches wrote: > > On Wed, 2017-11-08 at 12:40 +0300, Dan Carpenter wrote: > > > On Wed, Nov 08, 2017 at 10:20:48AM +0100, Greg KH wrote: > > > > On Tue, Nov 07, 2017 at 07:45:03PM -0500, Joshua Abraham wrote: > >

[PATCH] Fixes issue with bit shift in rf69_get_modulation

2017-11-08 Thread Marcus Wolf
Fixes issue with bit shift in rf69_get_modulation Signed-off-by: Marcus Wolf --- drivers/staging/pi433/rf69.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/pi433/rf69.c b/drivers/staging/pi433/rf69.c index 290b419..c945b4b

Re: [PATCH] staging: fsl-dpaa2: Fix multiple assignments should be avoided

2017-11-08 Thread Randy Dunlap
On 11/08/2017 03:39 AM, Joe Perches wrote: > On Wed, 2017-11-08 at 12:40 +0300, Dan Carpenter wrote: >> On Wed, Nov 08, 2017 at 10:20:48AM +0100, Greg KH wrote: >>> On Tue, Nov 07, 2017 at 07:45:03PM -0500, Joshua Abraham wrote: This patch fixes the checkpatch.pl warning: "CHECK:

Kernel Device Driver Testing

2017-11-08 Thread tedheadster
Greg, I had an idea about device drivers and self-tests. Create a compiler tag called __selftest which would function similar to __init. A device driver author could write directly into their kernel module self-test functions identified with this tag. Using the tag, the person compiling the

Re: [PATCH] staging: fsl-dpaa2: Fix multiple assignments should be avoided

2017-11-08 Thread Josh Abraham
On Wed, Nov 08, 2017 at 10:20:48AM +0100, Greg KH wrote: > On Tue, Nov 07, 2017 at 07:45:03PM -0500, Joshua Abraham wrote: > > This patch fixes the checkpatch.pl warning: > > "CHECK: multiple assignments should be avoided" > > > > Signed-off-by: Joshua Abraham > > --- >

Re: [PATCH] staging: pi433: #define shift constants in rf69.c

2017-11-08 Thread Josh Abraham
On Wed, Nov 08, 2017 at 02:52:30PM +0300, Dan Carpenter wrote: > On Wed, Nov 08, 2017 at 06:25:06AM -0500, Joshua Abraham wrote: > > This patch completes TODO improvements in rf69.c to change shift > > constants to a define. > > > > Signed-off-by: Joshua Abraham > > ---

RE: [Revised PATCH v2] hv: kvp: Avoid reading past allocated blocks from KVP file

2017-11-08 Thread Haiyang Zhang
> -Original Message- > From: Long Li [mailto:lon...@exchange.microsoft.com] > Sent: Wednesday, November 1, 2017 2:45 PM > To: KY Srinivasan ; Haiyang Zhang > ; Stephen Hemminger > ; de...@linuxdriverproject.org; linux- >

Re: [PATCH] staging: pi433: #define shift constants in rf69.c

2017-11-08 Thread Marcus Wolf
Hello everybody! Concerning the naming: == When writing the rf69.c it wasn't intended to write a driver for Linux. This file was written at a time, where the complete controlling of Pi433 was implemented in the application. Therefore it is written in a completely different

[PATCH] staging: rtlwifi: remove redundant assignments to ul_enc_algo

2017-11-08 Thread Colin King
From: Colin Ian King Variable ul_enc_algo is being initialized with a value that is never read, it is being set again in the following switch statements in all of the case and default paths. Hence the unitialization is redundant and can be removed. Cleans up two clang

Re: [PATCH] staging: fsl-dpaa2: Fix multiple assignments should be avoided

2017-11-08 Thread Joe Perches
On Wed, 2017-11-08 at 12:40 +0300, Dan Carpenter wrote: > On Wed, Nov 08, 2017 at 10:20:48AM +0100, Greg KH wrote: > > On Tue, Nov 07, 2017 at 07:45:03PM -0500, Joshua Abraham wrote: > > > This patch fixes the checkpatch.pl warning: > > > "CHECK: multiple assignments should be avoided" > > > > >

Re: [PATCH v2 1/3] staging: ccree: copy IV to DMAable memory

2017-11-08 Thread Herbert Xu
On Wed, Nov 08, 2017 at 01:54:03PM +0200, Gilad Ben-Yossef wrote: > > As a HW based crypto driver maintainer I sympathize, but let's play > devil's advocate for a second here: > > In the current state, HW based crypto drivers need to allocate a buffer > and copy the IV, because they don't know if

Re: [PATCH v2 1/3] staging: ccree: copy IV to DMAable memory

2017-11-08 Thread Gilad Ben-Yossef
Hi, On Wed, Nov 8, 2017 at 12:26 PM, Horia Geantă wrote: > On 11/2/2017 10:14 AM, Gilad Ben-Yossef wrote: >> We are being passed an IV buffer from unknown origin, which may be >> stack allocated and thus not safe for DMA. Allocate a DMA safe >> buffer for the IV and use

[PATCH 3/4] hv_balloon: fix bugs in num_pages_onlined accounting

2017-11-08 Thread Vitaly Kuznetsov
Our num_pages_onlined accounting is buggy: 1) In case we're offlining a memory block which was present at boot (e.g. when there was no hotplug at all) we subtract 32k from 0 and as num_pages_onlined is unsigned get a very big positive number. 2) Commit 6df8d9aaf3af ("Drivers: hv: balloon:

[PATCH 4/4] hv_balloon: trace post_status

2017-11-08 Thread Vitaly Kuznetsov
Hyper-V balloon driver makes non-trivial calculations to convert Linux's representation of free/used memory to what Hyper-V host expects to see. Add a tracepoint to see what's being sent and where the data comes from. Signed-off-by: Vitaly Kuznetsov --- drivers/hv/Makefile

[PATCH 2/4] hv_balloon: simplify hv_online_page()/hv_page_online_one()

2017-11-08 Thread Vitaly Kuznetsov
Instead of doing pfn_to_page() and continuosly casting page to unsigned long just cache the pfn of the page with page_to_pfn(). Signed-off-by: Vitaly Kuznetsov --- drivers/hv/hv_balloon.c | 27 +-- 1 file changed, 5 insertions(+), 22 deletions(-)

[PATCH 1/4] hv_balloon: fix printk loglevel

2017-11-08 Thread Vitaly Kuznetsov
We have a mix of different ideas of which loglevel should be used. Unify on the following: - pr_info() for normal operation - pr_warn() for 'strange' host behavior - pr_err() for all errors. Signed-off-by: Vitaly Kuznetsov --- drivers/hv/hv_balloon.c | 12 ++-- 1

[PATCH 0/4] hv_balloon: fixes for num_pages_onlined accounting and misc improvements

2017-11-08 Thread Vitaly Kuznetsov
While doing routing code review I noticed that commit 6df8d9aaf3af ("Drivers: hv: balloon: Correctly update onlined page count") introduced an issue with num_pages_onlined accounting on memory offlining. Deeper look showed that the accounting was always buggy. This is fixed in PATCH3. PATCHes 1

Re: [PATCH] staging: pi433: #define shift constants in rf69.c

2017-11-08 Thread Dan Carpenter
On Wed, Nov 08, 2017 at 06:25:06AM -0500, Joshua Abraham wrote: > This patch completes TODO improvements in rf69.c to change shift > constants to a define. > > Signed-off-by: Joshua Abraham > --- > drivers/staging/pi433/rf69.c | 4 ++-- >

[PATCH] staging: pi433: #define shift constants in rf69.c

2017-11-08 Thread Joshua Abraham
This patch completes TODO improvements in rf69.c to change shift constants to a define. Signed-off-by: Joshua Abraham --- drivers/staging/pi433/rf69.c | 4 ++-- drivers/staging/pi433/rf69_registers.h | 4 2 files changed, 6 insertions(+), 2 deletions(-)

Re: [PATCH 02/11] staging: greybus: Remove redundant license text

2017-11-08 Thread Bryan O'Donoghue
On 07/11/17 13:58, Greg Kroah-Hartman wrote: Now that the SPDX tag is in all greybus files, that identifies the license in a specific and legally-defined manner. So the extra GPL text wording can be removed as it is no longer needed at all. This is done on a quest to remove the 700+ different

Re: [PATCH] staging: comedi: usbdux: remove redundant initialization of val

2017-11-08 Thread Ian Abbott
On 07/11/17 19:07, Colin King wrote: From: Colin Ian King The early initialization of val is redundant as the value is never read and is updated inside a for-loop. Remove the initialization and move the declaration and initialization to the for-loop scope. Cleans up

Re: [PATCH v2 1/3] staging: ccree: copy IV to DMAable memory

2017-11-08 Thread Horia Geantă
On 11/2/2017 10:14 AM, Gilad Ben-Yossef wrote: > We are being passed an IV buffer from unknown origin, which may be > stack allocated and thus not safe for DMA. Allocate a DMA safe > buffer for the IV and use that instead. > IIUC this fixes only the (a)blkcipher / skcipher algorithms. What about

Re: [PATCH] staging: fsl-dpaa2: Fix multiple assignments should be avoided

2017-11-08 Thread Dan Carpenter
On Wed, Nov 08, 2017 at 10:20:48AM +0100, Greg KH wrote: > On Tue, Nov 07, 2017 at 07:45:03PM -0500, Joshua Abraham wrote: > > This patch fixes the checkpatch.pl warning: > > "CHECK: multiple assignments should be avoided" > > > > Signed-off-by: Joshua Abraham > > --- >

Re: [PATCH net-next v2 2/2] hv_netvsc: hide warnings about uninitialized/missing rndis device

2017-11-08 Thread Vitaly Kuznetsov
Stephen Hemminger writes: > On Nov 2, 2017 19:35, "Vitaly Kuznetsov" wrote: > > Hyper-V hosts are known to send RNDIS messages even after we halt the > device in rndis_filter_halt_device(). Remove user visible messages > as they are not really

Re: [PATCH] staging: fsl-dpaa2: Fix multiple assignments should be avoided

2017-11-08 Thread Greg KH
On Tue, Nov 07, 2017 at 07:45:03PM -0500, Joshua Abraham wrote: > This patch fixes the checkpatch.pl warning: > "CHECK: multiple assignments should be avoided" > > Signed-off-by: Joshua Abraham > --- > drivers/staging/fsl-dpaa2/ethernet/dpaa2-eth.c | 3 ++- > 1 file