[PATCH] staging: vchiq_arm: fix open brace placement errors

2017-12-17 Thread Tara Null
Fix checkpatch errors relating to open brace placement for enums and function definitions. Signed-off-by: Tara Null --- drivers/staging/vc04_services/interface/vchiq_arm/vchiq_core.c | 9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/drivers/staging/vc04_services/interf

Re: [PATCHv2 0/6] staging: pi433: pi433_if.c various codestyle fixes

2017-12-17 Thread Oliver Graute
On 13/12/17, Oliver Graute wrote: > rearranged the patches and summarized them > > Oliver Graute (6): > staging: pi433: pi433_if.c codestyle space required > staging: pi433: pi433_if.c style fix wrong placed brace > staging: pi433: pi433_if.c style open brace > staging: pi433: pi433_if.c s

Re: [PATCH v5 0/4] NVIDIA Tegra video decoder driver

2017-12-17 Thread Dmitry Osipenko
On 12.12.2017 03:26, Dmitry Osipenko wrote: > VDE driver provides accelerated video decoding to NVIDIA Tegra SoC's, > it is a result of reverse-engineering efforts. Driver has been tested on > Toshiba AC100 and Acer A500, it should work on any Tegra20 device. > > In userspace this driver is utiliz

[PATCH 2/2] staging: greybus: arche-platform.c: Fix alignment should match open parenthesis

2017-12-17 Thread Kamal Heib
Fix "alignment should match open parenthesis" checkpatch.pl error. Signed-off-by: Kamal Heib --- drivers/staging/greybus/arche-platform.c | 21 - 1 file changed, 12 insertions(+), 9 deletions(-) diff --git a/drivers/staging/greybus/arche-platform.c b/drivers/staging/greybus

[PATCH 1/2] staging: greybus: arche-apb-ctrl.c: Fix alignment should match open parenthesis

2017-12-17 Thread Kamal Heib
Fix "alignment should match open parenthesis" checkpatch.pl error. Signed-off-by: Kamal Heib --- drivers/staging/greybus/arche-apb-ctrl.c | 39 1 file changed, 20 insertions(+), 19 deletions(-) diff --git a/drivers/staging/greybus/arche-apb-ctrl.c b/drivers/sta

[PATCH 0/2] staging: greybus: Fix alignments

2017-12-17 Thread Kamal Heib
This patch set fixes the alignments errors found by checkpatch.pl Kamal Heib (2): staging: greybus: arche-apb-ctrl.c: Fix alignment should match open parenthesis staging: greybus: arche-platform.c: Fix alignment should match open parenthesis drivers/staging/greybus/arche-apb-ctrl.c |

Re: [PATCH 6/6] staging: pi433: Rename enum modShaping in rf69_enum.h

2017-12-17 Thread Marcus Wolf
Am 04.12.2017 um 21:18 schrieb Dan Carpenter: On Mon, Dec 04, 2017 at 08:59:35PM +0200, Marcus Wolf wrote: Am 04.12.2017 um 12:33 schrieb Dan Carpenter: On Sun, Dec 03, 2017 at 04:17:26PM +0100, Simon Sandström wrote: diff --git a/drivers/staging/pi433/pi433_if.h b/drivers/staging/pi433/pi43

Re: [PATCH] hyperv: make HYPERV a menuconfig to ease disabling it all

2017-12-17 Thread Vincent Legoll
Hello, On Sat, Dec 16, 2017 at 6:51 PM, Stephen Hemminger wrote: > It makes sense to organize the config if you dont break old configs. > It would be more logical to group and treat all para-virtualized guest > support in same way. Hyper-V should be next to KVM and Xen. I agree, I can try to wo

Re: [PATCH 1/4] Staging: rtl8723bs: Replace true with x and false with !x

2017-12-17 Thread Joe Perches
On Sun, 2017-12-17 at 15:07 +0530, Shreeya Patel wrote: > Replace true and false keywords with "x" and "!x" > respectively to follow the kernel coding style. [] > diff --git a/drivers/staging/rtl8723bs/hal/sdio_ops.c > b/drivers/staging/rtl8723bs/hal/sdio_ops.c [] > @@ -191,8 +191,8 @@ static u32

Re: [PATCH 1/4] Staging: rtl8723bs: Replace true with x and false with !x

2017-12-17 Thread Shreeya Patel
On Sun, 2017-12-17 at 01:45 -0800, Joe Perches wrote: > On Sun, 2017-12-17 at 15:07 +0530, Shreeya Patel wrote: > > > > Replace true and false keywords with "x" and "!x" > > respectively to follow the kernel coding style. > [] > > > > diff --git a/drivers/staging/rtl8723bs/hal/sdio_ops.c > > b/dr

[PATCH 4/4] Staging: rtl8723bs: Use !x instead of NULL comparison

2017-12-17 Thread Shreeya Patel
If "x" is compared to NULL, use "!x" instead of it, so as to follow the kernel coding style. Signed-off-by: Shreeya Patel --- drivers/staging/rtl8723bs/hal/sdio_ops.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/drivers/staging/rtl8723bs/hal/sdio_ops.c

[PATCH 3/4] Staging: rtl8723bs: Change condition to assignment

2017-12-17 Thread Shreeya Patel
Change the conditional operator to assignment as it is not a conditional statement. Signed-off-by: Shreeya Patel --- drivers/staging/rtl8723bs/hal/sdio_ops.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8723bs/hal/sdio_ops.c b/drivers/staging/rtl8723bs/

[PATCH 2/4] Staging: rtl8723bs: Change names to conform to the kernel code

2017-12-17 Thread Shreeya Patel
Change names of some variables and functions to conform to the kernel coding style. Signed-off-by: Shreeya Patel --- drivers/staging/rtl8723bs/hal/sdio_ops.c | 714 +++ 1 file changed, 357 insertions(+), 357 deletions(-) diff --git a/drivers/staging/rtl8723bs/hal/sdi

[PATCH 1/4] Staging: rtl8723bs: Replace true with x and false with !x

2017-12-17 Thread Shreeya Patel
Replace true and false keywords with "x" and "!x" respectively to follow the kernel coding style. Signed-off-by: Shreeya Patel --- drivers/staging/rtl8723bs/hal/sdio_ops.c | 30 ++ 1 file changed, 14 insertions(+), 16 deletions(-) diff --git a/drivers/staging/rtl8723

[PATCH 0/4] Remove checkpatch warnings

2017-12-17 Thread Shreeya Patel
This patchset removes some warnings generated by checkpatch for cleanup of the rtl8723bs driver. Also some additional cleanups are introduced in the *[1/4] and *[3/4] patches to make the code according to the kernel coding style. Shreeya Patel (4): Staging: rtl8723bs: Replace true with x and fa

Re: [PATCH 1/1] drivers: android: Cleanup warnings

2017-12-17 Thread Greg Kroah-Hartman
On Sun, Dec 17, 2017 at 03:07:55AM +0530, Harsh Shandilya wrote: > Ran checkpatch across the entire drivers/android > directory and fixed all relevant warnings. Summary > of changes done: > > -> Convert all symbolic permissions into their > octal equivalents. > -> Use "%s", __func__ in loggi