Re: WARNING in __vm_enough_memory

2018-01-15 Thread Dmitry Vyukov
On Tue, Jan 16, 2018 at 12:58 AM, syzbot wrote: > Hello, > > syzkaller hit the following crash on > 8418f88764046d0e8ca6a3c04a69a0e57189aa1e > git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/master > compiler: gcc (GCC)

[PATCH v3 00/10] posix_clocks: Prepare syscalls for 64 bit time_t conversion

2018-01-15 Thread Deepa Dinamani
The series is a preparation series for individual architectures to use 64 bit time_t syscalls in compat and 32 bit emulation modes. This is a follow up to the series Arnd Bergmann posted: https://sourceware.org/ml/libc-alpha/2015-05/msg00070.html [1] Big picture is as per the lwn article:

[PATCH v3 02/10] include: Move compat_timespec/ timeval to compat_time.h

2018-01-15 Thread Deepa Dinamani
All the current architecture specific defines for these are the same. Refactor these common defines to a common header file. The new common linux/compat_time.h is also useful as it will eventually be used to hold all the defines that are needed for compat time types that support non y2038 safe

[staging:staging-next 468/515] drivers/staging/lustre/lnet/selftest/module.c:125:47: error: 'struct cfs_cpt_table' has no member named 'ctb_parts'

2018-01-15 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git staging-next head: 0f45b23aedf91ae66890d13320c5147c15013a0c commit: 6106c0f82481e686b337ee0c403821fb5c3c17ef [468/515] staging: lustre: lnet: convert selftest to use workqueues config: x86_64-randconfig-u0-01160700

[PATCH 01/10] staging: dgnc: remove PCI_DEVICE_NEO stuff

2018-01-15 Thread Greg Kroah-Hartman
The "Neo" devices are never allowed to be bound to this driver, as they are not in the valid list of PCI ids, so delete them from the driver as the code in the probe function has no way to ever run. Also delete the defines that are no longer used in relation to the Neo devices, as they are not

[PATCH 07/10] staging: dgnc: delete a bunch of PCI board variables

2018-01-15 Thread Greg Kroah-Hartman
None of these were being used at all, only set and never used again, so remove them from the code. Cc: Lidza Louina Cc: Mark Hounschell Signed-off-by: Greg Kroah-Hartman --- drivers/staging/dgnc/dgnc_driver.c | 8

[PATCH 09/10] staging: dgnc: remove "vpd" board variable

2018-01-15 Thread Greg Kroah-Hartman
It was only ever read from the device, and spit out to the kernel log for no good reason. So remove it, and the way it was read from the device, and the now unused "board file" callback. Cc: Lidza Louina Cc: Mark Hounschell Signed-off-by: Greg

[PATCH 08/10] staging: dgnc: delete serial_num board variable

2018-01-15 Thread Greg Kroah-Hartman
No one was even ever setting the thing, so just remove it. Cc: Lidza Louina Cc: Mark Hounschell Signed-off-by: Greg Kroah-Hartman --- drivers/staging/dgnc/dgnc_driver.h | 2 -- 1 file changed, 2 deletions(-) diff --git

[PATCH 06/10] staging: dgnc: delete is_pci_express board type variable.

2018-01-15 Thread Greg Kroah-Hartman
It was only set, and never looked at, so drop the thing as no one cares about it. And when it was set, it was not even set correctly, the index it was using to read from was incorrect, so this has never even been correct... Cc: Lidza Louina Cc: Mark Hounschell

[PATCH 05/10] staging: dgnc: delete dpastatus board type variable.

2018-01-15 Thread Greg Kroah-Hartman
It was only set, and never looked at, so drop the thing as no one cares about it. Cc: Lidza Louina Cc: Mark Hounschell Signed-off-by: Greg Kroah-Hartman --- drivers/staging/dgnc/dgnc_driver.c | 3 ---

[PATCH 02/10] staging: dgnc: delete dgnc_neo.* files

2018-01-15 Thread Greg Kroah-Hartman
As the Neo devices were never actually supported by the driver, delete the files that purported to control that type of device as they are not needed. This will let us shrink the driver a lot over time. Cc: Lidza Louina Cc: Mark Hounschell

[PATCH 04/10] staging: dgnc: delete dpatype board type variable.

2018-01-15 Thread Greg Kroah-Hartman
It was only set, and never looked at, so drop the thing as no one cares about it. Cc: Lidza Louina Cc: Mark Hounschell Signed-off-by: Greg Kroah-Hartman --- drivers/staging/dgnc/dgnc_driver.c | 3 ---

[PATCH 03/10] staging: dgnc: delete dgnc_pci.h

2018-01-15 Thread Greg Kroah-Hartman
Move the few #defines we actually use into the dgnc_driver.c file, no need to have a .h file for a driver that is only used by a single .c file. Cc: Lidza Louina Cc: Mark Hounschell Signed-off-by: Greg Kroah-Hartman ---

[PATCH 10/10] staging: dgnc: drop unused neo_uart_struct

2018-01-15 Thread Greg Kroah-Hartman
Now that the "neo" portion of the driver is gone (it was never being used), drop the unused neo_uart_struct variable as well. Cc: Lidza Louina Cc: Mark Hounschell Signed-off-by: Greg Kroah-Hartman ---

Re: [PATCH] staging: unisys: change select to depends for subsystems

2018-01-15 Thread Randy Dunlap
On 01/15/18 06:54, Greg Kroah-Hartman wrote: > On Sun, Jan 14, 2018 at 09:10:54PM -0800, Randy Dunlap wrote: >> From: Randy Dunlap >> >> Drivers should not 'select' a subsystem. Instead they should depend >> on it. If the subsystem is disabled, the user probably did that

RE: [lustre-devel] [bug report] staging: lustre: replace simple cases of LIBCFS_ALLOC with kzalloc.

2018-01-15 Thread Eremin, Dmitry
Hello Dan, It looks this condition is missed in the code. Sorry we should fix this. Dmitry. > -Original Message- > From: Eremin, Dmitry > Sent: Monday, January 15, 2018 9:27 PM > To: Dan Carpenter ; ne...@suse.com > Cc: de...@driverdev.osuosl.org;

[PATCH v5 1/2] staging: xgifb: vb_setmode: fix long line warnings

2018-01-15 Thread Kenny Ballou
Fix a number of checkpatch warnings in xgfib/vb_setmode.c about line length being over 80 characters. Signed-off-by: Kenny Ballou --- drivers/staging/xgifb/vb_setmode.c | 58 -- 1 file changed, 37 insertions(+), 21 deletions(-) diff

[PATCH v5 0/2] staging: xgifb: checkpatch fixes

2018-01-15 Thread Kenny Ballou
Changes since v4: - Old 1/3 was accepted, shifting the patch numbers - Removed pythonisms and bad line edits in 1/2: fix long line warnings - Removed bad patch/commit separation in 2/2: brace style fixes ___ devel mailing list

[PATCH v5 2/2] staging: xgifb: vb_setmode: brace style fixes

2018-01-15 Thread Kenny Ballou
Add braces to certain "multiline" conditions where "multiline" means including comments. Signed-off-by: Kenny Ballou --- drivers/staging/xgifb/vb_setmode.c | 23 +++ 1 file changed, 15 insertions(+), 8 deletions(-) diff --git

RE: [lustre-devel] [bug report] staging: lustre: replace simple cases of LIBCFS_ALLOC with kzalloc.

2018-01-15 Thread Eremin, Dmitry
Hello Dan, The function kiblnd_destroy_conn() is conditionally free the conn pointer. void kiblnd_destroy_conn(kib_conn_t *conn, bool free_conn) { […] if (free_conn) LIBCFS_FREE(conn, sizeof(*conn)); } Therefore > 3317

[staging:staging-testing 468/515] drivers/staging/lustre/lnet/selftest/module.c:125:49: error: 'struct cfs_cpt_table' has no member named 'ctb_parts'; did you mean 'ctb_nparts'?

2018-01-15 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git staging-testing head: 0f45b23aedf91ae66890d13320c5147c15013a0c commit: 6106c0f82481e686b337ee0c403821fb5c3c17ef [468/515] staging: lustre: lnet: convert selftest to use workqueues config: mn10300-allmodconfig (attached

Re: [PATCH 1/8] staging: lustre: Enclose complex macros in parentheses

2018-01-15 Thread Greg Kroah-Hartman
On Thu, Jan 11, 2018 at 06:16:55PM +0100, Fabian Huegel wrote: > Checkpatch wants complex macros to be enclosed in parentheses, so we > put parentheses around these four macros. > > Signed-off-by: Fabian Huegel > Signed-off-by: Christoph Volkert

Re: [PATCH 4/8] staging: lustre: Fix comment style

2018-01-15 Thread Greg Kroah-Hartman
On Thu, Jan 11, 2018 at 06:16:58PM +0100, Fabian Huegel wrote: > Most multi-line comments started on the first line, but the preferred > linux kernel style is to start multi-line comments on the second line. > Some comments became less readable after the change, so we changed them > to single-line

Re: [patch v4 2/3] staging: xgifb: vb_setmode: fix long line warnings

2018-01-15 Thread Greg KH
On Fri, Jan 12, 2018 at 03:34:44PM -0700, Kenny Ballou wrote: > Fix a number of checkpatch warnings in xgfib/vb_setmode.c about line > length being over 80 characters. > > Signed-off-by: Kenny Ballou > --- > drivers/staging/xgifb/vb_setmode.c | 64 >

Re: [patch v4 3/3] staging: xgifb: vb_setmode: brace style fixes

2018-01-15 Thread Greg KH
On Fri, Jan 12, 2018 at 03:34:45PM -0700, Kenny Ballou wrote: > Add braces to certain "multiline" conditions where "multiline" means > including comments. > > Signed-off-by: Kenny Ballou > --- > drivers/staging/xgifb/vb_setmode.c | 26 +- > 1 file

Re: [PATCH] staging: unisys: change select to depends for subsystems

2018-01-15 Thread Greg Kroah-Hartman
On Sun, Jan 14, 2018 at 09:10:54PM -0800, Randy Dunlap wrote: > From: Randy Dunlap > > Drivers should not 'select' a subsystem. Instead they should depend > on it. If the subsystem is disabled, the user probably did that for > a purpose and one driver shouldn't be changing

Re: [PATCH v5 2/2] staging: ccree: fixed pointer signedness warnings.

2018-01-15 Thread Greg KH
On Thu, Jan 11, 2018 at 08:36:59AM +, Jeremy Sowden wrote: > This patch fixes sparse warnings arising when the addresses of signed > variables are passed to functions expecting pointers to unsigned What exact sparse warnings are being fixed here? Please include that in the changelog text.

Re: [PATCH v5 1/2] staging: ccree: removed some hard-coded array indices.

2018-01-15 Thread Greg KH
On Thu, Jan 11, 2018 at 08:36:58AM +, Jeremy Sowden wrote: > Replaced hard-coded indices used during initialization of array elements > with a variable which is incremented once initialization of each element > is complete. Why? What does this help out with? confused, greg k-h

Re: [PATCH v2 2/7] x86/hyper-v: add a function to read both TSC and TSC page value simulateneously

2018-01-15 Thread Vitaly Kuznetsov
Thomas Gleixner writes: > On Wed, 13 Dec 2017, Vitaly Kuznetsov wrote: > >> This is going to be used from KVM code where we need to get both >> TSC and TSC page value. >> >> When Hyper-V code is compiled out just return rdtsc(), this will allow us >> to avoid ugly ifdefs in

Re: [PATCH v2 4/7] x86/hyper-v: redirect reenlightment notifications on CPU offlining

2018-01-15 Thread Vitaly Kuznetsov
Thomas Gleixner writes: > On Wed, 13 Dec 2017, Vitaly Kuznetsov wrote: >> +static int hv_cpu_die(unsigned int cpu) >> +{ >> +struct hv_reenlightenment_control re_ctrl; >> +int i; >> +static DEFINE_SPINLOCK(lock); >> + >> +if (hv_reenlightenment_cb == NULL) >>

[bug report] staging: lustre: DLC Feature dynamic net config

2018-01-15 Thread Dan Carpenter
Hello Amir Shehata, The patch 6c9e5a55cb62: "staging: lustre: DLC Feature dynamic net config" from Feb 15, 2016, leads to the following static checker warning: drivers/staging/lustre/lnet/lnet/api-ni.c:1804 lnet_dyn_add_ni() error: dereferencing freed memory 'ni'

[bug report] staging: lustre: replace simple cases of LIBCFS_ALLOC with kzalloc.

2018-01-15 Thread Dan Carpenter
[ This code was already buggy, it's just that Neil's change made it show up in static analysis. - dan ] Hello NeilBrown, The patch 3c88bdbbf919: "staging: lustre: replace simple cases of LIBCFS_ALLOC with kzalloc." from Jan 9, 2018, leads to the following static checker warning:

Re: hyperv/netvsc: Delete two error messages for a failed memory allocation in netvsc_init_buf()

2018-01-15 Thread SF Markus Elfring
> These messages are not displayed anywhere else: > "unable to allocate receive buffer of size %u\n" > "unable to allocate send buffer of size %u\n", > > After set ret = -ENOMEM; and cleanup, we won't know which buffer allocation > failed without the error message. How do you think about to