Re: [PATCH 6/6] staging: wilc1000: fix line over 80 chars in wilc_spi_clear_int_ext()

2018-02-18 Thread Ajay Singh
On Fri, 16 Feb 2018 20:16:02 +0200 Claudiu Beznea wrote: > Or you could use: > unsigned long expected_irqs, unexpected_irqs; > > expected_irqs = val & GENMASK(g_spi.int - 1, 0); > unexpected_irq = val & GENMASK(MAX_NUM_INT - 1, g_spi.int); > > for (i = 0; i < g_spi.nint

Re: [PATCH] Staging: bcm2048: Fix function argument alignment in radio-bcm2048.c.

2018-02-18 Thread Dan Carpenter
On Sun, Feb 18, 2018 at 04:44:46PM -0800, Quytelda Kahja wrote: > Fix a coding style problem. > > Signed-off-by: Quytelda Kahja > --- > drivers/staging/media/bcm2048/radio-bcm2048.c | 24 > 1 file changed, 12 insertions(+), 12 deletions(-) > > diff --git a/drivers/stagi

Re: [PATCH 4/6] staging: wilc1000: fix line over 80 characters in wilc_spi_init()

2018-02-18 Thread Ajay Singh
On Fri, 16 Feb 2018 15:30:22 +0100 Greg KH wrote: > > diff --git a/drivers/staging/wilc1000/wilc_spi.c > > b/drivers/staging/wilc1000/wilc_spi.c > > index 30a9a61..fddc0db 100644 > > --- a/drivers/staging/wilc1000/wilc_spi.c > > +++ b/drivers/staging/wilc1000/wilc_spi.c > > @@ -835,7 +835,6 @@ s

[PATCH] Staging: bcm2048: Fix function argument alignment in radio-bcm2048.c.

2018-02-18 Thread Quytelda Kahja
Fix a coding style problem. Signed-off-by: Quytelda Kahja --- drivers/staging/media/bcm2048/radio-bcm2048.c | 24 1 file changed, 12 insertions(+), 12 deletions(-) diff --git a/drivers/staging/media/bcm2048/radio-bcm2048.c b/drivers/staging/media/bcm2048/radio-bcm2048.

I have been trying to reach you

2018-02-18 Thread Gavin
My name is Gavin, from the US. I'm in Syria right now fighting IS. I want to get to know you better, if I may be so bold. I consider myself an easy-going man, and I am currently looking for a relationship in which I feel loved. Please tell me more about yourself, if you don't mind. _

[PATCH 3/3] Staging: gdm724x: tty: Remove unused macro 'gdm_tty_send_control'.

2018-02-18 Thread Quytelda Kahja
Remove the macro 'gdm_tty_send_control' which adds unnecessary complexity, is unused, and has arguments that could mistakenly be evaluated multiple times. Signed-off-by: Quytelda Kahja --- drivers/staging/gdm724x/gdm_tty.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/staging/gdm

[PATCH 2/3] Staging: gdm724x: tty: Remove unnecessary macro 'gdm_tty_recv'.

2018-02-18 Thread Quytelda Kahja
Remove the macro 'gdm_tty_recv' which adds unnecessary complexity and has arguments that could mistakenly be evaluated multiple times. Signed-off-by: Quytelda Kahja --- drivers/staging/gdm724x/gdm_tty.c | 11 ++- 1 file changed, 6 insertions(+), 5 deletions(-) diff --git a/drivers/stagi

[PATCH 1/3] Staging: gdm724x: tty: Remove unnecessary macro 'gdm_tty_send'.

2018-02-18 Thread Quytelda Kahja
Remove the macro 'gdm_tty_send' which adds unnecessary complexity and has arguments that could mistakenly be evaluated multiple times. Signed-off-by: Quytelda Kahja --- drivers/staging/gdm724x/gdm_tty.c | 15 ++- 1 file changed, 6 insertions(+), 9 deletions(-) diff --git a/drivers/s

[PATCH v2 1/2] staging: rtl8712: make unsigned length for rtl8717_get{_wpa_, _wpa2_, _}ie

2018-02-18 Thread Stefano Manni
Fixed r8712_get_ie, r8712_get_wpa_ie, r8712_get_wpa2_ie to have a length as unsigned int pointer instead of signed. Sparse warnings: drivers/staging/rtl8712/rtl871x_ioctl_linux.c:173:27: warning: incorrect type in argument 3 (different signedness) drivers/staging/rtl8712/rtl871x_ioctl_linux.c:17

[PATCH v2 2/2] staging: rtl8712: fix signedness of length to rtl8717_set_ie

2018-02-18 Thread Stefano Manni
rtl8717_set_it() takes an unsigned int pointer as length, fixed signedness in code using it. Sparse warnings: drivers/staging/rtl8712/ieee80211.c:191:53: warning: incorrect type in argument 5 (different signedness) drivers/staging/rtl8712/ieee80211.c:191:53:expected unsigned int [usertype]

Re: [PATCH 1/2] staging: rtl8712: make unsigned length for rtl8717_get{_wpa_,_wpa2_,_}ie

2018-02-18 Thread Stefano Manni
On Fri, 2018-02-16 at 15:48 +0100, Greg KH wrote: > Can you rebase both of these patches on the staging-testing branch of > the staging.git tree so that I can apply them?  Right now they have > too > many conflicts. Rebased on staging-testing d92a1fa. v2 to come.

Re: [PATCH] Staging: ks7010: Fix Unnecessary parentheses in ks_hostif.c

2018-02-18 Thread kbuild test robot
://github.com/0day-ci/linux/commits/Yash-Omer/Staging-ks7010-Fix-Unnecessary-parentheses-in-ks_hostif-c/20180218-223344 config: i386-randconfig-a0-201807 (attached as .config) compiler: gcc-4.9 (Debian 4.9.4-2) 4.9.4 reproduce: # save the attached .config to linux build tree make ARCH=i386

Re: [PATCH] Staging: ks7010: Fix Unnecessary parentheses in ks_hostif.c

2018-02-18 Thread kbuild test robot
-ci/linux/commits/Yash-Omer/Staging-ks7010-Fix-Unnecessary-parentheses-in-ks_hostif-c/20180218-223344 config: i386-randconfig-x017-201807 (attached as .config) compiler: gcc-7 (Debian 7.3.0-1) 7.3.0 reproduce: # save the attached .config to linux build tree make ARCH=i386 All errors

Re: [PATCH 1/3] Staging: iio: adis16209: Use SPDX identifier

2018-02-18 Thread Jonathan Cameron
On Sun, 18 Feb 2018 13:14:27 +0100 Lars-Peter Clausen wrote: > On 02/18/2018 01:08 PM, Lars-Peter Clausen wrote: > > On 02/18/2018 01:02 PM, Jonathan Cameron wrote: > >> On Sun, 18 Feb 2018 17:07:57 +0530 > >> Shreeya Patel wrote: > >> > >>> On Sun, 2018-02-18 at 17:01 +0530, Himanshu Jha wr

Re: [PATCH 3/3] Staging: iio: adis16209: Use sign_extend32 and adjust a switch statement

2018-02-18 Thread Jonathan Cameron
On Sat, 17 Feb 2018 21:51:35 +0530 Shreeya Patel wrote: > Use sign_extend32 function instead of manually coding it. Also, adjust a > switch block to explicitly match channels and return -EINVAL as default > case which improves code readability. Two items, two patches please. The -EINVAL is a bit

Re: [PATCH 2/3] Staging: iio: adis16209: Remove unnecessary comments and add suitable suffix

2018-02-18 Thread Jonathan Cameron
On Sat, 17 Feb 2018 21:37:37 +0530 Shreeya Patel wrote: > Remove some unnecessary comments and therefore, add _REG suffix > for registers. Group the control register and register field > macros together. > Also, align function arguments to match open parentheses using > tabs. Lots of different c

Re: [PATCH 1/3] Staging: iio: adis16209: Use SPDX identifier

2018-02-18 Thread Lars-Peter Clausen
On 02/18/2018 01:02 PM, Jonathan Cameron wrote: > On Sun, 18 Feb 2018 17:07:57 +0530 > Shreeya Patel wrote: > >> On Sun, 2018-02-18 at 17:01 +0530, Himanshu Jha wrote: >>> Hi Shreeya, >>> >> Hi Himanshu, >> >>> On Sat, Feb 17, 2018 at 09:34:56PM +0530, Shreeya Patel wrote: Use SPDX

Re: [PATCH 1/3] Staging: iio: adis16209: Use SPDX identifier

2018-02-18 Thread Lars-Peter Clausen
On 02/18/2018 01:08 PM, Lars-Peter Clausen wrote: > On 02/18/2018 01:02 PM, Jonathan Cameron wrote: >> On Sun, 18 Feb 2018 17:07:57 +0530 >> Shreeya Patel wrote: >> >>> On Sun, 2018-02-18 at 17:01 +0530, Himanshu Jha wrote: Hi Shreeya, >>> Hi Himanshu, >>> On Sat, Feb 17, 2018 at

Re: [PATCH 1/3] Staging: iio: adis16209: Use SPDX identifier

2018-02-18 Thread Jonathan Cameron
On Sat, 17 Feb 2018 21:34:56 +0530 Shreeya Patel wrote: > Use SPDX identifier format instead of GPLv2. Also rearrange the > headers in alphabetical order. As Dan pointed out for the Himanshu Jha's patches, the moment we see the word 'also' in a patch it pretty much makes it obvious that the auth

Re: [PATCH 1/3] Staging: iio: adis16209: Use SPDX identifier

2018-02-18 Thread Jonathan Cameron
On Sun, 18 Feb 2018 17:07:57 +0530 Shreeya Patel wrote: > On Sun, 2018-02-18 at 17:01 +0530, Himanshu Jha wrote: > > Hi Shreeya, > > > Hi Himanshu, > > > On Sat, Feb 17, 2018 at 09:34:56PM +0530, Shreeya Patel wrote: > > > > > > Use SPDX identifier format instead of GPLv2. Also rearrange t

Re: [PATCH 1/3] Staging: iio: adis16209: Use SPDX identifier

2018-02-18 Thread Shreeya Patel
On Sun, 2018-02-18 at 17:01 +0530, Himanshu Jha wrote: > Hi Shreeya, > Hi Himanshu, > On Sat, Feb 17, 2018 at 09:34:56PM +0530, Shreeya Patel wrote: > > > > Use SPDX identifier format instead of GPLv2. Also rearrange the > > headers in alphabetical order. > > > > Signed-off-by: Shreeya Patel >

[PATCH] staging:r8188eu: Use lib80211 to decrypt WEP-frames

2018-02-18 Thread Ivan Safonov
Use native lib80211 WEP decrypt instead of custom implementation. Signed-off-by: Ivan Safonov --- drivers/staging/rtl8188eu/Kconfig| 2 + drivers/staging/rtl8188eu/core/rtw_recv.c| 2 +- drivers/staging/rtl8188eu/core/rtw_security.c| 80 +--- dri

Re: [PATCH 1/3] Staging: iio: adis16209: Use SPDX identifier

2018-02-18 Thread Himanshu Jha
Hi Shreeya, On Sat, Feb 17, 2018 at 09:34:56PM +0530, Shreeya Patel wrote: > Use SPDX identifier format instead of GPLv2. Also rearrange the > headers in alphabetical order. > > Signed-off-by: Shreeya Patel > --- > drivers/staging/iio/accel/adis16209.c | 7 +++ > 1 file changed, 3 insertion