[PATCH] staging: ks7010: remove unnecessary brackets in single statement block

2018-03-10 Thread Sergio Paracuellos
This patch fix the following sparse warning: braces {} are not necessary for single statement blocks Signed-off-by: Sergio Paracuellos --- drivers/staging/ks7010/ks_hostif.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/ks7010/ks_hostif.c b/drivers/st

Re: [PATCH 4/4] staging:iio:ad2s1210: Add comments/documentation

2018-03-10 Thread Jonathan Cameron
On Fri, 9 Mar 2018 20:46:40 -0300 Rodrigo Siqueira wrote: > The original code of AD2S1210 does not have documentation for structs > and register configurations; this difficult the code comprehension. This > patch adds structs documentation, briefly comments some register > settings and acronyms,

Re: [PATCH 3/4] staging:iio:ad2s1210: Remove old_data from ad2s1210_state

2018-03-10 Thread Jonathan Cameron
On Fri, 9 Mar 2018 20:46:25 -0300 Rodrigo Siqueira wrote: > The variable old_data is a bool type, which only receives the value > 'true' in the function ad2s1210_config_write and ad2s1210_config_read. > There is no other use for this variable. This patch removes old_data > from the ad2s1210_state

Re: [PATCH 2/4] staging:iio:ad2s1210: Remove unused #define directive

2018-03-10 Thread Jonathan Cameron
On Fri, 9 Mar 2018 20:46:05 -0300 Rodrigo Siqueira wrote: > This patch removes some #define directives not used in the code. > > Signed-off-by: Rodrigo Siqueira Applied. One comment inline. > --- > drivers/staging/iio/resolver/ad2s1210.c | 10 -- > 1 file changed, 10 deletions(-) > >

Re: [PATCH 1/4] staging:iio:ad2s1210: Remove end of line with '['

2018-03-10 Thread Jonathan Cameron
On Fri, 9 Mar 2018 20:45:50 -0300 Rodrigo Siqueira wrote: > This patch fixes the checkpatch.pl check: > > iio/resolver/ad2s1210.c:202: CHECK: Lines should not end with a '[' > > Signed-off-by: Rodrigo Siqueira Applied to the togreg branch of iio.git and pushed out as testing for the autobuilde

Re: [PATCH v2] Staging: iio: adis16209: Move adis16209 driver out of staging

2018-03-10 Thread Jonathan Cameron
On Sat, 10 Mar 2018 15:50:23 +0530 Shreeya Patel wrote: > Move the adis16209 driver out of staging directory and merge to the > mainline IIO subsystem. > > Signed-off-by: Shreeya Patel As this has a clear dependency on the previous patch, please put them in the same series for the next version.

Re: [PATCH v5] Staging: iio: adis16209: Change some macro names

2018-03-10 Thread Jonathan Cameron
On Sat, 10 Mar 2018 15:40:14 +0530 Shreeya Patel wrote: > Make some of the macro names according to the names > given in the datasheet of the adis16209 driver and > have slight indentation in field definitions to make > them clearly different from the register addresses. > > Signed-off-by: Shree

Re: [PATCH v2 1/3] staging:iio:meter: Replaces IIO_DEV_ATTR_CH_OFF by IIO_DEVICE_ATTR

2018-03-10 Thread Jonathan Cameron
On Thu, 8 Mar 2018 21:37:33 -0300 Rodrigo Siqueira wrote: > On 03/07, Jonathan Cameron wrote: > > On Tue, 6 Mar 2018 21:43:47 -0300 > > Rodrigo Siqueira wrote: > > > > > The macro IIO_DEV_ATTR_CH_OFF is a wrapper for IIO_DEVICE_ATTR, with a > > > tiny change in the name definition. This extra

Re: [PATCH 10/11] Staging: iio: accel: Add comments about units in data read function

2018-03-10 Thread Jonathan Cameron
On Thu, 8 Mar 2018 12:58:19 +0530 Himanshu Jha wrote: > On Wed, Mar 07, 2018 at 08:50:30PM +, Jonathan Cameron wrote: > > On Mon, 5 Mar 2018 13:19:29 +0530 > > Himanshu Jha wrote: > > > > > Clarify the conversion and formation of resultant data in the > > > adis16201_read_raw() with suff

Re: [PATCH 12/12] staging: iio: tsl2x7x: make proximity sensor function correctly

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:42 -0500 Brian Masney wrote: > The bits for setting up the proximity diode were not setup correctly and > this was causing the proximity sensor to not function correctly. This > patch sets up the correct bit mask in tsl2x7x_chip_on() based on what > the data sheet expect

Re: [PATCH 11/12] staging: iio: tsl2x7x: remove unnecessary sysfs attribute

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:41 -0500 Brian Masney wrote: > The tsl2771 and tmd2771 devices create the > in_proximity0_calibscale_available sysfs attribute. These two particular > devices do not support changing the proximity gain value on the > chip so this patch removes that sysfs attribute. As ex

Re: [PATCH 10/12] staging: iio: tsl2x7x: make logging consistent and correct newlines

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:40 -0500 Brian Masney wrote: > This patch updates all of the logging commands so that they are > consistent with the other messages, includes __func__ in the message, > and all of the messages include newlines. > > This patch also removes some debug log messages from ts

Re: [PATCH 09/12] staging: iio: tsl2x7x: add missing error checks

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:39 -0500 Brian Masney wrote: > The functions in_illuminance0_calibrate_store() and > in_illuminance0_lux_table_store() did not have complete error handling > in place. This patch adds the missing error handling. > > Signed-off-by: Brian Masney Applied. Thanks, > --- >

Re: [PATCH 08/12] staging: iio: tsl2x7x: add error handling to tsl2x7x_prox_cal()

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:38 -0500 Brian Masney wrote: > tsl2x7x_prox_cal() did not have any error checks. This patch adds > the missing error handling and ensures that any errors are reported to > user space via in_proximity0_calibrate_store(). > > Signed-off-by: Brian Masney applied. Thanks,

Re: [PATCH 07/12] staging: iio: tsl2x7x: correct 'Avoid CamelCase' warning from checkpatch

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:37 -0500 Brian Masney wrote: > The statP and calP variables triggered an 'Avoid CamelCase' warning > from checkpatch.pl. This patch renames these variables to stat and cal > to fix this warning. > > Signed-off-by: Brian Masney Applied. > --- > drivers/staging/iio/ligh

Re: [PATCH 06/12] staging: iio: tsl2x7x: correctly return errors in tsl2x7x_get_prox()

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:36 -0500 Brian Masney wrote: > Not all errors that occurred in tsl2x7x_get_prox() were correctly > reported in the return value. This patch changes the error handling > so that errors are now returned properly. > > Note that the ret variable is from the call to tsl2x7x_

Re: [PATCH 05/12] staging: iio: tsl2x7x: convert mutex_trylock() to mutex_lock()

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:35 -0500 Brian Masney wrote: > The driver uses mutex_lock() and mutex_trylock() in several places. > Convert the mutex_trylock() to mutex_lock() for consistency with other > IIO light drivers in mainline. > > Signed-off-by: Brian Masney This was a little odd given we d

Re: [PATCH 04/12] staging: iio: tsl2x7x: add common function for writing to the control register

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:34 -0500 Brian Masney wrote: > There were four places where the same chunk of code was used to write > to the control register. This patch creates a common function > tsl2x7x_write_control_reg() to reduce duplicate code. > > The function tsl2x7x_chip_off() did not corre

Re: [PATCH 03/12] staging: iio: tsl2x7x: add common function for reading chip status

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:33 -0500 Brian Masney wrote: > There were three places where the same chunk of code was used to read > the chip status. This patch creates a common function > tsl2x7x_read_status() to reduce duplicate code. This patch also corrects > tsl2x7x_event_handler() to properly c

Re: [PATCH 02/12] staging: iio: tsl2x7x: add common function for clearing interrupts

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:32 -0500 Brian Masney wrote: > There were three places where the same chunk of code was used to clear > interrupts. This patch creates a common function > tsl2x7x_clear_interrupts() to reduce duplicate code. > > Signed-off-by: Brian Masney Hmm. This one wasn't immediat

Re: [PATCH 01/12] staging: iio: tsl2x7x: remove power functions from tsl2X7X_platform_data

2018-03-10 Thread Jonathan Cameron
On Sat, 3 Mar 2018 20:49:31 -0500 Brian Masney wrote: > The tsl2X7X_platform_data structure contains the platform_power, > power_on, and power_off function pointers. These power management > functions should not be in the platform data. These functions were > likely used before the regulator fra

[PATCH] staging: speakup: Add unicode support to the speakup_dummy driver

2018-03-10 Thread Samuel Thibault
This extends spk_io_ops with a synth_out_unicode which takes a u16 character instead of just a byte, and extends spk_ttyio to implement it to emit utf-8. spk_do_catch_up_unicode can then be introduced to benefit from synth_out_unicode, and speakup_dummy made to use spk_do_catch_up_unicode instead o

[PATCH v2] Staging: iio: adis16209: Move adis16209 driver out of staging

2018-03-10 Thread Shreeya Patel
Move the adis16209 driver out of staging directory and merge to the mainline IIO subsystem. Signed-off-by: Shreeya Patel --- Changes in v2 -Re-send the patch after having some cleanups in the file included in this patch. drivers/iio/accel/Kconfig | 12 ++ drivers/iio/accel/Makef

[PATCH v5] Staging: iio: adis16209: Change some macro names

2018-03-10 Thread Shreeya Patel
Make some of the macro names according to the names given in the datasheet of the adis16209 driver and have slight indentation in field definitions to make them clearly different from the register addresses. Signed-off-by: Shreeya Patel --- Changes in v5 -Re-send the corrected patch. drivers