RE: [PATCH net-next,1/2] hv_netvsc: Fix the return status in RX path

2018-03-24 Thread Haiyang Zhang
> -Original Message- > From: Michael Kelley (EOSG) > Sent: Saturday, March 24, 2018 12:48 PM > To: Haiyang Zhang ; da...@davemloft.net; > net...@vger.kernel.org > Cc: KY Srinivasan ; Stephen Hemminger > ; o...@aepfle.de;

Re: meter ABI: (was Re: [PATCH v2 1/3] staging:iio:meter: Replaces IIO_DEV_ATTR_CH_OFF by IIO_DEVICE_ATTR)

2018-03-24 Thread John Syne
> On Mar 24, 2018, at 8:02 AM, Jonathan Cameron wrote: > > On Mon, 19 Mar 2018 22:57:16 -0700 > John Syne wrote: > >> Hi Jonathan, >> >> Thank you for all your hard work. Your feedback is really helpful. I’m >> surprised that no one from Analog Device

[PATCH] staging: pi433: cleanup tx_fifo locking

2018-03-24 Thread Valentin Vidic
pi433_write requires locking due to multiple kfifo writers. After acquiring the lock check if enough free space is available in the kfifo to write the whole message. This check should prevent partial writes to kfifo so kfifo_reset is not needed anymore. pi433_tx_thread is the only kfifo reader

Re: [PATCH][next][V2] staging: r8822be: fix typos in header guard macros

2018-03-24 Thread Larry Finger
On 03/23/2018 01:00 PM, Colin King wrote: From: Colin Ian King The macros for __PHYDMKFREE_H__ and __PHYDM_FEATURES_H__ contain typos and don't match the #if guard check. Defined them correctly. Cleans up clang warnings: warning: '__PHYDMKFREE_H__' is used as a

[PATCH 3/4] staging: iio: tsl2x7x: use either direction for IIO_EV_INFO_{ENABLE, PERIOD}

2018-03-24 Thread Brian Masney
The events IIO_EV_INFO_VALUE and IIO_EV_INFO_ENABLE currently have a falling and rising direction configured. There does not need to be a separate distinction so this patch changes these to use the either direction. Directory listing of event sysfs attributes for a TSL2772 with this patch applied:

[PATCH 1/4] staging: iio: tsl2x7x: use auto increment I2C protocol

2018-03-24 Thread Brian Masney
The hardware supports 16-bit ALS and proximity readings, however the datasheet recommends using the I2C auto increment protocol so that the correct high and low bytes are read even if the integration cycle ends between reading the lower and upper registers. More information about this protocol can

[PATCH 2/4] staging: iio: tsl2x7x: move IIO_CHAN_INFO_CALIB{SCALE, BIAS} to IIO_LIGHT channel

2018-03-24 Thread Brian Masney
The IIO_CHAN_INFO_CALIBSCALE and IIO_CHAN_INFO_CALIBBIAS masks are currently associated with the IIO_INTENSITY channel but should be associated with the IIO_LIGHT channel since these values are used to calculate the lux. Directory listing of the sysfs attributes for a TSL2772 with this patch

[PATCH 4/4] staging: iio: tsl2x7x: move out of staging

2018-03-24 Thread Brian Masney
Move the tsl2x7x driver out of staging and into mainline. Signed-off-by: Brian Masney --- Note: I intentionally ran git format-patch with --no-renames since Jonathan likes to see the whole files in the email body for staging graduation patches. The #include "tsl2x7x.h"

[PATCH 0/4] staging: iio: tsl2x7x: move out of staging

2018-03-24 Thread Brian Masney
Here is a patch series to move the tsl2x7x driver out of staging and into mainline. Driver was tested using various TSL2X7X devices on a Raspberry Pi 2. Datasheet for the TSl2772: https://ams.com/eng/content/download/291503/1066377/file/TSL2772_DS000181_2-00.pdf Brian Masney (4): staging: iio:

Re: [PATCH 10/11] staging: iio: ad2s1200: Replace angle channel with inclination channel

2018-03-24 Thread Jonathan Cameron
On Sat, 24 Mar 2018 15:57:19 +0100 David Julian Veenstra wrote: > On 24, March 2018 14:12, Jonathan Cameron wrote: > > > On Sat, 24 Mar 2018 13:36:44 +0100 > > David Julian Veenstra wrote: > > > >> On 23, March 2018 14:27,

RE: [PATCH v2] storvsc: Set up correct queue depth values for IDE devices

2018-03-24 Thread Michael Kelley (EOSG)
> -Original Message- > From: linux-kernel-ow...@vger.kernel.org > On Behalf > Of Long Li > Sent: Thursday, March 22, 2018 2:47 PM > To: KY Srinivasan ; Haiyang Zhang > ; Stephen > Hemminger

RE: [PATCH net-next,1/2] hv_netvsc: Fix the return status in RX path

2018-03-24 Thread Michael Kelley (EOSG)
> -Original Message- > From: linux-kernel-ow...@vger.kernel.org > On Behalf > Of Haiyang Zhang > Sent: Thursday, March 22, 2018 12:01 PM > To: da...@davemloft.net; net...@vger.kernel.org > Cc: Haiyang Zhang ; KY Srinivasan >

Re: meter ABI: (was Re: [PATCH v2 1/3] staging:iio:meter: Replaces IIO_DEV_ATTR_CH_OFF by IIO_DEVICE_ATTR)

2018-03-24 Thread Jonathan Cameron
On Mon, 19 Mar 2018 23:28:45 -0700 John Syne wrote: > Hi Jonathan, > > I broke out the {Direction}_{Type}_{Index}_{Modifier}_{Info_Mask} into > separate columns to make sure I understand your instructions. Good way to > check the results. > > Probably easier to copy and

Re: meter ABI: (was Re: [PATCH v2 1/3] staging:iio:meter: Replaces IIO_DEV_ATTR_CH_OFF by IIO_DEVICE_ATTR)

2018-03-24 Thread Jonathan Cameron
On Mon, 19 Mar 2018 22:57:16 -0700 John Syne wrote: > Hi Jonathan, > > Thank you for all your hard work. Your feedback is really helpful. I’m > surprised that no one from Analog Device has offered any suggestions. > Sadly those active in the mainline linux kernel from ADI

Re: [PATCH 10/11] staging: iio: ad2s1200: Replace angle channel with inclination channel

2018-03-24 Thread David Julian Veenstra
On 24, March 2018 14:12, Jonathan Cameron wrote: > On Sat, 24 Mar 2018 13:36:44 +0100 > David Julian Veenstra wrote: > >> On 23, March 2018 14:27, Jonathan Cameron wrote: >> >> > On Sun, 18 Mar 2018 14:37:04 +0100 >> > David Veenstra

Re: [PATCH 4/4] Staging: iio: accel: adis16201: Move adis16201 driver out of staging

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 00:42:45 +0530 Himanshu Jha wrote: > Move adis16201 driver out of staging and merge into mainline > IIO subsystem. > > Signed-off-by: Himanshu Jha There are a few really minor points inline. However, non prevent

Re: [PATCH 3/4] Staging: iio: accel: adis16201: Fix 80 character line limit

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 00:42:44 +0530 Himanshu Jha wrote: > Split the line over 80 characters limit to fix checkpatch > warning. > > Signed-off-by: Himanshu Jha Applied, Thanks, Jonathan > --- > drivers/staging/iio/accel/adis16201.c |

Re: [PATCH 2/4] Staging: iio: accel: adis16201: Use GENMASK

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 00:42:43 +0530 Himanshu Jha wrote: > Use GENMASK to improve readability and remove the local variables used to > store intermediate data. > > Signed-off-by: Himanshu Jha Applied to the togreg branch of iio.git.

Re: [PATCH 1/4] Staging: iio: accel: adis16201: Remove unused headers

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 00:42:42 +0530 Himanshu Jha wrote: > Remove few unused headers files since the adis core handles the buffer and > sysfs support. > > Signed-off-by: Himanshu Jha Applied to the togreg branch of iio.git and pushed out

Re: [PATCH 10/11] staging: iio: ad2s1200: Replace angle channel with inclination channel

2018-03-24 Thread Jonathan Cameron
On Sat, 24 Mar 2018 13:36:44 +0100 David Julian Veenstra wrote: > On 23, March 2018 14:27, Jonathan Cameron wrote: > > > On Sun, 18 Mar 2018 14:37:04 +0100 > > David Veenstra wrote: > > > >> The angle channel is not defined in

Re: [PATCH 05/11] staging: iio: ad2s1200: Introduce variable for repeated value

2018-03-24 Thread Jonathan Cameron
On Sat, 24 Mar 2018 13:22:22 +0100 David Julian Veenstra wrote: > On 23, March 2018 14:17, Jonathan Cameron wrote: > > > On Sun, 18 Mar 2018 14:35:46 +0100 > > David Veenstra wrote: > > > >> Add variable to hold >dev in

Re: [PATCH 11/11] staging: iio: tsl2x7x: add copyright

2018-03-24 Thread Jonathan Cameron
On Wed, 21 Mar 2018 06:29:12 -0400 Brian Masney wrote: > Add Brian Masney's copyright and to the list of module authors for all > of the staging cleanups. This patch also update's Jon Brenner's current > work email address since AMS now owns TAOS. > > Signed-off-by: Brian

Re: [PATCH 10/11] staging: iio: tsl2x7x: put local variables in reverse Christmas tree order

2018-03-24 Thread Jonathan Cameron
On Wed, 21 Mar 2018 06:29:11 -0400 Brian Masney wrote: > This patch ensures that all of the local variable declarations are in > reverse Christmas tree order where possible to increase code > readability. > > Signed-off-by: Brian Masney Applied. As

Re: [PATCH 09/11] staging: iio: tsl2x7x: remove ch0 and ch1 variables from tsl2x7x_get_lux()

2018-03-24 Thread Jonathan Cameron
On Wed, 21 Mar 2018 06:29:10 -0400 Brian Masney wrote: > Remove the ch0 and ch1 variables from tsl2x7x_get_lux() and > write those values directly into the chip->als_cur_info.als_ch0 > and chip->als_cur_info.als_ch01 variables. > > Signed-off-by: Brian Masney

Re: [PATCH 07/11] staging: iio: tsl2x7x: split out als and prox persistence settings

2018-03-24 Thread Jonathan Cameron
On Wed, 21 Mar 2018 06:29:08 -0400 Brian Masney wrote: > The struct tsl2x7x_settings contained a persistence member that > contained both the ALS and proximity persistence fields. This patch > splits this out into two separate fields so that the bitmasks in > several parts

Re: [PATCH 08/11] staging: iio: tsl2x7x: remove unused variables from tsl2x7x_get_lux()

2018-03-24 Thread Jonathan Cameron
On Wed, 21 Mar 2018 06:29:09 -0400 Brian Masney wrote: > tsl2x7x_get_lux() has a ch0lux and ch1lux variables that are not used > so this patch removes them. > > Signed-off-by: Brian Masney Had to argue with this one ;) Applied, Thanks, Jonathan

Re: [PATCH 06/11] staging: iio: tsl2x7x: make logging consistent and correct newlines

2018-03-24 Thread Jonathan Cameron
On Wed, 21 Mar 2018 06:29:07 -0400 Brian Masney wrote: > This patch updates all of the logging commands so that they are > consistent with the other messages, includes __func__ in the message, > and all of the messages include newlines. This patch also removes some > debug

Re: [PATCH 05/11] staging: iio: tsl2x7x: split out als and prox interrupt settings

2018-03-24 Thread Jonathan Cameron
On Wed, 21 Mar 2018 06:29:06 -0400 Brian Masney wrote: > The struct tsl2x7x_settings contained an interrupts_en member that was > a bitmask for which interrupts are enabled. This required having > bitmasks in several parts of the code. This patch splits this field > out

Re: [PATCH 04/11] staging: iio: tsl2x7x: simplify tsl2x7x_prox_cal()

2018-03-24 Thread Jonathan Cameron
On Wed, 21 Mar 2018 06:29:05 -0400 Brian Masney wrote: > tsl2x7x_prox_cal() would set the interrupt flag, and reset the device to > start doing the calibration routine. However, this did not actually > affect the readings since they are polled. This patch drops the

Re: [PATCH 03/11] staging: iio: tsl2x7x: no need to clear interrupt flag when getting lux

2018-03-24 Thread Jonathan Cameron
On Wed, 21 Mar 2018 06:29:04 -0400 Brian Masney wrote: > tsl2x7x_get_lux() does not need to clear the interrupt flag when > querying the ALS. The interrupt flag is cleared in > tsl2x7x_event_handler(). This patches removes the unnecessary code. > > Signed-off-by: Brian

Re: [PATCH 02/11] staging: iio: tsl2x7x: correct interrupt handler trigger

2018-03-24 Thread Jonathan Cameron
On Wed, 21 Mar 2018 06:29:03 -0400 Brian Masney wrote: > tsl2x7x_event_handler() was not called as expected when the device was > asserting a hardware interrupt. This patch changes the interrupt line > trigger from rising to falling. I guess the original test board used

Re: [PATCH 01/11] staging: iio: tsl2x7x: remove unnecessary code

2018-03-24 Thread Jonathan Cameron
On Wed, 21 Mar 2018 06:29:02 -0400 Brian Masney wrote: > As a follow up to the work in commit a0722d05a195 ("staging: iio: > tsl2x7x: convert mutex_trylock() to mutex_lock()"), this patch removes > the unnecessary calls to tsl2x7x_get_prox() and tsl2x7x_get_lux() in >

Re: [PATCH v3 8/8] staging:iio:ade7854: Remove read_reg_* duplications

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 11:27:27 -0300 Rodrigo Siqueira wrote: > The original code had a read function per data size; after updates, all > read functions tasks were centralized in a single function, but the old > signature was kept to maintain the module working

Re: [PATCH v3 7/8] staging:iio:ade7854: Rework SPI read function

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 11:27:12 -0300 Rodrigo Siqueira wrote: > Rework read SPI function to reduce the code duplication and centralizes > all the task in a single function. > > Signed-off-by: Rodrigo Siqueira Applied to the togreg

Re: [PATCH v3 6/8] staging:iio:ade7854: Rework I2C read function

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 11:26:57 -0300 Rodrigo Siqueira wrote: > The read operation for the I2C function has many duplications that can > be generalized into a single function. This patch reworks the read > operation for I2C to centralizes all similar code in a single

Re: [PATCH v3 5/8] staging:iio:ade7854: Remove write_reg_* duplications

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 11:26:41 -0300 Rodrigo Siqueira wrote: > This patch removes code duplications related to the write_reg_* > functions and centralizes them in a single function. Also, it eliminates > the legacy functions and replaces them by a unique signature

Re: [PATCH v3 4/8] staging:iio:ade7854: Rework SPI write function

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 11:26:25 -0300 Rodrigo Siqueira wrote: > The write operation using SPI has a many code duplications (similar to > I2C) and four different interfaces per data size. This patch introduces > a single function that centralizes the main task related

Re: [PATCH v3 3/8] staging:iio:ade7854: Rework I2C write function

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 11:26:06 -0300 Rodrigo Siqueira wrote: > The write operation using I2C has many code duplications and four > different interfaces per data size. This patch introduces a single > function that centralizes the main tasks. > > The central function

Re: [PATCH v3 2/8] staging:iio:ade7854: Fix the wrong number of bits to read

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 11:25:48 -0300 John Syne wrote: > Fixes: correctly handle the data size in the read operation for I2C > > The function ade7854_i2c_read_reg_32() have to invoke the > i2c_master_recv() for read 32 bits values, however, the counter is set > to 3

Re: [PATCH v3 1/8] staging:iio:ade7854: Fix error handling on read/write

2018-03-24 Thread Jonathan Cameron
On Fri, 23 Mar 2018 11:22:10 -0300 John Syne wrote: > Fixes: correctly handle errors on the read and write operation for I2C Please look at the Submitting patches documentation. This is not what a fixes tag is about! I'll fix it up this time but please look at

Re: [PATCH 10/11] staging: iio: ad2s1200: Replace angle channel with inclination channel

2018-03-24 Thread David Julian Veenstra
On 23, March 2018 14:27, Jonathan Cameron wrote: > On Sun, 18 Mar 2018 14:37:04 +0100 > David Veenstra wrote: > >> The angle channel is not defined in sysfs iio ABI. So it is replaced >> with an inclination channel, because it is defined in the ABI, and has the >>

Re: [PATCH 07/11] staging: iio: ad2s1200: Ensure udelay(1) in all necessary code paths

2018-03-24 Thread David Julian Veenstra
On 23, March 2018 14:20, Jonathan Cameron wrote: > On Sun, 18 Mar 2018 14:36:15 +0100 > David Veenstra wrote: > >> After a successful spi transaction, a udelay(1) is needed. >> This doesn't happen for the default case of the switch statement >> in

Re: [PATCH 05/11] staging: iio: ad2s1200: Introduce variable for repeated value

2018-03-24 Thread David Julian Veenstra
On 23, March 2018 14:17, Jonathan Cameron wrote: > On Sun, 18 Mar 2018 14:35:46 +0100 > David Veenstra wrote: > >> Add variable to hold >dev in ad2s1200_probe. This value is repeatedly >> used in ad2s1200_probe. >> >> Signed-off-by: David Veenstra

[PATCH 1/2] staging: ks7010: Remove trailing "_t" from all structure names.

2018-03-24 Thread Quytelda Kahja
The "_t" suffix is not needed for structure names in this driver, and is a reflection of an older typedef system that is no longer in place. Remove the "_t" suffix from every structure defined in this driver. Signed-off-by: Quytelda Kahja ---

[PATCH 2/2] staging: ks7010: Fix spelling mistakes.

2018-03-24 Thread Quytelda Kahja
Fix two spelling mistakes in comments. Signed-off-by: Quytelda Kahja --- drivers/staging/ks7010/ks_hostif.h | 2 +- drivers/staging/ks7010/ks_wlan.h | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/ks7010/ks_hostif.h

[PATCH 0/4] net: drivers/net: Use octal permissions

2018-03-24 Thread Joe Perches
Using octal and not symbolic permissions is preferred by many as more readable. https://lkml.org/lkml/2016/8/2/1945 Rather than getting these piecemeal, just do them all. Done with checkpatch and some typing. Joe Perches (4): ethernet: Use octal not symbolic permissions wireless: Use octal