On Apr 30, 2018, at 16:56, Wenwen Wang wrote:
>
> In ll_dir_ioctl(), the object lumv3 is firstly copied from the user space
> using Its address, i.e., lumv1 = &lumv3. If the lmm_magic field of lumv3 is
> LOV_USER_MAGIC_V3, lumv3 will be modified by the second copy from the user
> space. The secon
On Mon, Apr 30 2018, Christian Lütke-Stetzkamp wrote:
> On Mon, Apr 30, 2018 at 08:28:26AM +1000, NeilBrown wrote:
>> On Sun, Apr 29 2018, Christian Lütke-Stetzkamp wrote:
>>
>> > The function uffs that is implemented by this driver returns the same
>> > values as the kernel function ffs. So the
In ll_dir_ioctl(), the object lumv3 is firstly copied from the user space
using Its address, i.e., lumv1 = &lumv3. If the lmm_magic field of lumv3 is
LOV_USER_MAGIC_V3, lumv3 will be modified by the second copy from the user
space. The second copy is necessary, because the two versions (i.e.,
lov_u
On Mon, Apr 30, 2018 at 5:38 PM, Dilger, Andreas
wrote:
> On Apr 29, 2018, at 07:20, Greg Kroah-Hartman
> wrote:
>>
>> On Sat, Apr 28, 2018 at 04:04:25PM +, Dilger, Andreas wrote:
>>> On Apr 27, 2018, at 17:45, Wenwen Wang wrote:
[PATCH] staging: luster: llite: fix potential missing-ch
On Apr 29, 2018, at 07:20, Greg Kroah-Hartman
wrote:
>
> On Sat, Apr 28, 2018 at 04:04:25PM +, Dilger, Andreas wrote:
>> On Apr 27, 2018, at 17:45, Wenwen Wang wrote:
>>> [PATCH] staging: luster: llite: fix potential missing-check bug when
>>> copying lumv
>>
>> (typo) s/luster/lustre/
>>
On Mon, Apr 30, 2018 at 08:57:38AM +1000, NeilBrown wrote:
> On Sun, Apr 29 2018, Christian Lütke-Stetzkamp wrote:
>
> > Here are the next cleanups for the mt7621-mmc driver. It contains the
> > removal of some unused things, the removal of the non DMA code and
> > always using linked DMA mode tog
On Mon, Apr 30, 2018 at 08:51:45AM +1000, NeilBrown wrote:
> On Sun, Apr 29 2018, Christian Lütke-Stetzkamp wrote:
>
> > The function msdc_set_blknum consists of one (real) line of code and
> > is only called once, so inline it makes the code shorter and more
> > readable.
> >
> > Signed-off-by: C
On Mon, Apr 30, 2018 at 08:33:07AM +1000, NeilBrown wrote:
> On Sun, Apr 29 2018, Christian Lütke-Stetzkamp wrote:
>
> > Currently sdr_get_field is a macro, to bring the code in line with the
> > upstream driver mtk-sd, it is changed to a function.
> >
> > Signed-off-by: Christian Lütke-Stetzkamp
On Mon, 2018-04-30 at 15:19 +0100, Colin King wrote:
> + P2P_STATE_RECV_INVITE_REQ_DISMATCH =
> 17,/* receiving the P2P Inviation request and mismatch
> with the profile. */
Might as well fix the "inviation" as well, no? :)
Thanks
___
On Mon, Apr 30, 2018 at 08:28:26AM +1000, NeilBrown wrote:
> On Sun, Apr 29 2018, Christian Lütke-Stetzkamp wrote:
>
> > The function uffs that is implemented by this driver returns the same
> > values as the kernel function ffs. So the uffs function is removed and
> > the calls to it are replaced
From: Colin Ian King
Trivial fix to spelling mistakes in message text and comments
"dismatch" -> "mismatch"
"Inviation" -> "Invitation"
Signed-off-by: Colin Ian King
---
V2: Add Inviation fix as noted by Bastien Nocera
---
drivers/staging/rtl8723bs/hal/HalBtc8723b2Ant.c | 2 +-
drivers/stag
Note that your kernel hits the:
inconsistent {HARDIRQ-ON-W} -> {IN-HARDIRQ-W} usage.
swapper/0/0 [HC1[1]:SC0[0]:HE0:SE1] takes:
(ptrval) (fs_reclaim){?.+.}, at: fs_reclaim_acquire+0x12/0x35
{HARDIRQ-ON-W} state was registered at:
fs_reclaim_acquire
On Mon, Apr 30, 2018 at 07:59:16PM +0530, Ajay Singh wrote:
> Reviewed-by: Ajay Singh
>
> On Mon, 30 Apr 2018 07:50:40 -0500
> "Gustavo A. R. Silva" wrote:
>
> > If i < slot_id is initially true then it will remain true. Also,
> > as i is being decremented it will end up accessing memory out of
Reviewed-by: Ajay Singh
On Mon, 30 Apr 2018 07:50:40 -0500
"Gustavo A. R. Silva" wrote:
> If i < slot_id is initially true then it will remain true. Also,
> as i is being decremented it will end up accessing memory out of
> bounds.
>
> Fix this by incrementing *i* instead of decrementing it.
From: Colin Ian King
Trivial fix to spelling mistake in message text and comment
Signed-off-by: Colin Ian King
---
drivers/staging/rtl8723bs/hal/HalBtc8723b2Ant.c | 2 +-
drivers/staging/rtl8723bs/include/wifi.h| 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/driv
Local variable 'connect_code' is declared as unsigned short in
hostif_connect_indication function. Its value is got calling
get_word which returns an 'u16' so change its type to u16
which is preferred.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
1 file change
Local variable 'result_code' is declared as unsigned int in
hostif_bss_scan_confirm function. Its value is got calling
get_dword which returns an 'u32' so change its type to u32
which is preferred
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
1 file changed, 1
Handle invalid values first and assign good ones at the
end if it is the case. This makes code simplier.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_wlan_net.c | 15 ++-
1 file changed, 6 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/ks7010/ks_wlan_n
This commit refactor a bit ks_get_wireless_stats using
ternary operator for return code. It also change a comment
to use preferred style.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_wlan_net.c | 11 ---
1 file changed, 4 insertions(+), 7 deletions(-)
diff --git a/dri
This commit refactors ks_wlan_set_mlme function changing
switch-case block for more simple if paths improving
readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_wlan_net.c | 23 ++-
1 file changed, 10 insertions(+), 13 deletions(-)
diff --git a/driv
This commit refactors ks_wlan_set_sleep_mode function
avoiding to use switch-case statement ans using simple
if logic to handle invalid values first. This simplifies
data paths as well as improves readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_wlan_net.c | 22 ++
WLAN_EID_DS_PARAMS case inside switch case is just doing nothing
and it is located inside other cases. There is a place inside
the switch with other don't do anything cases are located. Move
this to that place.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 4 +---
1
This commit changes types for local variables declared in
hostif_phy_information_confirm function to use the preferred
one 'u8' and 'u32'. Its values are get using get_byte and get_dword
functions which returns 'u8' and 'u32' so it makes sense.
Signed-off-by: Sergio Paracuellos
---
drivers/stagi
This commit refactor hostif_sme_power_mgmt_set avoiding to
use switch-case statement and simplifying data paths. This
improves readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 33 ++---
1 file changed, 10 insertions(+), 23 deleti
Instead of use memcpy to copy ethernet addresses use
ether_addr_copy created for that.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks7010/ks_host
New three functions have been created to centralice and simplify
calls related with set MIB requests:
- hostif_mib_set_request_int
- hostif_mib_set_request_bool
- hostif_mib_set_request_ostring
Using these in different calls simplify functions related with
this mainly when types are b
This commit simplify conditional paths in LOCAL_EEPROM_SUM case
inside hostif_mib_get_confirm function. It change logic to handle
invalid values first and assign good ones at the end if it is the
case.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 17 +++-
Local variable 'byte' in ks7010_sdio_init_irqs is declared as
unsigned char and can be declared as u8 which is preferred.
It is being used in calls to ks7010_sdio_writeb which is already
expected an u8.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file cha
Instead of use memcpy for copying ethernet addresses, use
ether_addr_copy that do the same.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_wlan_net.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_wlan_net.c
b/drivers/staging/ks701
Header file ks_wlan.h has a lot of nonsense comments along
the different declarations included on it. Most of them are
just the same as the variable name. Just remove them all.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_wlan.h | 49
1
Local variable 'event' is declared as unsigned short in hostif_event_check
function. Its value is got calling get_word which returns an 'u16'
so change its type to u16 which is preferred.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
1 file changed, 1 insertion
Fix some checkpatch complains about long lines in some
parts of the code. It also fix some lines where spaces
instead of tabs were inserted.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 46 +-
1 file changed, 26 insertions(+), 20
Field rsn_enabled included in wpa_status struct is declared as
unsigned int but it is only be set using 0 and 1 values and
in conditional if code is just being used as a boolean. Change
its type to be a boolean.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
d
This commit changes custom implementation of CIRC_CNT_TO_END.
Just use the linux kernel header one to simplify code.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/ks7010/ks_hostif
Comments which say the same as the code are not useful at all
so just remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/k
Use ether_addr_copy to copy ethernet address instad of using
memcpy in ks_wlan_set_mac_address function.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_wlan_net.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_wlan_net.c
b/drivers/
Add blank line after definitions in hostif_aplist_init function
to fix a checkpatch script complain about that.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks701
This commit cleans code for the event SME_MIC_FAILURE_REQUEST
changing if logic to handle invalid value first and using a
local variable.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 23 ++-
1 file changed, 10 insertions(+), 13 deletions(-)
diff
Local variables 'status', 'rsize' and 'byte' are declared as
unsigned char and can be declared as u8 which is preferred.
They are being used in ks7010_sdio_readb calls which is already
expected an u8.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file chang
In all functions related with requests to the device the same
patter in used and is also adding a comment to make clear the
intention of the code. Just factor out the pattern into a new
send_request_to_device function to improve readability and make
clear code intention.
Signed-off-by: Sergio Para
This commit changes some type cast in rate related preprocessor
definitions included in ks_hostif header file to use preferred
u8 type.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.h | 24
1 file changed, 12 insertions(+), 12 deletions(-)
diff
This commit make use of ether_addr_copy to copy ethernet
address instead of copy it using memcpy.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks7
Local variable event in ks_wlan_hw_rx function is declared
as unsigned short and can be declared as u16 which is preferred
style.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/
This commit just change some preprocessor definitions related
with MIB attributes into an enumeration which is much cleaner
for this here. Also add kerneldoc to avoid long comment lines.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.h | 130 --
This commit avoid two checkpatch script complains about
two long lines.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/drivers/staging/ks7010/ks_hostif.c
inde
Event to send to init the card are always the same so change
code to be more readable putting them into an array and
enqueuing also using a for loop.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 31 +--
1 file changed, 13 insertions(+),
Parameters for hostif_power_mgmt_request are declared as unsigned
long and then are forced to be change to be u32. Also the caller
declares explicitly unsigned long parameters just to assign them
and pass into the function. Change types for those to be u32 instead
so no conversion is needed at all
Declaration of second parameter 'event' in ks_hostif .h and .c
file is different using uint16_t and unsigned short respectively.
Just unify both using 'u16' which is preferred instead.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
drivers/staging/ks7010/ks_host
In ks_wlan_translate_scan function there are two preprocessor
definitions:
- RSN_INFO_ELEM_ID
- GENERIC_INFO_ELEM_ID
These can be moved to common ks_wlan.h because they can be used
in get_current_ap function instead of use hardcoded values.
GENERIC_INFO_ELEM_ID has been renamed to WPA_INF
Use ether_addr_copy kernel function to copy an ethernet address
instead of a simple memcpy with ETH_ALEN size.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/ks7010/ks_hostif.c
b/driv
Local variable 'auth_type' is declared as unsigned short in
hostif_data_indication function. Its value is got calling get_word
which returns an 'u16' so change its type to u16 which is preferred.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 2 +-
1 file changed, 1 i
This commit changes parameter types to use enum mib_attribute, enum
mib_data_type and size_t for size instead of unsigned short. It also
reorder them in a more sense way. Code is updated in different
calls to use new parameters order using 'size' auxiliar local variables
in some of them to improve
This commit make use of two introduced local variables
to make more readable code of hostif_sme_set_rsn function.
It just assign those local variables in different cases
where are needed and extract common code to assign them
at the end.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks70
This commit just change some preprocessor definitions related
with MIB data types into an enumeration which is much cleaner
for this here.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.h | 21 -
1 file changed, 16 insertions(+), 5 deletions(-)
diff -
ks_wlan_private struct has a pointer to struct ks_sdio_card in its
fields. Because of that a forward declaration in needed in ks_wlan.h
header and also it makes necessary to have ks_sdio_card public in
a ks7010_sdio.h header. Changing this pointer into a void pointer
makes no longer necessary to ha
This commit avoids a long line changing a bit message in
_ks_wlan_hw_power_save function.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 7 ++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/ks7010/ks7010_sdio.c
b/drivers/staging/k
Local variable 'byte' in _ks_wlan_hw_power_save function is declared
as unsigned char and can be declared as u8 which is preferred. It
is being using with ks7010_sdio_readb which expects u8 already.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed
Local variable 'byte' in ks7010_rw_function is declared as unsigned
char and can be declared as u8 which is preferred. It is being used
in ks7010_sdio_readb which is already expecting an u8.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks7010_sdio.c | 2 +-
1 file changed, 1 inse
Parameter buffer in write_to_device function is declared as
a pointer to unsigned char and can be declared as an u8 type
which is preferred. Internally it calls to ks7010_sdio_write
which is using also u8 as parameter type. Update calls to this
function as well.
Signed-off-by: Sergio Paracuellos
There are some definitions for rx and tx queues in ks7010_sdio
which is not the best place to put them. Changing them into the
ks_wlan header file there is no need to explicity include ks7010_sdio.h
which makes no sense at all and can be resolved easily using
forward declarations. The functions rel
Commit 92c1552caef3661f049c4e967550e933599e2663 removes WPS hardcoded
definition and its related conditional preprocessor code. There
was some missing stuff already in this files. Remove it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/ks7010/ks_hostif.c | 6 --
drivers/staging/ks70
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Fix up the all of the staging ks7010 files to have a proper SPDX
identifier, based on the license text in the file itself. The SPDX
identifier is a legally binding shorthand, which can
This patch series are all of my patches that haven't been
applied yet. Most of them are from previous series and
there are also a few new patches included.
Sergio Paracuellos (47):
staging: ks7010: add SPDX identifiers to all files
staging: ks7010: move tx and rx queues definitions into ks_wl
On Sun, Apr 29, 2018 at 03:23:02PM +0200, Greg KH wrote:
> On Fri, Apr 27, 2018 at 04:05:54PM +0200, Sergio Paracuellos wrote:
> > Cleanups continues with this patch series. Main changes are
> > related with MIB where some preprocessor stuff has been change
> > in favour of an enumeration and some
Christoph Hellwig wrote:
> +
> +struct proc_dir_entry *proc_create_seq_data(const char *name, umode_t mode,
> + struct proc_dir_entry *parent, const struct seq_operations *ops,
> + void *data)
> +{
> ...
> +EXPORT_SYMBOL(proc_create_seq_data);
Please add documentation com
If i < slot_id is initially true then it will remain true. Also,
as i is being decremented it will end up accessing memory out of
bounds.
Fix this by incrementing *i* instead of decrementing it.
Addresses-Coverity-ID: 1468454 ("Infinite loop")
Fixes: faa657641081 ("staging: wilc1000: refactor sca
Hi,
On Thu, Mar 29, 2018 at 12:06:06AM +0800, Li Jun wrote:
> +Optional properties for usb-c-connector:
> +- power-type: should be one of "source", "sink" or "dual"(DRP) if typec
> + connector has power support.
> +- try-power-role: preferred power role if "dual"(DRP) can support Try.SNK
> + or
On Sun, Apr 29, 2018 at 03:58:55PM -0500, Wenwen Wang wrote:
> It is worth fixing this bug, since it offers an opportunity for adversaries
> to provide inconsistent user data. In addition to the unwanted version
> LOV_USER_MAGIC_V1, a malicious user can also use the version
> LMV_USER_MAGIC, which
Hi Li Jun,
Are you working on an updated version of this patch series?
I'm pondering other changes that builds on these patches (the documentation
and the fwnode added to the tcpc_dev and tcpm primarily).
Btw, there is a semi-colon missing in your example below.
BR // Mats
On 2018-03-28 18:06,
69 matches
Mail list logo