Fixes: 82784e31bba8 ("staging: goldfish: Add goldfish sync driver")
Signed-off-by: kbuild test robot
---
goldfish_sync_timeline.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/goldfish/goldfish_sync_timeline.c
b/drivers/staging/goldfish/goldfi
Hi Roman,
Thank you for the patch! Perhaps something to improve:
[auto build test WARNING on staging/staging-testing]
[also build test WARNING on v4.18-rc2 next-20180627]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https
Hi Roman,
Thank you for the patch! Perhaps something to improve:
[auto build test WARNING on staging/staging-testing]
[also build test WARNING on v4.18-rc2 next-20180627]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https
On Thu, Jun 28, 2018 at 01:42:52AM +0200, Ard Biesheuvel wrote:
> But what point is there to letting LSMs decide that they do not trust
> an I/O device if there is nothing we can do about it? How can we
> prevent such an I/O device from modifying our memory?
Simply LSMs can opt to not trust such s
On 28 June 2018 at 01:33, Luis R. Rodriguez wrote:
> On Thu, Jun 28, 2018 at 12:21:47AM +0200, Ard Biesheuvel wrote:
>> On 27 June 2018 at 20:00, Luis R. Rodriguez wrote:
>> > On Mon, Jun 25, 2018 at 05:08:08PM -0700, Bjorn Andersson wrote:
>> >> On Thu 07 Jun 11:42 PDT 2018, Ard Biesheuvel wrote
On Thu, Jun 28, 2018 at 12:21:47AM +0200, Ard Biesheuvel wrote:
> On 27 June 2018 at 20:00, Luis R. Rodriguez wrote:
> > On Mon, Jun 25, 2018 at 05:08:08PM -0700, Bjorn Andersson wrote:
> >> On Thu 07 Jun 11:42 PDT 2018, Ard Biesheuvel wrote:
> >>
> >> > On 7 June 2018 at 20:21, Bjorn Andersson
On 27 June 2018 at 20:00, Luis R. Rodriguez wrote:
> On Mon, Jun 25, 2018 at 05:08:08PM -0700, Bjorn Andersson wrote:
>> On Thu 07 Jun 11:42 PDT 2018, Ard Biesheuvel wrote:
>>
>> > On 7 June 2018 at 20:21, Bjorn Andersson
>> > wrote:
>> > > On Thu 07 Jun 09:33 PDT 2018, Greg Kroah-Hartman wrote:
On Tue, Jun 26, 2018 at 11:56:24AM +0800, Greg KH wrote:
> On Sun, Jun 24, 2018 at 04:34:51PM +0100, John Whitmore wrote:
> > Changed a number of hard coded function names to use %s and __func__
> >
> > Mailing list response suggest that there is a better method for debugging
> > using netdev_dbg(
Remove unrequired whitespace in some declarations,
fix an indentation and remove unrequired blank lines.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/os_dep/recv_linux.c | 11 ---
1 file changed, 4 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rtl8188eu/os_d
On Wed, Jun 27, 2018 at 09:42:47AM -0700, Joe Perches wrote:
> On Wed, 2018-06-27 at 19:14 +0300, Andy Shevchenko wrote:
> > On Wed, Jun 27, 2018 at 4:11 PM, Dan Carpenter
> > wrote:
> > > On Wed, Jun 27, 2018 at 02:56:00PM +0200, Michael Straube wrote:
> > > > Should I add a thanks line to the c
On Mon, Jun 25, 2018 at 05:08:08PM -0700, Bjorn Andersson wrote:
> On Thu 07 Jun 11:42 PDT 2018, Ard Biesheuvel wrote:
>
> > On 7 June 2018 at 20:21, Bjorn Andersson wrote:
> > > On Thu 07 Jun 09:33 PDT 2018, Greg Kroah-Hartman wrote:
> [..]
> > >>
> > >> Why not just use kmalloc, it will always
Using is_broadcast_ether_addr() and is_zero_ether_addr() instead of
testing each byte of the mac[] array for 0xff and 0x00 shortens the
code and improves readability.
If np == NULL, of_get_property() returns NULL, hence the "np" check
is not needed.
Instead of a fixed default mac address use a ra
Fix comparsion to NULL issues found by checkpatch.
Use !x instead of x == NULL.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
b/drivers/stag
Use the mac_pton() helper to convert the mac address string.
The functions key_char2num() and key_2char2num() are not used
anywhere else and can be removed.
This also has the benefit of validating the input since mac_pton()
returns false if the string is not valid.
Signed-off-by: Michael Straube
Use ether_addr_copy() instead of memcpy() to copy the mac address.
Suggested-by: Andy Shevchenko
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee802
On Wed, 2018-06-27 at 19:14 +0300, Andy Shevchenko wrote:
> On Wed, Jun 27, 2018 at 4:11 PM, Dan Carpenter
> wrote:
> > On Wed, Jun 27, 2018 at 02:56:00PM +0200, Michael Straube wrote:
> > > Should I add a thanks line to the commit message:
> > >
> > > Thanks to Dan Carpenter, Joe Perches an
On Wed, Jun 27, 2018 at 4:11 PM, Dan Carpenter wrote:
> On Wed, Jun 27, 2018 at 02:56:00PM +0200, Michael Straube wrote:
>> Should I add a thanks line to the commit message:
>>
>> Thanks to Dan Carpenter, Joe Perches and Andy Shevchenko.
>>
>> Or would that be considered as too much?
>
> You c
On Tue, Jun 26, 2018 at 11:56:40AM +0800, Greg Kroah-Hartman wrote:
> On Mon, Jun 25, 2018 at 08:50:26PM +0100, John Whitmore wrote:
> > On Mon, Jun 25, 2018 at 02:05:04PM +0100, Justin Skists wrote:
> > >
> > > > On 25 June 2018 at 13:36 John Whitmore wrote:
> > > >
> > > >
> > > > On Mon, Jun
On Wed, 2018-06-27 at 11:40 +0300, Dan Carpenter wrote:
> On Tue, Jun 26, 2018 at 11:30:56PM +0200, Daniel Graefe wrote:
> > Changes in v2:
> > - replaced "GPL-2.0-or-later" with "GPL-2.0+"
>
> We should make checkpatch.pl complain when people use wrong tags like
> GPL-2.0-or-later.
I'd rather we
On Wed, Jun 27, 2018 at 02:56:00PM +0200, Michael Straube wrote:
> Should I add a thanks line to the commit message:
>
> Thanks to Dan Carpenter, Joe Perches and Andy Shevchenko.
>
> Or would that be considered as too much?
You can write whatever the heck you want... :P No one cares.
When
Am 27.06.2018 um 10:33 schrieb Dan Carpenter:
On Tue, Jun 26, 2018 at 10:32:09PM +0200, Michael Straube wrote:
On 06/26/18 22:17, Joe Perches wrote:
On Tue, 2018-06-26 at 21:44 +0200, Michael Straube wrote:
On 06/26/18 19:32, Andy Shevchenko wrote:
On Tue, Jun 26, 2018 at 11:14 AM, Michael S
On Wed, 27 Jun 2018 at 17:25, Vitaly Kuznetsov wrote:
>
> Wanpeng Li writes:
>
> > Hi Vitaly, (fix my reply mess this time)
> > On Sat, 23 Jun 2018 at 01:09, Vitaly Kuznetsov wrote:
> >>
> >> When reviewing my "x86/hyper-v: use cheaper HVCALL_FLUSH_VIRTUAL_ADDRESS_
> >> {LIST,SPACE} hypercalls w
Wanpeng Li writes:
> Hi Vitaly, (fix my reply mess this time)
> On Sat, 23 Jun 2018 at 01:09, Vitaly Kuznetsov wrote:
>>
>> When reviewing my "x86/hyper-v: use cheaper HVCALL_FLUSH_VIRTUAL_ADDRESS_
>> {LIST,SPACE} hypercalls when possible" patch Michael suggested to apply the
>> same idea to PV
Wanpeng Li writes:
> Hi Vitaly, (fix my reply mess this time)
> On Sat, 23 Jun 2018 at 01:09, Vitaly Kuznetsov wrote:
>>
>> When reviewing my "x86/hyper-v: use cheaper HVCALL_FLUSH_VIRTUAL_ADDRESS_
>> {LIST,SPACE} hypercalls when possible" patch Michael suggested to apply the
>> same idea to PV
On Tue, Jun 26, 2018 at 11:30:56PM +0200, Daniel Graefe wrote:
> Changes in v2:
> - replaced "GPL-2.0-or-later" with "GPL-2.0+"
We should make checkpatch.pl complain when people use wrong tags like
GPL-2.0-or-later.
regards,
dan carpenter
___
devel mai
On Tue, Jun 26, 2018 at 10:32:09PM +0200, Michael Straube wrote:
>
> On 06/26/18 22:17, Joe Perches wrote:
> > On Tue, 2018-06-26 at 21:44 +0200, Michael Straube wrote:
> > > On 06/26/18 19:32, Andy Shevchenko wrote:
> > > > On Tue, Jun 26, 2018 at 11:14 AM, Michael Straube
> > > > wrote:
> > > >
26 matches
Mail list logo