Re: [RFC PATCH v3] Xilinx AXI-Stream FIFO v4.1 IP core driver

2018-07-20 Thread Greg KH
On Thu, Jul 19, 2018 at 09:45:31PM -0400, Jacob Feder wrote: > First I run "make menuconfig" and select my driver in "device drivers" > > "staging". If I run "make" or "make all" or > "make drivers/staging/axis-fifo" everything compiles without errors or > warnings even if I put blatant syntax

[PATCH v2] vmbus: add numa_node to sysfs

2018-07-20 Thread Stephen Hemminger
Being able to find the numa_node for a device is useful for userspace drivers (DPDK) and also for diagnosing performance issues. This makes vmbus similar to pci. Signed-off-by: Stephen Hemminger --- v2 - add sysfs doc Documentation/ABI/stable/sysfs-bus-vmbus | 7 +++

Re: [PATCH 4/4] staging: wilc1000: use descriptor-based interface for GPIO

2018-07-20 Thread Linus Walleij
On Fri, Jul 20, 2018 at 2:02 PM Ajay Singh wrote: > Now making use of descriptor-based interface instead of integer-based > interface for IRQ GPIO. > Added device tree binding reference for WILC SDIO and SPI interface > module. Also moved the code to free gpio descriptor in module remove > as

[PATCH 13/14] staging:rtl8192u: Rename MaxTxPwrDbmList > max_tx_pwr_dbm_list - Style

2018-07-20 Thread John Whitmore
Rename the member variable MaxTxPwrDbmList to max_tx_pwr_dbm_list. This change clears the checkpatch issue with CamelCase naming. The change is a simple coding style change which should not impact runtime code execution. Signed-off-by: John Whitmore ---

[PATCH 07/14] staging:rtl8192u: Remove typedef and rename struct RT_DOT11D_INFO - Style

2018-07-20 Thread John Whitmore
Removed the typedef from structure RT_DOT11D_INFO. This change clears the checkpatch issue with declaring new types. Rename the structure from RT_DOT11D_INFO to rt_dot11d_info. Coding style changes which should not impact runtime execution of code. Signed-off-by: John Whitmore ---

[PATCH 08/14] staging:rtl8192u: Rename bEnabled > enabled - Style

2018-07-20 Thread John Whitmore
Rename the member variable bEnabled to enabled. This change clears the checkpatch issue with CamelCase. Purely a coding style change which should not impact runtime execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.c | 2 +-

[PATCH 14/14] staging:rtl8192u: Rename variable State > state - Style

2018-07-20 Thread John Whitmore
Rename the variable State to state, this clears the checkpatch issue with CamelCase naming. The change is purely coding style and should not impact runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.c | 10 +-

[PATCH 09/14] staging:rtl8192u: Rename CountryIeLen > country_ie_len - Style

2018-07-20 Thread John Whitmore
Rename CountryIeLen to country_ie_len, coding style change to clear checkpatch issue with CamelCase naming. The change should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.c | 6 +++---

[PATCH 10/14] staging:rtl8192u: Rename CountryIeBuf > country_ie_buf - Style

2018-07-20 Thread John Whitmore
Rename variable CountryIeBuf to country_ie_buf, this clears the checkpatch issue with CamelCase naming. This change is a coding style change which should not impact runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.c | 2 +-

[PATCH 06/14] staging:rtl8192u: Remove typedef and rename DOT11D_STATE - Style

2018-07-20 Thread John Whitmore
Remove typedef from enumerated type DOT11D_STATE to clear checkpatch issue with declaring new types. Rename the enumertion from DOT11D_STATE to dot11d_state. These changes are coding style changes which should not effect runtime execution of code. Signed-off-by: John Whitmore ---

[PATCH 03/14] staging:rtl8192u: Rename structure member FirstChnl - Style

2018-07-20 Thread John Whitmore
Rename structure member FirstChnl to first_channel. This coding style change clears a checkpatch issue with CamelCase naming. This change should not impact the runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.c | 10 +-

[PATCH 02/14] staging:rtl8192u: Remove typedef from structure - Style

2018-07-20 Thread John Whitmore
Remove the typedef directive from struct _CHNL_TXPOWER_TRIPLE. This is a coding style change which clears a checkpatch issue with declaring new types. There should be no impact on runtime execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.c | 6 +++---

[PATCH 12/14] staging:rtl8192u: Rename CountryIeWatchdog > country_ie_watchdog - Style

2018-07-20 Thread John Whitmore
Rename the member variable CountryIeWatchdog to country_ie_watchdog, this change clears the checkpatch issue with CamelCase naming of variables. The change is a simple coding style change which should not impact runtime code execution. Signed-off-by: John Whitmore ---

[PATCH 11/14] staging:rtl8192u: Rename CountryIeSrcAddr > country_ie_src_addr - Style

2018-07-20 Thread John Whitmore
Rename variable CountryIeSrcAddr to country_ie_src_addr, this change clears the checkpatch issue with CamelCase naming. This coding style change should not impact runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.h | 6 +++--- 1 file changed, 3

[PATCH 04/14] staging:rtl8192u: Rename variable NumChnls - Style

2018-07-20 Thread John Whitmore
Rename the member variable NumChnls to num_channels. This change clears the checkpatch issue with CamelCase naming. The change should not impact runtime execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.c | 4 ++-- drivers/staging/rtl8192u/ieee80211/dot11d.h

[PATCH 00/14] staging:rtl8192u: Coding style changes

2018-07-20 Thread John Whitmore
This is a collection of simple coding style chages to clear checkpatch issues in the file drivers/staging/rtl8192u/ieee80211/dot11d.h John Whitmore (14): staging:rtl8192u: Remove multiple blank lines - Style staging:rtl8192u: Remove typedef from structure - Style staging:rtl8192u: Rename

[PATCH 01/14] staging:rtl8192u: Remove multiple blank lines - Style

2018-07-20 Thread John Whitmore
Remove multiple blank lines which cause checkpatch issues. These are purely coding style changes which should not impact execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.h | 2 -- 1 file changed, 2 deletions(-) diff --git

[PATCH 05/14] staging:rtl8192u: Rename variable MaxTxPowerInDbm - Style

2018-07-20 Thread John Whitmore
Rename the variable MaxTxPowerInDbm to max_tx_pwr_dbm. This change clears a checkpatch issue with CamelCase naming. This coding style change should not impact runtime execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.c | 2 +-

Re: [PATCH] vmbus: add numa_node to sysfs

2018-07-20 Thread Greg KH
On Fri, Jul 20, 2018 at 10:07:12AM -0700, Stephen Hemminger wrote: > Having the numa_node for a device is useful for userspace drivers > (ie DPDK) and also for diagnosing performance issues. This makes > vmbus similar to pci. > > Signed-off-by: Stephen Hemminger > --- > drivers/hv/vmbus_drv.c

[PATCH] staging: rtl8712: remove redundant pointer 'nic'

2018-07-20 Thread Colin King
From: Colin Ian King Pointer 'nic' is being assigned but is never used hence it is redundant and can be removed. Cleans up clang warning: warning: variable 'nic' set but not used [-Wunused-but-set-variable] Signed-off-by: Colin Ian King --- drivers/staging/rtl8712/rtl8712_led.c | 3 --- 1

[PATCH] Drivers: HV: panic kmsg dump, move MSR access to arch specific

2018-07-20 Thread Sunil Muthuswamy
Moves the MSR access from arch independent code to arch dependent code. Also includes minor bug fixes. Signed-off-by: Sunil Muthuswamy --- arch/x86/include/asm/mshyperv.h | 3 +++ drivers/hv/vmbus_drv.c | 26 +- 2 files changed, 12 insertions(+), 17

[PATCH 1/2] staging: vboxvideo: Pass a new framebuffer to vbox_crtc_do_set_base

2018-07-20 Thread Steve Longerbeam
This modifies vbox_crtc_do_set_base() to take a new framebuffer to be activated, instead of the existing framebuffer attached to the crtc. This change allows the function to be given the new framebuffer from a page-flip request. Signed-off-by: Steve Longerbeam ---

[PATCH 2/2] staging: vboxvideo: Add page-flip support

2018-07-20 Thread Steve Longerbeam
Adds crtc page-flip support by passing the new requested framebuffer to vbox_crtc_do_set_base(). Note there is no attempt to support vblank interrupts, it's not not known how to do this in VBOX or if it is even possible. Since this page-flip implementation does not try to sync the page-flip to

[PATCH] vmbus: add numa_node to sysfs

2018-07-20 Thread Stephen Hemminger
Having the numa_node for a device is useful for userspace drivers (ie DPDK) and also for diagnosing performance issues. This makes vmbus similar to pci. Signed-off-by: Stephen Hemminger --- drivers/hv/vmbus_drv.c | 17 + 1 file changed, 17 insertions(+) diff --git

Re: [RFC PATCH v3] Xilinx AXI-Stream FIFO v4.1 IP core driver

2018-07-20 Thread Stephen Hemminger
On Thu, 19 Jul 2018 21:45:31 -0400 Jacob Feder wrote: > First I run "make menuconfig" and select my driver in "device drivers" > > "staging". If I run "make" or "make all" or > "make drivers/staging/axis-fifo" everything compiles without errors or > warnings even if I put blatant syntax errors

[PATCH 3/4] staging: wilc1000: change compatible string from atmel to microchip

2018-07-20 Thread Ajay Singh
Use 'microchip' in compatible string instead of 'atmel', also replace '_' with '-' before the module. Remove 'wilc1000' prefix from device table name. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_sdio.c | 11 +-- drivers/staging/wilc1000/wilc_spi.c | 14 +++--- 2

[PATCH 1/4] staging: wilc1000: remove gpio parameter from wilc_netdev_init()

2018-07-20 Thread Ajay Singh
Instead of passing the gpio as parameter to wilc_netdev_init() now setting its value after finishing wilc_netdev_init() call. Avoided passing of extra parameter to wilc_netdev_init(). Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_wlan.c | 3 +--

[PATCH 2/4] staging: wilc1000: rename variable from 'gpio' to 'gpio_irq'

2018-07-20 Thread Ajay Singh
Rename from 'gpio' to 'gpio_irq', so its inlcude the information about the purpose of GPIO. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_wlan.c | 17 + drivers/staging/wilc1000/wilc_sdio.c | 2 +- drivers/staging/wilc1000/wilc_spi.c |

[PATCH 0/4] staging: wilc1000: make use of descriptor-based interface for GPIO

2018-07-20 Thread Ajay Singh
This patch series contains changes mainly related to make use of descriptor-based interface instead of integer-based interface for GPIO. Modified the compatible string to use 'microchip' instead of 'atmel' prefix. Also added the DT binding reference file. This patch is created on top of [1] patch

[PATCH 4/4] staging: wilc1000: use descriptor-based interface for GPIO

2018-07-20 Thread Ajay Singh
Now making use of descriptor-based interface instead of integer-based interface for IRQ GPIO. Added device tree binding reference for WILC SDIO and SPI interface module. Also moved the code to free gpio descriptor in module remove as the reference was fetched in probe function. Updated the TODO

Re: [PATCH V3 0/4] KVM/x86/hyper-V: Introduce PV guest address space mapping flush support

2018-07-20 Thread Paolo Bonzini
On 20/07/2018 05:58, KY Srinivasan wrote: > > >> -Original Message- >> From: Tianyu Lan >> Sent: Thursday, July 19, 2018 1:40 AM >> Cc: Tianyu Lan ; de...@linuxdriverproject.org; >> Haiyang Zhang ; h...@zytor.com; >> k...@vger.kernel.org; KY Srinivasan ; linux- >> ker...@vger.kernel.org;

Re: [PATCH 17/32] staging: gasket: annotate ioctl arg with __user

2018-07-20 Thread Greg Kroah-Hartman
On Thu, Jul 19, 2018 at 07:44:53PM -0700, Todd Poynor wrote: > >> /* Type of the ioctl permissions check callback. See below. */ > >> typedef int (*gasket_ioctl_permissions_cb_t)( > >> - struct file *filp, uint cmd, ulong arg); > >> + struct file *filp, uint cmd, void __user *arg); > >>