There is no need to '#if CONFIG_EROFS_FS_XATTR' in xattr.c,
let's remove it.
Reviewed-by: Chao Yu
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/xattr.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/erofs/xattr.c b/drivers/staging/erofs/xattr.c
index b74b314..6b9685f
This patch adds a missing break after adding the default case.
Reviewed-by: Chao Yu
Signed-off-by: Gao Xiang
---
Hi Greg,
There are two erofs bugfix & cleanup patches ready for staging-next upstream.
The original preview thread:
https://lists.ozlabs.org/pipermail/linux-erofs/2018-July/000281.
our NAND SPI
NAND is supported, if it's not add support for it, and if you find a
bug report/fix it.
Thanks,
Boris
[1]https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/tree/drivers/mtd/nand/spi?h=next-20180731
>
> Signed-off-by: Jheng-Jhong Wu
> ---
> drivers/stagi
From: Vitaly Kuznetsov Sent: Tuesday, July 31, 2018 4:20
AM
>
> Reviewed-by: Vitaly Kuznetsov
Thanks for the review
>
> Alternatively, we can get rid of synic_initialized flag altogether:
> hv_synic_init() never fails in the first place but we can always
> implement something like:
>
> int
Hi Dan,
On Mon, 30 Jul 2018 14:32:31 +0300
Dan Carpenter wrote:
> On Mon, Jul 30, 2018 at 03:40:24PM +0530, Ajay Singh wrote:
> > Hi Dan,
> >
> > On Mon, 30 Jul 2018 11:41:13 +0300
> > Dan Carpenter wrote:
> >
> > > On Fri, Jul 20, 2018 at 04:35:24AM +0530, Ajay Singh wrote:
> > > > Hi Da
Refactor wilc_wlan_handle_isr_ext() to avoid the use of the goto label.
Also avoid the unnecessary NULL check for 'wilc->rx_buffer' and
calling wilc_wlan_handle_rxq() only after wilc_wlan_rxq_add() call.
The link [1] contains details for discussion related to this changes.
[1]. https://patchwork.k
On Wed, Aug 01, 2018 at 07:56:38AM +1000, NeilBrown wrote:
> On Tue, Jul 31 2018, Sergio Paracuellos wrote:
>
> > This patch series include an attempt to avoid the use of custom
> > read and writes in driver code and use PCI subsystem common ones.
> >
> > In order to do this 'map_bus' callback is
For NAND flash chips with more than 1Gbit (e.g. MT29F2G) more than 16 bits
are necessary to address the correct page. The driver sets the address for
more than 16 bits, but it uses 16-bit arguments and variables (these are
page_id, block_id, row) to do address operations. Obviously, these
arguments
On Tue, Jul 31 2018, Sergio Paracuellos wrote:
> This patch series include an attempt to avoid the use of custom
> read and writes in driver code and use PCI subsystem common ones.
>
> In order to do this 'map_bus' callback is implemented and also
> data structures for driver are included. The reg
A number of block comments have been changed to comply with the coding
standard. These are coding style changes which should have no impact
on runtime code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 14 +++---
1 file changed, 7 insertio
The macro IsACValid is renamed to resolve the checkpatch issue with
CamelCase naming. In addition the parameter has parenthesis added to
clear the checkpatch issue with precedence issues.
These changes are coding style changes and as such should have not
impact on runtime code execution.
Signed-o
Move the union QOS_TCLAS from the header file rtl819x_Qos.h to header
file rtl819x_TS.h, where the structure is actually used, as the member
of another structure.
This is a coding style change, which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
.../staging/r
Rename TSInfo, the memeber variable of struct tspec_body to ts_info.
This change clears the checkpatch issue with CamelCase naming.
This is a coding style change which should not impact runtime code
execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_BAProc.c
The union aci_aifsn is not used as a union, but only as a struct.
The union seems to have been used to ensure that the size of the
structure was only a single byte. That size is set by the bitfield
structure, adding a union with an unused byte adds nothing.
The union has been removed. This is a co
The macro UP2AC is commented out of the header file so the macro and its
associated comment are removed.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 3 ---
1 file changed
The union is never used as a union but only as a bitfield struct.
One side of the union (u8 charData[3];) Only seems to be present to
ensure that the structures size is 3 bytes in length. That length, of
the structure is dictated by the largest element of the union, so the
byte array only dictates
Rename the structure OCTET_STRING to octet_string. This is to comply
with the coding style of using lowercase for types. In addition the
typedef directive is removed to clear the checkpatch issue with
defining new types.
These are coding style changes which should have no impact on runtime
code ex
Rename the structure octet_string's member variables Octet to octet and
Length to length. This change clears the checkpatch issue with CamelCase
naming of variables.
This is purely a coding style change which should have no impact on
runtime code execution.
Signed-off-by: John Whitmore
---
.../
The member variables of struct qos_tsinfo all cause checkpatch issues
with CamelCase naming. As the variables are used in so few places the
changes are combined into this single patch.
Additionally the member variable usReserved is never used in code so
has been removed.
These are all coding styl
The member variables of the tspec_body have been renamed to clear the
checkpatch issue with CamelCase naming. As these member variables are
never used in the code the changes are combined into this single
patch.
These changes are coding style changes which should have no impact on
runtime code exe
The only useful piece of information in the header comment of this
static function was the name of the function and parameters. That
is not useful information, given that they are in the C Source of
the function declaration, a few lines below the comment. The block
comment has been removed.
This i
A number of structures have been commented out of code. Obviously they
are not used and as a result have been removed from the code.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
.../staging/rtl8192u/ieee80211/rtl819x_Qos.h
The first patch is a change to the block comment on the function
cmpk_counttxstatistic(). The function is a static to the file so the
block comment could be trimmed. Unfortunately I could find no useful
information in the block comment, apart from function name and list
of parameter types, which is
The union TSPEC_BODY is never used as a union. The union comprises an
array of bytes and a bitfield structure, both of which are 55 bytes in
length, but the byte array is never used. As a result the union has
been truncated to the bitfield struct, which is actually used.
Additionally the typedef h
From: Todd Poynor
Fix multi-line alignment formatting to look like:
int ret = long_function_name(device, VARIABLE1, VARIABLE2,
VARIABLE3, VARIABLE4);
Many of these TODO items were previously cleaned up during the conversion
to standard logging functions.
From: Todd Poynor
Fix multi-line alignment formatting to look like:
int ret = long_function_name(device, VARIABLE1, VARIABLE2,
VARIABLE3, VARIABLE4);
Many of these TODO items were previously cleaned up during the conversion
to standard logging functions.
From: Todd Poynor
Remove forward declarations of static functions, move code to avoid
forward references, for kernel style.
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/gasket_page_table.c | 1433 ++--
1 file changed, 684 insertions(+), 749 deletions(-)
diff --git a/d
From: Todd Poynor
apex.h is supposed to contain kernel-userspace interface definitions,
but has a number of defines that are only used by apex_driver.c or are
not used at all. Move driver implementation defines not shared with
userspace to the driver source. Remove unused defines.
Signed-off-b
From: Todd Poynor
The include guard symbol for gasket_page_table.h is out-of-date.
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/gasket_page_table.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/gasket/gasket_page_table.h
b/drivers/staging/g
From: Todd Poynor
Multi-line alignment formatting issues fixed, remove the TODO entry for
this.
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/TODO | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/gasket/TODO b/drivers/staging/gasket/TODO
index 6aa2a7f6bc4b..6ff8e01
From: Todd Poynor
Fix multi-line alignment formatting to look like:
int ret = long_function_name(device, VARIABLE1, VARIABLE2,
VARIABLE3, VARIABLE4);
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/gasket_sysfs.c | 26 +++---
drive
From: Todd Poynor
gasket_free_dev() is called only from driver PCI probe and remove
function. It is guaranteed that that pci_dev structure is not going
anywhere during that time; there is no need to take this additional
reference.
This reverts commit dd9d1502feea3c23d412f289aad79e1d4e86d45d.
Re
From: Todd Poynor
Fix multi-line alignment formatting to look like:
int ret = long_function_name(device, VARIABLE1, VARIABLE2,
VARIABLE3, VARIABLE4);
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/gasket_core.c | 294 +--
From: Todd Poynor
When gasket core was converted from using capable() to use ns_capable()
instead, the type of the variable holding the result should have been
converted from int to bool.
Reported-by: Dmitry Torokhov
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/gasket_core.c | 4 ++--
From: Todd Poynor
Fix multi-line alignment formatting to look like:
int ret = long_function_name(device, VARIABLE1, VARIABLE2,
VARIABLE3, VARIABLE4);
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/gasket_interrupt.c | 73 +++
From: Todd Poynor
Remove forward declarations of static functions, move code to avoid
forward references, for kernel style.
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/gasket_core.c | 1900 +-
1 file changed, 922 insertions(+), 978 deletions(-)
diff --git a/d
From: Todd Poynor
The static function declarations are removed, remove the TODO file entry
for this.
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/TODO | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/gasket/TODO b/drivers/staging/gasket/TODO
index 7f4c13ce021b..6aa2a
From: Todd Poynor
Remove forward declarations of static functions, move code to avoid
forward references, for kernel style.
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/gasket_ioctl.c | 356 --
1 file changed, 168 insertions(+), 188 deletions(-)
diff --git a/d
From: Todd Poynor
Remove forward declarations of static functions, move code to avoid
forward references, for kernel style.
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/gasket_interrupt.c | 499 +++---
1 file changed, 242 insertions(+), 257 deletions(-)
diff --git a/d
From: Todd Poynor
More cleanups for the gasket and apex drivers: finish up TODO items
for static function forward declarations and multi-line alignment
style, a couple of fixups for recent patch feedback, and a couple
other issues found in the meantime.
Todd Poynor (15):
staging: gasket: core:
Convert the DPAA2 Ethernet driver documentation to .rst format
and rename the file accordingly.
Also add a SPDX tag to the new rst file.
Signed-off-by: Ioana Ciornei
---
.../ethernet/{README => ethernet-driver.rst} | 39 +++---
1 file changed, 19 insertions(+), 20 deletions
The DPAA2 Ethernet driver files use a GPL-2.0+ OR BSD-3-Clause
license. Add SPDX tags and delete the full license text,
keeping the existing licenses for each file.
Add a GPL-2.0 tag for the Makefile.
Signed-off-by: Ioana Ciornei
---
drivers/staging/fsl-dpaa2/ethernet/Makefile| 1 +
...
On Wednesday, 25 July 2018 04:20:29 MSK Dmitry Osipenko wrote:
> On Wednesday, 25 July 2018 03:37:33 MSK Mauro Carvalho Chehab wrote:
> > Em Wed, 25 Jul 2018 01:38:37 +0300
> >
> > Dmitry Osipenko escreveu:
> > > On Wednesday, 25 July 2018 01:06:52 MSK Mauro Carvalho Chehab wrote:
> > > > Em Sat,
Add handling of possible allocation failure.
Reported by smatch:
drivers/staging/gasket/gasket_sysfs.c:105 put_mapping() error: potential null
dereference 'files_to_remove'. (kcalloc returns null)
Signed-off-by: Ivan Bornyakov
---
drivers/staging/gasket/gasket_sysfs.c | 6 ++
1 file cha
read_config function is always called with bus and func
being 0. Avoid those params and just use 0 inside the
function. Return readed value instead pass a reference
parameter.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 32 +++-
1 f
RALINK_PCI_BASE has no sense and this driver has base address readed
and mapped from device tree. Remove remaining uses of it and
change code to use pcie_read and pcie_write functions in places
where this was being used.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621
RALINK_PCI_CONFIG_DATA_VIRTUAL_REG is a very long name. Make it a bit
shorter renaming it to RALINK_PCI_CONFIG_DATA.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/mt7621-pc
The pcie node of the device tree only contains registers
for the host-bridge and pcie port 0. Add the pcie port 1
and pcie port 2 also.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-dts/mt7621.dtsi | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/s
write_config function is always called with bus and func
being 0. Avoid those params and just use 0 inside the
function. Review parameter types changing for more proper
ones.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 20 +---
1 file changed,
Use pcie_[read|write] fucntions to read and write controller registers.
Define those only by offset and pass controller offset + register offset
relative to base address to functions.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 70 -
Some preprocessor definitions are using a custom implementation of
BIT macro. Just use linux kernel BIT macro instead.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/
pcibios_* remaining code is not neccessary at all. We can use
map_irq set to of_irq_parse_and_map_pci driver 'probe' function.
Remove this code.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 33 +
1 file changed, 1 insertion(+), 3
There some macros that are not being used. Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 24 +---
1 file changed, 1 insertion(+), 23 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci
RALINK_PCI_PCICFG_ADDR and RALINK_PCI_PCIMSK_ADDR are defined to be directly
referenced for read and write. Use pcie_read and pcie_write instead changing
its definition to a simple relative offset to pcie base address.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c
There are some includes that are being used that are not really
needed to correct driver compilation. Remove them and reorder the
rest alphabetically.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 22 --
1 file changed, 8 insertions(+), 14 de
This patch series include an attempt to avoid the use of custom
read and writes in driver code and use PCI subsystem common ones.
In order to do this 'map_bus' callback is implemented and also
data structures for driver are included. The regs base address
ranges and data is being readed from devic
Instead of custom macros use pcie_read and pcie_write functions.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 67 -
1 file changed, 32 insertions(+), 35 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/driver
Driver is using now pci subsystem generics reads and writes and requesting
bus resources without using legacy code functions. Because of this there is
a lot of dead code that can be removed.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 135 -
Introdice this functions to make easier to write/read to/from
an offset relative to base address
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/stagin
map_bus callback is called before every .read/.write operation.
Implement it and change custom read write operations for the
pci subsystem generics. Make the probe function to don't use
legacy stuff and request bus resources directly. Get pci register
base and ranges from device tree.
The driver is
Rename source and header file to avoid CamelCase.
odm_RTL8188E.c -> odm_rtl8188e.c
odm_RTL8188E.h -> odm_rtl8188e.h
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/Makefile | 2 +-
.../staging/rtl8188eu/hal/{odm_RTL8188E.c => odm_rtl8188e.c}| 0
driv
The function rtw_remove_bcn_ie() is never used, so remove it.
Discovered by cppcheck.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_ap.c| 40 --
drivers/staging/rtl8188eu/include/rtw_ap.h | 2 --
2 files changed, 42 deletions(-)
diff --git a/driv
Use is_broadcast_ether_addr instead of checking each byte of the
address array for 0xff. Shortens the code and improves readability.
As required by is_broadcast_ether_addr, the address array sta_addr
is properly aligned in all uses. Thanks to Joe Perches.
Signed-off-by: Michael Straube
---
.../
The function rtw_add_bcn_ie() is never used, so remove it.
Discovered by cppcheck.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_ap.c| 66 --
drivers/staging/rtl8188eu/include/rtw_ap.h | 2 -
2 files changed, 68 deletions(-)
diff --git a/drivers/
Use x instead of x != NULL.
Use !x instead of x == NULL.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/os_dep/os_intfs.c | 2 +-
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 6 +++---
drivers/staging/rtl8188eu/os_dep/usb_ops_linux.c | 10 +-
drivers/staging/rt
Remove unnecessary parentheses to improve readability.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/os_dep/usb_ops_linux.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/os_dep/usb_ops_linux.c
b/drivers/staging/rtl8188eu/os_dep/
Fix indentation to clear checkpatch warnings.
WARNING: suspect code indent for conditional statements
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/os_dep/ioctl_linux.c | 4 ++--
drivers/staging/rtl8188eu/os_dep/usb_intf.c| 2 +-
2 files changed, 3 insertions(+), 3 deletions(-
mhkelle...@gmail.com writes:
> From: Michael Kelley
>
> The synic_initialized flag is part of the global hv_context
> structure. But the Hyper-V synthetic interrupt controller is
> fundamentally a per-cpu device, and other synic related
> fields are in hv_per_cpu_context. In a multi-CPU system,
On Tue, Jul 31, 2018 at 03:25:43PM +1000, NeilBrown wrote:
> On Tue, Jul 31 2018, Sergio Paracuellos wrote:
>
> > On Tue, Jul 31, 2018 at 08:55:52AM +1000, NeilBrown wrote:
> >> On Mon, Jul 30 2018, Sergio Paracuellos wrote:
> >>
> >> > This patch series include an attempt to avoid the use of cus
69 matches
Mail list logo