Re: [PATCH v2 01/15] staging:rtl8192u: Remove macro eqMacAddr - Style

2018-08-08 Thread Joe Perches
On Wed, 2018-08-08 at 22:00 +0100, John Whitmore wrote: > The macro eqMacAddr implements the same functionality as the > ether_addr_equal function defined in etherdevice.h, as a result the > macro has been removed from the code, and its use replaced with the > function call. [] > diff --git

[PATCH v2 08/15] staging:rtl8192u: Rename Dot11d_Reset - Style

2018-08-08 Thread John Whitmore
The function Dot11d_Reset causes a checkpatch issue due to its use of CamelCase naming, so has been renamed to dot11d_reset. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.c

[PATCH v2 10/15] staging:rtl8192u: Rename dot11d_update_country_ie() parameters - Style

2018-08-08 Thread John Whitmore
The function dot11d_update_country_ie() uses parameter names which cause a checkpatch issue due to the use of CamelCase naming. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/dot11d.h | 6

[PATCH v2 04/15] staging:rtl8192u: Rename macro parameter __pIeeeDev - Style

2018-08-08 Thread John Whitmore
Multiple macros, defined in dot11d.h, use the variable __pIeeeDev as a parameter. This name causes a checkpatch issue due to its use of CamelCase naming. The parameter name has been changed to ieee_dev to clear this issue. This is a coding style change which should have no impact on runtime code

[PATCH v2 01/15] staging:rtl8192u: Remove macro eqMacAddr - Style

2018-08-08 Thread John Whitmore
The macro eqMacAddr implements the same functionality as the ether_addr_equal function defined in etherdevice.h, as a result the macro has been removed from the code, and its use replaced with the function call. Note that to use the ether_addr_equal function the data array containing the MAC

[PATCH v2 02/15] staging:rtl8192u: Remove macro cpMacAddr - Style

2018-08-08 Thread John Whitmore
The macro cpMacAddr implements the same functionality as the ether_addr_copy function defined in etherdevice.h, as a result the macro has been removed from the code, and its use replaced with the function call. Note that the header comment of the function ether_addr_copy states that the two byte

[PATCH v2 11/15] staging:rtl8192u: Rename DOT11D_GetMaxTxPwrInDbm - Style

2018-08-08 Thread John Whitmore
The function DOT11D_GetMaxTxPwrInDbm causes a checkpatch issue due to its use of CamelCase naming. The function has been renamed to dot11d_get_max_tx_pwr_in_dbm. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore ---

[PATCH v2 07/15] staging:rtl8192u: Rename Dot11d_Init - Style

2018-08-08 Thread John Whitmore
The function Dot11d_Init() causes a checkpatch issue due to its use of CamelCase naming. The function has been renamed to dot11d_init. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore ---

[PATCH v2 03/15] staging:rtl8192u: Replace magic number 6 with ETH_ALEN - Style

2018-08-08 Thread John Whitmore
The array size 6 represents the length of an Ethernet address so the magic number has been replaced with the defined constant representing that length. This is a coding style change which should not impact runtime code execution. Signed-off-by: John Whitmore ---

[PATCH v2 12/15] staging:rtl8192u: Rename Channel - Style

2018-08-08 Thread John Whitmore
The function dot11d_get_max_tx_pwr_in_dbm() uses a parameter name, Channel, which causes a checkpatch issue with CamelCase naming. The parameter has been renamed to channel. The change is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore

[PATCH v2 13/15] staging:rtl8192u: Rename DOT11D_ScanComplete - Style

2018-08-08 Thread John Whitmore
The function DOT11D_ScanComplete causes a checkpatch issue due to its use of CamelCase naming. The function has been renamed to dot11d_scan_complete. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore ---

[PATCH v2 15/15] staging:rtl8192u: Rename ToLegalChannel - Style

2018-08-08 Thread John Whitmore
Rename the function ToLegalChannel, which causes a checkpatch issue due to its use of CamelCase naming. The function has been renamed to to_legal_channel. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore ---

[PATCH v2 09/15] staging:rtl8192u: Rename Dot11d_UpdateCountryIe - Style

2018-08-08 Thread John Whitmore
The function Dot11d_UpdateCountryIe causes a checkpatch issue due to its use of CamelCase naming, the function has been renamed to dot11d_update_country_ie. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore ---

[PATCH v2 14/15] staging:rtl8192u: Rename IsLegalChannel - Style

2018-08-08 Thread John Whitmore
The function IsLegalChannel causes a checkpatch issue due to its use of CamelCase naming. The function has been renamed to is_legal_channel. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore ---

[PATCH v2 05/15] staging:rtl8192u: Rename __pTa - Style

2018-08-08 Thread John Whitmore
The macro parameter __pTa causes a checkpatch issue because of its use of CamelCase naming. The parameter has this been renamed to addr. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore ---

[PATCH v2 06/15] staging:rtl8192u: Lines should not end with a '(' - Style

2018-08-08 Thread John Whitmore
A number of function prototypes cause a checkpatch issue - "Lines should not end with a '(' ". This issue has been cleared by moving function prototype parameters to the same line as the function name. This is a coding style change which should have no impact on runtime code execution.

[PATCH v2 00/15] staging:rtl8192u: Coding style

2018-08-08 Thread John Whitmore
In this second version of the series I've replaced the macros eqMacAddr and cpMacAddr with functions suggested by Joe Perches One issue with this change is that both of the functions now used, defined in etherdevice.h, rely on the parameters being u16 aligned. To achieve this I've re-ordered

Re: [PATCH] Staging:rtl8712: Style - Removed inline block comment to fix "Statements should start on a tapstop"

2018-08-08 Thread Dan Carpenter
On Wed, Aug 08, 2018 at 11:22:57AM +0200, Greg KH wrote: > On Sun, Aug 05, 2018 at 09:41:06PM +0200, Frank Werner-Krippendorf wrote: > > Removed 5 inline comments "/*volatile*/" rtl87x_event.h, to fix > > a coding style issue "Statements should start on a tabstop" > > detected by checkpatch.pl

Re: [PATCH] Staging:rtl8712: Style - Removed inline block comment to fix "Statements should start on a tapstop"

2018-08-08 Thread Dan Carpenter
Oh, yeah. Greg's comments were very clear. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH] Staging:rtl8712: Style - Removed inline block comment to fix "Statements should start on a tapstop"

2018-08-08 Thread Dan Carpenter
On Wed, Aug 08, 2018 at 10:59:26AM -0500, Larry Finger wrote: > On 08/08/2018 04:22 AM, Greg KH wrote: > > On Sun, Aug 05, 2018 at 09:41:06PM +0200, Frank Werner-Krippendorf wrote: > > > Removed 5 inline comments "/*volatile*/" rtl87x_event.h, to fix > > > a coding style issue "Statements should

[PATCH v2] vmbus: add driver_override support

2018-08-08 Thread Stephen Hemminger
Add support for overriding the default driver for a VMBus device in the same way that it can be done for PCI devices. This patch adds the /sys/bus/vmbus/devices/.../driver_override file and the logic for matching. This is used by driverctl tool to do driver override.

Re: [PATCH] staging: most: do not show interface dependent attrs by default in sysfs

2018-08-08 Thread Greg KH
On Wed, Aug 08, 2018 at 04:51:26PM +0200, Christian Gromm wrote: > On 08.08.2018 14:10, Greg KH wrote: > > On Mon, Aug 06, 2018 at 12:03:10PM +0200, Christian Gromm wrote: > > > The channel attribute dbr_size is only relevant for the DIM2 interface. So > > > is the packets_per_xact for USB.

Re: [PATCH] Staging:rtl8712: Style - Removed inline block comment to fix "Statements should start on a tapstop"

2018-08-08 Thread Larry Finger
On 08/08/2018 04:22 AM, Greg KH wrote: On Sun, Aug 05, 2018 at 09:41:06PM +0200, Frank Werner-Krippendorf wrote: Removed 5 inline comments "/*volatile*/" rtl87x_event.h, to fix a coding style issue "Statements should start on a tabstop" detected by checkpatch.pl script. Signed-off-by: Frank

[PATCH v3] Staging: One Laptop Per Child: fix SPDX-License-Identifier issue

2018-08-08 Thread Arkadiusz Lis
Add SPDX-License-Identifier to the source files. Remove redundant, old license. Signed-off-by: Arkadiusz Lis --- Changes in v3: - change old license to SPDX - adding change summary, missing in v2 drivers/staging/olpc_dcon/olpc_dcon.c| 5 +

Re: [PATCH v2] staging/vc04_services: Fix alignment of function arguments

2018-08-08 Thread greg gallagher
On 2018-08-07 09:34 PM, Greg Gallagher wrote: Fix warnings generated by checkpatch.pl for alignment should match open parenthesis. This is a coding style change only. Signed-off-by: Greg Gallagher --- .../staging/vc04_services/bcm2835-audio/bcm2835-ctl.c | 18 +- 1 file

Re: [PATCH] staging: most: do not show interface dependent attrs by default in sysfs

2018-08-08 Thread Christian Gromm
On 08.08.2018 14:10, Greg KH wrote: On Mon, Aug 06, 2018 at 12:03:10PM +0200, Christian Gromm wrote: The channel attribute dbr_size is only relevant for the DIM2 interface. So is the packets_per_xact for USB. Currently, all attrs are shown by default in sysfs for any channel. To get a clean

Re: [PATCH v10 00/15] staging: mt7621-pci: avoid custom pci config read and writes

2018-08-08 Thread Sergio Paracuellos
On Wed, Aug 8, 2018 at 2:08 PM, Greg KH wrote: > On Mon, Aug 06, 2018 at 10:21:46AM +1000, NeilBrown wrote: >> On Fri, Aug 03 2018, Sergio Paracuellos wrote: >> >> > This patch series include an attempt to avoid the use of custom >> > read and writes in driver code and use PCI subsystem common

Re: [PATCH v2] staging/bcm2835-audio: Fix alignment of function arguments - Style

2018-08-08 Thread Greg Kroah-Hartman
On Wed, Aug 08, 2018 at 08:54:49AM -0400, Greg Gallagner wrote: > On 08/08/2018 08:26 AM, Greg Kroah-Hartman wrote: > > On Tue, Aug 07, 2018 at 09:40:47PM -0400, Greg Gallagher wrote: > >> Fix warnings generated by checkpatch.pl for alignment should match open > >> parenthesis. This is a coding

Re: [PATCH 04/17] staging:rtl8192u: Rename eqMacAddr macro - Style

2018-08-08 Thread Joe Perches
On Tue, 2018-08-07 at 22:12 +0100, John Whitmore wrote: > The eqMacAddr(a, b) macro causes a checkpatch issue, due to CamelCase > naming, so has been renamed to eq_mac_addr(a, b). > > This is a coding style change which should not impact on runtime code > execution. [] > diff --git

Re: [PATCH v2] staging/bcm2835-audio: Fix alignment of function arguments - Style

2018-08-08 Thread Greg Gallagner
On 08/08/2018 08:26 AM, Greg Kroah-Hartman wrote: > On Tue, Aug 07, 2018 at 09:40:47PM -0400, Greg Gallagher wrote: >> Fix warnings generated by checkpatch.pl for alignment should match open >> parenthesis. This is a coding style change only. >> >> Signed-off-by: Greg Gallagher >> --- >> Changes

Re: [PATCH v2] staging/bcm2835-audio: Fix alignment of function arguments - Style

2018-08-08 Thread Greg Kroah-Hartman
On Tue, Aug 07, 2018 at 09:40:47PM -0400, Greg Gallagher wrote: > Fix warnings generated by checkpatch.pl for alignment should match open > parenthesis. This is a coding style change only. > > Signed-off-by: Greg Gallagher > --- > Changes in v2: > - Clean up all the alignment warnings in

Re: [PATCH v2 15/15] staging: fbtft: Replaces custom debug macro with dev_dbg().

2018-08-08 Thread Greg Kroah-Hartman
On Tue, Aug 07, 2018 at 09:30:10PM -0300, Leonardo Brás wrote: > Changes custom macro to dev_dbg to avoid parameter multiple usage and use of > typeof(). linewrap please. And while this is a good start, please replace the places this custom macro is called with dev_dbg(), and then delete this

Re: [PATCH v2 04/15] staging: fbtft: Fixes some lines long lines (>80) - Style

2018-08-08 Thread Greg Kroah-Hartman
On Tue, Aug 07, 2018 at 09:28:42PM -0300, Leonardo Brás wrote: > Trying to keep the code in the 80-char line limit. > > Signed-off-by: Leonardo Brás > > diff --git a/drivers/staging/fbtft/fb_ssd1306.c > b/drivers/staging/fbtft/fb_ssd1306.c > index 9276be499303..f5e0ec1c01dc 100644 > ---

Re: [PATCH v2 11/15] staging: fbtft: Includes description to mutex and spinlock - Style

2018-08-08 Thread Greg Kroah-Hartman
On Tue, Aug 07, 2018 at 09:29:31PM -0300, Leonardo Brás wrote: > Includes description to mutex and spinlocks, as recommended by checkpatch.pl. > > Signed-off-by: Leonardo Brás > --- > drivers/staging/fbtft/fbtft.h | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git

Re: [PATCH v2 10/15] staging: fbtft: Fixes some defines styles - Style

2018-08-08 Thread Greg Kroah-Hartman
On Tue, Aug 07, 2018 at 09:29:25PM -0300, Leonardo Brás wrote: > Fixing some styles as recommended by checkpatch.pl. > > Signed-off-by: Leonardo Brás > --- > drivers/staging/fbtft/fbtft-bus.c | 10 ++ > drivers/staging/fbtft/fbtft-core.c | 6 -- > drivers/staging/fbtft/fbtft.h

Re: [PATCH v2 01/15] staging: fbtft: Changes udelay(n) to usleep_range(n, n + x). - Style

2018-08-08 Thread Greg Kroah-Hartman
On Tue, Aug 07, 2018 at 09:28:00PM -0300, Leonardo Brás wrote: > Changes some udelay(n) for n >= 10 to usleep_range(n, n+x) as recommended by > checkpatch.pl. Please properly wrap your changelog lines at 72 columns or close to that. > > Signed-off-by: Leonardo Brás > --- >

Re: [PATCH] staging: most: do not show interface dependent attrs by default in sysfs

2018-08-08 Thread Greg KH
On Mon, Aug 06, 2018 at 12:03:10PM +0200, Christian Gromm wrote: > The channel attribute dbr_size is only relevant for the DIM2 interface. So > is the packets_per_xact for USB. Currently, all attrs are shown by default > in sysfs for any channel. To get a clean content of a channel directory, >

Re: [PATCH v10 00/15] staging: mt7621-pci: avoid custom pci config read and writes

2018-08-08 Thread Greg KH
On Mon, Aug 06, 2018 at 10:21:46AM +1000, NeilBrown wrote: > On Fri, Aug 03 2018, Sergio Paracuellos wrote: > > > This patch series include an attempt to avoid the use of custom > > read and writes in driver code and use PCI subsystem common ones. > > > > In order to do this 'map_bus' callback is

Re: [PATCH v6 1/8] media: v4l: Add definitions for MPEG2 slice format and metadata

2018-08-08 Thread Paul Kocialkowski
Hi, On Sat, 2018-08-04 at 15:30 +0200, Hans Verkuil wrote: > On 07/25/2018 12:02 PM, Paul Kocialkowski wrote: [...] > > diff --git a/Documentation/media/uapi/v4l/pixfmt-compressed.rst > > b/Documentation/media/uapi/v4l/pixfmt-compressed.rst > > index abec03937bb3..4e73f62b5163 100644 > > ---

Re: [PATCH v6 1/8] media: v4l: Add definitions for MPEG2 slice format and metadata

2018-08-08 Thread Paul Kocialkowski
Hi Hans, On Sat, 2018-08-04 at 13:35 +0200, Hans Verkuil wrote: > Hi Paul, > > Some comments below. It looks pretty good, it's mostly small things that I > commented upon. And thanks for the review! > On 07/25/2018 12:02 PM, Paul Kocialkowski wrote: > > Stateless video decoding engines require

[PATCH] staging: rtl8188eu: remove unused mp_custom_oid.h

2018-08-08 Thread Michael Straube
The header mp_custom_oid.h is not used, so remove it. 'git grep mp_custom_oid.h drivers/staging/rtl8188eu/' returns nothing. Signed-off-by: Michael Straube --- .../staging/rtl8188eu/include/mp_custom_oid.h | 339 -- 1 file changed, 339 deletions(-) delete mode 100644

Re: [PATCH 05/17] staging:rtl8192u: Rename cpMacAddr Macro - Style

2018-08-08 Thread Joe Perches
On Tue, 2018-08-07 at 22:12 +0100, John Whitmore wrote: > Rename the Macro cpMacAddr(des, src), as it causes a checkpatch issue > due its use of CamelCase naming, to cp_mac_addr(des, src). [] > diff --git a/drivers/staging/rtl8192u/ieee80211/dot11d.h >

[PATCH] ddk750_mode.c: Wraps line to 80 charecters

2018-08-08 Thread Abishek V Ashok
Splits definition of function programModeRegisters into two lines such that each line is less than 80 characters. Signed-off-by: Abishek V Ashok --- drivers/staging/sm750fb/ddk750_mode.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

Re: [PATCH v6 4/8] media: platform: Add Cedrus VPU decoder driver

2018-08-08 Thread Paul Kocialkowski
Hi, On Mon, 2018-08-06 at 16:21 +0200, Paul Kocialkowski wrote: > Hi, > > On Fri, 2018-08-03 at 17:49 -0300, Ezequiel Garcia wrote: > > On Wed, 2018-07-25 at 12:02 +0200, Paul Kocialkowski wrote: > > > This introduces the Cedrus VPU driver that supports the VPU found in > > > Allwinner SoCs,

Re: [PATCH] Staging:rtl8712: Style - Removed inline block comment to fix "Statements should start on a tapstop"

2018-08-08 Thread Greg KH
On Sun, Aug 05, 2018 at 09:41:06PM +0200, Frank Werner-Krippendorf wrote: > Removed 5 inline comments "/*volatile*/" rtl87x_event.h, to fix > a coding style issue "Statements should start on a tabstop" > detected by checkpatch.pl script. > > Signed-off-by: Frank Werner-Krippendorf > --- >

Re: [PATCH 00/15] staging: gasket: unwrap pci core and more

2018-08-08 Thread Greg Kroah-Hartman
On Sun, Aug 05, 2018 at 01:07:34PM -0700, Todd Poynor wrote: > From: Todd Poynor > > Stop wrapping PCI core calls like probe, enable, remove, etc. in the > gasket framework, move these calls to the device driver instead. Have > gasket drivers call into framework on init, enable, disable, > etc.

Re: [PATCH 04/15] staging: gasket: core: convert remaining info logs to debug

2018-08-08 Thread Greg Kroah-Hartman
On Sun, Aug 05, 2018 at 01:07:38PM -0700, Todd Poynor wrote: > From: Todd Poynor > > Remaining info-level logs in gasket core converted to debug-level; the > information is not needed during normal system operation. > > Signed-off-by: Todd Poynor > --- > drivers/staging/gasket/gasket_core.c |

Re: [PATCH 04/17] staging:rtl8192u: Rename eqMacAddr macro - Style

2018-08-08 Thread John Whitmore
On Wed, Aug 08, 2018 at 01:12:53AM -0700, Joe Perches wrote: > On Tue, 2018-08-07 at 22:12 +0100, John Whitmore wrote: > > The eqMacAddr(a, b) macro causes a checkpatch issue, due to CamelCase > > naming, so has been renamed to eq_mac_addr(a, b). > > > > This is a coding style change which should