Re: [PATCH v2 00/20] staging: mt7621-pci: Parse ports info from DT and other minor cleanups

2018-08-21 Thread Sergio Paracuellos
On Mon, Aug 20, 2018 at 3:33 AM, NeilBrown wrote: > On Sun, Aug 12 2018, Sergio Paracuellos wrote: > >> This patch series parse remaining port info from device tree storing >> it in mt7621_pcie_port struct created for this. >> >> Also minor cleanups are performed here: >> - Remove not used

[PATCH 15/17] staging:rtl8192u: Rename BaTimeoutValue - Style

2018-08-21 Thread John Whitmore
Rename BaTimeoutValue to timeout_value. This clears checkpatch issue with CamelCase naming. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_BA.h| 2 +-

[PATCH 17/17] staging:rtl8192u: Remove commented out code and indent - Style

2018-08-21 Thread John Whitmore
Remove old commented out structure and clean up the indentation. These are coding style changes which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- .../staging/rtl8192u/ieee80211/rtl819x_BA.h | 47 --- 1 file changed, 20 insertions(+), 27

[PATCH 16/17] staging:rtl8192u: Rename BaStartSeqCtrl - Style

2018-08-21 Thread John Whitmore
Rename BaStartSeqCtrl to start_seq_ctrl. This change clears the checkpatch issue with CamelCase naming. This is a coding style change which should not impact runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/ieee80211_tx.c | 2 +-

[PATCH 11/17] staging:rtl8192u: Rename member variable Timer - Style

2018-08-21 Thread John Whitmore
Rename the member variable Timer to all lowercase to clear the checkpatch issue with CamelCase naming. This change is purely a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_BA.h | 2 +-

[PATCH 05/17] staging:rtl8192u: Refactor BA_PARAM_SET - Style

2018-08-21 Thread John Whitmore
Refactor the union BA_PARAM_SET, firstly removing the 'typedef', this clears the checkpatch issue with defining new types. Secondly the union is renamed to lowercase to comply with the coding standard. These are coding style changes which should have no impact on runtime code execution.

[PATCH 13/17] staging:rtl8192u: Rename DialogToken - Style

2018-08-21 Thread John Whitmore
Rename the member variable DialogToken to dialog_token. This clears the checkpatch issue with CamelCase naming. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_BA.h| 2 +-

[PATCH 14/17] staging:rtl8192u: Rename BaParamSet - Style

2018-08-21 Thread John Whitmore
Rename the member variable BaParamSet to param_set. This clears the checkpatch issue with CamelCase naming. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- .../staging/rtl8192u/ieee80211/rtl819x_BA.h | 2 +-

[PATCH 12/17] staging:rtl8192u: Rename bValid - Style

2018-08-21 Thread John Whitmore
Rename the member variable bValid to valid, this clears the checkpatch issue with CamelCase naming. This is a coding style change which should have no impatch on runtime code execution. Signed-off-by: John Whitmore --- .../staging/rtl8192u/ieee80211/ieee80211_tx.c | 2 +-

[PATCH 09/17] staging:rtl8192u: Refactor union delba_param_set - Style

2018-08-21 Thread John Whitmore
remove member 'charData' from the union delba_param_set, as it is not used in code. The remaining member variables have all been renamed to clear the checkpatch issue with CamelCase naming. shortData to short_data Reserved to reserved Initiator to initiator TIDto tid These changes

[PATCH 08/17] staging:rtl8192u: Refactor DELBA_PARAM_SET - Style

2018-08-21 Thread John Whitmore
Remove the typedef directive from union DELBA_PARAM_SET, to clear the checkpatch issue with CamelCase naming. Rename the union to lowercase to comply with the coding standard. These changes are coding style changes which should have no impact on runtime code execution. Signed-off-by: John

[PATCH 04/17] staging:rtl8192u: Rename member variables - Style

2018-08-21 Thread John Whitmore
Rename the member variables FragNum and SeqNum. This change clears a checkpatch issue with CamelCase naming. This is a coding style change and should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/ieee80211_tx.c | 2 +-

[PATCH 07/17] staging:rtl8192u: Rename ba_param_set members - Style

2018-08-21 Thread John Whitmore
Rename the member variables of union ba_param_set to clear the checkpatch issue with CamelCase naming: AMSDU_Support to amsdu_support BAPolicy to ba_policy TIDto tid BufferSize to buffer_size These are coding style changes which should have no impact on runtime code

[PATCH 10/17] staging:rtl8192u: Refactor struct BA_RECORD - Style

2018-08-21 Thread John Whitmore
Remove the 'typedef' directive from the BA_RECORD structure, to clear the checkpatch issue with defining new types. Additionally rename the structure to lowercase to comply with the coding style. These changes are purely coding style changes which should have no impact on runtime code execution.

[PATCH 06/17] staging:rtl8192u: Remove charData and rename shortData - Style

2018-08-21 Thread John Whitmore
The union ba_param_set contains the member variable charData which is unused. The variable has been removed. Additionally the member variable shortData has been renamed to clear a checkpatch issue with CamelCase naming. These are coding style changes which should not impact runtime code

[PATCH 03/17] staging:rtl8192u: Rename ShortData - Style

2018-08-21 Thread John Whitmore
Rename the ShortData member variable to short_data. This clears a checkpatch issue with CamelCase naming. This is a coding style change which should not impact runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_BA.h | 2 +-

[PATCH 02/17] staging:rtl8192u: Refactor SEQUENCE_CONTROL - Style

2018-08-21 Thread John Whitmore
Remove the 'typedef' from union SEQUENCE_CONTROL. This clears a checkpatch issue with defining new types. Additionally renamed the union to lowercase to comply with coding standard. These are coding style changes which should not impact runtime code execution. typedef union _SEQUENCE_CONTROL{

[PATCH 01/17] staging:rtl8192u: Remove unused defines - Style

2018-08-21 Thread John Whitmore
Remove a number of unused constant definitions. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl8192u/ieee80211/rtl819x_BA.h | 5 - 1 file changed, 5 deletions(-) diff --git

[PATCH 00/17] staging:rtl8192u: Coding Style changes

2018-08-21 Thread John Whitmore
This is a series of patches to clean up the header file: drivers/staging/rtl8192u/ieee80211/rtl819x_BA.h John Whitmore (17): staging:rtl8192u: Remove unused defines - Style staging:rtl8192u: Refactor SEQUENCE_CONTROL - Style staging:rtl8192u: Rename ShortData - Style staging:rtl8192u:

[PATCH 2/9] staging: erofs: separate erofs_get_meta_page

2018-08-21 Thread Chao Yu
From: Gao Xiang This patch separates 'erofs_get_meta_page' into 'erofs_get_meta_page' and 'erofs_get_meta_page_nofail'. The second one ensures that it should not fail under memory pressure and should make best efforts if IO errors occur. It also adds auxiliary variables in order to fulfill 80

[PATCH 7/9] staging: erofs: fix integer overflow on 32-bit platform

2018-08-21 Thread Chao Yu
From: Gao Xiang This patch fixes integer overflow on multiplication of 32-bit `lcn' in z_erofs_map_blocks_iter. Signed-off-by: Gao Xiang Reviewed-by: Chao Yu Signed-off-by: Chao Yu --- drivers/staging/erofs/unzip_vle.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff

[PATCH 4/9] staging: erofs: cleanup z_erofs_vle_work_{lookup, register}

2018-08-21 Thread Chao Yu
From: Gao Xiang This patch introduces 'struct z_erofs_vle_work_finder' to clean up arguments of z_erofs_vle_work_lookup and z_erofs_vle_work_register. Signed-off-by: Gao Xiang Reviewed-by: Chao Yu Signed-off-by: Chao Yu --- drivers/staging/erofs/unzip_vle.c | 89

[PATCH v2 0/9] staging: erofs: fix some issues and clean up codes

2018-08-21 Thread Chao Yu
From: Chao Yu This patchset mainly adds error handing code for erofs xattr subsystem. In addition, some code cleanups are also included in this patchset. P.S. Some other patches are still previewing in the linux-erofs mailing list, which will be posted in the 2nd part later. [changelog] v1 ->

[PATCH 8/9] staging: erofs: fix compression mapping beyond EOF

2018-08-21 Thread Chao Yu
From: Gao Xiang Logical address of EOF LTP mapping should start at `inode->i_size' rather than `inode->i_size - 1' to `m_la(in)', fix it. Signed-off-by: Gao Xiang Reviewed-by: Chao Yu Signed-off-by: Chao Yu --- drivers/staging/erofs/unzip_vle.c | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH 9/9] staging: erofs: fix potential overflow in erofs_grab_bio()

2018-08-21 Thread Chao Yu
From: Chao Yu As Dan reported in LKP's mailing list: https://lists.01.org/pipermail/kbuild-all/2018-August/051419.html New smatch warnings: drivers/staging/erofs/internal.h:446 erofs_grab_bio() warn: should 'blkaddr << (12 - 9)' be a 64 bit type? drivers/staging/erofs/data.c:78

[PATCH 6/9] staging: erofs: fix vle_decompressed_index_clusterofs

2018-08-21 Thread Chao Yu
From: Gao Xiang This patch adds error handing code, and fixes a missing endian conversion in vle_decompressed_index_clusterofs. Signed-off-by: Gao Xiang Reviewed-by: Chao Yu Signed-off-by: Chao Yu --- drivers/staging/erofs/unzip_vle.c | 26 +++--- 1 file changed, 15

[PATCH 1/9] staging: erofs: introduce erofs_grab_bio

2018-08-21 Thread Chao Yu
From: Gao Xiang this patch renames prepare_bio to erofs_grab_bio, and adds a nofail option in order to retry in the bio allocator under memory pressure. Signed-off-by: Gao Xiang Reviewed-by: Chao Yu Signed-off-by: Chao Yu --- drivers/staging/erofs/data.c | 12 +--

[PATCH 5/9] staging: erofs: rearrange vle clustertype definitions

2018-08-21 Thread Chao Yu
From: Gao Xiang This patch moves vle clustertype definitions to erofs_fs.h since they are part of on-disk format. It also adds compile time check for Z_EROFS_VLE_DI_CLUSTER_TYPE_BITS Signed-off-by: Gao Xiang Reviewed-by: Chao Yu Signed-off-by: Chao Yu --- drivers/staging/erofs/erofs_fs.h

[PATCH 3/9] staging: erofs: add error handling for xattr submodule

2018-08-21 Thread Chao Yu
From: Gao Xiang This patch enhances the missing error handling code for xattr submodule, which improves the stability for the rare cases. Signed-off-by: Gao Xiang Reviewed-by: Chao Yu Signed-off-by: Chao Yu --- drivers/staging/erofs/internal.h | 6 +- drivers/staging/erofs/xattr.c|

RE: [PATCH 1/2] staging: rtl8192e: Fix compiler warning about strncpy

2018-08-21 Thread David Laight
From: Larry Finger > Sent: 20 August 2018 18:51 > When strncpy() is called with source and destination strings the same > length, gcc 8 warns that there may be an unterminated string. Using > strlcpy() rather than strncpy() forces a null at the end and quiets the > warning. > > Signed-off-by:

[PATCH RFCv2 6/6] memory-hotplug.txt: Add some details about locking internals

2018-08-21 Thread David Hildenbrand
Let's document the magic a bit, especially why device_hotplug_lock is required when adding/removing memory and how it all play together with requests to online/offline memory from user space. Cc: Jonathan Corbet Cc: Michal Hocko Cc: Andrew Morton Signed-off-by: David Hildenbrand ---

[PATCH RFCv2 5/6] powerpc/powernv: hold device_hotplug_lock in memtrace_offline_pages()

2018-08-21 Thread David Hildenbrand
Let's perform all checking + offlining + removing under device_hotplug_lock, so nobody can mess with these devices via sysfs concurrently. Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: Michael Ellerman Cc: Rashmica Gupta Cc: Balbir Singh Cc: Michael Neuling Signed-off-by: David

[PATCH RFCv2 4/6] powerpc/powernv: hold device_hotplug_lock when calling device_online()

2018-08-21 Thread David Hildenbrand
device_online() should be called with device_hotplug_lock() held. Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: Michael Ellerman Cc: Rashmica Gupta Cc: Balbir Singh Cc: Michael Neuling Signed-off-by: David Hildenbrand --- arch/powerpc/platforms/powernv/memtrace.c | 2 ++ 1 file

[PATCH RFCv2 3/6] mm/memory_hotplug: fix online/offline_pages called w.o. mem_hotplug_lock

2018-08-21 Thread David Hildenbrand
There seem to be some problems as result of 30467e0b3be ("mm, hotplug: fix concurrent memory hot-add deadlock"), which tried to fix a possible lock inversion reported and discussed in [1] due to the two locks a) device_lock() b) mem_hotplug_lock While add_memory() first takes b),

[PATCH RFCv2 0/6] mm: online/offline_pages called w.o. mem_hotplug_lock

2018-08-21 Thread David Hildenbrand
This is the same approach as in the first RFC, but this time without exporting device_hotplug_lock (requested by Greg) and with some more details and documentation regarding locking. Tested only on x86 so far. -- Reading

[PATCH RFCv2 2/6] mm/memory_hotplug: make add_memory() take the device_hotplug_lock

2018-08-21 Thread David Hildenbrand
add_memory() currently does not take the device_hotplug_lock, however is aleady called under the lock from arch/powerpc/platforms/pseries/hotplug-memory.c drivers/acpi/acpi_memhotplug.c to synchronize against CPU hot-remove and similar. In general, we should hold the

[PATCH RFCv2 1/6] mm/memory_hotplug: make remove_memory() take the device_hotplug_lock

2018-08-21 Thread David Hildenbrand
remove_memory() is exported right now but requires the device_hotplug_lock, which is not exported. So let's provide a variant that takes the lock and only export that one. The lock is already held in arch/powerpc/platforms/pseries/hotplug-memory.c drivers/acpi/acpi_memhotplug.c

Re: [PATCH v2] staging: rtl8188eu: Removed code valid for 5GHz

2018-08-21 Thread Dan Carpenter
Great. Thanks! regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH v2] staging: rtl8188eu: Removed a function and coded inline

2018-08-21 Thread Dan Carpenter
Looks good. Thanks. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [RFC RFT PATCH v4 1/4] gpiolib: Pass bitmaps, not integer arrays, to get/set array

2018-08-21 Thread Peter Rosin
Sorry for replying to self... On 2018-08-21 08:49, Peter Rosin wrote: > On 2018-08-21 01:43, Janusz Krzysztofik wrote: >> Most users of get/set array functions iterate consecutive bits of data, >> usually a single integer, while or processing array of results obtained >> from or building an array

Re: [RFC RFT PATCH v4 1/4] gpiolib: Pass bitmaps, not integer arrays, to get/set array

2018-08-21 Thread Peter Rosin
On 2018-08-21 01:43, Janusz Krzysztofik wrote: > Most users of get/set array functions iterate consecutive bits of data, > usually a single integer, while or processing array of results obtained > from or building an array of values to be passed to those functions. > Save time wasted on those