Re: [PATCH] Staging: media: replaced deprecated probe method

2018-09-30 Thread Dan Carpenter
On Sat, Sep 29, 2018 at 09:51:50PM +0300, Andrey Abramov wrote: > drivers/staging/media/bcm2048/radio-bcm2048.c replaced i2c_driver::probe with > i2c_driver::probe_new, because documentation says that i2c_driver::probe > "soon to be deprecated" > This needs to be line wrapped at 72 characters.

Re: [PATCH] gpiolib: Fix incorrect use of find_next_zero_bit()

2018-09-30 Thread Marek Szyprowski
Hi Janusz, On 2018-09-29 14:20, Janusz Krzysztofik wrote: > Commit b17566a6b08b ("gpiolib: Implement fast processing path in > get/set array"), already fixed to some extent with commit 5d581d7e8cdc > ("gpiolib: Fix missing updates of bitmap index"), introduced a new mode > of processing bitmaps wh

Re: [PATCH 01/19] staging: rtl8188eu: cleanup inconsistent indenting

2018-09-30 Thread Dan Carpenter
On Sun, Sep 30, 2018 at 01:30:11PM -0700, Joe Perches wrote: > On Sun, 2018-09-30 at 21:52 +0200, Michael Straube wrote: > > Cleanup all inconsistent indenting reported by smatch. > > There are also some others like: > > drivers/staging/rtl8188eu/core/rtw_mlme.c:1752: WARNING:SUSPECT_CODE_INDENT:

Re: [PATCH] staging: rtlwifi: Removed unused define and code efuse_re_pg* from wifi.h

2018-09-30 Thread Kalle Valo
Joe Perches writes: > On Sun, 2018-09-30 at 20:29 +0200, Rick Veens wrote: >> The following: >> bool efuse_re_pg_sec1flag; >> u8 efuse_re_pg_data[8]; >> are not referenced anywhere in the rtlwifi code. >> >> Signed-off-by: Rick Veens >> --- >> drivers/staging/rtlwifi/wifi.h | 4 > > Pres

[PATCH] staging: rtl8723bs: clean up clang warning on extraneous parentheses

2018-09-30 Thread Colin King
From: Colin Ian King There are extraneous parantheses that are causing clang to produce a warning so remove these. Clean up 3 clang warnings: equality comparison with extraneous parentheses [-Wparentheses-equality] Signed-off-by: Colin Ian King --- drivers/staging/rtl8723bs/core/rtw_security.

Re: [PATCH 01/19] staging: rtl8188eu: cleanup inconsistent indenting

2018-09-30 Thread Joe Perches
On Sun, 2018-09-30 at 21:52 +0200, Michael Straube wrote: > Cleanup all inconsistent indenting reported by smatch. There are also some others like: drivers/staging/rtl8188eu/core/rtw_mlme.c:1752: WARNING:SUSPECT_CODE_INDENT: suspect code indent for conditional statements (8, 24) 1750: if ((ndi

[PATCH 05/19] staging: rtl8188eu: add spaces around '*' in odm_hwconfig.c

2018-09-30 Thread Michael Straube
Add spaces around '*' in odm_hwconfig.c to follow kernel coding style. Reported by checkpatch. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 28 ++-- 1 file changed, 14 insertions(+), 14 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/

[PATCH 04/19] staging: rtl8188eu: add spaces around '+' in odm_hwconfig.c

2018-09-30 Thread Michael Straube
Add spaces around '+' in odm_hwconfig.c to follow kernel coding style. Reported by checkpatch. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/odm_hwconfig.c b

[PATCH 14/19] staging: rtl8188eu: correct block comment in bb_cfg.c

2018-09-30 Thread Michael Straube
Correct block comment to clear a checkpatch warning. WARNING: Block comments should align the * on each line Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/bb_cfg.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/bb_cfg.

[PATCH 16/19] staging: rtl8188eu: add spaces around '+' in fw.c

2018-09-30 Thread Michael Straube
Add spaces around '+' in fw.c to follow kernel coding style. Reported by checkpatch. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/fw.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/fw.c b/drivers/staging/rtl8188eu/hal

[PATCH 01/19] staging: rtl8188eu: cleanup inconsistent indenting

2018-09-30 Thread Michael Straube
Cleanup all inconsistent indenting reported by smatch. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_efuse.c| 2 +- .../staging/rtl8188eu/core/rtw_ieee80211.c| 2 +- drivers/staging/rtl8188eu/core/rtw_led.c | 4 ++-- drivers/staging/rtl8188eu/core/rtw_mlme

[PATCH 18/19] staging: rtl8188eu: remove braces from single if statement

2018-09-30 Thread Michael Straube
Remove braces from single line if statement. Reported by checkpatch. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_rtl8188e.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/odm_rtl8188e.c b/drivers/staging/rtl8188eu/hal

[PATCH 10/19] staging: rtl8188eu: rename odm_EVMdbToPercentage()

2018-09-30 Thread Michael Straube
Rename odm_EVMdbToPercentage() to avoid CamelCase. odm_EVMdbToPercentage -> odm_evm_db_to_percentage Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/odm_hwconfig.

[PATCH 07/19] staging: rtl8188eu: rename parameter of odm_QueryRxPwrPercentage()

2018-09-30 Thread Michael Straube
Rename parameter of odm_QueryRxPwrPercentage() to avoid CamelCase. AntPower -> antpower Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/odm_hwconfig.c b/driv

[PATCH 19/19] staging: rtl8188eu: fix spelling mistake in comment

2018-09-30 Thread Michael Straube
Fix a spelling mistake reported by checkpatch. Caculate -> Calculate Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_rtl8188e.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/hal/odm_rtl8188e.c b/drivers/staging/rtl8188eu/hal/o

[PATCH 15/19] staging: rtl8188eu: simplify block comment in pwrseq.c

2018-09-30 Thread Michael Straube
Simplify block comment to a single line to clear a checkpatch warning. WARNING: Block comments use * on subsequent lines Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/pwrseq.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8188eu/ha

[PATCH 02/19] staging: rtl8188eu: rename odm_HWConfig

2018-09-30 Thread Michael Straube
Rename source and header file to avoid CamelCase. odm_HWConfig.c -> odm_hwconfig.c odm_HWConfig.h -> odm_hwconfig.h Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/Makefile | 2 +- .../staging/rtl8188eu/hal/{odm_HWConfig.c => odm_hwconfig.c}| 0 .../

[PATCH 12/19] staging: rtl8188eu: rename variable in odm_SignalScaleMapping()

2018-09-30 Thread Michael Straube
Rename variable in odm_SignalScaleMapping() to avoid CamelCase. RetSig -> retsig Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/odm_hwconfig.c

[PATCH 06/19] staging: rtl8188eu: replace tabs with spaces in odm_hwconfig.c

2018-09-30 Thread Michael Straube
Replace tabs with spaces in odm_hwconfig.c where appropriate. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/odm_hwconfig.c b/drivers/staging/rtl8188eu/hal/odm_

[PATCH 09/19] staging: rtl8188eu: rename parameter of odm_EVMdbToPercentage()

2018-09-30 Thread Michael Straube
Rename parameter of odm_EVMdbToPercentage() to avoid CamelCase. Value -> value Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/odm_hwconfig.c b/drivers/staging/r

[PATCH 17/19] staging: rtl8188eu: remove unnecessary parentheses in odm_rtl8188e.c

2018-09-30 Thread Michael Straube
Remove unnecessary parentheses in odm_rtl8188e.c. Reported by checkpatch. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_rtl8188e.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/odm_rtl8188e.c b/drivers/staging/rtl8

[PATCH 11/19] staging: rtl8188eu: rename parameter of odm_SignalScaleMapping()

2018-09-30 Thread Michael Straube
Rename parameter of odm_SignalScaleMapping() to avoid CamelCase. CurrSig -> currsig Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 31 ++-- 1 file changed, 16 insertions(+), 15 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/odm_hwconfi

[PATCH 13/19] staging: rtl8188eu: rename odm_SignalScaleMapping()

2018-09-30 Thread Michael Straube
Rename odm_SignalScaleMapping to avoid CamelCase. odm_SignalScaleMapping -> odm_signal_scale_mapping Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/odm_hwconfi

[PATCH 08/19] staging: rtl8188eu: rename odm_QueryRxPwrPercentage()

2018-09-30 Thread Michael Straube
Rename odm_QueryRxPwrPercentage() to avoid CamelCase. odm_QueryRxPwrPercentage -> odm_query_rxpwrpercentage Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/od

[PATCH 03/19] staging: rtl8188eu: remove wrapper odm_SignalScaleMapping()

2018-09-30 Thread Michael Straube
The function odm_SignalScaleMapping() is just a wrapper for odm_SignalScaleMapping_92CSeries(). Rename odm_SignalScaleMapping_92CSeries() to odm_SignalScaleMapping() and remove the wrapper. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/odm_hwconfig.c | 7 +-- 1 file chang

[PATCH] staging: rtlwifi: Removed unused define and code efuse_re_pg* from wifi.h

2018-09-30 Thread Rick Veens
The following: bool efuse_re_pg_sec1flag; u8 efuse_re_pg_data[8]; are not referenced anywhere in the rtlwifi code. Signed-off-by: Rick Veens --- drivers/staging/rtlwifi/wifi.h | 4 1 file changed, 4 deletions(-) diff --git a/drivers/staging/rtlwifi/wifi.h b/drivers/staging/rtlwifi/wifi.h

[PATCH v4] staging: android: ion: Add per-heap counters

2018-09-30 Thread Alexey Skidanov
Heap statistics have been removed and currently even basics statistics are missing. This patch creates per heap debugfs directory /sys/kernel/debug/ and adds the following counters: - the number of allocated buffers; - the number of allocated bytes; - the number of allocated bytes watermark. Sign

[PATCH] staging: ks7010: Remove unnecessary null check

2018-09-30 Thread Aymen Qader
Remove the unnecessary socket buffer null check in hostif_data_request. There is already an appropriate null check in the calling function: (ks_wlan_net.c) ks_wlan_start_xmit Signed-off-by: Aymen Qader --- drivers/staging/ks7010/ks_hostif.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions