Re: [PATCH RFC 02/11] staging: bcm2835-camera: fix module autoloading

2018-12-18 Thread Peter Robinson
On Thu, Oct 25, 2018 at 4:30 PM Stefan Wahren wrote: > > In order to make the module bcm2835-camera load automatically, we need to > add a module alias. > > Fixes: 4bebb0312ea9 ("staging/bcm2835-camera: Set ourselves up as a platform > driver.") > Signed-off-by: Stefan Wahren Reviewed-by:

Re: [PATCH RFC 03/11] staging: bcm2835-camera: Move module info to the end

2018-12-18 Thread Peter Robinson
On Thu, Oct 25, 2018 at 4:30 PM Stefan Wahren wrote: > > In order to have this more consistent between the vc04 services move > the module information to the end of the file. > > Signed-off-by: Stefan Wahren Reviewed-by: Peter Robinson Tested-by: Peter Robinson Tested with a v2 camera module.

Re: [PATCH v2 14/17] staging: rtl8188eu: simplify null array initializations

2018-12-18 Thread Greg KH
On Tue, Dec 18, 2018 at 07:34:48PM +0100, Michael Straube wrote: > Simplfy initialization of null arrays to improve readability > and save some lines. > > Signed-off-by: Michael Straube > --- > drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 4 ++-- > drivers/staging/rtl8188eu/core/rtw_xmit.c

Re: [PATCH] staging: rtlwifi: Fix one line with over 80 chars.

2018-12-18 Thread Greg KH
On Tue, Dec 18, 2018 at 10:30:05AM -0500, Lei Zhou wrote: > Add local temporary variable used as buffer to pass caller pointer into > function ieee80211_connection_loss() to avoid over 80 characters on one > line. > > Signed-off-by: Lei Zhou > --- > drivers/staging/rtlwifi/base.c | 4 +++- > 1

Re: [PATCH v3 2/2] dt-bindings: net: dsa: ksz9477: add sample of switch bindings managed in i2c mode

2018-12-18 Thread Sergio Paracuellos
Hi Rob, On Tue, Dec 18, 2018 at 4:10 PM Rob Herring wrote: > > On Mon, Dec 17, 2018 at 09:44:23PM +0100, Sergio Paracuellos wrote: > > Add device-tree binding example of the ksz9477 switch managed in i2c mode. > > > > Cc: devicet...@vger.kernel.org > > Signed-off-by: Sergio Paracuellos > > ---

[PATCH v2 11/17] staging: rtl8188eu: constify some arrays

2018-12-18 Thread Michael Straube
The values of these arrays in rtw_mlme_ext.c and rtw_wlan_util.c are never changed, so make them const. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 14 +- .../staging/rtl8188eu/core/rtw_wlan_util.c| 26 +--

[PATCH v2 17/17] staging: rtl8188eu: cleanup brace coding style issues

2018-12-18 Thread Michael Straube
Cleanup brace coding style issues reported by checkpatch. ERROR: space required before the open brace '{' WARNING: braces {} are not necessary for single statement blocks CHECK: Unbalanced braces around else statement Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_cmd.c

[PATCH v2 09/17] staging: rtl8188eu: remove redundant declaration in rtw_mlme_ext.c

2018-12-18 Thread Michael Straube
The array REALTEK_96B_IE is already declared in rtw_mlme.h, so remove the declaration in rtw_mlme_ext.c. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c

[PATCH v2 12/17] staging: rtl8188eu: make some arrays static in rtw_mlme_ext.c

2018-12-18 Thread Michael Straube
Make some arrays that are only used in rtw_mlme_ext.c static and remove the corresponding extern declarations from rtw_mlme_ext.h. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c| 6 +++--- drivers/staging/rtl8188eu/include/rtw_mlme_ext.h | 5 - 2 files

[PATCH v2 14/17] staging: rtl8188eu: simplify null array initializations

2018-12-18 Thread Michael Straube
Simplfy initialization of null arrays to improve readability and save some lines. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 4 ++-- drivers/staging/rtl8188eu/core/rtw_xmit.c | 6 ++ 2 files changed, 4 insertions(+), 6 deletions(-) diff --git

[PATCH v2 16/17] staging: rtl8188eu: add spaces around '&' in rtw_mlme_ext.c

2018-12-18 Thread Michael Straube
Add spaces around '&' to follow kernel coding style. Reported by checkpatch. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 90 +-- 1 file changed, 45 insertions(+), 45 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c

[PATCH v2 15/17] staging: rtl8188eu: change return type of is_basicrate() to bool

2018-12-18 Thread Michael Straube
The function is_basicrate() returns true or false, so change the return type from int to bool. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_wlan_util.c

[PATCH v2 10/17] staging: rtl8188eu: convert unsigned char arrays to u8

2018-12-18 Thread Michael Straube
Change the type of some arrays from unsigned char to u8. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 16 +++--- .../staging/rtl8188eu/core/rtw_wlan_util.c| 22 +-- drivers/staging/rtl8188eu/include/rtw_mlme.h | 6 ++---

[PATCH v2 06/17] staging: rtl8188eu: remove unnecessary comments in rtw_mlme_ext.c

2018-12-18 Thread Michael Straube
Remove comments from 'endif's where the corresponding 'if' is just a few lines above to improve readability. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git

[PATCH v2 01/17] staging: rtl8188eu: cleanup declarations in rtw_mlme_ext.c

2018-12-18 Thread Michael Straube
Replace tabs with spaces and/or remove spaces in declarations. Signed-off-by: Michael Straube --- v1 -> v2 one logical thing per patch replace some more tabs with spaces remove some more comments drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 482 +- 1 file changed, 241

[PATCH v2 02/17] staging: rtl8188eu: replace tabs with spaces in rtw_mlme_ext.c

2018-12-18 Thread Michael Straube
Replace tabs with spaces where appropriate. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c

[PATCH v2 04/17] staging: rtl8188eu: remove blank lines between declarations

2018-12-18 Thread Michael Straube
Remove blank lines between declarations in rtw_mlme_ext.c. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c index

[PATCH v2 07/17] staging: rtl8188eu: remove unnecessary parentheses in rtw_mlme_ext.c

2018-12-18 Thread Michael Straube
Remove unnecessary parentheses, most of them reported by checkpatch. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 322 +- 1 file changed, 161 insertions(+), 161 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c

[PATCH v2 05/17] staging: rtl8188eu: add blank line after declarations

2018-12-18 Thread Michael Straube
Add a missing blank line after declarations in rtw_mlme_ext.c. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c

[PATCH v2 13/17] staging: rtl8188eu: change order of declarations to improve readability

2018-12-18 Thread Michael Straube
Change the order of array declarations in rtw_mlme_ext.c to improve readability. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c

[PATCH v2 03/17] staging: rtl8188eu: remove commented declarations in rtw_mlme_ext.c

2018-12-18 Thread Michael Straube
Remove unused/commented declarations. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c index

[PATCH v2 08/17] staging: rtl8188eu: remove unused arrays WFD_OUI and WMM_INFO_OUI

2018-12-18 Thread Michael Straube
The arrays WFD_OUI and WMM_INFO_OUI are not used anywhere, so remove them. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c| 2 -- drivers/staging/rtl8188eu/include/rtw_mlme_ext.h | 2 -- 2 files changed, 4 deletions(-) diff --git

Re: [PATCH] Drivers: hv: vmbus: Check for ring when getting debug info

2018-12-18 Thread Sasha Levin
On Mon, Dec 17, 2018 at 08:16:09PM +, Dexuan Cui wrote: fc96df16a1ce is good and can already fix the "return stack garbage" issue, but let's also improve hv_ringbuffer_get_debuginfo(), which would silently return stack garbage, if people forget to check channel->state or

Re: [PATCH v3] staging: android: ion: Add implementation of dma_buf_vmap and dma_buf_vunmap

2018-12-18 Thread Alexey Skidanov
On 12/17/18 20:42, Liam Mark wrote: > On Sun, 16 Dec 2018, Alexey Skidanov wrote: > >> >> >> On 12/16/18 7:20 AM, Liam Mark wrote: >>> On Tue, 6 Feb 2018, Alexey Skidanov wrote: >>> On 02/07/2018 01:56 AM, Laura Abbott wrote: > On 01/31/2018 10:10 PM, Alexey Skidanov wrote:

[PATCH] staging: rtlwifi: Fix one line with over 80 chars.

2018-12-18 Thread Lei Zhou
Add local temporary variable used as buffer to pass caller pointer into function ieee80211_connection_loss() to avoid over 80 characters on one line. Signed-off-by: Lei Zhou --- drivers/staging/rtlwifi/base.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git

Re: [PATCH v3 2/2] dt-bindings: net: dsa: ksz9477: add sample of switch bindings managed in i2c mode

2018-12-18 Thread Rob Herring
On Mon, Dec 17, 2018 at 09:44:23PM +0100, Sergio Paracuellos wrote: > Add device-tree binding example of the ksz9477 switch managed in i2c mode. > > Cc: devicet...@vger.kernel.org > Signed-off-by: Sergio Paracuellos > --- > Changes v3: > - No changes. Just resent patches together. > >

[PATCH v3 -next] staging: fbtft: fix strncmp() size warning

2018-12-18 Thread YueHaibing
strncmp() stops comparing when either the end of one of the first two arguments is reached or when 'n' characters have been compared, whichever comes first.That means that strncmp(s1, s2, n) is equivalent to strcmp(s1, s2) if n exceeds the length of s1 or the length of s2. This patch avoids that

Re: [PATCH v2 -next] staging: fbtft: use strcmp() instead of strncmp() for

2018-12-18 Thread YueHaibing
On 2018/12/18 21:37, Dan Carpenter wrote: > On Tue, Dec 18, 2018 at 09:25:08PM +0800, YueHaibing wrote: >> strncmp() stops comparing when either the end of one of the first two >> arguments is reached or when 'n' characters have been compared, whichever >> comes first.That means that strncmp(s1,

Re: [PATCH v2 -next] staging: fbtft: use strcmp() instead of strncmp() for

2018-12-18 Thread Dan Carpenter
On Tue, Dec 18, 2018 at 09:25:08PM +0800, YueHaibing wrote: > strncmp() stops comparing when either the end of one of the first two > arguments is reached or when 'n' characters have been compared, whichever > comes first.That means that strncmp(s1, s2, n) is equivalent to > strcmp(s1, s2) if n

[PATCH v2 -next] staging: fbtft: use strcmp() instead of strncmp() for

2018-12-18 Thread YueHaibing
strncmp() stops comparing when either the end of one of the first two arguments is reached or when 'n' characters have been compared, whichever comes first.That means that strncmp(s1, s2, n) is equivalent to strcmp(s1, s2) if n exceeds the length of s1 or the length of s2. This patch avoids

Re: [PATCH -next] staging: fbtft: use strcmp() instead of strncmp() for subsystem lookup

2018-12-18 Thread YueHaibing
sorry, Pls ignore this. The title need fix. On 2018/12/18 21:09, YueHaibing wrote: > strncmp() stops comparing when either the end of one of the first two > arguments is reached or when 'n' characters have been compared, whichever > comes first.That means that strncmp(s1, s2, n) is equivalent

[PATCH -next] staging: fbtft: use strcmp() instead of strncmp() for subsystem lookup

2018-12-18 Thread YueHaibing
strncmp() stops comparing when either the end of one of the first two arguments is reached or when 'n' characters have been compared, whichever comes first.That means that strncmp(s1, s2, n) is equivalent to strcmp(s1, s2) if n exceeds the length of s1 or the length of s2. This patch avoids

Re: [PATCH v3 3/3] staging: greybus: arche-platform: Switch to the gpio descriptor interface

2018-12-18 Thread Johan Hovold
On Thu, Nov 22, 2018 at 10:39:24PM +0530, Nishad Kamdar wrote: > Use the gpiod interface instead of the deprecated > old non-descriptor interface. > > Signed-off-by: Nishad Kamdar > --- > Changes in v2: > - Move comment to the same line as to what it applies to. > --- >

[PATCH][next] staging: most: sound: replace snprintf with strscpy

2018-12-18 Thread Colin King
From: Colin Ian King Using snprintf without a format specifier is potentially risky if the string device_name contains format specifiers. Replace this with the safer and more efficient strscpy. Cleans up clang warning: drivers/staging/most/sound/sound.c:673:41: warning: format string is not a

Re: [PATCH v3 2/3] staging: greybus: arche-apb-ctrl.c: Switch to the gpio descriptor interface

2018-12-18 Thread Johan Hovold
On Thu, Nov 22, 2018 at 10:38:18PM +0530, Nishad Kamdar wrote: > Use the gpiod interface instead of the deprecated old non-descriptor > interface. > > Signed-off-by: Nishad Kamdar > --- > Changes in v2: > - Resolved compilation errors. > --- > drivers/staging/greybus/arche-apb-ctrl.c | 159

Re: [PATCH v2] comedi/ni_pcidio: make all defines uppercase

2018-12-18 Thread Ian Abbott
On 17/12/2018 20:51, Alexander Schroth wrote: According to the Linux coding guidelines, defines should be written in uppercase. This patch converts all define-statements in the ni_pcidio.c file to uppercase, thus matching the coding style of the kernel. Signed-off-by: Alexander Schroth

Re: [PATCH v3 1/3] staging: greybus: gpio: switch GPIO portions to use GPIOLIB_IRQCHIP

2018-12-18 Thread Johan Hovold
On Thu, Nov 22, 2018 at 10:37:16PM +0530, Nishad Kamdar wrote: > Convert the GPIO driver to use the GPIO irqchip library > GPIOLIB_IRQCHIP instead of reimplementing the same. > > Signed-off-by: Nishad Kamdar > --- > Changes in v2: > - Retained irq.h and irqdomain.h headers. > - Dropped

Your Response Needed

2018-12-18 Thread Alfredo Gomez
Dear Sir/Madam, My Names are Mr.Alfredo Gomez. I am the Administrative manager at a vault financial & security Institution here in Madrid. I am contacting you based on a financial opportunity I discovered here in my organization. It's about an abandoned sum of 25,000,000.00 million US dollars