Re: [PATCH RFC 00/11] staging: vc04_services: Improve driver load/unload

2019-01-07 Thread Peter Robinson
Hi Stefan, > This patch series improves the load/unload of bcm2835 camera and audio > drivers. It has been tested with Raspberry Pi 3 B and a camera module V1. > > This series based on current linux-next and Phil Elwell's series ("Improve > VCHIQ > cache line size handling"). After Nicolas'

Re: [PATCH] hv_balloon: avoid touching uninitialized struct page during tail onlining

2019-01-07 Thread Greg KH
On Mon, Jan 07, 2019 at 07:38:20PM +0100, Vitaly Kuznetsov wrote: > (I remember Greg disliked when people were tagging patches for stable@ > themselves, he prefered maintainers deciding if the particular commit > deserves stable@ or not - but as you have a tree now we may as well have > different

Re: [PATCH -next] media: staging/intel-ipu3: Fix err handle of ipu3_css_find_binary

2019-01-07 Thread Bingbu Cao
On 01/07/2019 07:00 PM, Sakari Ailus wrote: Hi Bingbu, On Mon, Jan 07, 2019 at 10:38:19AM +0800, Bingbu Cao wrote: Hi, Haibing Thanks for your patch, it looks fine for me. Reviewed-by: Bingbu Cao On 12/29/2018 10:45 AM, YueHaibing wrote: css->pipes[pipe].bindex = binary; I'm taking

Re: [PATCH v4] staging: wilc1000: fix registration frame size

2019-01-07 Thread Ajay.Kathat
On 1/7/2019 8:13 PM, Július Milan wrote: > Fixes the following sparse warnings: > > drivers/staging/wilc1000/host_interface.c:2360:30: warning: > incorrect type in assignment (different base types) > expected restricted __le32 [addressable] [assigned] [usertype] frame_type > got

Re: [PATCH 0/2] staging: erofs: fixed -Wmissing-prototype warnings.

2019-01-07 Thread Gao Xiang
Hi Jeremy, On 2019/1/8 2:25, Jeremy Sowden wrote: > Fixes for -Wmissing-prototype warnings in the erofs driver. One group of > functions have been made static; for the second, prototypes have been moved > to a > head Is -Wmissing-prototypes required for the current linux kernel? I cannot see

Re: [linux-sunxi] [PATCH v2 1/2] media: v4l: Add definitions for the HEVC slice format and controls

2019-01-07 Thread Ayaka
Sent from my iPad > On Jan 7, 2019, at 5:57 PM, Paul Kocialkowski > wrote: > > Hi, > >> On Mon, 2019-01-07 at 11:49 +0800, Randy Li wrote: >>> On 12/12/18 8:51 PM, Paul Kocialkowski wrote: >>> Hi, >>> >>> On Wed, 2018-12-05 at 21:59 +0100, Jernej Škrabec wrote: >>> > + > +#define

Re: drivers/staging/media/ipu3/ipu3-css.c:1831: bad compare ?

2019-01-07 Thread sakari.ai...@linux.intel.com
Hi David, On Mon, Jan 07, 2019 at 10:30:55PM +, David Binderman wrote: > Hello there, > > drivers/staging/media/ipu3/ipu3-css.c:1831:30: warning: comparison of > unsigned expression < 0 is always false [-Wtype-limits] > > Source code is > css->pipes[pipe].bindex = >

[PATCH] staging: rtl8192e: fix various indentation issues

2019-01-07 Thread Colin King
From: Colin Ian King There are several statements that have indentation issues, fix these. Signed-off-by: Colin Ian King --- drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c | 8 drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 6 +++--- drivers/staging/rtl8192e/rtl8192e/rtl_dm.c |

[PATCH] [v3] staging: rtl8723bs: Clean up dead code

2019-01-07 Thread Aditya Pakki
rtw_wps_start() is part of dead code due to CONFIG_INTEL_WIDI. The fix removes the deadcode and replaces the function with NULL in rtw_private_handler. Identified as part of copy_from_user bug. Changes from v1 & 2: The return value of copy_from_user() is not checked appropriately. However,

[PATCH] staging: rtl8712: clean up various indentation and coding style issues

2019-01-07 Thread Colin King
From: Colin Ian King There are several statements that are indented incorrectly so fix these. Also remove unnecessary { } braces and clean up a comment. Signed-off-by: Colin Ian King --- drivers/staging/rtl8712/ieee80211.c | 2 +- drivers/staging/rtl8712/rtl8712_led.c | 6 +++---

drivers/staging/media/ipu3/ipu3-css.c:1831: bad compare ?

2019-01-07 Thread David Binderman
Hello there, drivers/staging/media/ipu3/ipu3-css.c:1831:30: warning: comparison of unsigned expression < 0 is always false [-Wtype-limits] Source code is css->pipes[pipe].bindex = ipu3_css_find_binary(css, pipe, q, r); if (css->pipes[pipe].bindex < 0) {

[RESEND PATCH] staging: mt7621-pci: use PCI definitions instead of hardcode values

2019-01-07 Thread Sergio Paracuellos
Seting up ports to enable PCI_COMMAND_MASTER is using '0x4' as a hardcore value and '0x4' also for PCI_COMMAND register instead of use definitions from linux pci system headers. Replace both. Signed-off-by: Sergio Paracuellos --- Greg, I resend this PATCH because it has not been applied and I

Re: [PATCH] staging: rtl8188eu: Add device code for D-Link DWA-121 rev B1

2019-01-07 Thread Larry Finger
On 1/7/19 11:28 AM, Michael Straube wrote: This device was added to the stand-alone driver on github. Add it to the staging driver as well. Link: https://github.com/lwfinger/rtl8188eu/commit/a0619a07cd1e Signed-off-by: Michael Straube Acked-by: Larry Finger Thanks, Larry

[PATCH 0/2] staging: erofs: fixed -Wmissing-prototype warnings.

2019-01-07 Thread Jeremy Sowden
Fixes for -Wmissing-prototype warnings in the erofs driver. One group of functions have been made static; for the second, prototypes have been moved to a head Jeremy Sowden (2): staging: erofs: fixed -Wmissing-prototype warnings. staging: erofs: fixed -Wmissing-prototype warnings.

[PATCH 1/2] staging: erofs: fixed -Wmissing-prototype warnings.

2019-01-07 Thread Jeremy Sowden
Define three functions which are not used outside their own translation-units as static in order to fix the following warnings: drivers/staging/erofs/utils.c:134:6: warning: no previous prototype for ‘erofs_try_to_release_workgroup’ [-Wmissing-prototypes] bool

[PATCH 2/2] staging: erofs: fixed -Wmissing-prototype warnings.

2019-01-07 Thread Jeremy Sowden
Moved prototypes for two functions to header file in order to fix the following warnings: drivers/staging/erofs/unzip_vle.c:577:6: warning: no previous prototype for ‘erofs_workgroup_free_rcu’ [-Wmissing-prototypes] void erofs_workgroup_free_rcu(struct erofs_workgroup *grp)

Re: [PATCH] hv_balloon: avoid touching uninitialized struct page during tail onlining

2019-01-07 Thread Vitaly Kuznetsov
Sasha Levin writes: > On Mon, Jan 07, 2019 at 02:44:30PM +0100, Vitaly Kuznetsov wrote: >>P.S. I still think about bringing mem_hotplug_begin()/done() to >>hv_balloon but that's going to be a separate discussion, here I want to >>have a small fix backportable to stable. > > This should probably

Re: [PATCH v2 13/17] power: supply: olpc_battery: Use DT to get battery version

2019-01-07 Thread Lubomir Rintel
On Wed, 2018-12-05 at 21:54 +0100, Sebastian Reichel wrote: > Hi, > > On Fri, Nov 16, 2018 at 05:23:59PM +0100, Lubomir Rintel wrote: > > Avoid using the x86 OLPC platform specific call to get the board > > version. It won't work on FDT-based ARM MMP2 platform. > > > > Signed-off-by: Lubomir

[PATCH] ipu3: add missing #include

2019-01-07 Thread Mauro Carvalho Chehab
Lots of warning due to non-static functions are generated because the headers with define them were not included. Signed-off-by: Mauro Carvalho Chehab --- drivers/staging/media/ipu3/ipu3-css-params.c | 1 + drivers/staging/media/ipu3/ipu3-dmamap.c | 1 + 2 files changed, 2 insertions(+)

Re: [PATCH v2 17/17] power: supply: olpc_battery: Add OLPC XO 1.75 support

2019-01-07 Thread Lubomir Rintel
On Sun, 2018-12-02 at 15:34 -0800, Darren Hart wrote: > On Fri, Nov 16, 2018 at 05:24:03PM +0100, Lubomir Rintel wrote: > > The battery and the protocol are essentially the same as OLPC XO 1.5, > > but the responses from the EC are LSB first. > > > > Signed-off-by: Lubomir Rintel > > Acked-by:

Re: [PATCH] Staging: iio: ad7192: replaced bool in struct

2019-01-07 Thread Himanshu Jha
On Wed, Jan 02, 2019 at 01:25:27PM -0800, Matt Ranostay wrote: > > > On Dec 24, 2018, at 01:58, Himanshu Jha wrote: > > > >> On Fri, Dec 21, 2018 at 03:26:26PM -0800, Amir Mahdi Ghorbanian wrote: > >> Replaced bool in struct with unsigned int bitfield to conserve space and > >> more clearly

Re: [PATCH] hv_balloon: avoid touching uninitialized struct page during tail onlining

2019-01-07 Thread Sasha Levin
On Mon, Jan 07, 2019 at 02:44:30PM +0100, Vitaly Kuznetsov wrote: David Hildenbrand writes: On 04.01.19 15:19, Vitaly Kuznetsov wrote: Hyper-V memory hotplug protocol has 2M granularity and in Linux x86 we use 128M. To deal with it we implement partial section onlining by registering custom

[PATCH] staging: rtl8188eu: Add device code for D-Link DWA-121 rev B1

2019-01-07 Thread Michael Straube
This device was added to the stand-alone driver on github. Add it to the staging driver as well. Link: https://github.com/lwfinger/rtl8188eu/commit/a0619a07cd1e Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/os_dep/usb_intf.c | 1 + 1 file changed, 1 insertion(+) diff --git

Re: staging: rtl8188eu: D-Link DWA-121 rev B1

2019-01-07 Thread Greg Kroah-Hartman
On Mon, Jan 07, 2019 at 05:08:34PM +0100, Michael Straube wrote: > Hi, > > I noticed "D-Link DWA-121 rev B1" was added to the stand-alone driver on > github. > https://github.com/lwfinger/rtl8188eu/commit/a0619a07cd1e31776b1c9bb956a5b8570a912598 > > Should it also be added to the staging

staging: rtl8188eu: D-Link DWA-121 rev B1

2019-01-07 Thread Michael Straube
Hi, I noticed "D-Link DWA-121 rev B1" was added to the stand-alone driver on github. https://github.com/lwfinger/rtl8188eu/commit/a0619a07cd1e31776b1c9bb956a5b8570a912598 Should it also be added to the staging driver? I have no such device to test.. Michael

Re: [PATCH v2] staging: wilc1000: fix cast to restricted __le32

2019-01-07 Thread Július Milan
On Mon, Jan 07, 2019 at 06:06:55AM +, ajay.kat...@microchip.com wrote: Hi Ajay, > Please resubmit the patch by changing 'frame_type' type to '__le16' in > 'wilc_reg_frame' struct. Done, sent patch version 4. Message subject changed to: "[PATCH v4] staging: wilc1000: fix registration frame

[PATCH v4] staging: wilc1000: fix registration frame size

2019-01-07 Thread Július Milan
Fixes the following sparse warnings: drivers/staging/wilc1000/host_interface.c:2360:30: warning: incorrect type in assignment (different base types) expected restricted __le32 [addressable] [assigned] [usertype] frame_type got restricted __le16 [usertype] Fixes: 147ccfd451024

Re: [PATCH] hv_balloon: avoid touching uninitialized struct page during tail onlining

2019-01-07 Thread Vitaly Kuznetsov
David Hildenbrand writes: > On 04.01.19 15:19, Vitaly Kuznetsov wrote: >> Hyper-V memory hotplug protocol has 2M granularity and in Linux x86 we use >> 128M. To deal with it we implement partial section onlining by registering >> custom page onlining callback (hv_online_page()). Later, when more

Re: [PATCH] staging: wilc1000: fix cast to restricted __le32

2019-01-07 Thread Luc Van Oostenryck
On Mon, Jan 07, 2019 at 03:54:37PM +0300, Dan Carpenter wrote: > I'm sort of surprised that the zero day bot didn't complain about this. > It probably should. > > The endianness checking is not turned on by default in Sparse. You have > to do "make C=1 CF=-D__CHECK_ENDIAN__" to turn it on.

Re: linux-5.0-rc1/drivers/staging/rtl8188eu/hal/hal8188e_rate_adaptive.c:412]: (style) Expression is always false

2019-01-07 Thread Dan Carpenter
On Mon, Jan 07, 2019 at 11:40:08AM +, David Binderman wrote: > > Hello there, > > linux-5.0-rc1/drivers/staging/rtl8188eu/hal/hal8188e_rate_adaptive.c:412]: > (style) Expression is always false because 'else if' condition matches > previous condition at line 410. > > Source code is > >

Re: rtl8192e: need help with variable naming convention

2019-01-07 Thread Dan Carpenter
On Mon, Jan 07, 2019 at 11:52:14AM +0100, Greg KH wrote: > On Mon, Jan 07, 2019 at 04:04:46PM +0530, Himadri Pandya wrote: > > Hello, > > > > I'm getting started with device drivers. And as a starter, I'm working on > > some clean-up patches. I'm particularly targeting to rename a structure > >

Re: [PATCH] v2 staging: rtl8723bs: Clean up dead code

2019-01-07 Thread Dan Carpenter
Oh, put the v2 inside the square brackets. [PATCH v3]. That way it gets handled correctly by `cat raw_email.txt | git am`. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org

Re: [PATCH] v2 staging: rtl8723bs: Clean up dead code

2019-01-07 Thread Dan Carpenter
On Sun, Jan 06, 2019 at 10:20:59AM -0600, Aditya Pakki wrote: > rtw_wps_start() is part of dead code due to CONFIG_INTEL_WIDI. > The fix removes the deadcode and replaces the function with NULL > in rtw_private_handler. Identified as part of copy_from_user bug. > Thanks! Reviewed-by: Dan

Re: [PATCH] staging: wilc1000: fix cast to restricted __le32

2019-01-07 Thread Dan Carpenter
I'm sort of surprised that the zero day bot didn't complain about this. It probably should. The endianness checking is not turned on by default in Sparse. You have to do "make C=1 CF=-D__CHECK_ENDIAN__" to turn it on. regards, dan carpenter On Sat, Jan 05, 2019 at 09:23:23AM +0100, Július

Re: linux-5.0-rc1/drivers/staging/rtl8188eu/hal/hal8188e_rate_adaptive.c:412]: (style) Expression is always false

2019-01-07 Thread gre...@linuxfoundation.org
On Mon, Jan 07, 2019 at 11:40:08AM +, David Binderman wrote: > > Hello there, > > linux-5.0-rc1/drivers/staging/rtl8188eu/hal/hal8188e_rate_adaptive.c:412]: > (style) Expression is always false because 'else if' condition matches > previous condition at line 410. > > Source code is > >

linux-5.0-rc1/drivers/staging/rtl8188eu/hal/hal8188e_rate_adaptive.c:412]: (style) Expression is always false

2019-01-07 Thread David Binderman
Hello there, linux-5.0-rc1/drivers/staging/rtl8188eu/hal/hal8188e_rate_adaptive.c:412]: (style) Expression is always false because 'else if' condition matches previous condition at line 410. Source code is else if (pRaInfo->HighestRate > 0x0b) pRaInfo->PTModeSS = 2;

Re: [PATCH -next] media: staging/intel-ipu3: Fix err handle of ipu3_css_find_binary

2019-01-07 Thread Sakari Ailus
Hi Bingbu, On Mon, Jan 07, 2019 at 10:38:19AM +0800, Bingbu Cao wrote: > Hi, Haibing > > Thanks for your patch, it looks fine for me. > Reviewed-by: Bingbu Cao > > On 12/29/2018 10:45 AM, YueHaibing wrote: > > css->pipes[pipe].bindex = binary; I'm taking Colin's patch with equivalent content;

Re: rtl8192e: need help with variable naming convention

2019-01-07 Thread Greg KH
On Mon, Jan 07, 2019 at 04:04:46PM +0530, Himadri Pandya wrote: > Hello, > > I'm getting started with device drivers. And as a starter, I'm working on > some clean-up patches. I'm particularly targeting to rename a structure > array "ChannelPlan"(in file dot11d.c) to fix a checkpatch.pl warning

Re: [PATCH] hv_balloon: avoid touching uninitialized struct page during tail onlining

2019-01-07 Thread David Hildenbrand
On 04.01.19 15:19, Vitaly Kuznetsov wrote: > Hyper-V memory hotplug protocol has 2M granularity and in Linux x86 we use > 128M. To deal with it we implement partial section onlining by registering > custom page onlining callback (hv_online_page()). Later, when more memory > arrives we try to

Re: [PATCH] v2 staging: rtl8723bs: Clean up dead code

2019-01-07 Thread Greg Kroah-Hartman
On Sun, Jan 06, 2019 at 10:20:59AM -0600, Aditya Pakki wrote: > rtw_wps_start() is part of dead code due to CONFIG_INTEL_WIDI. > The fix removes the deadcode and replaces the function with NULL > in rtw_private_handler. Identified as part of copy_from_user bug. > > Signed-off-by: Aditya Pakki >

Re: [linux-sunxi] [PATCH v2 1/2] media: v4l: Add definitions for the HEVC slice format and controls

2019-01-07 Thread Paul Kocialkowski
Hi, On Mon, 2019-01-07 at 11:49 +0800, Randy Li wrote: > On 12/12/18 8:51 PM, Paul Kocialkowski wrote: > > Hi, > > > > On Wed, 2018-12-05 at 21:59 +0100, Jernej Škrabec wrote: > > > > > > + > > > > +#define V4L2_HEVC_DPB_ENTRY_RPS_ST_CURR_BEFORE 0x01 > > > > +#define