Re: [PATCH v2 3/8] staging: wilc1000: move macro and function prototype from wilc_wlan_if.h file

2019-02-07 Thread Ajay.Kathat
On 2/7/2019 6:21 PM, Claudiu Beznea - M18063 wrote: > > > On 07.02.2019 13:29, ajay.kat...@microchip.com wrote: >> From: Ajay Singh >> >> Move data structure and function prototype from 'wilc_wlan_if.h file. >> Now, this file contains constant specific to the firmware. >> >> Signed-off-by: Ajay

[driver-core:debugfs_cleanup 124/124] drivers/platform/x86/acer-wmi.c:2166:15: warning: return type defaults to 'int'

2019-02-07 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git debugfs_cleanup head: 3cc275229e713135bfacb30ea82112f15a03d74f commit: 3cc275229e713135bfacb30ea82112f15a03d74f [124/124] platform/x86: fix up changelog config: x86_64-rhel (attached as .config) compiler: gcc-8

Re: [PATCH] PCI: hv: Add hv_pci_remove_slots() when we unload the driver

2019-02-07 Thread Stephen Hemminger
On Thu, 7 Feb 2019 20:36:32 + Dexuan Cui wrote: > When we unload pci-hyperv, the host doesn't send us a PCI_EJECT message. > In this case we also need to make sure the sysfs pci slot directory > is removed, otherwise "cat /sys/bus/pci/slots/2/address" will trigger > "BUG: unable to handle

[PATCH] media: imx: Set capture compose rectangle in capture_device_set_format

2019-02-07 Thread Steve Longerbeam
From: Steve Longerbeam The capture compose rectangle was not getting updated when setting the source subdevice's source pad format. This causes the compose window to be zero (or not updated) at stream start unless the capture device format was set explicitly at the capture device node. Fix by

Re: [PATCH 1/3] sched/wait: use freezable_schedule when possible

2019-02-07 Thread Hugo Lefeuvre
> Sure, add these test results to the patch as well showing reduced wakeups. > > I would say submit the freezable_schedule as a single separate patch > independent of the vsoc series since it can go in separately, and also > benefits other things than vsoc. > > Also CC Rafael (power maintainer)

[PATCH v2 2/2] staging/android: simplify handle_vsoc_cond_wait

2019-02-07 Thread Hugo Lefeuvre
simplify handle_vsoc_cond_wait (drivers/staging/android/vsoc.c) using newly added wait_event_freezable_hrtimeout helper and remove duplicate include. Signed-off-by: Hugo Lefeuvre --- Changes in v2: - Fix removal of necessary linux/freezer.h include. - Make commit message more precise about

[driver-core:debugfs_cleanup 124/124] drivers/platform/x86/acer-wmi.c:2172:1: warning: no return statement in function returning non-void

2019-02-07 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git debugfs_cleanup head: 3ec9bc11e2cea5023fd7bda21dd0c942f4a67b67 commit: 3ec9bc11e2cea5023fd7bda21dd0c942f4a67b67 [124/124] platform/x86: fix changelog config: x86_64-rhel (attached as .config) compiler: gcc-8 (Debian

[PATCH v2 1/2] sched/wait: introduce wait_event_freezable_hrtimeout

2019-02-07 Thread Hugo Lefeuvre
introduce wait_event_freezable_hrtimeout, an interruptible and freezable version of wait_event_hrtimeout. This helper will allow for simplifications in staging/android/vsoc.c, among others. Signed-off-by: Hugo Lefeuvre --- Changes in v2: - No change. include/linux/wait.h | 25

[PATCH v2 0/2] sched/wait, staging/android: simplification of freeze related code

2019-02-07 Thread Hugo Lefeuvre
This patchset introduces a new wait_event_freezable_hrtimeout method to the wait api. wait_event_freezable_hrtimeout is then used to greatly simplify handle_vsoc_cond_wait in the android vsoc driver, reducing the size of the vsoc driver. Changes since v1 [1]: - Delete "[1/3] sched/wait: use

[driver-core:debugfs_cleanup 124/124] drivers/platform/x86/intel_pmc_core.c:721:2: warning: 'return' with a value, in function returning void

2019-02-07 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git debugfs_cleanup head: 3ec9bc11e2cea5023fd7bda21dd0c942f4a67b67 commit: 3ec9bc11e2cea5023fd7bda21dd0c942f4a67b67 [124/124] platform/x86: fix changelog config: i386-randconfig-a2-201905 (attached as .config) compiler:

[PATCH] PCI: hv: Add hv_pci_remove_slots() when we unload the driver

2019-02-07 Thread Dexuan Cui
When we unload pci-hyperv, the host doesn't send us a PCI_EJECT message. In this case we also need to make sure the sysfs pci slot directory is removed, otherwise "cat /sys/bus/pci/slots/2/address" will trigger "BUG: unable to handle kernel paging request". And, if we unload/reload the driver

Re: [Linaro-mm-sig] [PATCH 2/4] staging: android: ion: Restrict cache maintenance to dma mapped memory

2019-02-07 Thread Ørjan Eide
On Wed, Feb 06, 2019 at 11:31:04PM -0800, Christoph Hellwig wrote: > The CPU may only access DMA mapped memory if ownership has been > transferred back to the CPU using dma_sync_{single,sg}_to_cpu, and then > before the device can access it again ownership needs to be transferred > back to the

[PATCH V3 0/3] x86/Hyper-V/IOMMU: Add Hyper-V IOMMU driver to support x2apic mode

2019-02-07 Thread lantianyu1986
From: Lan Tianyu On the bare metal, enabling X2APIC mode requires interrupt remapping function which helps to deliver irq to cpu with 32-bit APIC ID. Hyper-V doesn't provide interrupt remapping function so far and Hyper-V MSI protocol already supports to deliver interrupt to the CPU whose

[PATCH V3 1/3] x86/Hyper-V: Set x2apic destination mode to physical when x2apic is available

2019-02-07 Thread lantianyu1986
From: Lan Tianyu Hyper-V doesn't provide irq remapping for IO-APIC. To enable x2apic, set x2apic destination mode to physcial mode when x2apic is available and Hyper-V IOMMU driver makes sure cpus assigned with IO-APIC irqs have 8-bit APIC id. Signed-off-by: Lan Tianyu --- Change since v2:

Re: [PATCH 1/3] sched/wait: use freezable_schedule when possible

2019-02-07 Thread Joel Fernandes
On Thu, Feb 07, 2019 at 12:30:50AM +0100, Hugo Lefeuvre wrote: > Hi Joel, > > > I'm curious did you try the freezing process and see if pointless wakeups > > are > > reduced? That would be an added bonus if you did. > > I'm currently testing these changes. I hope to be able to come back with >

Re: [PATCH 1/3] sched/wait: use freezable_schedule when possible

2019-02-07 Thread Hugo Lefeuvre
Hi, > > The result is a potential performance gain during freeze, since less > > tasks have to be awaken. > > I'm curious did you try the freezing process and see if pointless wakeups are > reduced? That would be an added bonus if you did. Test env: fresh Debian QEMU vm with 4.19 stable

Re: [PATCH v2 3/8] staging: wilc1000: move macro and function prototype from wilc_wlan_if.h file

2019-02-07 Thread Claudiu.Beznea
On 07.02.2019 13:29, ajay.kat...@microchip.com wrote: > From: Ajay Singh > > Move data structure and function prototype from 'wilc_wlan_if.h file. > Now, this file contains constant specific to the firmware. > > Signed-off-by: Ajay Singh > --- > drivers/staging/wilc1000/host_interface.c |

Re: [PATCH] staging: wlan-ng: formatting change in cfg80211.c

2019-02-07 Thread Greg KH
On Tue, Feb 05, 2019 at 05:49:03AM -0500, K Hodges wrote: > Resolve "Line over 80 characters" warning from checkpatch > > Signed-off-by: K Hodges Same name question here. ___ devel mailing list de...@linuxdriverproject.org

Re: [PATCH] staging: android: formatting change in ashmem.c

2019-02-07 Thread Greg KH
On Tue, Feb 05, 2019 at 11:53:54PM -0500, K Hodges wrote: > Resolved "Line over 80 characters" warning from checkpatch > > Signed-off-by: K Hodges We need a "full" name here, unless you really do sign legal documents with just "K"? thanks, greg k-h

Re: [PATCH v2 1/8] staging: wilc1000: fix to set correct value for 'vif_num'

2019-02-07 Thread Dan Carpenter
Thanks so much! Reviewed-by: Dan Carpenter regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

[PATCH v2 2/8] staging: wilc1000: add 'wilc_' prefix to have proper namespace

2019-02-07 Thread Ajay.Kathat
From: Ajay Singh Cleanup patch to rename data structure and function name to have 'wilc_' prefix. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 54 +++ drivers/staging/wilc1000/host_interface.h | 12 ++---

[PATCH v2 0/8] staging: wilc1000: fixes & changes for mainline review comments

2019-02-07 Thread Ajay.Kathat
From: Ajay Singh This series contains the following changes: - fix to set 'vif_num' value correctly. - use 'wilc_' prefix for variables and function names. - avoid use of unnecessary 'linux_' prefix from file names. Changes since v1: - merged patch 1 & 2 and added modification as

[PATCH v2 4/8] staging: wilc1000: avoid function forward declaration in wilc_sdio.c file

2019-02-07 Thread Ajay.Kathat
From: Ajay Singh Cleanup patch to avoid function forward declaration by reordering the function. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_sdio.c | 91 +--- 1 file changed, 43 insertions(+), 48 deletions(-) diff --git

[PATCH v2 3/8] staging: wilc1000: move macro and function prototype from wilc_wlan_if.h file

2019-02-07 Thread Ajay.Kathat
From: Ajay Singh Move data structure and function prototype from 'wilc_wlan_if.h file. Now, this file contains constant specific to the firmware. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/host_interface.c | 1 + drivers/staging/wilc1000/host_interface.h | 11 ++

[PATCH v2 1/8] staging: wilc1000: fix to set correct value for 'vif_num'

2019-02-07 Thread Ajay.Kathat
From: Ajay Singh Set correct value in '->vif_num' for the total number of interfaces and set '->idx' value using 'i'. Fixes: 735bb39ca3be ("staging: wilc1000: simplify vif[i]->ndev accesses") Fixes: 0e490657c721 ("staging: wilc1000: Fix problem with wrong vif index") Cc: Suggested-by: Dan

[PATCH v2 8/8] staging: wilc1000: rename linux_wlan.c and linux_mon.c

2019-02-07 Thread Ajay.Kathat
From: Ajay Singh Rename linux_wlan.c and linux_mon.c to wilc_netdev.c and wilc_mon.c to include 'wilc_' prefix. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/Makefile| 2 +- drivers/staging/wilc1000/{linux_mon.c => wilc_mon.c} | 0

[PATCH v2 6/8] staging: wilc1000: rename wilc_frmw_to_linux()

2019-02-07 Thread Ajay.Kathat
From: Ajay Singh Rename wilc_frmw_to_linux() to wilc_frmw_to_host() to be remove the _linux suffix. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_wlan.c | 3 ++- drivers/staging/wilc1000/wilc_wfi_netdevice.h | 2 +- drivers/staging/wilc1000/wilc_wlan.c | 5

[PATCH v2 7/8] staging: wilc1000: remove 'linux_' prefix in function names

2019-02-07 Thread Ajay.Kathat
From: Ajay Singh Remove 'linux_' prefix and replace it with 'wilc_' namespace. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/linux_wlan.c | 17 - drivers/staging/wilc1000/wilc_sdio.c | 10 +- 2 files changed, 13 insertions(+), 14 deletions(-) diff --git

[PATCH v2 5/8] staging: wilc1000: added 'wilc_' prefix for function in wilc_sdio.c file

2019-02-07 Thread Ajay.Kathat
From: Ajay Singh Cleanup patch to have proper follow clear namespace in wilc_sdio.c file. Signed-off-by: Ajay Singh --- drivers/staging/wilc1000/wilc_sdio.c | 92 ++-- 1 file changed, 46 insertions(+), 46 deletions(-) diff --git

Re: [PATCH 1/9] staging: wilc1000: revert fix related to vif index

2019-02-07 Thread Dan Carpenter
On Thu, Feb 07, 2019 at 09:39:54AM +, ajay.kat...@microchip.com wrote: > Hi Dan, > > On 2/7/2019 1:42 PM, Dan Carpenter wrote: > > This patch was very confusing to review... > > Apologies for the confusion. > > > From a process perspective, you really should fold patches 1 and 2 > >

Re: [PATCH 1/9] staging: wilc1000: revert fix related to vif index

2019-02-07 Thread Ajay.Kathat
Hi Dan, On 2/7/2019 1:42 PM, Dan Carpenter wrote: > This patch was very confusing to review... Apologies for the confusion. > From a process perspective, you really should fold patches 1 and 2 > together. Otherwise we're re-introducing a bug. Patch 1 and Patch 2 both are required if commit

Re: [PATCH 2/9] staging: wilc1000: fix to set the correct value for 'vif_num'

2019-02-07 Thread Dan Carpenter
On Thu, Feb 07, 2019 at 07:22:25AM +, ajay.kat...@microchip.com wrote: > From: Ajay Singh > > Set correct interface count value in '->vif_num'. > 'vif_num' was incorrectly set one less than total number of interfaces > because 'i' is used to set its value, which starts from 0. > > Fixes:

Re: [PATCH 1/9] staging: wilc1000: revert fix related to vif index

2019-02-07 Thread Dan Carpenter
This patch was very confusing to review... >From a process perspective, you really should fold patches 1 and 2 together. Otherwise we're re-introducing a bug. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org