Re: [PATCH v2 1/2] sched/wait: introduce wait_event_freezable_hrtimeout

2019-02-10 Thread Ingo Molnar
* Hugo Lefeuvre wrote: > introduce wait_event_freezable_hrtimeout, an interruptible and freezable > version of wait_event_hrtimeout. > > This helper will allow for simplifications in staging/android/vsoc.c, among > others. > > Signed-off-by: Hugo Lefeuvre > --- > Changes in v2: > - No

Re: [PATCH] staging: mt7621-pci: update driver's TODO file

2019-02-10 Thread NeilBrown
On Sun, Feb 10 2019, Sergio Paracuellos wrote: > Some of the things included in driver's TODO file have > been properly achieved. Update file accordly. > > Signed-off-by: Sergio Paracuellos > --- > Hi Neil, > > I've been looking through the code of this driver and pci-phy > driver while thinking

[PATCH net-next v3 7/9] net: dsa: Handle SWITCHDEV_PORT_ATTR_GET/SET

2019-02-10 Thread Florian Fainelli
Following patches will change the way we communicate getting or setting a port's attribute and use a blocking notifier to perform those tasks. Prepare DSA to support receiving notifier events targeting SWITCHDEV_PORT_ATTR_GET/SET and simply translate that into the existing

[PATCH net-next v3 6/9] staging: fsl-dpaa2: ethsw: Handle SWITCHDEV_PORT_ATTR_GET/SET

2019-02-10 Thread Florian Fainelli
Following patches will change the way we communicate getting or setting a port's attribute and use a blocking notifier to perform those tasks. Prepare ethsw to support receiving notifier events targeting SWITCHDEV_PORT_ATTR_GET/SET and simply translate that into the existing

[PATCH net-next v3 1/9] Documentation: networking: switchdev: Update port parent ID section

2019-02-10 Thread Florian Fainelli
Update the section about switchdev drivers having to implement a switchdev_port_attr_get() function to return SWITCHDEV_ATTR_ID_PORT_PARENT_ID since that is no longer valid after commit bccb30254a4a ("net: Get rid of SWITCHDEV_ATTR_ID_PORT_PARENT_ID"). Fixes: bccb30254a4a ("net: Get rid of

[PATCH net-next v3 9/9] net: Remove switchdev_ops

2019-02-10 Thread Florian Fainelli
Now that we have converted all possible callers to using a switchdev notifier for attributes we do not have a need for implementing switchdev_ops anymore, and this can be removed from all drivers the net_device structure. Signed-off-by: Florian Fainelli ---

[PATCH net-next v3 8/9] net: switchdev: Replace port attr get/set SDO with a notification

2019-02-10 Thread Florian Fainelli
Drop switchdev_ops.switchdev_port_attr_get and _set. Drop the uses of this field from all clients, which were migrated to use switchdev notification in the previous patches. Add a new function switchdev_port_attr_notify() that sends the switchdev notifications SWITCHDEV_PORT_ATTR_GET and _SET.

[PATCH net-next v3 5/9] net: mscc: ocelot: Handle SWITCHDEV_PORT_ATTR_GET/SET

2019-02-10 Thread Florian Fainelli
Following patches will change the way we communicate getting or setting a port's attribute and use a blocking notifier to perform those tasks. Prepare ocelot to support receiving notifier events targeting SWITCHDEV_PORT_ATTR_GET/SET and simply translate that into the existing

[PATCH net-next v3 4/9] mlxsw: spectrum_switchdev: Handle SWITCHDEV_PORT_ATTR_GET/SET

2019-02-10 Thread Florian Fainelli
Following patches will change the way we communicate getting or setting a port's attribute and use a blocking notifier to perform those tasks. Prepare mlxsw to support receiving notifier events targeting SWITCHDEV_PORT_ATTR_GET/SET and simply translate that into the existing

[PATCH net-next v3 2/9] switchdev: Add SWITCHDEV_PORT_ATTR_SET, SWITCHDEV_PORT_ATTR_GET

2019-02-10 Thread Florian Fainelli
In preparation for allowing switchdev enabled drivers to veto specific attribute settings from within the context of the caller, introduce a new switchdev notifier type for port attributes. Suggested-by: Ido Schimmel Signed-off-by: Florian Fainelli --- include/net/switchdev.h | 10 ++

[PATCH net-next v3 0/9] net: Remove switchdev_ops

2019-02-10 Thread Florian Fainelli
Hi all, This patch series finishes by the removal of switchdev_ops. To get there we need to do a few things: - get rid of the one and only call to switchdev_port_attr_get() which is used to fetch the device's bridge port flags capabilities, instead we can just check what flags are being

[PATCH net-next v3 3/9] rocker: Handle SWITCHDEV_PORT_ATTR_GET/SET

2019-02-10 Thread Florian Fainelli
Following patches will change the way we communicate getting or setting a port's attribute and use a blocking notifier to perform those tasks. Prepare rocker to support receiving notifier events targeting SWITCHDEV_PORT_ATTR_GET/SET and simply translate that into the existing

Re: [PATCH V3 1/3] x86/Hyper-V: Set x2apic destination mode to physical when x2apic is available

2019-02-10 Thread Thomas Gleixner
On Thu, 7 Feb 2019, lantianyu1...@gmail.com wrote: > From: Lan Tianyu > > Hyper-V doesn't provide irq remapping for IO-APIC. To enable x2apic, > set x2apic destination mode to physcial mode when x2apic is available > and Hyper-V IOMMU driver makes sure cpus assigned with IO-APIC irqs have >

Re: [PATCH net-next v2 00/16] net: Remove switchdev_ops

2019-02-10 Thread David Miller
From: Florian Fainelli Date: Sun, 10 Feb 2019 12:44:47 -0800 > I am going to submit a v3 which moves the port_attr_{get,set} to a > switchdev notifier, but does not yet get rid of > switchdev_port_attr_get() entirely since there is not a clear path yet > to split the setting between non-sleeping

Re: [PATCH net-next v2 00/16] net: Remove switchdev_ops

2019-02-10 Thread Florian Fainelli
Le 2/10/19 à 9:50 AM, Florian Fainelli a écrit : > Hi all, > > This patch series finishes by the removal of switchdev_ops. To get there > we need to do a few things: > > - get rid of the one and only call to switchdev_port_attr_get() which is > used to fetch the device's bridge port flags

Re: [PATCH net-next v2 06/16] net: bridge: Stop calling switchdev_port_attr_get()

2019-02-10 Thread Florian Fainelli
Le 2/10/19 à 11:05 AM, Ido Schimmel a écrit : > On Sun, Feb 10, 2019 at 09:50:55AM -0800, Florian Fainelli wrote: >> Now that all switchdev drivers have been converted to checking the >> bridge port flags during the prepare phase of the >> switchdev_port_attr_set(), we can move straight to trying

Re: [PATCH net-next v2 06/16] net: bridge: Stop calling switchdev_port_attr_get()

2019-02-10 Thread Ido Schimmel
On Sun, Feb 10, 2019 at 09:50:55AM -0800, Florian Fainelli wrote: > Now that all switchdev drivers have been converted to checking the > bridge port flags during the prepare phase of the > switchdev_port_attr_set(), we can move straight to trying to set the > desired flag through

[PATCH net-next v2 16/16] net: Remove switchdev_ops

2019-02-10 Thread Florian Fainelli
Now that we have converted all possible callers to using a switchdev notifier for attributes we do not have a need for implementing switchdev_ops anymore, and this can be removed from all drivers the net_device structure. Signed-off-by: Florian Fainelli ---

[PATCH net-next v2 05/16] rocker: Check bridge flags during prepare phase

2019-02-10 Thread Florian Fainelli
In preparation for getting rid of switchdev_port_attr_get(), have rocker check for the bridge flags being set through switchdev_port_attr_set() with the SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS attribute identifier. Acked-by: Jiri Pirko Signed-off-by: Florian Fainelli ---

[PATCH net-next v2 09/16] switchdev: Add SWITCHDEV_PORT_ATTR_SET

2019-02-10 Thread Florian Fainelli
In preparation for allowing switchdev enabled drivers to veto specific attribute settings from within the context of the caller, introduce a new switchdev notifier type for port attributes. Suggested-by: Ido Schimmel Acked-by: Jiri Pirko Signed-off-by: Florian Fainelli ---

[PATCH net-next v2 13/16] net: mscc: ocelot: Handle SWITCHDEV_PORT_ATTR_SET

2019-02-10 Thread Florian Fainelli
Following patches will change the way we communicate getting or setting a port's attribute and use a blocking notifier to perform those tasks. Prepare ocelot to support receiving notifier events targeting SWITCHDEV_PORT_ATTR_SET and simply translate that into the existing ocelot_port_attr_set()

[PATCH net-next v2 02/16] mlxsw: spectrum: Check bridge flags during prepare phase

2019-02-10 Thread Florian Fainelli
In preparation for getting rid of switchdev_port_attr_get(), have mlxsw check for the bridge flags being set through switchdev_port_attr_set() with the SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS attribute identifier. Acked-by: Jiri Pirko Signed-off-by: Florian Fainelli ---

[PATCH net-next v2 15/16] net: switchdev: Replace port attr set SDO with a notification

2019-02-10 Thread Florian Fainelli
Drop switchdev_ops.switchdev_port_attr_set. Drop the uses of this field from all clients, which were migrated to use switchdev notification in the previous patches. Add a new function switchdev_port_attr_notify() that sends the switchdev notifications SWITCHDEV_PORT_ATTR_SET. Drop

[PATCH net-next v2 11/16] net: dsa: Handle SWITCHDEV_PORT_ATTR_SET

2019-02-10 Thread Florian Fainelli
Following patches will change the way we communicate getting or setting a port's attribute and use a blocking notifier to perform those tasks. Prepare DSA to support receiving notifier events targeting SWITCHDEV_PORT_ATTR_SET and simply translate that into the existing dsa_slave_port_attr_set()

[PATCH net-next v2 08/16] net: Get rid of switchdev_port_attr_get()

2019-02-10 Thread Florian Fainelli
With the bridge no longer calling switchdev_port_attr_get() to obtain the supported bridge port flags from a driver but instead trying to set the bridge port flags directly and relying on driver to reject unsupported configurations, we can effectively get rid of switchdev_port_attr_get() entirely

[PATCH net-next v2 06/16] net: bridge: Stop calling switchdev_port_attr_get()

2019-02-10 Thread Florian Fainelli
Now that all switchdev drivers have been converted to checking the bridge port flags during the prepare phase of the switchdev_port_attr_set(), we can move straight to trying to set the desired flag through SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS. Acked-by: Jiri Pirko Signed-off-by: Florian Fainelli

[PATCH net-next v2 14/16] staging: fsl-dpaa2: ethsw: Handle SWITCHDEV_PORT_ATTR_SET

2019-02-10 Thread Florian Fainelli
Following patches will change the way we communicate getting or setting a port's attribute and use a blocking notifier to perform those tasks. Prepare ethsw to support receiving notifier events targeting SWITCHDEV_PORT_ATTR_SET and simply translate that into the existing swdev_port_attr_set()

[PATCH net-next v2 12/16] mlxsw: spectrum_switchdev: Handle SWITCHDEV_PORT_ATTR_SET

2019-02-10 Thread Florian Fainelli
Following patches will change the way we communicate getting or setting a port's attribute and use a blocking notifier to perform those tasks. Prepare mlxsw to support receiving notifier events targeting SWITCHDEV_PORT_ATTR_SET and simply translate that into the existing mlxsw_sp_port_attr_set()

[PATCH net-next v2 10/16] rocker: Handle SWITCHDEV_PORT_ATTR_SET

2019-02-10 Thread Florian Fainelli
Following patches will change the way we communicate getting or setting a port's attribute and use a blocking notifier to perform those tasks. Prepare rocker to support receiving notifier events targeting SWITCHDEV_PORT_ATTR_SET and simply translate that into the existing rocker_port_attr_set

[PATCH net-next v2 07/16] net: Remove SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS_SUPPORT

2019-02-10 Thread Florian Fainelli
Now that we have converted the bridge code and the drivers to check for bridge port(s) flags at the time we try to set them, there is no need for a get() -> set() sequence anymore and SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS_SUPPORT therefore becomes unused. Acked-by: Jiri Pirko Signed-off-by:

[PATCH net-next v2 03/16] staging: fsl-dpaa2: ethsw: Check bridge port flags during set

2019-02-10 Thread Florian Fainelli
In preparation for removing SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS_SUPPORT, have ethsw check that the bridge port flags that are being set are supported. Acked-by: Jiri Pirko Signed-off-by: Florian Fainelli --- drivers/staging/fsl-dpaa2/ethsw/ethsw.c | 5 - 1 file changed, 4 insertions(+), 1

[PATCH net-next v2 01/16] Documentation: networking: switchdev: Update port parent ID section

2019-02-10 Thread Florian Fainelli
Update the section about switchdev drivers having to implement a switchdev_port_attr_get() function to return SWITCHDEV_ATTR_ID_PORT_PARENT_ID since that is no longer valid after commit bccb30254a4a ("net: Get rid of SWITCHDEV_ATTR_ID_PORT_PARENT_ID"). Fixes: bccb30254a4a ("net: Get rid of

[PATCH net-next v2 00/16] net: Remove switchdev_ops

2019-02-10 Thread Florian Fainelli
Hi all, This patch series finishes by the removal of switchdev_ops. To get there we need to do a few things: - get rid of the one and only call to switchdev_port_attr_get() which is used to fetch the device's bridge port flags capabilities, instead we can just check what flags are being

[PATCH net-next v2 04/16] net: dsa: Add setter for SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS

2019-02-10 Thread Florian Fainelli
In preparation for removing SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS_SUPPORT, add support for a function that processes the SWITCHDEV_ATTR_ID_PORT_BRIDGE_FLAGS attribute and returns not supported for any flag set, since DSA does not currently support toggling those bridge port attributes (yet).

[PATCH] staging: mt7621-pci: update driver's TODO file

2019-02-10 Thread Sergio Paracuellos
Some of the things included in driver's TODO file have been properly achieved. Update file accordly. Signed-off-by: Sergio Paracuellos --- Hi Neil, I've been looking through the code of this driver and pci-phy driver while thinking in what is missing already to get this mainlined out of

[PATCH 2/8] staging: rtl8192e: rename function Dot11d_Channelmap to dot11d_channel_map - style

2019-02-10 Thread Himadri Pandya
Rename function Dot11d_Channelmap to dot11d_channel_map to fix checkpatch warning: Avoid CamelCase. Signed-off-by: Himadri Pandya --- drivers/staging/rtl8192e/dot11d.c| 4 ++-- drivers/staging/rtl8192e/dot11d.h| 2 +- drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 2 +-

[PATCH 6/8] staging: rtl8192e: rename local variables of function dot11d_update_country - style

2019-02-10 Thread Himadri Pandya
Rename following local variables of function dot11d_update_country to fix checkpatch warning: Avoid CamelCase and make the variable names more readable, understandable. NumTriples -> number_of_triples MaxChnlNum -> max_channel_number pTriple -> triple Signed-off-by:

[PATCH 4/8] staging: rtl8192e: rename function Dot11d_UpdateCountryIe to dot11d_update_country - style

2019-02-10 Thread Himadri Pandya
Rename function Dot11d_UpdateCountryIe to dot11d_update_country to fix checkpatch warning: Avoid CamelCase. Signed-off-by: Himadri Pandya --- drivers/staging/rtl8192e/dot11d.c| 2 +- drivers/staging/rtl8192e/dot11d.h| 2 +- drivers/staging/rtl8192e/rtllib_rx.c | 2 +- 3 files changed, 3

[PATCH 5/8] staging: rtl8192e: rename function DOT11D_ScanComplete to dot11d_scan_complete - style

2019-02-10 Thread Himadri Pandya
Rename function DOT11D_ScanComplete to dot11d_scan_complete to fix checkpatch warning: Avoid CamelCase. Signed-off-by: Himadri Pandya --- drivers/staging/rtl8192e/dot11d.c | 2 +- drivers/staging/rtl8192e/dot11d.h | 2 +- drivers/staging/rtl8192e/rtllib_softmac.c | 4 ++-- 3

[PATCH 7/8] staging: rtl8192e: rename parameters of function dot11d_update_country - style

2019-02-10 Thread Himadri Pandya
Rename following parameters of function dot11d_update_country to fix checkpatch warning: Avoid CamelCase and make the parameter names more readable, understandable. pTaddr -> address CoutryIeLen -> country_len pCoutryIe -> country Signed-off-by: Himadri Pandya ---

[PATCH 8/8] staging: rtl8192e: rename macro arguments to avoid camel case - style

2019-02-10 Thread Himadri Pandya
Rename following macro arguments to fix checkpatch warning: Avoid Camelcase and make the arguments more readable, understandable. __pIeeeDev -> __ieee_dev __pTa -> __address Signed-off-by: Himadri Pandya --- drivers/staging/rtl8192e/dot11d.h | 30 +++---

[PATCH 3/8] staging: rtl8192e: rename function Dot11d_Reset to dot11d_reset - style

2019-02-10 Thread Himadri Pandya
Rename function Dot11d_Reset to dot11d_reset to fix checkpatch warning: Avoid CamelCase. Signed-off-by: Himadri Pandya --- drivers/staging/rtl8192e/dot11d.c | 4 ++-- drivers/staging/rtl8192e/dot11d.h | 2 +- drivers/staging/rtl8192e/rtllib_softmac.c | 2 +- 3 files changed, 4

[PATCH 1/8] staging: rtl8192e: rename function cpMacAddr to copy_mac_addr - style

2019-02-10 Thread Himadri Pandya
Rename function cpMacAddr to copy_mac_addr in order to fix checkpatch warning:Avoid CamelCase and make the function name more readable, understandable. Signed-off-by: Himadri Pandya --- drivers/staging/rtl8192e/dot11d.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git