[PATCH] staging: comedi: Fix spelling mistake

2019-04-03 Thread Hariprasad Kelam
changes interupts --> interrupts to fix warning reported by checkpatch tool Signed-off-by: Hariprasad Kelam --- drivers/staging/comedi/drivers/dt2811.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers/dt2811.c

Re: [PATCH] Staging: rtlwifi: Remove unwanted parentheses

2019-04-03 Thread Madhumthia Prabakaran
On Wed, Apr 03, 2019 at 07:21:45PM +0300, Dan Carpenter wrote: > On Wed, Apr 03, 2019 at 07:18:03PM +0300, Dan Carpenter wrote: > > data_bit = (data & BIT(i)) ? 1 : 0; > > I quite like the !! idiom also... > > data_bit = !!(data & BIT(i)); Thanks for reviewing it. >

[PATCH v2] Staging: rtlwifi: Remove unwanted parentheses

2019-04-03 Thread Madhumitha Prabakaran
Remove unwanted parentheses and use !! idiom in place of ternary operator to make code simple and more understandable. Signed-off-by: Madhumitha Prabakaran --- Changes in v2: - Changed commit log - Replaced ternary operator with !! idiom - Modified a BIT operator ---

[PATCH] staging: greybus: power_supply: Use struct_size() helper

2019-04-03 Thread Gustavo A. R. Silva
Make use of the struct_size() helper instead of an open-coded version in order to avoid any potential type mistakes, in particular in the context in which this code is being used. So, replace code of the following form: sizeof(*resp) + props_count * sizeof(struct gb_power_supply_props_desc)

[PATCH] staging: ralink-gdma: Use struct_size() in kzalloc()

2019-04-03 Thread Gustavo A. R. Silva
One of the more common cases of allocation size calculations is finding the size of a structure that has a zero-sized array at the end, along with memory for some number of elements for that array. For example: struct foo { int stuff; struct boo entry[]; }; size = sizeof(struct foo) +

[PATCH] staging: iio: cdc: ad7746: Replace bitshift by BIT

2019-04-03 Thread Lucas Oshiro
Replace bitshifts on lines 54, 56 and 78 of ad7746.c. Signed-off-by: Lucas Oshiro --- drivers/staging/iio/cdc/ad7746.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/iio/cdc/ad7746.c b/drivers/staging/iio/cdc/ad7746.c index 0eb28fea876e..ea48b14cee72

Re: [Lkcamp] [PATCH] staging/rtl8723bs: Fix code indent.

2019-04-03 Thread Helen Koike
Hi Beatriz, Thank you for the patch, just some small comments. Regarding the patch title, if you run git log drivers/staging/rtl8723bs/hal/hal_com_phycfg.c You will see that commits starts with the following tags "staging: rtl8723bs: " Also, try to add a bit more information to the title,

Re: [PATCH 03/16] staging: m57621-mmc: delete driver from the tree.

2019-04-03 Thread George Hilliard
On Tue, Apr 2, 2019 at 3:45 PM Christian Lütke-Stetzkamp wrote: > There are two other larger differences that I found during my > work. One is that drivers/mmc/host/mtk-sd.c has much more features, > like voltage and clock handling and some support for high speed > modes. I don't know if these

[PATCH] staging/rtl8723bs: Fix code indent.

2019-04-03 Thread Beatriz Martins de Carvalho
Fix Error: code indent Signed-off-by: Beatriz Martins de Carvalho --- drivers/staging/rtl8723bs/hal/hal_com_phycfg.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8723bs/hal/hal_com_phycfg.c b/drivers/staging/rtl8723bs/hal/hal_com_phycfg.c index

[PATCH 1/2] staging: rtl8188eu: remove unnecessary declaration

2019-04-03 Thread Michael Straube
The declaration of sta2sta_data_frame() is directly above the function definition. Remove the unnecessary declaration. This also clears a checkpatch issue. CHECK: Lines should not end with a '(' Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_recv.c | 6 -- 1 file

[PATCH 2/2] staging: rtl8188eu: make sta2sta_data_frame() static

2019-04-03 Thread Michael Straube
Function sta2sta_data_frame() is only used in rtw_recv.c. So make it static. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_recv.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_recv.c

Re: [PATCH] Staging: rtlwifi: Remove unwanted parentheses

2019-04-03 Thread Dan Carpenter
On Wed, Apr 03, 2019 at 07:18:03PM +0300, Dan Carpenter wrote: > data_bit = (data & BIT(i)) ? 1 : 0; I quite like the !! idiom also... data_bit = !!(data & BIT(i)); regards, dan carpenter ___ devel mailing list

Re: [PATCH] Staging: rtlwifi: Remove unwanted parentheses

2019-04-03 Thread Dan Carpenter
On Wed, Apr 03, 2019 at 11:04:45AM -0500, Madhumitha Prabakaran wrote: > Remove unwanted parentheses around right hand side of an assignment to > make code better and more understandable. > > Issue found by Coccinelle. > > Signed-off-by: Madhumitha Prabakaran > --- >

[PATCH] Staging: rtlwifi: Remove unwanted parentheses

2019-04-03 Thread Madhumitha Prabakaran
Remove unwanted parentheses around right hand side of an assignment to make code better and more understandable. Issue found by Coccinelle. Signed-off-by: Madhumitha Prabakaran --- drivers/staging/rtlwifi/core.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH] Staging: mt7621-mmc: Use DIV_ROUND_UP in function msdc_set_mclk

2019-04-03 Thread Madhumitha Prabakaran
Use DIV_ROUND_UP to make code simple and more understandable. Signed-off-by: Madhumitha Prabakaran --- drivers/staging/mt7621-mmc/sd.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/mt7621-mmc/sd.c b/drivers/staging/mt7621-mmc/sd.c index

[PATCH v3] Staging: gasket: Use DIV_ROUND_UP

2019-04-03 Thread Madhumitha Prabakaran
Use DIV_ROUND_UP in-kernel function to make code simple and more understandable. Issue found using Coccinelle. Signed-off-by: Madhumitha Prabakaran --- Changes in v3: - Included version no in patch Changes in v2: - Commit log modified --- drivers/staging/gasket/gasket_page_table.c | 5 ++---

[PATCH] Staging: gasket: Use DIV_ROUND_UP

2019-04-03 Thread Madhumitha Prabakaran
Use DIV_ROUND_UP in-kernel function to make code simple and more understandable. Issue found using Coccinelle. Signed-off-by: Madhumitha Prabakaran --- Changes in v2: - Commit log modified --- drivers/staging/gasket/gasket_page_table.c | 5 ++--- 1 file changed, 2 insertions(+), 3

Re: [PATCH 1/2] staging:iio:accel:adis16203: add SPDX license identifier tag

2019-04-03 Thread Greg Kroah-Hartman
On Wed, Apr 03, 2019 at 11:41:28AM +0200, Nicholas Mc Guire wrote: > Pop in the SPDX tag as the license is clearly indicated > as GPL V2 or later this should also be indicated with a SPDX license > identifier tag. > > Signed-off-by: Nicholas Mc Guire I sent patches yesterday to fix up all of

[PATCH v4 10/12] staging: most: configfs: make create attributes write-only

2019-04-03 Thread Christian Gromm
Reading the create attribute that triggers the creation of a link to a certain channel is not necessary. Hence, it is being removed. Signed-off-by: Christian Gromm --- v2: v3: v4: drivers/staging/most/configfs.c | 17 ++--- 1 file changed, 2 insertions(+), 15 deletions(-) diff

[PATCH v4 12/12] staging: most: Documentation: update driver documentation

2019-04-03 Thread Christian Gromm
This patch updates the driver documentation files to reflect the latest changes regarding configfs. Signed-off-by: Christian Gromm v2: - changed kernel version to 5.2 v3: v4: Signed-off-by: Christian Gromm --- .../most/Documentation/ABI/configfs-most.txt | 204

[PATCH v4 01/12] staging: most: add new file configfs.c

2019-04-03 Thread Christian Gromm
This patch adds the file configfs.c to the driver directory. The file registers the necessary subsystems with configfs in order to move the driver configuration from sysfs to configfs. Signed-off-by: Christian Gromm --- v2: Reported-by: Dan Carpenter - remove unnecessary variable init

[PATCH v4 06/12] staging: most: core: make sysfs attributes read-only

2019-04-03 Thread Christian Gromm
This patch changes the access flags of the channel attributes to read-only. This is needed, because configuration is done via configfs. Signed-off-by: Christian Gromm --- v2: v3: v4: drivers/staging/most/core.c | 122 +++- 1 file changed, 7

[PATCH v4 02/12] staging: most: change signature of function probe_channel

2019-04-03 Thread Christian Gromm
This patch adds the param argument to the function parameter of the call-back probe_channel. This parameter is needed to configure the channels of an attached device. Signed-off-by: Christian Gromm --- v2: v3: v4: drivers/staging/most/cdev/cdev.c | 2 +- drivers/staging/most/core.c|

[PATCH v4 05/12] staging: most: enable configfs support

2019-04-03 Thread Christian Gromm
This patch enables the configfs functionality of the driver by registering the configfs subsystems and compiling the configfs part of the sources. Signed-off-by: Christian Gromm --- v2: - remove call to configfs_exit function v3: v4: - add dependency to CONFIGFS_FS

[PATCH v4 00/12] staging: most: switch to configfs

2019-04-03 Thread Christian Gromm
This patch set makes the driver provide its configuration interface via configfs. The configuration interface is being switched to simplify the process of setting up the driver and to introduce the new feature of speculative configuration. v2: v3: v4: Reported-by: Greg Kroah-Hartman -

[PATCH v4 08/12] staging: most: core: remove attribute add_link

2019-04-03 Thread Christian Gromm
This patch removes the driver attribute add_link. It is not needed, because the link management is now done via configfs. Signed-off-by: Christian Gromm --- v2: v3: v4: drivers/staging/most/core.c | 61 - 1 file changed, 61 deletions(-) diff --git

[PATCH v4 11/12] staging: most: configfs: add code for link removal

2019-04-03 Thread Christian Gromm
This patch adds code that cleans up established links whenever the destroy attribute is set or if the config_item (directory) is being removed. Signed-off-by: Christian Gromm --- v2: - follow-up adaptions due to changes introduced w/ [PATCH v2 01/14] v3: v4:

[PATCH v4 09/12] staging: most: allow speculative configuration

2019-04-03 Thread Christian Gromm
This patch makes the driver accept a link configuration eventhough no device is attached to the bus. Instead the configuration is being applied as soon as a device is being registered with the core. Signed-off-by: Christian Gromm --- v2: - follow-up adaptions due to changes introduced w/

[PATCH v4 03/12] staging: most: core: add configfs interface functions

2019-04-03 Thread Christian Gromm
This patch adds the core's interface to configfs file. Signed-off-by: Christian Gromm --- v2: v3: v4: drivers/staging/most/core.c | 142 drivers/staging/most/core.h | 16 - 2 files changed, 157 insertions(+), 1 deletion(-) diff --git

[PATCH v4 04/12] staging: most: sound: introduce new sound adapter management

2019-04-03 Thread Christian Gromm
This patch adapts the sound card management to the configfs changes. Signed-off-by: Christian Gromm --- v2: v3: Reported-by: Dan Carpenter - return 0 in function audio_create_sound_card v4: drivers/staging/most/sound/sound.c | 41 +- 1 file changed,

[PATCH v4 07/12] staging: most: usb: remove prefix from description tag

2019-04-03 Thread Christian Gromm
This patch cuts off the usb_device prefix of the description string. It is not needed, as the interface type is already available with the interface attribute of a channel. Signed-off-by: Christian Gromm --- v2: v3: v4: drivers/staging/most/usb/usb.c | 2 +- 1 file changed, 1 insertion(+), 1

Re: [PATCH 1/2] staging:iio:accel:adis16203: add SPDX license identifier tag

2019-04-03 Thread Himanshu Jha
hackpatch.pl was warning: > WARNING: Missing or malformed SPDX-License-Identifier tag in line 1 > > Patch was compile tested with: X86_64_defconfig + SPI=y, IIO=m > STAGING=y, ADIS16203=m > > Patch is against 5.1-rc3 (localversion-next is next-20190403) > > drivers/staging/

Re: [PATCH] staging: most: core: use device description as name

2019-04-03 Thread Sasha Levin
Hi, [This is an automated email] This commit has been processed because it contains a -stable tag. The stable tag indicates that it's relevant for the following trees: all The bot has tested the following trees: v5.0.5, v4.19.32, v4.14.109, v4.9.166, v4.4.177, v3.18.137. v5.0.5: Build OK!

[PATCH 1/2] staging:iio:accel:adis16203: add SPDX license identifier tag

2019-04-03 Thread Nicholas Mc Guire
tested with: X86_64_defconfig + SPI=y, IIO=m STAGING=y, ADIS16203=m Patch is against 5.1-rc3 (localversion-next is next-20190403) drivers/staging/iio/accel/adis16203.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/iio/accel/adis16203.c b/drivers/staging/iio/accel/adis16203.c

[PATCH 2/2] staging:iio:accel:adis16240: add SPDX license identifier tag

2019-04-03 Thread Nicholas Mc Guire
tested with: x86_64_defconfig + SPI=y, IIO=m STAGING=y, ADIS16240=m Patch is against 5.1-rc3 (localversion-next is next-20190403) drivers/staging/iio/accel/adis16240.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/iio/accel/adis16240.c b/drivers/staging/iio/accel/adis16240.c

Re: [PATCH 06/16] staging: vc04_services: remove remaining redundant license text

2019-04-03 Thread Greg Kroah-Hartman
On Tue, Apr 02, 2019 at 12:37:57PM +0200, Stefan Wahren wrote: > Am 02.04.19 um 12:31 schrieb Greg Kroah-Hartman: > > Now that the SPDX tag is in all vc04_services files, that identifies the > > license in a specific and legally-defined manner. So the extra GPL and > > BSD text wording can be

Re: [PATCH 02/16] staging: add missing SPDX lines to Makefile files

2019-04-03 Thread Greg Kroah-Hartman
On Tue, Apr 02, 2019 at 05:36:20PM +0530, Mukesh Ojha wrote: > > On 4/2/2019 4:01 PM, Greg Kroah-Hartman wrote: > > There are a few remaining drivers/staging/*/Makefile files that do not > > have SPDX identifiers in them. Add the correct GPL-2.0 identifier to > > them to make scanning tools

Re: [driver-core:driver-core-testing 4/14] arch/ia64/kernel/acpi.c:669:38: error: passing argument 2 of 'acpi_table_parse' from incompatible pointer type

2019-04-03 Thread Greg Kroah-Hartman
On Wed, Apr 03, 2019 at 02:18:18AM +0800, kbuild test robot wrote: > tree: > https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git > driver-core-testing > head: 5e29ef654e7be73a579b96c1b912dac5cea33046 > commit: 088d0b345be1952be1a5004fb78cfffa0835cbe1 [4/14] acpi: Create

Re: [PATCH] staging: vchiq_arm: remove space after open '('

2019-04-03 Thread Stefan Wahren
Am 03.04.19 um 05:07 schrieb Mario Balan: > Fix checkpatch error "ERROR: space prohibited after that open > parenthesis '('" in vchiq_arm.c:563. > > Signed-off-by: Mario Balan Acked-by: Stefan Wahren ___ devel mailing list