Re: [RESEND PATCH v6 0/5] Add i.MX8MM OCOTP support

2019-05-04 Thread Bryan O'Donoghue
On 04/05/2019 18:10, Srinivas Kandagatla wrote: Normally I don't take patches that are sent after rc5 into next merge window. Unless there is an urgent fix. In this case I will be applying these series to nvmem next branch once rc1 is released for 5.3 merge window. Great, that'll done fine Sr

Re: [PATCH 2/7] staging: rtl8723bs: core: Remove return in void function.

2019-05-04 Thread Julia Lawall
> @@ -5828,8 +5822,6 @@ void survey_timer_hdl(struct timer_list *t) > > > exit_survey_timer_hdl: > - > - return; > } Are you sure that you compiled this code? I'm not sure that it is possible to have a label without a subsequent statement. julia

[PATCH 6/7] staging: rtl8723bs: core: Fix variable constant comparisons.

2019-05-04 Thread Vatsala Narang
Swap the terms of comparisons whenever the constant comes first to get rid of checkpatch warning. Signed-off-by: Vatsala Narang --- drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c

[PATCH 5/7] staging: rtl8723bs: core: Remove braces from single if statement.

2019-05-04 Thread Vatsala Narang
Remove braces from single if statement to get rid of checkpatch warning. Signed-off-by: Vatsala Narang --- drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 12 1 file changed, 4 insertions(+), 8 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c b/drivers/stagi

[PATCH 7/7] staging: rtl8723bs: core: Moved logical operator to previous line.

2019-05-04 Thread Vatsala Narang
Moved logical operator to previous line to get rid of checkpatch warning. Signed-off-by: Vatsala Narang --- drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c b/drivers/staging/rtl

[PATCH 4/7] staging: rtl8723bs: core: Remove unnecessary parentheses.

2019-05-04 Thread Vatsala Narang
Remove unnecessary parentheses after 'address-of' operator to get rid of checkpatch warning. Signed-off-by: Vatsala Narang --- drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.

[PATCH 0/7] staging: rtl8723bs: core: Fix various checkpatch

2019-05-04 Thread Vatsala Narang
This series fix the following warnings: -Remove multiple blank lines. -Remove return in void function. -Replace NULL comparison. -Remove unnecessary parentheses. -Remove braces from single if statement. -Fix variable constant comparison. -Move logical operator to previous line. Vatsala Narang (7):

[PATCH 3/7] staging: rtl8723bs: core: Replace NULL comparisons.

2019-05-04 Thread Vatsala Narang
Replace NULL comparisons in the file to get rid of checkpatch warning. Signed-off-by: Vatsala Narang --- drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 32 +-- 1 file changed, 16 insertions(+), 16 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c b/driver

[PATCH 2/7] staging: rtl8723bs: core: Remove return in void function.

2019-05-04 Thread Vatsala Narang
Remove return in void function to get rid of checkpatch warning. Signed-off-by: Vatsala Narang --- drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 10 -- 1 file changed, 10 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c b/drivers/staging/rtl8723bs/core/rtw_mlme

[PATCH 1/7] staging: rtl8723bs: core: Remove blank line.

2019-05-04 Thread Vatsala Narang
To avoid style issues, remove multiple blank lines. Signed-off-by: Vatsala Narang --- drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 5 - 1 file changed, 5 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c b/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c index d110d45

Re: [RESEND PATCH v6 0/5] Add i.MX8MM OCOTP support

2019-05-04 Thread Srinivas Kandagatla
On 04/05/2019 15:49, Bryan O'Donoghue wrote: On 04/05/2019 09:39, Greg KH wrote: On Fri, May 03, 2019 at 05:53:37PM +0100, Bryan O'Donoghue wrote: V6 RESEND: - Adding Greg to sender list. Greg looks like you are the right person to    apply this. $ ./scripts/get_maintainer.pl --file drive

Re: [RESEND PATCH v6 0/5] Add i.MX8MM OCOTP support

2019-05-04 Thread Greg KH
On Sat, May 04, 2019 at 03:49:05PM +0100, Bryan O'Donoghue wrote: > On 04/05/2019 09:39, Greg KH wrote: > > On Fri, May 03, 2019 at 05:53:37PM +0100, Bryan O'Donoghue wrote: > > > V6 RESEND: > > > - Adding Greg to sender list. Greg looks like you are the right person to > > >apply this. > > >

Re: [RESEND PATCH v6 0/5] Add i.MX8MM OCOTP support

2019-05-04 Thread Bryan O'Donoghue
On 04/05/2019 09:39, Greg KH wrote: On Fri, May 03, 2019 at 05:53:37PM +0100, Bryan O'Donoghue wrote: V6 RESEND: - Adding Greg to sender list. Greg looks like you are the right person to apply this. $ ./scripts/get_maintainer.pl --file drivers/nvmem/imx-ocotp.c Srinivas Kandagatla (maintai

Re: [PATCH 0/4] staging: iio: ad7150: improve driver readability

2019-05-04 Thread Alexandru Ardelean
On Sat, May 4, 2019 at 2:12 PM Alexandru Ardelean wrote: > > On Sat, May 4, 2019 at 1:24 AM Melissa Wen wrote: > > > > This patchset solves readability issues in AD7150 code, such as clarify > > register and mask definition, fashion improvement of mask uses, reduce > > tedious operation and usele

Re: [PATCH 0/4] staging: iio: ad7150: improve driver readability

2019-05-04 Thread Alexandru Ardelean
On Sat, May 4, 2019 at 1:24 AM Melissa Wen wrote: > > This patchset solves readability issues in AD7150 code, such as clarify > register and mask definition, fashion improvement of mask uses, reduce > tedious operation and useless comments. > Hey, Two patches seem a bit noisy/un-needed. The othe

Re: [PATCH 2/4] staging: iio: ad7150: use FIELD_GET and GENMASK

2019-05-04 Thread Alexandru Ardelean
On Sat, May 4, 2019 at 1:25 AM Melissa Wen wrote: > > Use the bitfield macro FIELD_GET, and GENMASK to do the shift and mask in > one go. This makes the code more readable than explicit masking followed > by a shift. > This looks neat. I'd have to remember to ack it from my work email. One minor

Re: [PATCH 3/4] staging: iio: ad7150: simplify i2c SMBus return treatment

2019-05-04 Thread Alexandru Ardelean
On Sat, May 4, 2019 at 1:26 AM Melissa Wen wrote: > > Since i2c_smbus_write_byte_data returns no-positive value, this commit > making the treatment of its return value less verbose. > > Signed-off-by: Melissa Wen > --- > drivers/staging/iio/cdc/ad7150.c | 10 +++--- > 1 file changed, 3 inser

Re: [PATCH 1/4] staging: iio: ad7150: organize registers definition

2019-05-04 Thread Alexandru Ardelean
On Sat, May 4, 2019 at 1:25 AM Melissa Wen wrote: > > Use the suffix REG to make the register addresses clear > and indentation to highlight field names. > I'm inclined to say that this change is a bit too much noise versus added value. While the REG suffix does make sense (generally), since it h

Re: RFC: kpc2000 driver naming

2019-05-04 Thread 'gre...@linuxfoundation.org'
On Fri, May 03, 2019 at 10:24:00PM +, Matt Sickler wrote: > Hello, > > Recently Greg KH posted the first set of drivers for our PCIe device > (kpc2000) and shortly after that I posted the kpc2000_dma driver. I was > wondering about naming / structure standards in the Linux kernel. > First,

Re: [RESEND PATCH v6 0/5] Add i.MX8MM OCOTP support

2019-05-04 Thread Greg KH
On Fri, May 03, 2019 at 05:53:37PM +0100, Bryan O'Donoghue wrote: > V6 RESEND: > - Adding Greg to sender list. Greg looks like you are the right person to > apply this. $ ./scripts/get_maintainer.pl --file drivers/nvmem/imx-ocotp.c Srinivas Kandagatla (maintainer:NVMEM FRAMEWORK) Shawn Guo (m

[PATCH] Staging: rtl8723bs: core: Fix Spelling mistake in comments

2019-05-04 Thread Puranjay Mohan
Change spelling of 'associcated' to 'associated', to fix the spelling mistake. Signed-off-by: Puranjay Mohan --- drivers/staging/rtl8723bs/core/rtw_ap.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_ap.c b/drivers/staging/rtl8723bs/