[PATCH] staging: wlan-ng: collect return status without variable

2019-05-09 Thread Hariprasad Kelam
err and result variables are declared to collect return status of prism2_domibset_uint32. Check return status in if loop and return directly. Rearragne code such that we can avoid declaring these variables. Signed-off-by: Hariprasad Kelam --- drivers/staging/wlan-ng/cfg80211.c | 17

Re: [PATCH v2 3/7] lib/hexdump.c: Optionally suppress lines of repeated bytes

2019-05-09 Thread Alastair D'Silva
On Wed, 2019-05-08 at 17:58 -0700, Randy Dunlap wrote: > On 5/8/19 12:01 AM, Alastair D'Silva wrote: > > From: Alastair D'Silva > > > > Some buffers may only be partially filled with useful data, while > > the rest > > is padded (typically with 0x00 or 0xff). > > > > This patch introduces a

Re: [RFC] simple_lmk: Introduce Simple Low Memory Killer for Android

2019-05-09 Thread Sultan Alsawaf
On Thu, May 09, 2019 at 05:56:46PM +0200, Oleg Nesterov wrote: > Impossible ;) I bet lockdep should report the deadlock as soon as > find_victims() > calls find_lock_task_mm() when you already have a locked victim. I hope you're not a betting man ;) With the following configured:

RE: [PATCH v2] kpc_i2c: Remove unused file

2019-05-09 Thread Matt Sickler
>-Original Message- >From: Dan Carpenter > >Add Staging: to the subject. Added to my notes so I don't forget it next time. >[PATCH v2] Staging: kpc_i2c: Remove unused file fileops.c > >On Thu, May 09, 2019 at 01:38:27PM +, Matt Sickler wrote: >> The whole file was wrapped in an #if

Re: [RFC] simple_lmk: Introduce Simple Low Memory Killer for Android

2019-05-09 Thread Oleg Nesterov
On 05/07, Sultan Alsawaf wrote: > > On Tue, May 07, 2019 at 05:31:54PM +0200, Oleg Nesterov wrote: > > > Did you test this patch with lockdep enabled? > > > > If I read the patch correctly, lockdep should complain. vtsk_is_duplicate() > > ensures that we do not take the same ->alloc_lock twice or

RE: [PATCH v2] kpc_i2c: Remove unused file

2019-05-09 Thread Matt Sickler
>-Original Message- >From: Dan Carpenter > >On Thu, May 09, 2019 at 02:47:50PM +, Matt Sickler wrote: > >A few people/subsystems (DRM) put the change log in the commit message >but that's pretty weird and I don't know if they do it on purpose or >they're just not aware how to do it

Re: [PATCH v2] kpc_i2c: Remove unused file

2019-05-09 Thread Dan Carpenter
On Thu, May 09, 2019 at 02:47:50PM +, Matt Sickler wrote: > >> --- > > ^^^ > > > >Here. > > Noted. I just looked up a "v2" patch in the mailing list > archive to see what that looks like. I'll try to do that > next time. > A few people/subsystems (DRM) put the change log in the commit

Re: [PATCH v3 4/4] staging: vchiq: stop explicitly comparing with zero to catch errors

2019-05-09 Thread Dan Carpenter
On Thu, May 09, 2019 at 04:31:36PM +0200, Nicolas Saenz Julienne wrote: > The vchiq code tends to follow a coding pattern that's not accepted as > per the Linux kernel coding style > > We have this: > if (expression != 0) > > We want this: > if (expression) > > We make an exception

[PATCH v3 4/4] staging: vchiq: stop explicitly comparing with zero to catch errors

2019-05-09 Thread Nicolas Saenz Julienne
The vchiq code tends to follow a coding pattern that's not accepted as per the Linux kernel coding style We have this: if (expression != 0) We want this: if (expression) We make an exception if the expression refers to a size, in which case it's accepted for the sake of clarity.

[PATCH v3 2/4] staging: vchiq: revert "switch to wait_for_completion_killable"

2019-05-09 Thread Nicolas Saenz Julienne
The killable version of wait_for_completion() is meant to be used on situations where it should not fail at all costs, but still have the convenience of being able to kill it if really necessary. VCHIQ doesn't fit this criteria, as it's mainly used as an interface to V4L2 and ALSA devices. Fixes:

[PATCH v3 3/4] staging: vchiq: make wait events interruptible

2019-05-09 Thread Nicolas Saenz Julienne
The killable version of wait_event() is meant to be used on situations where it should not fail at all costs, but still have the convenience of being able to kill it if really necessary. Wait events in VCHIQ doesn't fit this criteria, as it's mainly used as an interface to V4L2 and ALSA devices.

[PATCH v3 0/4] staging: vchiq: use interruptible waits

2019-05-09 Thread Nicolas Saenz Julienne
Hi, this series tries to address an issue that came up in Raspbian's kernel tree [1] and upstream distros [2][3]. We adopted some changes that moved wait calls from a custom implementation to the more standard killable family of functions. Users complained that all the VCHIQ threads showed up in

[PATCH v3 1/4] staging: vchiq_2835_arm: revert "quit using custom down_interruptible()"

2019-05-09 Thread Nicolas Saenz Julienne
The killable version of down() is meant to be used on situations where it should not fail at all costs, but still have the convenience of being able to kill it if really necessary. VCHIQ doesn't fit this criteria, as it's mainly used as an interface to V4L2 and ALSA devices. Fixes: ff5979ad8636

Re: [PATCH v2] kpc_i2c: Remove unused file

2019-05-09 Thread Dan Carpenter
Add Staging: to the subject. [PATCH v2] Staging: kpc_i2c: Remove unused file fileops.c On Thu, May 09, 2019 at 01:38:27PM +, Matt Sickler wrote: > The whole file was wrapped in an #if 0. I'm guessing it was a leftover file > from when we were first developing the driver and we just forgot

[PATCH v2] kpc_i2c: Remove unused file

2019-05-09 Thread Matt Sickler
The whole file was wrapped in an #if 0. I'm guessing it was a leftover file from when we were first developing the driver and we just forgot about it. V2: Forgot the signed-off-by line on the first patch. Signed-off-by: Matt Sickler --- drivers/staging/kpc2000/kpc_i2c/Makefile | 2 +-

Re: [PATCH] kpc_i2c: Remove unused file

2019-05-09 Thread Greg KH
On Thu, May 09, 2019 at 02:05:22AM +, Matt Sickler wrote: > The whole file was wrapped in an #if 0. I'm guessing it was a leftover file > from when we were first developing the driver and we just forgot about it. > --- > drivers/staging/kpc2000/kpc_i2c/Makefile | 2 +- >