[PATCH 00/22] staging: erofs: updates according to erofs-outofstaging v4

2019-07-28 Thread Gao Xiang
This patchset includes all meaningful modifications till now according to erofs-outofstaging v4: https://lore.kernel.org/linux-fsdevel/20190725095658.155779-1-gaoxian...@huawei.com/ Some empty lines which were add or delete are not included in this patchset, I will send erofs-outofstaging v5 later

[PATCH 04/22] staging: erofs: keep up erofs_fs.h with erofs-outofstaging patchset

2019-07-28 Thread Gao Xiang
The main change is to reserve all checksums except for superblock, since it's more useful to do block-based verity for read-only fs. Some comments change as well, which is minor. Signed-off-by: Gao Xiang --- drivers/staging/erofs/erofs_fs.h | 39 1 file changed,

[PATCH 03/22] staging: erofs: fix dummy functions erofs_{get, list}xattr

2019-07-28 Thread Gao Xiang
dummy functions erofs_{get,list}xattr should be inlined without xattr enabled. Signed-off-by: Yue Hu [ Gao Xiang : this patch was "staging: erofs: remove needless dummy functions of erofs_{get,list}xattr. "] Signed-off-by: Gao Xiang --- drivers/staging/erofs/xattr.h | 14 +++--

[PATCH 14/22] staging: erofs: tidy up zpvec.h

2019-07-28 Thread Gao Xiang
- use shorter function names: z_erofs_pagevec_enqueue and z_erofs_pagevec_dequeue; - minor code cleanup. In order to keep in line with erofs-outofstaging patchset. Signed-off-by: Gao Xiang --- drivers/staging/erofs/zdata.c | 6 +++--- drivers/staging/erofs/zpvec.h | 25 +-

[PATCH 16/22] staging: erofs: tidy up decompression frontend

2019-07-28 Thread Gao Xiang
Although this patch has an amount of changes, it is hard to separate into smaller patches. Most changes are due to structure renaming for better understand and straightforward, z_erofs_vle_workgroup to z_erofs_pcluster since it represents a physical cluster; z_erofs_vle_work to z_er

[PATCH 21/22] staging: erofs: update super.c

2019-07-28 Thread Gao Xiang
Keep in line with erofs-outofstaging patchset: - "Chao Yu" is most commonly used in Linux community; - quoted string split across lines. Signed-off-by: Gao Xiang --- drivers/staging/erofs/super.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/staging/erofs/super

[PATCH 06/22] staging: erofs: clean up internal.h

2019-07-28 Thread Gao Xiang
Tidy up relative order of variables / declarations in internal.h, and moving some local static functions out to other files. No logic change. Signed-off-by: Gao Xiang --- drivers/staging/erofs/decompressor.c | 27 ++ drivers/staging/erofs/internal.h | 130 +++ d

[PATCH 20/22] staging: erofs: tidy up internal.h

2019-07-28 Thread Gao Xiang
keep in line with erofs-outofstaging patchset: - remove an extra #ifdef CONFIG_EROFS_FS_ZIP; - add tags at the end of #endif acrossing several lines. Signed-off-by: Gao Xiang --- drivers/staging/erofs/internal.h | 29 + 1 file changed, 13 insertions(+), 16 deletions

[PATCH 13/22] staging: erofs: kill CONFIG_EROFS_FS_USE_VM_MAP_RAM

2019-07-28 Thread Gao Xiang
Turn into a module parameter ("use_vmap") as it can be set at runtime. Suggested-by: David Sterba Signed-off-by: Gao Xiang --- drivers/staging/erofs/Kconfig| 8 -- drivers/staging/erofs/decompressor.c | 37 +++- 2 files changed, 20 insertions(+), 25 deletion

[PATCH 15/22] staging: erofs: remove redundant braces in inode.c

2019-07-28 Thread Gao Xiang
Remove redundant braces in inode.c since these are all single statements. Signed-off-by: Gao Xiang --- drivers/staging/erofs/inode.c | 18 -- 1 file changed, 8 insertions(+), 10 deletions(-) diff --git a/drivers/staging/erofs/inode.c b/drivers/staging/erofs/inode.c index c13d66c

[PATCH 22/22] staging: erofs: update Kconfig

2019-07-28 Thread Gao Xiang
Keep in line with erofs-outofstaging patchset: - turn on CONFIG_EROFS_FS_ZIP by default; - turn on CONFIG_EROFS_FS_SECURITY by default suggested by David; - update Kconfig description. Signed-off-by: Gao Xiang --- drivers/staging/erofs/Kconfig | 54 ++- 1 file

[PATCH 02/22] staging: erofs: rename source files for better understanding

2019-07-28 Thread Gao Xiang
Keep in line with erofs-outofstaging patchset as well, see https://lore.kernel.org/linux-fsdevel/20190725095658.155779-1-gaoxian...@huawei.com/ Signed-off-by: Gao Xiang --- drivers/staging/erofs/Makefile | 2 +- drivers/staging/erofs/{include/linux => }/tagptr.h | 6 +++--- d

[PATCH 18/22] staging: erofs: turn cache strategies into mount options

2019-07-28 Thread Gao Xiang
Kill all kconfig cache strategies and turn them into mount options "cache_strategy={disable|readahead|readaround}". As the first step, cached pages can still be usable after cache is disabled by remounting, and these pages will be fallen out over time, which can be refined in the later version if

[PATCH 10/22] staging: erofs: kill sbi->dev_name

2019-07-28 Thread Gao Xiang
As Al said, "the only use of sbi->dev_name is debugging printks and all of those have sb->s_id available, with device name stored in there. Which makes the whole thing bloody weird". sbi->dev_name was used for our debugging use and it's better to just use s_id in community and delete the whole er

[PATCH 17/22] staging: erofs: remove clusterbits in sbi

2019-07-28 Thread Gao Xiang
clustersize can now be set on per-file basis rather than per-filesystem basis. Signed-off-by: Gao Xiang --- drivers/staging/erofs/internal.h | 5 - drivers/staging/erofs/super.c| 9 - drivers/staging/erofs/zmap.c | 3 +-- 3 files changed, 1 insertion(+), 16 deletions(-) diff

[PATCH 12/22] staging: erofs: refine erofs_allocpage()

2019-07-28 Thread Gao Xiang
remove duplicated code in decompressor by introducing failable erofs_allocpage(). Signed-off-by: Gao Xiang --- drivers/staging/erofs/decompressor.c | 12 +++- drivers/staging/erofs/internal.h | 2 +- drivers/staging/erofs/utils.c| 5 +++-- drivers/staging/erofs/zdata.c

[PATCH 19/22] staging: erofs: tidy up utils.c

2019-07-28 Thread Gao Xiang
keep in line with erofs-outofstaging patchset: - Update comments in erofs_try_to_release_workgroup; - code style cleanup. Signed-off-by: Gao Xiang --- drivers/staging/erofs/utils.c | 27 +-- 1 file changed, 13 insertions(+), 14 deletions(-) diff --git a/drivers/staging

[PATCH 01/22] staging: erofs: update source file headers

2019-07-28 Thread Gao Xiang
- Use the correct style for all SPDX License Identifiers; - Get rid of the unnecessary license boilerplate; - Use "GPL-2.0-only" instead of "GPL-2.0" suggested-by Stephen. Signed-off-by: Gao Xiang --- drivers/staging/erofs/Kconfig | 2 +- drivers/staging/erofs/Makefile

[PATCH 11/22] staging: erofs: kill all failure handling in fill_super()

2019-07-28 Thread Gao Xiang
.kill_sb() will do that instead in order to remove duplicated code. Note that the initialzation of managed_cache is now moved after s_root is assigned since it's more preferred to iput() in .put_super() and all inodes should be evicted before the end of generic_shutdown_super(sb). Suggested-by: A

[PATCH 05/22] staging: erofs: sunset erofs_workstn_{lock,unlock}

2019-07-28 Thread Gao Xiang
It was used for Linux backward compatibility, and no use for upstream kernel. Signed-off-by: Gao Xiang --- drivers/staging/erofs/internal.h | 3 --- drivers/staging/erofs/utils.c| 10 +- 2 files changed, 5 insertions(+), 8 deletions(-) diff --git a/drivers/staging/erofs/internal.h

[PATCH 07/22] staging: erofs: remove redundant #include "internal.h"

2019-07-28 Thread Gao Xiang
Because #include "internal.h" is included in xattr.h Signed-off-by: Gao Xiang --- drivers/staging/erofs/namei.c | 1 - drivers/staging/erofs/super.c | 1 - 2 files changed, 2 deletions(-) diff --git a/drivers/staging/erofs/namei.c b/drivers/staging/erofs/namei.c index 50816b4c05fc..8e06526da023

[PATCH 08/22] staging: erofs: kill CONFIG_EROFS_FS_IO_MAX_RETRIES

2019-07-28 Thread Gao Xiang
CONFIG_EROFS_FS_IO_MAX_RETRIES seems a runtime setting and users have no idea about the change in behaviour. Let's remove the setting currently and fold it into code, turn it into a module parameter if it's really needed. Suggested-by: David Sterba Signed-off-by: Gao Xiang --- drivers/staging/

[PATCH 09/22] staging: erofs: clean up shrinker stuffs

2019-07-28 Thread Gao Xiang
- rename erofs_register_super / erofs_unregister_super to erofs_shrinker_register / erofs_shrinker_unregister; - fold the only erofs_shrink_workstation external call to erofs_shrinker_unregister; - localize erofs_shrink_workstation; - localize erofs_shrinker_info by introducing erofs_init_shr

[PATCH] staging: olpc_dcon: Remove TODO item

2019-07-28 Thread Jerry Lin
All uses of old GPIO API have been converted to new API. This item can be removed from TODO file. Signed-off-by: Jerry Lin --- drivers/staging/olpc_dcon/TODO | 4 1 file changed, 4 deletions(-) diff --git a/drivers/staging/olpc_dcon/TODO b/drivers/staging/olpc_dcon/TODO index fe09efb..d829

[PATCH] staging: rtl8723bs: core: Remove unneeded variables sgi_20m,sgi_40m and sgi_80m

2019-07-28 Thread Hariprasad Kelam
htpriv.sgi_* variables are of type u8 ,instead of storing them in local variables ,its better to read value directly from structure. Signed-off-by: Hariprasad Kelam --- drivers/staging/rtl8723bs/core/rtw_xmit.c | 11 --- 1 file changed, 4 insertions(+), 7 deletions(-) diff --git a/drive

[PATCH] staging: rtl8723bs: Remove Unnecessary parentheses

2019-07-28 Thread Saurav-Girepunje
Removed Unnecessary parentheses around "padapter->mlmepriv", "pmlmeext->mlmext_info" and "pmlmeinfo->network" Signed-off-by: Saurav-Girepunje --- drivers/staging/rtl8723bs/core/rtw_ap.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/rtl8723bs/cor

Re: [PATCH] RTWAP:Fixed Coding function and style issues

2019-07-28 Thread Greg KH
On Sun, Jul 28, 2019 at 05:51:57PM +0530, Saurav-Girepunje wrote: > RTWAP:Fixed Coding function and style issues > Removed Unnecessary parentheses What is "RRWAP:"? Please look at other commits for this driver and copy how they structure the subject and changelog information and then resend

[PATCH] RTWAP:Fixed Coding function and style issues

2019-07-28 Thread Saurav-Girepunje
RTWAP:Fixed Coding function and style issues Removed Unnecessary parentheses Signed-off-by: Saurav-Girepunje --- drivers/staging/rtl8723bs/core/rtw_ap.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_ap.c b/drivers/staging/rtl8723bs/

[PATCH] staging: rtl8723bs: core: Remove unneeded extern WFD_OUI

2019-07-28 Thread Hariprasad Kelam
Remove unneeded extern variable "extern unsigned char WFD_OUI" Signed-off-by: Hariprasad Kelam --- drivers/staging/rtl8723bs/core/rtw_ap.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_ap.c b/drivers/staging/rtl8723bs/core/rtw_ap.c index 7bd5c61..2bb20762