[PATCH 7/8] staging: exfat: Finished code movement for static cleanups in exfat_core.c

2019-10-22 Thread Valdis Kletnieks
Move static function bodies before first use, remove the definition in exfat.h Signed-off-by: Valdis Kletnieks --- drivers/staging/exfat/exfat.h | 10 - drivers/staging/exfat/exfat_core.c | 661 ++--- 2 files changed, 330 insertions(+), 341 deletions(-) diff --git

[PATCH 2/8] staging: exfat: Remove FAT/VFAT mount support, part 1

2019-10-22 Thread Valdis Kletnieks
Remove the top-level mount functionality, to make this driver handle only exfat file systems. Signed-off-by: Valdis Kletnieks --- drivers/staging/exfat/Kconfig | 9 -- drivers/staging/exfat/exfat.h | 2 - drivers/staging/exfat/exfat_core.c | 142

[PATCH 5/8] staging: exfat: Clean up static definitions in exfat_cache.c

2019-10-22 Thread Valdis Kletnieks
Move static function bodies before first use, remove the definition in exfat.h Signed-off-by: Valdis Kletnieks --- drivers/staging/exfat/exfat.h | 4 -- drivers/staging/exfat/exfat_cache.c | 94 +++-- 2 files changed, 48 insertions(+), 50 deletions(-) diff --git

[PATCH 8/8] staging: exfat: Update TODO

2019-10-22 Thread Valdis Kletnieks
Signed-off-by: Valdis Kletnieks --- drivers/staging/exfat/TODO | 20 1 file changed, 8 insertions(+), 12 deletions(-) diff --git a/drivers/staging/exfat/TODO b/drivers/staging/exfat/TODO index b60e50b9cf4e..110c30834bd2 100644 --- a/drivers/staging/exfat/TODO +++

[PATCH 1/8] staging: exfat: Clean up namespace pollution, part 1

2019-10-22 Thread Valdis Kletnieks
Make as much as possible static. We're over-exuberant here for the benefit of a following patch, as the compiler will flag now-unused static code Signed-off-by: Valdis Kletnieks --- drivers/staging/exfat/exfat.h | 156 ++--- drivers/staging/exfat/exfat_core.c | 142

[PATCH 4/8] staging: exfat: Cleanup static entries in exfat.h

2019-10-22 Thread Valdis Kletnieks
Many of the static definitions that remain are not needed, as the function definition is already before the first use. Signed-off-by: Valdis Kletnieks --- drivers/staging/exfat/exfat.h | 53 --- 1 file changed, 53 deletions(-) diff --git

[PATCH 6/8] staging: exfat: More static cleanups for exfat_core.c

2019-10-22 Thread Valdis Kletnieks
Move static function bodies before first use, remove the definition in exfat.h Signed-off-by: Valdis Kletnieks --- drivers/staging/exfat/exfat.h | 6 - drivers/staging/exfat/exfat_core.c | 500 ++--- 2 files changed, 250 insertions(+), 256 deletions(-) diff --git

[PATCH 3/8] staging: exfat: Remove FAT/VFAT mount support, part 2

2019-10-22 Thread Valdis Kletnieks
Remove no longer referenced FAT/VFAT routines. Signed-off-by: Valdis Kletnieks --- drivers/staging/exfat/exfat.h | 49 +- drivers/staging/exfat/exfat_core.c | 755 - 2 files changed, 2 insertions(+), 802 deletions(-) diff --git a/drivers/staging/exfat/exfat.h

[PATCH 0/8] staging: exfat: Code cleanups

2019-10-22 Thread Valdis Kletnieks
Two main goals here - remove the code to mount FAT and VFAT filesystes, and make a lot of functions static to reduce namespace pollution. Valdis Kletnieks (8): staging: exfat: Clean up namespace pollution, part 1 staging: exfat: Remove FAT/VFAT mount support, part 1 staging: exfat: Remove

Re: [PATCH RFC v1 00/12] mm: Don't mark hotplugged pages PG_reserved (including ZONE_DEVICE)

2019-10-22 Thread Dan Williams
Hi David, Thanks for tackling this! On Tue, Oct 22, 2019 at 10:13 AM David Hildenbrand wrote: > > This series is based on [2], which should pop up in linux/next soon: > https://lkml.org/lkml/2019/10/21/1034 > > This is the result of a recent discussion with Michal ([1], [2]). Right >

Re: [PATCH RFC v1 07/12] staging: kpc2000: Prepare transfer_complete_cb() for PG_reserved changes

2019-10-22 Thread David Hildenbrand
On 22.10.19 19:55, Matt Sickler wrote: Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change that. The pages are obtained via get_user_pages_fast(). I assume, these could be ZONE_DEVICE pages. Let's just exclude them as well explicitly. I'm not sure what ZONE_DEVICE

RE: [PATCH RFC v1 07/12] staging: kpc2000: Prepare transfer_complete_cb() for PG_reserved changes

2019-10-22 Thread Matt Sickler
>Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change >that. > >The pages are obtained via get_user_pages_fast(). I assume, these could be >ZONE_DEVICE pages. Let's just exclude them as well explicitly. I'm not sure what ZONE_DEVICE pages are, but these pages are normal

[PATCH RFC v1 10/12] powerpc/mm: Prepare maybe_pte_to_page() for PG_reserved changes

2019-10-22 Thread David Hildenbrand
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change that. We could explicitly check for is_zone_device_page(page). But looking at the pfn_valid() check, it seems safer to just use pfn_to_online_page() here, that will skip all ZONE_DEVICE pages right away. Cc: Benjamin

[PATCH RFC v1 09/12] powerpc/64s: Prepare hash_page_do_lazy_icache() for PG_reserved changes

2019-10-22 Thread David Hildenbrand
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change that. We could explicitly check for is_zone_device_page(page). But looking at the pfn_valid() check, it seems safer to just use pfn_to_online_page() here, that will skip all ZONE_DEVICE pages right away. Cc: Benjamin

[PATCH RFC v1 11/12] x86/mm: Prepare __ioremap_check_ram() for PG_reserved changes

2019-10-22 Thread David Hildenbrand
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change that. We could explicitly check for is_zone_device_page(page). But looking at the pfn_valid() check, it seems safer to just use pfn_to_online_page() here, that will skip all ZONE_DEVICE pages right away. Cc: Dave Hansen

[PATCH RFC v1 01/12] mm/memory_hotplug: Don't allow to online/offline memory blocks with holes

2019-10-22 Thread David Hildenbrand
Our onlining/offlining code is unnecessarily complicated. Only memory blocks added during boot can have holes. Hotplugged memory never has holes. That memory is already online. When we stop allowing to offline memory blocks with holes, we implicitly stop to online memory blocks with holes. This

[PATCH RFC v1 06/12] staging/gasket: Prepare gasket_release_page() for PG_reserved changes

2019-10-22 Thread David Hildenbrand
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change that. The pages are obtained via get_user_pages_fast(). I assume, these could be ZONE_DEVICE pages. Let's just exclude them as well explicitly. Cc: Rob Springer Cc: Todd Poynor Cc: Ben Chan Cc: Greg Kroah-Hartman

[PATCH RFC v1 08/12] powerpc/book3s: Prepare kvmppc_book3s_instantiate_page() for PG_reserved changes

2019-10-22 Thread David Hildenbrand
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change that. KVM has this weird use case that you can map anything from /dev/mem into the guest. pfn_valid() is not a reliable check whether the memmap was initialized and can be touched. pfn_to_online_page() makes sure that we

[PATCH RFC v1 12/12] mm/memory_hotplug: Don't mark pages PG_reserved when initializing the memmap

2019-10-22 Thread David Hildenbrand
Everything should be prepared to stop setting pages PG_reserved when initializing the memmap on memory hotplug. Most importantly, we stop marking ZONE_DEVICE pages PG_reserved. a) We made sure that any code that relied on PG_reserved to detect ZONE_DEVICE memory will no longer rely on

[PATCH RFC v1 07/12] staging: kpc2000: Prepare transfer_complete_cb() for PG_reserved changes

2019-10-22 Thread David Hildenbrand
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change that. The pages are obtained via get_user_pages_fast(). I assume, these could be ZONE_DEVICE pages. Let's just exclude them as well explicitly. Cc: Greg Kroah-Hartman Cc: Vandana BN Cc: "Simon Sandström" Cc: Dan

[PATCH RFC v1 05/12] vfio/type1: Prepare is_invalid_reserved_pfn() for PG_reserved changes

2019-10-22 Thread David Hildenbrand
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change that. KVM has this weird use case that you can map anything from /dev/mem into the guest. pfn_valid() is not a reliable check whether the memmap was initialized and can be touched. pfn_to_online_page() makes sure that we

[PATCH RFC v1 04/12] KVM: Prepare kvm_is_reserved_pfn() for PG_reserved changes

2019-10-22 Thread David Hildenbrand
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change that. KVM has this weird use case that you can map anything from /dev/mem into the guest. pfn_valid() is not a reliable check whether the memmap was initialized and can be touched. pfn_to_online_page() makes sure that we

[PATCH RFC v1 03/12] KVM: x86/mmu: Prepare kvm_is_mmio_pfn() for PG_reserved changes

2019-10-22 Thread David Hildenbrand
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change that. KVM has this weird use case that you can map anything from /dev/mem into the guest. pfn_valid() is not a reliable check whether the memmap was initialized and can be touched. pfn_to_online_page() makes sure that we

[PATCH RFC v1 02/12] mm/usercopy.c: Prepare check_page_span() for PG_reserved changes

2019-10-22 Thread David Hildenbrand
Right now, ZONE_DEVICE memory is always set PG_reserved. We want to change that. Let's make sure that the logic in the function won't change. Once we no longer set these pages to reserved, we can rework this function to perform separate checks for ZONE_DEVICE (split from PG_reserved checks). Cc:

[PATCH RFC v1 00/12] mm: Don't mark hotplugged pages PG_reserved (including ZONE_DEVICE)

2019-10-22 Thread David Hildenbrand
This series is based on [2], which should pop up in linux/next soon: https://lkml.org/lkml/2019/10/21/1034 This is the result of a recent discussion with Michal ([1], [2]). Right now we set all pages PG_reserved when initializing hotplugged memmaps. This includes ZONE_DEVICE memory. In

Re: [PATCH v8 5/5] media: imx: Try colorimetry at both sink and source pads

2019-10-22 Thread Steve Longerbeam
Hi Laurent, Rui, Besides field type ANY, the imx7 CSI should probably be dealing with other field type conversions as well. I may be mistaken, but like the imx6, the imx7 does not have the ability to detect whether a captured field is a top field or a bottom field, so it can't support

Re: [PATCH v8 5/5] media: imx: Try colorimetry at both sink and source pads

2019-10-22 Thread Rui Miguel Silva
Hi Laurent, On Tue 22 Oct 2019 at 02:44, Laurent Pinchart wrote: > Hi Steve, > > On Tue, May 21, 2019 at 06:03:17PM -0700, Steve Longerbeam wrote: >> Retask imx_media_fill_default_mbus_fields() to try colorimetry parameters, >> renaming it to to imx_media_try_colorimetry(), and call it at both

Re: [PATCH v2 1/3] media: cedrus: Fix decoding for some H264 videos

2019-10-22 Thread Paul Kocialkowski
Hi, On Tue 15 Oct 19, 19:16, Jernej Škrabec wrote: > Please understand that I was working on this on and off for almost half a > year > and checked many times all register values. At one point I tried libvdpau- > sunxi which has no problem with sample video. Still, all relevant register >

Re: [PATCH v1 1/5] staging: wfx: fix warnings of no space is necessary

2019-10-22 Thread Dan Carpenter
On Sun, Oct 20, 2019 at 12:36:50PM -0700, Joe Perches wrote: > > It's sort of tricky to know what "one thing per patch means". > > It seems somewhat arbitrary and based on Greg's understanding > of the experience of the patch submitter and also the language > of the potential commit message. Of