[PATCH] staging: mt7621-pci: avoid to set 'iomem_resource' addresses

2020-03-22 Thread Sergio Paracuellos
Setting up kernel resource 'iomem_resource' for PCI with addresses parsed from device tree gots into a conflict within the usb xhci driver: xhci-mtk 1e1c.xhci: can't request region for resource [mem 0x1e1c-0x1e1c0fff] xhci-mtk: probe of 1e1c.xhci failed with error -16 Don't assign it

Re: WARNING in hwahc_probe

2020-03-22 Thread Qiujun Huang
The return value of snprintf is longer than expected if the string is truncated. Bytes need to be checked here. diff --git a/drivers/staging/wusbcore/host/hwa-hc.c b/drivers/staging/wusbcore/host/hwa-hc.c index 8d959e9..1475a48 100644 --- a/drivers/staging/wusbcore/host/hwa-hc.c +++ b/drivers/stag

Re: WARNING in hwahc_probe

2020-03-22 Thread Greg KH
On Sun, Mar 22, 2020 at 03:53:44PM +0800, Qiujun Huang wrote: > The return value of snprintf is longer than expected if the string is > truncated. Bytes need to be checked here. > > diff --git a/drivers/staging/wusbcore/host/hwa-hc.c > b/drivers/staging/wusbcore/host/hwa-hc.c > index 8d959e9..1475

Re: WARNING in hwahc_probe

2020-03-22 Thread Qiujun Huang
On Sun, Mar 22, 2020 at 3:58 PM Greg KH wrote: > > On Sun, Mar 22, 2020 at 03:53:44PM +0800, Qiujun Huang wrote: > > The return value of snprintf is longer than expected if the string is > > truncated. Bytes need to be checked here. > > > > diff --git a/drivers/staging/wusbcore/host/hwa-hc.c > > b

[PATCH] staging: vt6656: remove unneeded variable: ret

2020-03-22 Thread John B. Wyatt IV
Remove unneeded variable ret; replace with 0 for the return value. Update function documentation (comment) on the return status as suggested by Julia Lawall . Issue reported by coccinelle (coccicheck). Signed-off-by: John B. Wyatt IV --- drivers/staging/vt6656/card.c | 6 ++ 1 file changed

[PATCH] staging: vt6656: Use DIV_ROUND_UP macro instead of specific code

2020-03-22 Thread Oscar Carter
Use DIV_ROUND_UP macro instead of specific code with the same purpose. Also, remove the unused variables. Signed-off-by: Oscar Carter --- drivers/staging/vt6656/baseband.c | 21 - 1 file changed, 4 insertions(+), 17 deletions(-) diff --git a/drivers/staging/vt6656/baseband.c

Re: [PATCH] staging: vt6656: remove unneeded variable: ret

2020-03-22 Thread Greg Kroah-Hartman
On Sun, Mar 22, 2020 at 02:23:03AM -0700, John B. Wyatt IV wrote: > Remove unneeded variable ret; replace with 0 for the return value. > > Update function documentation (comment) on the return status as > suggested by Julia Lawall . > > Issue reported by coccinelle (coccicheck). > > Signed-off-b

Re: [Outreachy kernel] [PATCH 01/11] Staging: rtl8188eu: hal_com: Add space around operators

2020-03-22 Thread Greg KH
On Sun, Mar 22, 2020 at 03:51:13AM +0530, Shreeya Patel wrote: > Add space around operators for improving the code > readability. > Reported by checkpatch.pl > > git diff -w shows no difference. > diff of the .o files before and after the changes shows no difference. There is no need to have thes

Re: [Outreachy kernel] [PATCH 01/11] Staging: rtl8188eu: hal_com: Add space around operators

2020-03-22 Thread Joe Perches
On Sun, 2020-03-22 at 12:27 +0100, Greg KH wrote: > On Sun, Mar 22, 2020 at 03:51:13AM +0530, Shreeya Patel wrote: > > Add space around operators for improving the code > > readability. > > Reported by checkpatch.pl > > > > git diff -w shows no difference. > > diff of the .o files before and after

[PATCH] staging: greybus: tools: Fix braces {} style

2020-03-22 Thread Simran Singhal
This patch fixes the check reported by checkpatch.pl for braces {} should be used on all arms of this statement. Signed-off-by: Simran Singhal --- drivers/staging/greybus/tools/loopback_test.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/greybus/tools/loo

Re: [greybus-dev] [PATCH] staging: greybus: tools: Fix braces {} style

2020-03-22 Thread Alex Elder
On 3/22/20 12:30 PM, Simran Singhal wrote: > This patch fixes the check reported by checkpatch.pl > for braces {} should be used on all arms of this statement. > > Signed-off-by: Simran Singhal Looks fine to me. And I saw no other instances of this in the Greybus code. Thanks for the patch. R

[PATCH] staging: rtl8723bs: Remove comparisons to NULL in conditionals

2020-03-22 Thread Simran Singhal
Remove comparisons to NULL in conditionals in drivers/staging/rtl8723bs/core/rtw_ap.c Issues reported by checkpatch.pl as: CHECK: Comparison to NULL could be written Signed-off-by: Simran Singhal --- drivers/staging/rtl8723bs/core/rtw_ap.c | 30 - 1 file changed, 15 inser

Re: [Outreachy kernel] [PATCH] staging: rtl8723bs: Remove comparisons to NULL in conditionals

2020-03-22 Thread Julia Lawall
On Mon, 23 Mar 2020, Simran Singhal wrote: > Remove comparisons to NULL in conditionals in > drivers/staging/rtl8723bs/core/rtw_ap.c > Issues reported by checkpatch.pl as: > CHECK: Comparison to NULL could be written The patch also drops some parentheses that are completely unrelated to the ch

Re: [Outreachy kernel] [PATCH 01/11] Staging: rtl8188eu: hal_com: Add space around operators

2020-03-22 Thread Shreeya Patel
On Sun, 2020-03-22 at 08:09 -0700, Joe Perches wrote: > On Sun, 2020-03-22 at 12:27 +0100, Greg KH wrote: Hi Greg and Joe, > > On Sun, Mar 22, 2020 at 03:51:13AM +0530, Shreeya Patel wrote: > > > Add space around operators for improving the code > > > readability. > > > Reported by checkpatch.pl

Re: [PATCH v2 08/10] arm64: dts: renesas: salvator: add a connection from adv748x codec (HDMI input) to the R-Car SoC

2020-03-22 Thread Kuninori Morimoto
Hi Alex Thank you for your pa > As all known variants of the Salvator board have the HDMI decoder > chip (the ADV7482) connected to the SSI4 on R-Car SoC, the ADV7482 > endpoint and the connection definitions are placed in the common board > file. > For the same reason, the CLK_C clock line and

Re: [Outreachy kernel] [PATCH] staging: kpc2000: Removing multiple blank lines

2020-03-22 Thread Stefano Brivio
On Sat, 21 Mar 2020 19:34:31 +0530 Simran Singhal wrote: > This patch fixes the checkpatch warning by removing multiple blank > lines. Actually, you're removing just one. Can you please re-post fixing the description? Mind that it's going to be a "v2", that is, the second version of this patch.

Re: [Outreachy kernel] [PATCH 01/11] Staging: rtl8188eu: hal_com: Add space around operators

2020-03-22 Thread Stefano Brivio
Hi Shreeya, On Mon, 23 Mar 2020 04:48:08 +0530 Shreeya Patel wrote: > On Sun, 2020-03-22 at 08:09 -0700, Joe Perches wrote: > > On Sun, 2020-03-22 at 12:27 +0100, Greg KH wrote: > > Hi Greg and Joe, > > > > On Sun, Mar 22, 2020 at 03:51:13AM +0530, Shreeya Patel wrote: > > > > Add space ar

BUSINESS PROPOSAL !!!

2020-03-22 Thread Abdul Kareem
Dearest Friend I am Mr Abdul Kareem working with Emirate NBD Bank Dubai,United Arab Emirate as Finance Manager. I have a very profitable Business that relate to you and will benefit both of us after completion. Kindly get back to me for more details. Awaiting your response. Regards Abdul Kareem

Re: [PATCH v5 16/17] dt: bindings: net: add microchip,wilc1000.yaml

2020-03-22 Thread Ajay.Kathat
Hi Rob, On 20/03/20 11:29 pm, Rob Herring wrote: > > On Wed, Mar 11, 2020 at 12:18:50PM +, ajay.kat...@microchip.com wrote: >> From: Ajay Singh >> >> This file describes the binding details to connect wilc1000 device. It's >> moved from staging to 'Documentation/devicetree/bindings/net/wirel