Re: [PATCH] taging: android: ashmem: Declared const key

2020-04-11 Thread kbuild test robot
Hi MugilRaj, Thank you for the patch! Yet something to improve: [auto build test ERROR on staging/staging-testing] [also build test ERROR on v5.6 next-20200411] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system. BTW, we also suggest to use '--base

Re: [PATCH] taging: android: ashmem: Declared const key

2020-04-11 Thread Joe Perches
On Sun, 2020-04-12 at 00:59 +0530, MugilRaj wrote: > From: mugil2301 <110117...@nitt.edu> You need to verify the patch subject. You need a change log message too. > Signed-off-by: mugil2301 <110117...@nitt.edu> You need to put your legal name here > diff --git

[PATCH] taging: android: ashmem: Declared const key

2020-04-11 Thread MugilRaj
From: mugil2301 <110117...@nitt.edu> Signed-off-by: mugil2301 <110117...@nitt.edu> --- drivers/staging/android/ashmem.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/android/ashmem.c b/drivers/staging/android/ashmem.c index 8044510..50f882a 100644 ---

[PATCH] staging: vt6656: formulate rspinf values into tables

2020-04-11 Thread Malcolm Priestley
Four tables can be extracted from RSPINF_A_* based on BB_TYPE_11A or else being GB rates. Preamble short or long tables from fixed size len of 14 for RSPINF_B rates. Remove function vnt_calculate_ofdm_rate and replace with the tables calling RSPINF_A and RSPINF_B separately. Signed-off-by:

[PATCH] media: staging: ipu3: Fix stale list entries on parameter queue failure

2020-04-11 Thread Tomasz Figa
When queuing parameters fails, current code bails out without deleting the corresponding vb2 buffer from the driver buffer list, but the buffer is returned to vb2. This leads to stale list entries and a crash when the driver stops streaming: [ 224.935561] ipu3-imgu :00:05.0: set parameters

[staging:staging-testing] BUILD SUCCESS 134c0700a05174f2520d51ba4dd95698ffa779de

2020-04-11 Thread kbuild test robot
randconfig-a001-20200410 c6x randconfig-a001-20200412 h8300randconfig-a001-20200412 microblaze randconfig-a001-20200412 nios2randconfig-a001-20200412 sparc64 randconfig-a001-20200412 s390 randconfig-a001-20200411 xtensa

Re: [PATCH] binderfs: Fix binderfs.c selftest compilation warning

2020-04-11 Thread Christian Brauner
On Sat, Apr 11, 2020 at 10:51:51PM +0800, Tang Bin wrote: > Fix missing braces compilation warning in the ARM > compiler environment: > drivers/android/binderfs.c: In function 'binderfs_fill_super': > drivers/android/binderfs.c:650:9: warning: missing braces around > initializer

[PATCH] binderfs: Fix binderfs.c selftest compilation warning

2020-04-11 Thread Tang Bin
Fix missing braces compilation warning in the ARM compiler environment: drivers/android/binderfs.c: In function 'binderfs_fill_super': drivers/android/binderfs.c:650:9: warning: missing braces around initializer [-Wmissing-braces] struct binderfs_device device_info = { 0 };

[PATCH 0/2] staging: vt6656: Refactor the vnt_vt3184_init function

2020-04-11 Thread Oscar Carter
This patch series makes a refactor of the vnt_vt3184_init function through two patches. The first one removes duplicate code in the if statements because different branches are almost the same. The second patch remove unnecessary local variable initialization. Oscar Carter (2): staging:

[PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization

2020-04-11 Thread Oscar Carter
Don't initialize the ret variable as it is set a few lines later. Signed-off-by: Oscar Carter --- drivers/staging/vt6656/baseband.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/vt6656/baseband.c b/drivers/staging/vt6656/baseband.c index

[PATCH 1/2] staging: vt6656: Remove duplicate code in vnt_vt3184_init function

2020-04-11 Thread Oscar Carter
Remove duplicate code in "if" statements because different branches are almost the same. Signed-off-by: Oscar Carter --- drivers/staging/vt6656/baseband.c | 52 +++ 1 file changed, 12 insertions(+), 40 deletions(-) diff --git a/drivers/staging/vt6656/baseband.c

[PATCH v2 2/2] staging: vt6656: Remove duplicate code for the phy->service assignment

2020-04-11 Thread Oscar Carter
Take out the "phy->service" assignment from the if-else statement due to it's the same for the two branches. Signed-off-by: Oscar Carter --- drivers/staging/vt6656/baseband.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/vt6656/baseband.c

[PATCH v2 1/2] staging: vt6656: Refactor the assignment of the phy->signal variable

2020-04-11 Thread Oscar Carter
Create a constant array with the values of the "phy->signal" for every rate. Remove all "phy->signal" assignments inside the switch statement and replace these with a single reading from the new vnt_phy_signal array. The constant array can be of one dimension because the OR mask with BIT(3) or

[PATCH v2 0/2] staging: vt6656: Refactor the vnt_get_phy_field function

2020-04-11 Thread Oscar Carter
This patch series makes a refactor of the vnt_get_phy_field function through two patches. The first one refactors the assignment of the "phy->signal" variable using a constant array with the correct values for every rate. The second patch removes duplicate code for the assignment of the