[PATCH v2] staging: rtl8188eu: remove unnecessary comments in hal8188e_phy_cfg.h

2020-06-28 Thread Michael Straube
Remove unnecessary comments in hal8188e_phy_cfg.h to improve readability and clear multiple blank lines checkpatch issues. CHECK: Please don't use multiple blank lines Signed-off-by: Michael Straube --- v1 -> v2 Remove one more line as suggested by Dan Carpenter. .../rtl8188eu/include/hal8188e

[PATCH v3] staging: wfx: Get descriptors for GPIOs

2020-06-28 Thread Linus Walleij
The code has the functionality to insert the GPIO lines using the global GPIO numbers through module parameters. As we are clearly deprecating the use of global GPIO numbers look up the GPIO descriptors from the device instead. This usually falls back to device hardware descriptions using e.g. dev

Re: [PATCH v3] staging: wfx: Get descriptors for GPIOs

2020-06-28 Thread Greg KH
On Sun, Jun 28, 2020 at 10:52:36AM +0200, Linus Walleij wrote: > The code has the functionality to insert the GPIO lines using > the global GPIO numbers through module parameters. > > As we are clearly deprecating the use of global GPIO numbers > look up the GPIO descriptors from the device instea

Re: [PATCH v3] staging: wfx: Get descriptors for GPIOs

2020-06-28 Thread Greg KH
On Sun, Jun 28, 2020 at 12:43:02PM +0200, Greg KH wrote: > On Sun, Jun 28, 2020 at 10:52:36AM +0200, Linus Walleij wrote: > > The code has the functionality to insert the GPIO lines using > > the global GPIO numbers through module parameters. > > > > As we are clearly deprecating the use of global

[PATCH] staging/wilc1000: let wilc_mac_xmit() to NETDEV_TX_OK

2020-06-28 Thread Luc Van Oostenryck
The method ndo_start_xmit() is defined as returning an 'netdev_tx_t', which is a typedef for an enum type defining 'NETDEV_TX_OK' but this driver returns '0' instead of 'NETDEV_TX_OK'. Fix this by returning ''NETDEV_TX_OK' instead of 0. Signed-off-by: Luc Van Oostenryck --- drivers/staging/wilc

[PATCH] staging: ks7010: fix ks_wlan_start_xmit()'s return type

2020-06-28 Thread Luc Van Oostenryck
The method ndo_start_xmit() is defined as returning an 'netdev_tx_t', which is a typedef for an enum type, but the implementation in this driver returns an 'int'. Fix this by returning 'netdev_tx_t' in this driver too and usind 'NETDEV_TX_OK' instead of 0 accordingly. Signed-off-by: Luc Van Ooste

Re: [PATCH] fbtft-bus.c: Removing that prohibited space before ')'

2020-06-28 Thread kernel test robot
Hi K, Thank you for the patch! Perhaps something to improve: [auto build test WARNING on staging/staging-testing] [also build test WARNING on v5.8-rc2 next-20200626] [If your patch is applied to the wrong git tree, kindly drop us a note. And when submitting patch, we suggest to use as documented

Re: [PATCH 1/4] usb: cdns3: gadget: Replace trace_printk by dev_dbg

2020-06-28 Thread Peter Chen
On 20-06-27 15:03:04, Nicolas Boichat wrote: > trace_printk should not be used in production code, replace it > call with dev_dbg. > > Signed-off-by: Nicolas Boichat > > --- > > Unclear why a trace_printk was used in the first place, it's > possible that some rate-limiting is necessary here. >

Re: [PATCH v2 4/4] staging: qlge: replace pr_err with netdev_err

2020-06-28 Thread Benjamin Poirier
On 2020-06-27 22:58 +0800, Coiby Xu wrote: [...] > void ql_dump_qdev(struct ql_adapter *qdev) > { > @@ -1611,99 +1618,100 @@ void ql_dump_qdev(struct ql_adapter *qdev) > #ifdef QL_CB_DUMP > void ql_dump_wqicb(struct wqicb *wqicb) > { > - pr_err("Dumping wqicb stuff...\n"); > - pr_err("

[PATCH] staging: rtl8188eu: include: hal8188e_rate_adaptive.h: fixed a blank space coding style issue

2020-06-28 Thread B K Karthik
added blank space around arithmetic operators to improve readability Signed-off-by: B K Karthik --- .../rtl8188eu/include/hal8188e_rate_adaptive.h | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/rtl8188eu/include/hal8188e_rate_adaptive.h b/