[PATCH 2/2] staging: rtl8188eu: include: rtw_pwrctrl.h: fixed a blank space coding style issue.

2020-07-01 Thread B K Karthik
add blank spaces to improve code readability. Signed-off-by: B K Karthik --- drivers/staging/rtl8188eu/include/rtw_pwrctrl.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h b/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h

[PATCH 1/2] staging: rtl8188eu: include: rtw_pwrctrl.h: fixed multiple parentheses coding style issues.

2020-07-01 Thread B K Karthik
add parentheses since complex valued macros must be enclosed within parentheses. Signed-off-by: B K Karthik --- drivers/staging/rtl8188eu/include/rtw_pwrctrl.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h

[PATCH] staging: rtl8188eu: include: rtl8188e_xmit.h: fixed multiple blank space coding style issues

2020-07-01 Thread B K Karthik
added blank spaces to improve code readability. (coding style issue) Signed-off-by: B K Karthik --- drivers/staging/rtl8188eu/include/rtl8188e_xmit.h | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/rtl8188eu/include/rtl8188e_xmit.h

[PATCH] staging: rtl8188eu: include: rtw_recv.h: fixed a blank space coding style issue.

2020-07-01 Thread B K Karthik
added blank spaces to improve code readability. Signed-off-by: B K Karthik --- drivers/staging/rtl8188eu/include/rtw_recv.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/include/rtw_recv.h b/drivers/staging/rtl8188eu/include/rtw_recv.h index

Re: [PATCH] staging: rtl8188eu: include: rtl8188e_xmit.h: fixed multiple blank space coding style issues

2020-07-01 Thread Kees Cook
On Thu, Jul 02, 2020 at 12:48:42AM -0400, B K Karthik wrote: > added blank spaces to improve code readability. > > Signed-off-by: B K Karthik > --- > drivers/staging/rtl8188eu/include/rtl8188e_xmit.h | 12 ++-- > 1 file changed, 6 insertions(+), 6 deletions(-) > > diff --git

[PATCH 2/2] staging: rtl8188eu: include: rtw_pwrctrl.h: fixed a blank space coding style issue.

2020-07-01 Thread B K Karthik
add blank spaces to improve code readability. Signed-off-by: B K Karthik --- drivers/staging/rtl8188eu/include/rtw_pwrctrl.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h b/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h

[PATCH 1/2] staging: rtl8188eu: include: rtw_pwrctrl.h: fixed multiple parentheses coding style issues.

2020-07-01 Thread B K Karthik
add parentheses since complex valued macros must be enclosed within parentheses. Signed-off-by: B K Karthik --- drivers/staging/rtl8188eu/include/rtw_pwrctrl.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h

[PATCH] staging: rtl8188eu: include: rtw_cmd.h: fixed a blank space coding style issue.

2020-07-01 Thread B K Karthik
add blank spaces for improved code readability. Signed-off-by: B K Karthik --- drivers/staging/rtl8188eu/include/rtw_cmd.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/include/rtw_cmd.h b/drivers/staging/rtl8188eu/include/rtw_cmd.h index

[PATCH] staging: rtl8188eu: include: rtl8188e_xmit.h: fixed multiple blank space coding style issues

2020-07-01 Thread B K Karthik
added blank spaces to improve code readability. Signed-off-by: B K Karthik --- drivers/staging/rtl8188eu/include/rtl8188e_xmit.h | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/rtl8188eu/include/rtl8188e_xmit.h

[staging:staging-testing] BUILD SUCCESS efa30b82ac7553c25405ac56034aecf03c182033

2020-07-01 Thread kernel test robot
rhel-kconfig powerpc allmodconfig powerpc allnoconfig i386 randconfig-a002-20200701 i386 randconfig-a001-20200701 i386 randconfig-a006-20200701 i386 randconfig-a005-20200701 i386

[PATCH AUTOSEL 5.7 12/53] staging: wfx: fix coherency of hif_scan() prototype

2020-07-01 Thread Sasha Levin
From: Jérôme Pouiller [ Upstream commit 29de523a6270a308d12d21f4fecf52dac491e226 ] The function hif_scan() return the timeout for the completion of the scan request. It is the only function from hif_tx.c that return another thing than just an error code. This behavior is not coherent with the

[PATCH v6 00/12] PCI: brcmstb: enable PCIe for STB chips

2020-07-01 Thread Jim Quinlan
Patchset Summary: Enhance a PCIe host controller driver. Because of its unusual design we are foced to change dev->dma_pfn_offset into a more general role allowing multiple offsets. See the 'v1' notes below for more info. v6: Commit "device core: Introduce DMA range map": --

[PATCH v6 08/12] device core: Introduce DMA range map, supplanting dma_pfn_offset

2020-07-01 Thread Jim Quinlan
The new field 'dma_range_map' in struct device is used to facilitate the use of single or multiple offsets between mapping regions of cpu addrs and dma addrs. It subsumes the role of "dev->dma_pfn_offset" which was only capable of holding a single uniform offset and had no region bounds checking.

[PATCH 0/2] staging: rtl8712: Minor cleanups

2020-07-01 Thread Mauro Dreissig
This series applies minor cleanups for rtl8712 staging driver. Mauro Dreissig (2): staging: rtl8712: Replace FIELD_OFFSET() with offsetof() staging: rtl8712: base_types: Remove unused macros drivers/staging/rtl8712/basic_types.h | 8 drivers/staging/rtl8712/hal_init.c

[PATCH 1/2] staging: rtl8712: Replace FIELD_OFFSET() with offsetof()

2020-07-01 Thread Mauro Dreissig
Use the existing offsetof() macro instead of duplicating code. Signed-off-by: Mauro Dreissig --- drivers/staging/rtl8712/basic_types.h | 1 - drivers/staging/rtl8712/hal_init.c| 4 ++-- drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 4 ++-- 3 files changed, 4 insertions(+),

[PATCH 2/2] staging: rtl8712: base_types: Remove unused macros

2020-07-01 Thread Mauro Dreissig
Those #define's are not used anywhere, get rid of them. Signed-off-by: Mauro Dreissig --- drivers/staging/rtl8712/basic_types.h | 7 --- 1 file changed, 7 deletions(-) diff --git a/drivers/staging/rtl8712/basic_types.h b/drivers/staging/rtl8712/basic_types.h index

[driver-core:debugfs_cleanup] BUILD SUCCESS 80e37912bf208f2c9ceeedb16213f0ff0a743f0a

2020-07-01 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git debugfs_cleanup branch HEAD: 80e37912bf208f2c9ceeedb16213f0ff0a743f0a debugfs: remove return value of debugfs_create_devm_seqfile() elapsed time: 3430m configs tested: 128 configs skipped: 13 The following

[PATCH] staging: rtl8188eu: use common ieee80211 constants

2020-07-01 Thread Michael Straube
Many defined constants in wifi.h are unused and/or available from , some with slightly different names. Use the common ones, rename where necessary and remove unused. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_ap.c | 12 ++---

[PATCH] staging: rtl8188eu: remove unused parameter

2020-07-01 Thread Michael Straube
Remove unused parameter 'padapter' from rtw_os_xmit_resource_alloc(). Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_xmit.c | 6 +++--- drivers/staging/rtl8188eu/include/xmit_osdep.h | 3 +-- drivers/staging/rtl8188eu/os_dep/xmit_linux.c | 3 +-- 3 files changed, 5

[PATCH] Staging: atomisp: Fix __func__ style warnings

2020-07-01 Thread Baidyanath Kundu
This patch fixes the checkpatch.pl warning: Prefer using '"%s...", __func__' to using '', this function's name, in a string Signed-off-by: Baidyanath Kundu --- .../atomisp/pci/base/refcount/src/refcount.c | 28 +-- 1 file changed, 14 insertions(+), 14 deletions(-) diff --git

[PATCH] staging: rtl8712: use common ieee80211 constants

2020-07-01 Thread Michael Straube
Many defined constants in wifi.h are unused and/or available from , some with slightly different names. Use the common ones, rename where necessary and remove unused. Signed-off-by: Michael Straube --- drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 2 +- drivers/staging/rtl8712/rtl871x_mlme.c

[RESEND PATCH v5] drivers: most: add USB adapter driver

2020-07-01 Thread Christian Gromm
This patch adds the usb driver source file most_usb.c and modifies the Makefile and Kconfig accordingly. Signed-off-by: Christian Gromm --- v2: Reported-by: Greg Kroah-Hartman - don't remove usb driver from staging area - don't touch staging/most/Kconfig - remove

[PATCH v1] Staging: rtl8188eu: core: Fix coding style issue

2020-07-01 Thread Puranjay Mohan
Use %s and __func__ in place of function names. This solves following checkpatch.pl warning WARNING: Prefer using '"%s...", __func__' to using 'rtw_do_join', this function's name, in a string Signed-off-by: Puranjay Mohan --- V1: Add staging in the subject. ---

[PATCH 13/13] staging: wfx: always enable FastPs in combo with new firmwares

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller When multiple interface on different channels are in use. It is necessary to advertise the AP that the device is no more awake before to switch to the other channel. Until now, PS-Poll was the preferred mechanism for that. However. The new firmwares (>= 3.7) now nicely

[PATCH 03/13] staging: wfx: correctly retrieve vif ID from Tx confirmation

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller The device is able to send multiple Tx confirmations in the one reply. In this case, there is only one vif identifier for all the confirmations. Unfortunately, to generate this kind of messages the device squashes all the confirmations whatever their vif ID and use the vif

[PATCH 07/13] staging: wfx: fix unexpected calls to ieee80211_sta_set_buffered()

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller When a station go to sleep, the driver receive the status REQUEUE and forward this answer to mac80211. So, neither the driver, neither the hardware buffer the frames. So the call to ieee80211_sta_set_buffered is useless. In add, it seems that mac80211 does not expect to

[PATCH 10/13] staging: wfx: simplify handling of encrypted frames

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller We don't want mac80211 try to check MMIC and other security mechanisms. So, the driver remove all the data related to the encryption (IV, ICV, MMIC). However, enabling RX_FLAG_PN_VALIDATED is sufficient for that. So, drop the useless function wfx_drop_encrypt_data() and

[PATCH 00/13] staging: wfx: multiple fixes

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller Hello, This series fixes a few issues/improvements discovered during the last months. Jérôme Pouiller (13): staging: wfx: associate tx_queues to vifs staging: wfx: check the vif ID of the Tx confirmations staging: wfx: correctly retrieve vif ID from Tx confirmation

[PATCH 06/13] staging: wfx: improve protection against malformed HIF messages

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller As discussed here[1], if a message was smaller than the size of the message header, it could be incorrectly processed. [1] https://lore.kernel.org/driverdev-devel/2302785.6C7ODC2LYm@pc-42/ Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/bh.c | 36

[PATCH 04/13] staging: wfx: add tracepoint "queues_stats"

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller It is useful to check which queue the driver choose to send to the hardware. Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/queue.c | 3 +++ drivers/staging/wfx/traces.h | 51 2 files changed, 54 insertions(+) diff --git

[PATCH 08/13] staging: wfx: drop counter of buffered frames

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller Since the driver does not call ieee80211_sta_set_buffered() anymore, it is no more necessary to maintain a counter of buffered frames for each stations. This change allows to simplify the processing in multiple places in the driver. Signed-off-by: Jérôme Pouiller ---

[PATCH 11/13] staging: wfx: fix CCMP/TKIP replay protection

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller To enable the TKIP/CCMP replay protection, the frames has to be processed in the right order. However, the device is not able to re-order the frames during BlockAck sessions. Mac80211 is able to reorder the frames, but it need the information about the BlockAck sessions

[PATCH 01/13] staging: wfx: associate tx_queues to vifs

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller The device handles 4 queues (one per AC) for each virtual interface (and maximum 4 virtual interfaces). Until now the driver unified the queue of all interfaces and handled only 4 queues for whole device. This architecture did not allow to balance the traffic between the

[PATCH 05/13] staging: wfx: load the firmware faster

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller During the loading of the firmware, the WFX_DCA_GET register provide the number available bytes in the receiving buffer. It is not necessary to access to the WFX_DCA_GET after sent of each firmware fragment. This patch allows to send the firmware: - in 64ms instead of 

[PATCH 12/13] staging: wfx: add a debugfs entry to force ps_timeout

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller In some advanced usage or debug scenarios, it could interesting to change the value of ps_timeout or eventually to force use of PS-Poll frames. The wext API (used by iwconfig) provide a way to change ps_timeout. However, this API is obsolete and it seems a little weird to

[PATCH 09/13] staging: wfx: fix handling of frames without RSSI data

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller It seems that in the old days, the RSSI information could be missing. In this case, in order to not pollute the RSSI stats, the frame was dropped (!). It is far better to mark the frame with the flag RX_FLAG_NO_SIGNAL_VAL. In add, the problem seems now fixed in the

[PATCH 02/13] staging: wfx: check the vif ID of the Tx confirmations

2020-07-01 Thread Jerome Pouiller
From: Jérôme Pouiller When the driver has sent a frame on a virtual interface (vif), it expects to receive the confirmation on the same vif. This patch add a check for that. Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/queue.c | 6 +- 1 file changed, 5 insertions(+), 1

[PATCH] Drivers: rtl8188eu: core: Fix coding style issue

2020-07-01 Thread Puranjay Mohan
Use %s and __func__ in place of function names. This solves following checkpatch.pl warning WARNING: Prefer using '"%s...", __func__' to using 'rtw_do_join', this function's name, in a string Signed-off-by: Puranjay Mohan --- drivers/staging/rtl8188eu/core/rtw_ioctl_set.c | 2 +- 1 file

Re: [PATCH v3 6/6] staging: greybus: audio: Enable GB codec, audio module compilation.

2020-07-01 Thread Greg Kroah-Hartman
On Fri, Jun 19, 2020 at 04:50:26PM +0530, Vaibhav Agarwal wrote: > Currently you can't enable the Gey Bus Audio Codec because there is no > entry for it in the Kconfig file. Originally the config name was going > to be AUDIO_MSM8994 but that's not correct because other types of > hardware are

Re: [PATCH v2 0/9] move Rockchip ISP bindings out of staging / add ISP DT nodes for RK3399

2020-07-01 Thread Heiko Stuebner
On Fri, 3 Apr 2020 13:15:29 -0300, Helen Koike wrote: > Move the bindings out of drivers/staging and place them in > Documentation/devicetree/bindings instead. > > Also, add DT nodes for RK3399 and verify with make ARCH=arm64 dtbs_check > and make ARCH=arm64 dt_binding_check. > > Tested by

Re: [PATCH v7 00/17] wilc1000: move out of staging

2020-07-01 Thread Pali Rohár
(adding Ulf) On Wednesday 01 July 2020 09:55:15 Pali Rohár wrote: > On Tuesday 30 June 2020 03:17:01 ajay.kat...@microchip.com wrote: > > On 29/06/20 6:56 pm, Pali Rohár wrote: > > > EXTERNAL EMAIL: Do not click links or open attachments unless you know > > > the content is safe > > > > > > On

Re: [PATCH v7 00/17] wilc1000: move out of staging

2020-07-01 Thread Pali Rohár
On Tuesday 30 June 2020 03:17:01 ajay.kat...@microchip.com wrote: > On 29/06/20 6:56 pm, Pali Rohár wrote: > > EXTERNAL EMAIL: Do not click links or open attachments unless you know the > > content is safe > > > > On Tuesday 23 June 2020 11:00:04 ajay.kat...@microchip.com wrote: > >> This patch

Re: [PATCH v4] staging: wfx: Get descriptors for GPIOs

2020-07-01 Thread Jérôme Pouiller
Hello Linus, On Tuesday 30 June 2020 10:21:33 CEST Linus Walleij wrote: > > The code has the functionality to insert the GPIO lines using > the global GPIO numbers through module parameters. > > As we are clearly deprecating the use of global GPIO numbers > look up the GPIO descriptors from the

Re: [PATCH] media: allegro: Fix some NULL vs IS_ERR() checks in probe

2020-07-01 Thread Michael Tretter
On Fri, 19 Jun 2020 17:30:07 +0300, Dan Carpenter wrote: > The devm_ioremap() function doesn't return error pointers, it returns > NULL on error. > > Fixes: f20387dfd065 ("media: allegro: add Allegro DVT video IP core driver") > Signed-off-by: Dan Carpenter Reviewed-by: Michael Tretter > ---

[PATCH v3 4/4] staging: kpc2000: kpc_dma: Remove additional goto statements

2020-07-01 Thread Souptick Joarder
As 3 goto level referring to same common code, those can be accomodated with a single goto level and renameing it to unpin_pages. Set the -ERRNO when returning partial mapped pages in more appropriate place. When dma_map_sg() failed, the previously allocated memory was not freed properly. This is

[PATCH v3 3/4] staging: kpc2000: kpc_dma: Convert get_user_pages() --> pin_user_pages()

2020-07-01 Thread Souptick Joarder
In 2019, we introduced pin_user_pages*() and now we are converting get_user_pages*() to the new API as appropriate. [1] & [2] could be referred for more information. This is case 2 as per document [1]. [1] Documentation/core-api/pin_user_pages.rst [2] "Explicit pinning of user-space pages":

[PATCH v3 2/4] staging: kpc2000: kpc_dma: Convert set_page_dirty() --> set_page_dirty_lock()

2020-07-01 Thread Souptick Joarder
First, convert set_page_dirty() to set_page_dirty_lock() Second, there is an interval in there after set_page_dirty() and before put_page(), in which the device could be running and setting pages dirty. Moving set_page_dirty_lock() after dma_unmap_sg(). Signed-off-by: Souptick Joarder

[PATCH v3 1/4] staging: kpc2000: kpc_dma: Unpin partial pinned pages

2020-07-01 Thread Souptick Joarder
There is a bug, when get_user_pages() failed but partially pinned pages are not unpinned and positive numbers are returned instead of -ERRNO. Fixed it. Also, int is more appropriate type for rv. Changed it. Signed-off-by: Souptick Joarder Cc: John Hubbard Cc: Dan Carpenter Cc: Bharath

[PATCH v3 0/4] staging: kpc2000: kpc_dma: Few clean up and Convert to pin_user_pages()

2020-07-01 Thread Souptick Joarder
This series contains few clean up, minor bug fixes and Convert get_user_pages() to pin_user_pages(). I'm compile tested this, but unable to run-time test, so any testing help is much appriciated. v2: Address Dan's review comments to return -ERRNO for partially mapped pages and