[PATCH v3] staging: most: hdm_usb: Register the driver with module_usb_driver macro

2017-10-06 Thread Alex Briskin
1. Register the driver with module_usb_driver macro instead of module_init and module_exit. 2. Remove redundant code. Signed-off-by: Alex Briskin <br.shu...@gmail.com> --- drivers/staging/most/hdm-usb/hdm_usb.c | 20 +--- 1 file changed, 1 insertion(+), 19 deletions(-)

[PATCH v3] staging: most: hdm_usb: Register the driver with module_usb_driver macro

2017-08-29 Thread Alex Briskin
1. Register the driver with module_usb_driver macro instead of module_init and module_exit. 2. Remove redundant code. Signed-off-by: Alex Briskin <br.shu...@gmail.com> --- drivers/staging/most/hdm-usb/hdm_usb.c | 20 +--- 1 file changed, 1 insertion(+), 19 deletions(-)

[PATCH v2] staging: most: hdm_usb: Driver registration with module_usb_driver

2017-08-28 Thread Alex Briskin
Register with module_usb_driver macro instead of module_init/module_exit. Signed-off-by: Alex Briskin <br.shu...@gmail.com> --- drivers/staging/most/hdm-usb/hdm_usb.c | 20 +--- 1 file changed, 1 insertion(+), 19 deletions(-) diff --git a/drivers/staging/most/hdm-usb/hdm

[PATCH v1] staging: most: hdm_usb: Driver registration with module_driver macro

2017-08-26 Thread Alex Briskin
Register with module_driver macro instead of module_init/module_exit. Signed-off-by: Alex Briskin <br.shu...@gmail.com> --- drivers/staging/most/hdm-usb/hdm_usb.c | 20 +--- 1 file changed, 1 insertion(+), 19 deletions(-) diff --git a/drivers/staging/most/hdm-usb/hdm_us

Re: [PATCH v2] staging: most: hdm_usb: Driver registration with module_driver macro

2017-08-25 Thread Alex Briskin
OK got it On 08/25/2017 07:19 PM, Andrey Shvetsov wrote: On Fri, Aug 25, 2017 at 06:40:18PM +0300, Alex Briskin wrote: 1. Remove redundant functions. 2. Remove potentially missleading return code (-EIO). 3. Add module_driver driver registration macro. s/module_driver/module_usb_driver/ /andy

[PATCH v1] staging: unisys: visorinput: Add module_driver driver registration

2017-08-25 Thread Alex Briskin
1. Remove module_init()/module_exit() macroes and visorbus_register_visor_driver/visorbus_unregister_visor_driver functions. 2. Replace with a short module_driver macro Signed-off-by: Alex Briskin <br.shu...@gmail.com> --- drivers/staging/unisys/visorinput/visorinput.c | 14 ++-

[PATCH v2] staging: most: hdm_usb: Driver registration with module_driver macro

2017-08-25 Thread Alex Briskin
1. Remove redundant functions. 2. Remove potentially missleading return code (-EIO). 3. Add module_driver driver registration macro. * Will also remove pr_info messages. Signed-off-by: Alex Briskin <br.shu...@gmail.com> --- drivers/staging/most/hdm-usb/hdm_usb.c | 20 +---

[PATCH] staging: most: hdm_usb: Driver registration with module_driver macro

2017-08-25 Thread Alex Briskin
1. Remove redundant functions. 2. Remove potentially missleading return code (-EIO). 3. Add module_driver driver registration macro. * Will also remove pr_info messages. Signed-off-by: Alex Briskin <br.shu...@gmail.com> --- drivers/staging/most/hdm-usb/hdm_usb.c | 20 +---

Re: [PATCH] staging: most: hdm_usb: Driver registration with module_driver macro

2017-08-25 Thread Alex Briskin
Shvetsov wrote: On Fri, Aug 25, 2017 at 12:47:33PM +0300, Alex Briskin wrote: 1. Remove redundant functions. 2. Remove potentially misleading return code (-EIO). 3. Add module_driver driver registration macro. * Will also remove pr_info messages. Signed-off-by: Alex Briskin <br.shu..

[PATCH] staging: most: hdm_usb: Driver registration with module_driver macro

2017-08-25 Thread Alex Briskin
1. Remove redundant functions. 2. Remove potentially misleading return code (-EIO). 3. Add module_driver driver registration macro. * Will also remove pr_info messages. Signed-off-by: Alex Briskin <br.shu...@gmail.com> --- drivers/staging/most/hdm-usb/hdm_usb.c | 20 +---

[PATCH] staging: most: hdm_usb: Driver registration with module_driver macro

2017-08-25 Thread Alex Briskin
1. Remove redundant functions. 2. Remove potentially missleading return code (-EIO). 3. Add module_driver driver registration macro. * Will also remove pr_info messages. Signed-off-by: Alex Briskin <br.shu...@gmail.com> --- drivers/staging/most/hdm-usb/hdm_usb.c | 20 +---

[PATCH] staging: sm750fb: Fix lock context error

2016-10-23 Thread Alex Briskin
the spin_lock will evoke spin_unlock. Signed-off-by: Alex Briskin <br.shu...@gmail.com> --- drivers/staging/sm750fb/sm750.c | 12 1 file changed, 8 insertions(+), 4 deletions(-) diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c index 0663ec0..4f0f98e

[PATCH] staging:r8188eu: Remove space before comma

2016-10-22 Thread Alex Briskin
Trivial style fix to remove unnecessary errors in checkpatch.pl Signed-off-by: Alex Briskin <br.shu...@gmail.com> --- drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/rtl8188e_hal_ini