Re: [PATCH v2] staging: most: hdm_usb: Driver registration with module_usb_driver

2017-08-29 Thread Andrey Shvetsov
On Tue, Aug 29, 2017 at 11:44:37AM +0300, Alex Briskin wrote: > A change was made to the commit message itself. > In V1, as pointed out by Andy, I left module_driver instead of > module_usb_driver in the commit message. Dont't forget to fix the subject. "Driver registration ..." is not compliant

Re: [PATCH v1] staging: most: hdm_usb: Driver registration with module_driver macro

2017-08-28 Thread Andrey Shvetsov
On Sun, Aug 27, 2017 at 08:22:10AM +0300, Alex Briskin wrote: > Register with module_driver macro instead of module_init/module_exit. It must be the module_usb_driver. Also in the subject. Hint: use the imperative sentence for the subject, like "staging: most: hdm_usb: use module_usb_driver ..."

Re: [PATCH v2] staging: most: hdm_usb: Driver registration with module_driver macro

2017-08-25 Thread Andrey Shvetsov
On Fri, Aug 25, 2017 at 06:40:18PM +0300, Alex Briskin wrote: > 1. Remove redundant functions. > 2. Remove potentially missleading return code (-EIO). > 3. Add module_driver driver registration macro. s/module_driver/module_usb_driver/ /andy > * Will also remove pr_info messages. > >

Re: [PATCH] staging: most: hdm_usb: Driver registration with module_driver macro

2017-08-25 Thread Andrey Shvetsov
__driver##_init(void) \ > { \ > return __register(&(__driver) , ##__VA_ARGS__); \ > } \ > module_init(__driver##_init); \ > static void __exit __driver##_exit(void) \ > { \ > __unregister(&(__driver) , ##__VA_ARGS__); \ > } \ > module_exit(__driver##_

Re: [PATCH] staging: most: hdm_usb: Driver registration with module_driver macro

2017-08-25 Thread Andrey Shvetsov
On Fri, Aug 25, 2017 at 12:47:33PM +0300, Alex Briskin wrote: > 1. Remove redundant functions. > 2. Remove potentially misleading return code (-EIO). > 3. Add module_driver driver registration macro. > * Will also remove pr_info messages. > > Signed-off-by: Alex Briskin >

Re: [PATCH 4/4] staging: most: net: hold used net device

2017-06-21 Thread Andrey Shvetsov
On Tue, Jun 20, 2017 at 10:56:43PM +0300, Dan Carpenter wrote: > On Tue, Jun 20, 2017 at 05:11:51PM +0200, Christian Gromm wrote: > > @@ -411,21 +428,31 @@ static int aim_rx_data(struct mbo *mbo) > > struct sk_buff *skb; > > struct net_device *dev; > > unsigned int skb_len; > > + int

Re: [PATCH -next] staging: most: fix error return code in audio_probe_channel()

2016-09-26 Thread Andrey Shvetsov
y: Wei Yongjun <weiyongj...@huawei.com> Signed-off-by: Andrey Shvetsov <andrey.shvet...@k2l.de> > --- > drivers/staging/most/aim-sound/sound.c | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) > > diff --git a/drivers/staging/most/aim-sound/sound.c > b/drivers/s

Re: [PATCH 01/11] staging: most: hdm-dim2: fix channel configuration

2016-09-20 Thread Andrey Shvetsov
On Fri, Sep 16, 2016 at 02:44:37PM +0300, Dan Carpenter wrote: > On Thu, Sep 15, 2016 at 04:19:03PM +0200, Christian Gromm wrote: > > From: Andrey Shvetsov <andrey.shvet...@k2l.de> > > > > The DIM2 HDM checks the parameters passed to the function > > configur

Re: [PATCH] staging: most: hdm-dim2: Remove possible dereference error

2016-03-19 Thread Andrey Shvetsov
On Fri, Mar 18, 2016 at 06:32:15PM +0530, Amitoj Kaur Chawla wrote: > Commit 3eced21a5afb ("staging: most: hdm-dim2: Replace request_irq > with devm_request_irq") introduced the following static checker > warning: > drivers/staging/most/hdm-dim2/dim2_hdm.c:841 dim2_probe() > error:

Re: staging: most: warning: ‘mbo’ may be used uninitialized in this function

2016-03-18 Thread Andrey Shvetsov
On Fri, Mar 18, 2016 at 01:41:19PM +0100, Geert Uytterhoeven wrote: > On Fri, Mar 18, 2016 at 6:42 AM, Linux Kernel Mailing List > wrote: > > Web: > > https://git.kernel.org/torvalds/c/f45b0fba43f415f69982df743dfa9b5d1b57785e > > Commit:

Re: [PATCH 3/5] staging: most: remove driver owner

2015-09-08 Thread Andrey Shvetsov
On Mon, Sep 07, 2015 at 06:16:21PM +0530, Sudip Mukherjee wrote: > On Mon, Sep 07, 2015 at 02:13:38PM +0200, Andrey Shvetsov wrote: > > On Fri, Sep 04, 2015 at 04:22:04PM +0530, Sudip Mukherjee wrote: > > > The platform driver core will set the owner value, we

Re: [PATCH 3/5] staging: most: remove driver owner

2015-09-07 Thread Andrey Shvetsov
On Fri, Sep 04, 2015 at 04:22:04PM +0530, Sudip Mukherjee wrote: > The platform driver core will set the owner value, we do not need to do > it in the module. > > Signed-off-by: Sudip Mukherjee > --- > drivers/staging/most/hdm-dim2/dim2_hdm.c | 1 - > 1 file changed, 1

Re: [PATCH] staging/most: fix return value for DIM_GetChannelState

2015-08-14 Thread Andrey Shvetsov
On Sun, Aug 09, 2015 at 05:08:41PM +0300, Tomas Melin wrote: Return NULL instead of 0 for invalid input. Signed-off-by: Tomas Melin tomas.me...@iki.fi Signed-off-by: Andrey Shvetsov andrey.shvet...@k2l.de --- drivers/staging/most/hdm-dim2/dim2_hal.c | 2 +- 1 file changed, 1 insertion

Re: [PATCH 07/19] staging: most: Remove unnecessary externs

2015-08-14 Thread Andrey Shvetsov
On Mon, Aug 10, 2015 at 02:51:22PM -0700, Joe Perches wrote: Using 'extern' is not necessary for function prototypes. We use them to mark dependency inversions (callbacks). I thought about comments instead of, but I'm not sure what is worse. -- Regards, Andrey