[PATCH 2/3] staging: unisys: visorchannel: Rename CamelCase variable nQueues

2014-11-10 Thread Bryan Thompson
Rename the visorchannel_debug parameter nQueues to num_queues. Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/visorchannel/visorchannel.h |2 +- .../unisys/visorchannel/visorchannel_funcs.c |4 ++-- 2 files changed, 3 insertions(+), 3 deletions

[PATCH 3/3] staging: unisys: visorchannel: Describe spinlocks in VISORCHANNEL_Tag struct

2014-11-10 Thread Bryan Thompson
Add comments indicating the requirements and use of the insert_lock and remove_lock in the VISORCHANNEL_Tag structure. Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- .../unisys/visorchannel/visorchannel_funcs.c |7 --- 1 file changed, 4 insertions(+), 3 deletions

[PATCH 0/4] staging: unisys: visorchannel: CamelCase and comment cleanup

2014-11-10 Thread Bryan Thompson
Resending due to return address error. This series of patches addresses two CamelCase issues and a spinlock commenting issue reported by checkpatch on the visorchannel tree. Bryan Thompson (3): staging: unisys: visorchannel: Rename CamelCase variable channelBytes staging: unisys

[PATCH 1/3] staging: unisys: visorchannel: Rename CamelCase variable channelBytes

2014-11-10 Thread Bryan Thompson
Rename channelBytes to channel_bytes in the series of visorchannel_create functions provided by visorchannel. Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/visorchannel/visorchannel.h | 10 .../unisys/visorchannel/visorchannel_funcs.c | 26

[PATCH 1/8] staging: unisys: visorchannel: Remove multiple blank lines

2014-11-06 Thread Bryan Thompson
Remove the instances of multiple blank lines in the visorchannel files. Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/visorchannel/globals.h |1 - .../unisys/visorchannel/visorchannel_funcs.c |1 - 2 files changed, 2 deletions(-) diff

[PATCH 4/8] staging: unisys: visorchannel: Remove unnecessary parentheses

2014-11-06 Thread Bryan Thompson
Remove extraneous parentheses around a variable in visorchannel_funcs.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- .../unisys/visorchannel/visorchannel_funcs.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/unisys/visorchannel

[PATCH 8/8] staging: unisys: visorchannel: Add braces to else arm of if/else statement

2014-11-06 Thread Bryan Thompson
Add braces to the else arm of an if/else block in visorchannel_funcs.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- .../unisys/visorchannel/visorchannel_funcs.c |3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/unisys/visorchannel

[PATCH 6/8] staging: unisys: visorchannel: Adjust lines to contain a maximum of 80 characters

2014-11-06 Thread Bryan Thompson
Split multiple logging lines to get them closer to 80 characters per line. Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- .../unisys/visorchannel/visorchannel_funcs.c | 18 -- 1 file changed, 12 insertions(+), 6 deletions(-) diff --git a/drivers/staging

[PATCH 2/8] staging: unisys: visorchannel: Fix alignment issues

2014-11-06 Thread Bryan Thompson
Use the appropriate whitespace for multiline statements in visorchannel_funcs.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- .../unisys/visorchannel/visorchannel_funcs.c | 11 ++- 1 file changed, 6 insertions(+), 5 deletions(-) diff --git a/drivers/staging/unisys

[PATCH 5/8] staging: unisys: visorchannel: Place logical continuation at the end of a line

2014-11-06 Thread Bryan Thompson
Move the || logical continuation from the start of the second line of an if statement to the end of the first line. Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- .../unisys/visorchannel/visorchannel_funcs.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff

[PATCH 7/8] staging: unisys: visorchannel: Rename goto label Away

2014-11-06 Thread Bryan Thompson
Rename the goto label used throughout visorchannel_funcs.c from Away to cleanup. Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- .../unisys/visorchannel/visorchannel_funcs.c | 54 ++-- 1 file changed, 27 insertions(+), 27 deletions(-) diff --git a/drivers

[PATCH 3/8] staging: unisys: visorchannel: Remove space between cast and variable

2014-11-06 Thread Bryan Thompson
Remove the whitespace between a cast and the variable in visorchannel_funcs.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- .../unisys/visorchannel/visorchannel_funcs.c | 22 ++-- 1 file changed, 11 insertions(+), 11 deletions(-) diff --git a/drivers

[PATCH] staging: unisys: virtpci: Remove GET_BUS_DEV macro

2014-11-04 Thread Bryan Thompson
The GET_BUS_DEV macro contained flow control statements that are undesirable. This patch removes the macro and places the code in each function. Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c | 48 -- 1 file

[PATCH 00/12] Fix CamelCase issues in virtpci.c

2014-11-03 Thread Bryan Thompson
This patch series renames the checkpatch.pl flagged CamelCase names in virtpci.c Bryan Thompson (12): staging: unisys: virtpci: Fix CamelCase Chipset_DriverInfo staging: unisys: virtpci: Fix CamelCase virtpci device list head staging: unisys: virtpci: Fix CamelCase virtpci device list lock

[PATCH 12/12] staging: unisys: virtpci: Fix CamelCase local variables in virtpci_device_add()

2014-11-03 Thread Bryan Thompson
Rename the following local variables in virtpci_device_add() pIoChan changed to io_chan pDev changed to dev Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git

[PATCH 05/12] staging: unisys: virtpci: Fix CamelCase write_vbus_chpInfo()

2014-11-03 Thread Bryan Thompson
Rename write_vbus_chpInfo() to write_vbus_chp_info() in virtpci.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/unisys/virtpci/virtpci.c b

[PATCH 10/12] staging: unisys: virtpci: Fix CamelCase parameters of fix_vbus_dev_info()

2014-11-03 Thread Bryan Thompson
Rename the following fix_vbus_dev_info() parameters devNo changed to dev_no devType changed to dev_type Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers

[PATCH 03/12] staging: unisys: virtpci: Fix CamelCase virtpci device list lock

2014-11-03 Thread Bryan Thompson
Rename VpcidevListLock to vpcidev_list_lock in virtpci.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c | 32 +++--- 1 file changed, 16 insertions(+), 16 deletions(-) diff --git a/drivers/staging/unisys/virtpci

[PATCH 04/12] staging: unisys: virtpci: Fix CamelCase vbus driver info variable

2014-11-03 Thread Bryan Thompson
Rename BusDriverInfo variable to bus_driver_info in virtpci.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c |9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/drivers/staging/unisys/virtpci/virtpci.c b/drivers

[PATCH 09/12] staging: unisys: virtpci: Fix CamelCase name fix_vbus_devInfo()

2014-11-03 Thread Bryan Thompson
Rename fix_vbus_devInfo() to fix_vbus_dev_info(). Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers/staging/unisys/virtpci/virtpci.c b/drivers/staging

[PATCH 02/12] staging: unisys: virtpci: Fix CamelCase virtpci device list head

2014-11-03 Thread Bryan Thompson
Rename VpcidevListHead to vpcidev_list_head in virtpci.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c | 32 +++--- 1 file changed, 16 insertions(+), 16 deletions(-) diff --git a/drivers/staging/unisys/virtpci

[PATCH 07/12] staging: unisys: virtpci: Fix CamelCase write_vbus_devInfo()

2014-11-03 Thread Bryan Thompson
Rename write_vbus_devInfo() to write_vbus_dev_info() in virtpci.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/unisys/virtpci/virtpci.c b/drivers

[PATCH 11/12] staging: unisys: virtpci: Fix CamelCase local variables in fix_vbus_dev_info()

2014-11-03 Thread Bryan Thompson
Rename the following local variables in fix_vbus_dev_info() Change pChan to chan Change devInfo to dev_info Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git

[PATCH 08/12] staging: unisys: virtpci: Fix CamelCase in delete_vbus_device()

2014-11-03 Thread Bryan Thompson
Rename pDev to dev in delete_vbus_device() Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/unisys/virtpci/virtpci.c b/drivers/staging/unisys/virtpci

[PATCH 06/12] staging: unisys: virtpci: Fix CamelCase write_vbus_busInfo()

2014-11-03 Thread Bryan Thompson
Rename write_vbus_busInfo() to write_vbus_bus_info() in virtpci.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/unisys/virtpci/virtpci.c b

[PATCH 01/12] staging: unisys: virtpci: Fix CamelCase Chipset_DriverInfo

2014-11-03 Thread Bryan Thompson
Rename Chipset_DriverInfo to chipset_driver_info in virtpci.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c |8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/unisys/virtpci/virtpci.c b/drivers

[PATCH 7/9] staging: unisys: virtpci: Use a single blank line to separate code blocks

2014-10-30 Thread Bryan Thompson
Remove one blank line of two between function variable declaration and implementation in virt_pci_mod_init(). Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com Signed-off-by: Benjamin Romer benjamin.ro...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c |1 - 1 file changed, 1

[PATCH 8/9] staging: unisys: virtpci: Fix alignment issues

2014-10-30 Thread Bryan Thompson
Use the appropriate whitespace alignment for multiline statements in virtpci.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com Signed-off-by: Benjamin Romer benjamin.ro...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c | 28 ++-- 1 file changed, 14

[PATCH 1/9] staging: unisys: virtpci: Add a blank line after the definition of driver_private

2014-10-30 Thread Bryan Thompson
Insert a blank line between the definition of the driver_private structure and the next statement. Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com Signed-off-by: Benjamin Romer benjamin.ro...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c |1 + 1 file changed, 1 insertion

[PATCH 4/9] staging: unisys: virtpci: Allocate memory using the size of the variable

2014-10-30 Thread Bryan Thompson
Change two instances of using the sizeof a structure to the size of a specific variable when allocating memory in virtpci.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com Signed-off-by: Benjamin Romer benjamin.ro...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c |4 ++-- 1

[PATCH 9/9] staging: unisys: virtpci: Adjust lines to contain a maximum of 80 characters

2014-10-30 Thread Bryan Thompson
Update delete_all_virt function definition to two lines so each line is less than 80 characters long. Move comments on virtpci_device_add function parameters to a header block to contain each line to 80 characters. Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com Signed-off-by: Benjamin

[PATCH 2/9] staging: unisys: virtpci: Remove extraneous blank lines

2014-10-30 Thread Bryan Thompson
Removed unnecessary blank lines from virtpci.c Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com Signed-off-by: Benjamin Romer benjamin.ro...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c |3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/staging/unisys/virtpci

[PATCH 6/9] staging: unisys: virtpci: Add braces to if/else statements

2014-10-30 Thread Bryan Thompson
Update if/else blocks with braces on both the if and the else blocks in virtpci.c. Signed-off-by: Bryan Thompson bryan.thomp...@unisys.com Signed-off-by: Benjamin Romer benjamin.ro...@unisys.com --- drivers/staging/unisys/virtpci/virtpci.c |7 --- 1 file changed, 4 insertions(+), 3

[PATCH 0/9] Cleanup in virtpci.c

2014-10-30 Thread Bryan Thompson
This series of patches cleans up some simple checkpatch.pl findings in virtpci.c Bryan Thompson (9): staging: unisys: virtpci: Add a blank line after the definition of driver_private staging: unisys: virtpci: Remove extraneous blank lines staging: unisys: virtpci: Remove space between