Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-16 Thread David Sterba
On Tue, Jun 16, 2020 at 11:53:50AM -0700, Joe Perches wrote: > On Mon, 2020-06-15 at 21:57 -0400, Waiman Long wrote: > > v4: > > - Break out the memzero_explicit() change as suggested by Dan Carpenter > > so that it can be backported to stable. > > - Drop the "crypto: Remove unnecessary

Re: [PATCH v4 3/3] btrfs: Use kfree() in btrfs_ioctl_get_subvol_info()

2020-06-16 Thread David Sterba
On Mon, Jun 15, 2020 at 09:57:18PM -0400, Waiman Long wrote: > In btrfs_ioctl_get_subvol_info(), there is a classic case where kzalloc() > was incorrectly paired with kzfree(). According to David Sterba, there > isn't any sensitive information in the subvol_info that needs to be > cl

Re: [PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-04-14 Thread David Sterba
On Mon, Apr 13, 2020 at 05:15:49PM -0400, Waiman Long wrote: > fs/btrfs/ioctl.c | 2 +- > diff --git a/fs/btrfs/ioctl.c b/fs/btrfs/ioctl.c > index 40b729dce91c..eab3f8510426 100644 > --- a/fs/btrfs/ioctl.c > +++ b/fs/btrfs/ioctl.c > @@ -2691,7 +2691,7 @@ static int

Re: [RFC] errno.h: Provide EFSCORRUPTED for everybody

2019-11-05 Thread David Sterba
On Sat, Nov 02, 2019 at 08:38:23AM +1100, Dave Chinner wrote: > On Fri, Nov 01, 2019 at 09:57:31PM +0100, Geert Uytterhoeven wrote: > > Hi Valdis, > > > > On Thu, Oct 31, 2019 at 2:11 AM Valdis Kletnieks > > wrote: > > > Three questions: (a) ACK/NAK on this patch, (b) should it be all in one > >

Re: [PATCH v8 11/24] erofs: introduce xattr & posixacl support

2019-09-02 Thread David Sterba
On Mon, Sep 02, 2019 at 09:51:59PM +0800, Chao Yu wrote: > On 2019-9-2 21:06, David Sterba wrote: > > On Mon, Sep 02, 2019 at 05:57:11AM -0700, Christoph Hellwig wrote: > >>> +config EROFS_FS_XATTR > >>> + bool "EROFS extended attributes" > >>&g

Re: [PATCH v6 01/24] erofs: add on-disk layout

2019-09-02 Thread David Sterba
On Mon, Sep 02, 2019 at 10:43:03AM +0200, Pavel Machek wrote: > > > > Rather than they didn't run "gdb" or "pahole" and change it by mistake. > > > > > > I think Christoph is not right here. > > > > > > Using external tools for validation is extra work > > > when necessary for understanding the

Re: [PATCH v6 05/24] erofs: add inode operations

2019-09-02 Thread David Sterba
On Sun, Sep 01, 2019 at 05:34:00PM +0800, Gao Xiang wrote: > > > +static int read_inode(struct inode *inode, void *data) > > > +{ > > > + struct erofs_vnode *vi = EROFS_V(inode); > > > + struct erofs_inode_v1 *v1 = data; > > > + const unsigned int advise = le16_to_cpu(v1->i_advise); > > > +

Re: [PATCH v8 11/24] erofs: introduce xattr & posixacl support

2019-09-02 Thread David Sterba
On Mon, Sep 02, 2019 at 05:57:11AM -0700, Christoph Hellwig wrote: > > +config EROFS_FS_XATTR > > + bool "EROFS extended attributes" > > + depends on EROFS_FS > > + default y > > + help > > + Extended attributes are name:value pairs associated with inodes by > > + the kernel or by

Re: [PATCH v6 01/24] erofs: add on-disk layout

2019-08-30 Thread David Sterba
On Thu, Aug 29, 2019 at 08:58:17AM -0700, Joe Perches wrote: > On Thu, 2019-08-29 at 18:32 +0800, Gao Xiang wrote: > > Hi Christoph, > > > > On Thu, Aug 29, 2019 at 02:59:54AM -0700, Christoph Hellwig wrote: > > > > --- /dev/null > > > > +++ b/fs/erofs/erofs_fs.h > > > > @@ -0,0 +1,316 @@ > > > >

Re: [PATCH] staging: exfat: add exfat filesystem code to staging

2019-08-30 Thread David Sterba
On Fri, Aug 30, 2019 at 10:06:25AM +0800, Chao Yu wrote: > On 2019/8/29 23:43, Dan Carpenter wrote: > >> p.s. There are 2947 (un)likely places in fs/ directory. > > > > I was complaining about you adding new pointless ones, not existing > > ones. The likely/unlikely annotations are supposed to

Re: [PATCH v3 23/24] erofs: introduce cached decompression

2019-07-23 Thread David Sterba
On Mon, Jul 22, 2019 at 06:58:59PM +0800, Gao Xiang wrote: > On 2019/7/22 6:18, David Sterba wrote: > > On Mon, Jul 22, 2019 at 10:50:42AM +0800, Gao Xiang wrote: > >> +choice > >> + prompt "EROFS Data Decompression mode" > >&

Re: [PATCH v3 23/24] erofs: introduce cached decompression

2019-07-22 Thread David Sterba
On Mon, Jul 22, 2019 at 10:50:42AM +0800, Gao Xiang wrote: > +choice > + prompt "EROFS Data Decompression mode" > + depends on EROFS_FS_ZIP > + default EROFS_FS_ZIP_CACHE_READAROUND > + help > + EROFS supports three options for decompression. > + "In-place I/O Only"

Re: [PATCH 2/3] mm: remove cleancache.c

2019-05-27 Thread David Sterba
btrfs part: > fs/btrfs/extent_io.c | 9 -- > fs/btrfs/super.c | 2 - Acked-by: David Sterba ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH v2 05/17] compat_ioctl: move more drivers to generic_compat_ioctl_ptrarg

2018-09-14 Thread David Sterba
uble-checked all these drivers to ensure that all ioctl arguments > are used as pointers or are ignored, but are not interpreted as integer > values. > > Signed-off-by: Arnd Bergmann > --- > fs/btrfs/super.c | 2 +- Acked-by: David Sterba _

Re: [PATCH 07/12] fs: btrfs: Use ktime_get_real_ts for root ctime

2017-04-12 Thread David Sterba
are used for vfs inode times as well. These can be > transitioned to using timespec64 when btrfs internally > changes to use timespec64 as well. > > Signed-off-by: Deepa Dinamani <deepa.ker...@gmail.com> > Acked-by: David Sterba <dste...@suse.com> > Reviewed-by: Ar