the system defined higher order value.
Thus replacing this hard-coded value with PAGE_ALLOC_COSTLY_ORDER
which is defined as 3.
This will help mapping the higher order request in system heap with
the actual allocation request.
Quite reasonable.
Reviewed-by: Heesub Shin
BTW, Anyone knows how the
uld
be fixed. I should have caught this before the merge, my bad.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_system_heap.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion_system_heap.c
b/drivers/staging/android/ion/ion_system_heap.c
index c
Now that the pages returned from the pool are compound pages, we do not
need to pass the order information to free_buffer_page().
Signed-off-by: Heesub Shin
Reviewed-by: Mitchel Humpherys
Tested-by: John Stultz
---
drivers/staging/android/ion/ion_system_heap.c | 9 -
1 file changed, 4
ION system heap creates a temporary list of pages to build
scatter/gather table, introducing an internal data type, page_info. Now
that the order field has been removed from it, we do not need to depend
on such data type anymore.
Signed-off-by: Heesub Shin
Reviewed-by: Mitchel Humpherys
Tested
ION system heap uses an internal data structure, struct page_info, for
tracking down the meta information of the pages allocated from the pool.
Now that the pool returns compound pages, we don't need to store page
order in struct page_info.
Signed-off-by: Heesub Shin
Reviewed-by: Mi
overhead to the slab.
Signed-off-by: Heesub Shin
Reviewed-by: Mitchel Humpherys
Tested-by: John Stultz
---
drivers/staging/android/ion/ion_system_heap.c | 13 +
1 file changed, 5 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/android/ion/ion_system_heap.c
b/drivers/staging
On 05/30/2014 05:42 AM, Greg Kroah-Hartman wrote:
On Wed, May 28, 2014 at 03:52:52PM +0900, Heesub Shin wrote:
For aesthetics and readability, rename goto labels, remove
useless code lines, and clarify function return type.
Signed-off-by: Heesub Shin
Reviewed-by: Mitchel Humpherys
Tested-by
: Heesub Shin
---
drivers/staging/android/ion/ion_page_pool.c | 6 +-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion_page_pool.c
b/drivers/staging/android/ion/ion_page_pool.c
index c1cea42b..5864f3d 100644
--- a/drivers/staging/android/ion
ION system heap uses an internal data structure, struct page_info, for
tracking down the meta information of the pages allocated from the pool.
Now that the pool returns compound pages, we don't need to store page
order in struct page_info.
Signed-off-by: Heesub Shin
---
drivers/staging/an
overhead to the slab.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_system_heap.c | 13 +
1 file changed, 5 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/android/ion/ion_system_heap.c
b/drivers/staging/android/ion/ion_system_heap.c
index d78d589e..690d866
ION system heap creates a temporary list of pages to build
scatter/gather table, introducing an internal data type, page_info. Now
that the order field has been removed from it, we do not need to depend
on such data type anymore.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion
Now that the pages returned from the pool are compound pages, we do not
need to pass the order information to free_buffer_page().
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_system_heap.c | 9 -
1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/drivers
.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_page_pool.c | 27 +--
1 file changed, 5 insertions(+), 22 deletions(-)
diff --git a/drivers/staging/android/ion/ion_page_pool.c
b/drivers/staging/android/ion/ion_page_pool.c
index 1684780..111777c 100644
Hi,
Here is my patchset with some modification, hoping reviews or comments
from you guys.
v2:
o No changes in the code, just reworded changelog
o Reorder patch
Heesub Shin (9):
staging: ion: tidy up a bit
staging: ion: simplify ion_page_pool_total()
staging: ion: remove struct
For aesthetics and readability, rename goto labels, remove
useless code lines, and clarify function return type.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_page_pool.c | 2 +-
drivers/staging/android/ion/ion_priv.h| 2 +-
drivers/staging/android/ion
Using compound pages relieves burden on tracking the meta information
which are currently stored in page_info.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_page_pool.c | 4 +++-
drivers/staging/android/ion/ion_system_heap.c | 2 +-
2 files changed, 4 insertions(+), 2
ion_page_pool_total() returns the total number of pages in the pool.
Depending on the argument passed, it counts highmem pages in or not.
This commit simplifies the code lines for better readability.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_page_pool.c | 10 +-
1
Hello Carpenter,
On 05/26/2014 07:36 PM, Dan Carpenter wrote:
On Mon, May 26, 2014 at 07:04:53PM +0900, Heesub Shin wrote:
@@ -124,7 +122,6 @@ static struct page_info *alloc_largest_available(struct
ion_system_heap *heap,
info->page = page;
info->
Hello,
On 05/26/2014 07:04 PM, Heesub Shin wrote:
Now that the order information is held on struct page itself, we do not
need to use extra data structure. This commit reduces unnecessary slab
usage for allocating small objects.
Oops. I need to amend changelog above and resend this patchset
overhead to the slab.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_system_heap.c | 13 +
1 file changed, 5 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/android/ion/ion_system_heap.c
b/drivers/staging/android/ion/ion_system_heap.c
index d78d589e..690d866
: Heesub Shin
---
drivers/staging/android/ion/ion_page_pool.c | 6 +-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/android/ion/ion_page_pool.c
b/drivers/staging/android/ion/ion_page_pool.c
index c1cea42b..5864f3d 100644
--- a/drivers/staging/android/ion
Not that the pages returned from the pool are compound pages, we do not
need to pass the order information to free_buffer_page().
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_system_heap.c | 9 -
1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/drivers
For aesthetics and readability, rename goto labels, remove
useless code lines, and clarify function return type.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_page_pool.c | 2 +-
drivers/staging/android/ion/ion_priv.h| 2 +-
drivers/staging/android/ion
Using compound pages relieves burden on tracking the meta information
which are currently stored in page_info.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_page_pool.c | 4 +++-
drivers/staging/android/ion/ion_system_heap.c | 2 +-
2 files changed, 4 insertions(+), 2
ION system heap uses a temporary list holding meta data on pages
allocated to build scatter/gather table. Now that the pages are compound
pages, we do not need to introduce a new data type redundantly.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_system_heap.c | 47
Now that the order information is held on struct page itself, we do not
need to use extra data structure. This commit reduces unnecessary slab
usage for allocating small objects.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_page_pool.c | 27 +--
1 file
ION system heap uses an internal data structure, struct page_info, for
tracking down the meta information of the pages allocated from the pool.
Now that the pool returns compound pages, we don't need to store page
order in struct page_info.
Signed-off-by: Heesub Shin
---
drivers/staging/an
ion_page_pool_total() returns the total number of pages in the pool.
Depending on the argument passed, it counts pages from highmem zone in
or not. This commit simplifies the code lines for better readability.
Signed-off-by: Heesub Shin
---
drivers/staging/android/ion/ion_page_pool.c | 10
28 matches
Mail list logo