Re: [PATCH v5 03/24] wfx: add Makefile/Kconfig

2021-03-16 Thread Leon Romanovsky
On Mon, Mar 15, 2021 at 05:21:35PM +0100, Jérôme Pouiller wrote: > Hi Leon, > > On Monday 15 March 2021 16:11:52 CET Leon Romanovsky wrote: > > On Mon, Mar 15, 2021 at 02:24:40PM +0100, Jerome Pouiller wrote: > > > From: Jérôme Pouiller > > > >

Re: [PATCH v5 03/24] wfx: add Makefile/Kconfig

2021-03-15 Thread Leon Romanovsky
On Mon, Mar 15, 2021 at 02:24:40PM +0100, Jerome Pouiller wrote: > From: Jérôme Pouiller > > Signed-off-by: Jérôme Pouiller > --- > drivers/net/wireless/silabs/wfx/Kconfig | 12 +++ > drivers/net/wireless/silabs/wfx/Makefile | 26 > 2 files changed, 38 insertion

Re: [PATCH] IB: Revert "remove redundant INFINIBAND kconfig dependencies"

2018-05-25 Thread Leon Romanovsky
On Fri, May 25, 2018 at 11:29:59PM +0200, Arnd Bergmann wrote: > Several subsystems depend on INFINIBAND_ADDR_TRANS, which in turn depends > on INFINIBAND. However, when with CONFIG_INIFIBAND=m, this leads to a > link error when another driver using it is built-in. The > INFINIBAND_ADDR_TRANS depen

Re: [PATCH 9/9] treewide: Inline ib_dma_map_*() functions

2017-01-12 Thread Leon Romanovsky
| 4 +- > drivers/infiniband/core/umem_odp.c | 6 +- > drivers/infiniband/hw/mlx4/cq.c| 2 +- > drivers/infiniband/hw/mlx4/mad.c | 28 +-- > drivers/infiniband/hw/mlx4/mr.c| 4 +- > drivers/in

Re: [PATCH 1/1] Drivers: infiniband: hw: vmbus-nd: NetworkDirect driver for Linux

2016-07-26 Thread Leon Romanovsky
On Tue, Jul 26, 2016 at 07:05:37PM -0700, k...@exchange.microsoft.com wrote: > From: K. Y. Srinivasan > > This driver is a bridge driver that surfaces a Mellanox device in the Linux > guest and plugs into > the "NetworkDirect" RDMA infrastructure on the Windows host. Only a subset of > the ibve

Re: [PATCH] staging/rdma/hfi1: use RCU_INIT_POINTER() when NULLing.

2016-05-01 Thread Leon Romanovsky
r commit message and don't need to resend, however the statements like "smaller code" need to be supported by ./scripts/bloat-o-meter and "faster code" by performance analysis. Reviewed-by: Leon Romanovsky > --- > drivers/staging/rdma/hfi1/init.c | 2 +- > 1 file ch

Re: [PATCH] Add tw5864 driver

2016-03-19 Thread Leon Romanovsky
On Mon, Mar 14, 2016 at 03:55:14AM +0200, Andrey Utkin wrote: > From: Andrey Utkin > > Support for boards based on Techwell TW5864 chip which provides > multichannel video & audio grabbing and encoding (H.264, MJPEG, > ADPCM G.726). > > Signed-off-by: Andrey Utkin > Tested-by: Andrey Utkin > -

Re: [PATCH v2] staging/rdma/hfi1: check for ARMED->ACTIVE transition in receive interrupt

2016-01-04 Thread Leon Romanovsky
On Mon, Jan 04, 2016 at 11:21:19AM -0500, Jubin John wrote: > From: Jim Snow > > } else { > + /* Auto activate link on non-SC15 packet receive */ > + if (unlikely(rcd->ppd->host_link_state == > + HLS_UP_ARMED))

Re: [RFC PATCH v0] Add tw5864 driver

2016-01-02 Thread Leon Romanovsky
On Sun, Jan 03, 2016 at 03:41:42AM +0200, Andrey Utkin wrote: > +/* > + * TW5864 driver - Exp-Golomb code functions > + * > + * Copyright (C) 2015 Bluecherry, LLC > + * Copyright (C) 2015 Andrey Utkin I doubt that you have contract with your employer which permits you to claim copyright

Re: [PATCH] staging/rdma/hfi1: Reduce number of parameters passed to send handlers

2015-11-11 Thread Leon Romanovsky
On Wed, Nov 11, 2015 at 08:39:08AM -0500, Dennis Dalessandro wrote: > On Wed, Nov 11, 2015 at 08:25:35AM +0200, Leon Romanovsky wrote: > >On Wed, Nov 11, 2015 at 12:34:37AM -0500, ira.we...@intel.com wrote: > >>From: Dennis Dalessandro > >> > >>+int snoop

Re: [PATCH] staging/rdma/hfi1: Reduce number of parameters passed to send handlers

2015-11-10 Thread Leon Romanovsky
On Wed, Nov 11, 2015 at 12:34:37AM -0500, ira.we...@intel.com wrote: > From: Dennis Dalessandro > > +int snoop_send_dma_handler(struct hfi1_qp *qp, struct hfi1_pkt_state *ps, > +u64 pbc) > { > - pr_alert("Snooping/Capture of Send DMA Packets Is Not Supported!\n"); >

Re: [PATCH 1/1] staging: rdma: hfi1 : Prefer using the BIT macro

2015-11-05 Thread Leon Romanovsky
On Thu, Nov 05, 2015 at 05:28:03PM +0530, Sunny Kumar wrote: > This patch replaces bit shifting on 1 with the BIT(x) macro > > Signed-off-by: Sunny Kumar > --- > drivers/staging/rdma/hfi1/user_sdma.c | 10 +- > 1 file changed, 5 insertions(+), 5 deletions(-) > > /* Last packet in the r

Re: [PATCH 1/4 v2] staging: ipath: ipath_driver: Use setup_timer

2015-10-27 Thread Leon Romanovsky
On Tue, Oct 27, 2015 at 11:19 AM, Dan Carpenter wrote: > On Sun, Oct 25, 2015 at 01:21:11PM +0200, Leon Romanovsky wrote: >> On Sun, Oct 25, 2015 at 12:17 PM, Muhammad Falak R Wani >> wrote: >> Please follow standard naming convention for the patches. >> It shoul

Re: [PATCH 1/4 v2] staging: ipath: ipath_driver: Use setup_timer

2015-10-25 Thread Leon Romanovsky
On Sun, Oct 25, 2015 at 12:17 PM, Muhammad Falak R Wani wrote: Please follow standard naming convention for the patches. It should be [PATCH v2 1/4] and not [PATCH 1/4 v2]. ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverp

Re: [PATCH 2195/2195] Staging: rdma: amso1100: Fix multiple assignments on single line.

2015-10-25 Thread Leon Romanovsky
On Sun, Oct 25, 2015 at 12:50 PM, Weston Silbaugh wrote: > Multiple assignments should be avoided. > > For example: > > cm_event.ird = cm_event.ord = 128; > > Should be: > > cm_event.ird = 128; > cm_event.ord = 128; > > Signed-off-by: Weston Silbaugh > --- > drivers/staging/rdma/amso1100/c2_ae.c