Re: [Outreachy kernel] Re: [PATCH v2 1/2] staging: kpc2000: kpc_dma: rearrange lines exceeding 100 columns

2020-10-25 Thread Matthew Wilcox
On Mon, Oct 26, 2020 at 09:34:53AM +0530, Deepak R Varma wrote: > > - dev_dbg(>pldev->dev, "Handling completed descriptor %p > > (acd = %p)\n", cur, cur->acd); > > + dev_dbg(>pldev->dev, "Handling completed descriptor %p > > (acd = %p)\n", > > + cur, > > +

Re: [Outreachy kernel] [PATCH] staging/rtl8192e: replace kmalloc with kzalloc

2020-10-23 Thread Matthew Wilcox
On Fri, Oct 23, 2020 at 03:03:17AM -0700, Elena Afanasova wrote: > - txb = kmalloc(sizeof(struct rtllib_txb) + (sizeof(u8 *) * nr_frags), > - gfp_mask); > + txb = kzalloc(sizeof(*txb) + (sizeof(u8 *) * nr_frags), gfp_mask); This would be a good opportunity to use

Re: [Outreachy kernel] [PATCH 3/3] staging/rtl8712: use BIT macro

2020-10-20 Thread Matthew Wilcox
On Tue, Oct 20, 2020 at 11:24:39AM -0700, Elena Afanasova wrote: > Reported by checkpatch.pl Checkpatch is wrong. > +++ b/drivers/staging/rtl8712/rtl871x_recv.h > @@ -8,7 +8,7 @@ > #define NR_RECVFRAME 256 > > #define RXFRAME_ALIGN8 > -#define RXFRAME_ALIGN_SZ (1 <<

Re: [Ocfs2-devel] [RFC] treewide: cleanup unreachable breaks

2020-10-18 Thread Matthew Wilcox
On Sun, Oct 18, 2020 at 12:13:35PM -0700, James Bottomley wrote: > On Sun, 2020-10-18 at 19:59 +0100, Matthew Wilcox wrote: > > On Sat, Oct 17, 2020 at 09:09:28AM -0700, t...@redhat.com wrote: > > > clang has a number of useful, new warnings see > > > https:

Re: [Ocfs2-devel] [RFC] treewide: cleanup unreachable breaks

2020-10-18 Thread Matthew Wilcox
On Sat, Oct 17, 2020 at 09:09:28AM -0700, t...@redhat.com wrote: > clang has a number of useful, new warnings see > https://urldefense.com/v3/__https://clang.llvm.org/docs/DiagnosticsReference.html__;!!GqivPVa7Brio!Krxz78O3RKcB9JBMVo_F98FupVhj_jxX60ddN6tKGEbv_cnooXc1nnBmchm-e_O9ieGnyQ$ > Please

Re: [PATCH RFC PKS/PMEM 33/58] fs/cramfs: Utilize new kmap_thread()

2020-10-13 Thread Matthew Wilcox
On Tue, Oct 13, 2020 at 11:44:29AM -0700, Dan Williams wrote: > On Fri, Oct 9, 2020 at 12:52 PM wrote: > > > > From: Ira Weiny > > > > The kmap() calls in this FS are localized to a single thread. To avoid > > the over head of global PKRS updates use the new kmap_thread() call. > > > > Cc:

Re: [PATCH RFC PKS/PMEM 22/58] fs/f2fs: Utilize new kmap_thread()

2020-10-12 Thread Matthew Wilcox
On Mon, Oct 12, 2020 at 12:53:54PM -0700, Ira Weiny wrote: > On Mon, Oct 12, 2020 at 05:44:38PM +0100, Matthew Wilcox wrote: > > On Mon, Oct 12, 2020 at 09:28:29AM -0700, Dave Hansen wrote: > > > kmap_atomic() is always preferred over kmap()/kmap_thread(). > > > k

Re: [PATCH RFC PKS/PMEM 22/58] fs/f2fs: Utilize new kmap_thread()

2020-10-12 Thread Matthew Wilcox
On Mon, Oct 12, 2020 at 09:28:29AM -0700, Dave Hansen wrote: > kmap_atomic() is always preferred over kmap()/kmap_thread(). > kmap_atomic() is _much_ more lightweight since its TLB invalidation is > always CPU-local and never broadcast. > > So, basically, unless you *must* sleep while the mapping

Re: [PATCH RFC PKS/PMEM 22/58] fs/f2fs: Utilize new kmap_thread()

2020-10-09 Thread Matthew Wilcox
On Fri, Oct 09, 2020 at 02:34:34PM -0700, Eric Biggers wrote: > On Fri, Oct 09, 2020 at 12:49:57PM -0700, ira.we...@intel.com wrote: > > The kmap() calls in this FS are localized to a single thread. To avoid > > the over head of global PKRS updates use the new kmap_thread() call. > > > > @@

Re: [PATCH 3/3] tasklet: Introduce new initialization API

2020-07-16 Thread Matthew Wilcox
On Wed, Jul 15, 2020 at 08:08:47PM -0700, Kees Cook wrote: > +#define DECLARE_TASKLET(name, _callback) \ > +struct tasklet_struct name = { \ > + .count = ATOMIC_INIT(0),\ > + .callback = _callback, \

Re: [PATCH 2/3] treewide: Replace DECLARE_TASKLET() with DECLARE_TASKLET_OLD()

2020-07-16 Thread Matthew Wilcox
On Wed, Jul 15, 2020 at 08:08:46PM -0700, Kees Cook wrote: > This converts all the existing DECLARE_TASKLET() (and ...DISABLED) > macros with DECLARE_TASKLET_OLD() in preparation for refactoring the > tasklet callback type. All existing DECLARE_TASKLET() users had a "0" > data argument, it has

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-17 Thread Matthew Wilcox
On Wed, Jun 17, 2020 at 01:31:57PM +0200, Michal Hocko wrote: > On Wed 17-06-20 04:08:20, Matthew Wilcox wrote: > > If you call vfree() under > > a spinlock, you're in trouble. in_atomic() only knows if we hold a > > spinlock for CONFIG_PREEMPT, so it's not safe t

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-17 Thread Matthew Wilcox
On Wed, Jun 17, 2020 at 09:12:12AM +0200, Michal Hocko wrote: > On Tue 16-06-20 17:37:11, Matthew Wilcox wrote: > > Not just performance critical, but correctness critical. Since kvfree() > > may allocate from the vmalloc allocator, I really think that kvfree() > > sh

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-16 Thread Matthew Wilcox
On Wed, Jun 17, 2020 at 01:01:30AM +0200, David Sterba wrote: > On Tue, Jun 16, 2020 at 11:53:50AM -0700, Joe Perches wrote: > > On Mon, 2020-06-15 at 21:57 -0400, Waiman Long wrote: > > > v4: > > > - Break out the memzero_explicit() change as suggested by Dan Carpenter > > > so that it can

Re: [PATCH v4 0/3] mm, treewide: Rename kzfree() to kfree_sensitive()

2020-06-16 Thread Matthew Wilcox
On Tue, Jun 16, 2020 at 11:53:50AM -0700, Joe Perches wrote: > To this larger audience and last week without reply: > https://lore.kernel.org/lkml/573b3fbd5927c643920e1364230c296b23e7584d.ca...@perches.com/ > > Are there _any_ fastpath uses of kfree or vfree? I worked on adding a 'free' a couple

Re: [PATCH] staging: exfat: Fix checkpatch.pl camelcase issues

2020-03-19 Thread Matthew Wilcox
On Thu, Mar 19, 2020 at 10:06:47AM -0400, Aravind Ceyardass wrote: > Fix ffsCamelCase function names and mixed case enums This driver is now gone from staging in -next; please review the code in fs/exfat instead. ___ devel mailing list

Re: [PATCH 1/2] staging: octeon: delete driver

2020-02-04 Thread Matthew Wilcox
On Wed, Feb 05, 2020 at 06:34:16AM +0300, Dan Carpenter wrote: > On Tue, Feb 04, 2020 at 12:31:16PM -0800, Matthew Wilcox wrote: > > On Tue, Feb 04, 2020 at 08:06:14PM +, Chris Packham wrote: > > > On Tue, 2020-02-04 at 07:09 +, gre...@linuxfoundation.org wrote: >

Re: [PATCH 1/2] staging: octeon: delete driver

2020-02-04 Thread Matthew Wilcox
build issues and other problems > > > > > for > > > > > people who want to fix coding style problems, but can not actually > > > > > build > > > > > it. > > > > > > > > > > As nothing is happening he

Re: [PATCH 1/2] staging: exfat: remove DOSNAMEs.

2020-02-03 Thread Matthew Wilcox
On Mon, Feb 03, 2020 at 08:15:59AM +, Greg Kroah-Hartman wrote: > On Mon, Feb 03, 2020 at 12:05:32AM -0800, Matthew Wilcox wrote: > > On Tue, Feb 04, 2020 at 01:31:17AM +0900, Tetsuhiro Kohada wrote: > > > remove 'dos_name','ShortName' and related definitions. >

Re: [PATCH 1/2] staging: exfat: remove DOSNAMEs.

2020-02-03 Thread Matthew Wilcox
On Tue, Feb 04, 2020 at 01:31:17AM +0900, Tetsuhiro Kohada wrote: > remove 'dos_name','ShortName' and related definitions. > > 'dos_name' and 'ShortName' are definitions before VFAT. > These are never used in exFAT. Why are we still seeing patches for the exfat in staging? Why are people not

Re: [PATCH v2] staging: octeon: fix missing a blank line after declaration

2019-11-08 Thread Matthew Wilcox
I would like to reiterate my opinion that this checkpatch warning is bullshit. For large functions, sure. For this kind of function, it's a waste of space. On Fri, Nov 08, 2019 at 02:23:29PM +, Valery Ivanov wrote: > This patch fixes "WARNING: Missing a blank line after declarations" >

Re: [PATCH 01/15] staging: exfat: Clean up return codes - FFS_FULL

2019-10-24 Thread Matthew Wilcox
On Thu, Oct 24, 2019 at 11:53:12AM -0400, Valdis Kletnieks wrote: > Start cleaning up the odd scheme of return codes, starting with FFS_FULL > +++ b/drivers/staging/exfat/exfat.h > @@ -221,7 +221,6 @@ static inline u16 get_row_index(u16 i) > #define FFS_PERMISSIONERR 11 > #define

Re: [PATCH v3 RESEND] staging: erofs: fix an error handling in erofs_readdir()

2019-08-18 Thread Matthew Wilcox
On Sun, Aug 18, 2019 at 11:21:11AM +0800, Gao Xiang wrote: > + if (dentry_page == ERR_PTR(-ENOMEM)) { > + errln("no memory to readdir of logical block %u of nid > %llu", > + i, EROFS_V(dir)->nid); I don't think you need the error message.

Re: [PATCH v2] staging: erofs: fix an error handling in erofs_readdir()

2019-08-17 Thread Matthew Wilcox
On Sun, Aug 18, 2019 at 10:32:45AM +0800, Gao Xiang wrote: > On Sat, Aug 17, 2019 at 07:20:55PM -0700, Matthew Wilcox wrote: > > On Sun, Aug 18, 2019 at 09:56:31AM +0800, Gao Xiang wrote: > > > @@ -82,8 +82,12 @@ static int erofs_readdir(struct file *f, struct >

Re: [PATCH v2] staging: erofs: fix an error handling in erofs_readdir()

2019-08-17 Thread Matthew Wilcox
On Sun, Aug 18, 2019 at 09:56:31AM +0800, Gao Xiang wrote: > @@ -82,8 +82,12 @@ static int erofs_readdir(struct file *f, struct > dir_context *ctx) > unsigned int nameoff, maxsize; > > dentry_page = read_mapping_page(mapping, i, NULL); > - if

Re: [PATCH] net: mdio-octeon: Fix build error and Kconfig warning

2019-08-02 Thread Matthew Wilcox
On Fri, Aug 02, 2019 at 06:30:31PM -0700, Nathan Chancellor wrote: > On Fri, Aug 02, 2019 at 06:11:32PM -0700, David Miller wrote: > > The proper way to fix this is to include either > > > > linux/io-64-nonatomic-hi-lo.h > > > > or > > > > linux/io-64-nonatomic-lo-hi.h > > > >

Re: [PATCH 00/34] put_user_pages(): miscellaneous call sites

2019-08-02 Thread Matthew Wilcox
On Fri, Aug 02, 2019 at 02:41:46PM +0200, Jan Kara wrote: > On Fri 02-08-19 11:12:44, Michal Hocko wrote: > > On Thu 01-08-19 19:19:31, john.hubb...@gmail.com wrote: > > [...] > > > 2) Convert all of the call sites for get_user_pages*(), to > > > invoke put_user_page*(), instead of put_page().

exfat filesystem

2019-07-09 Thread Matthew Wilcox
On Tue, Jul 09, 2019 at 11:30:39AM -0400, Theodore Ts'o wrote: > On Tue, Jul 09, 2019 at 04:21:36AM -0700, Matthew Wilcox wrote: > > How does > > https://www.zdnet.com/article/microsoft-open-sources-its-entire-patent-portfolio/ > > change your personal opinion? > &g

Re: Procedure questions - new filesystem driver..

2019-07-09 Thread Matthew Wilcox
On Tue, Jul 09, 2019 at 12:50:20AM -0400, Theodore Ts'o wrote: > How have you dealt with the patent claims which Microsoft has > asserted[1] on the exFAT file system design? > > [1] > https://www.microsoft.com/en-us/legal/intellectualproperty/mtl/exfat-licensing.aspx > > I am not making any

Re: [RFC] simple_lmk: Introduce Simple Low Memory Killer for Android

2019-03-12 Thread Matthew Wilcox
On Tue, Mar 12, 2019 at 09:05:32AM +0100, Michal Hocko wrote: > On Mon 11-03-19 15:15:35, Suren Baghdasaryan wrote: > > Yeah, killing speed is a well-known problem which we are considering > > in LMKD. For example the recent LMKD change to assign process being > > killed to a cpuset cgroup

Re: [PATCH RFC 2/6] mm: convert PG_balloon to PG_offline

2018-11-14 Thread Matthew Wilcox
On Wed, Nov 14, 2018 at 10:17:00PM +0100, David Hildenbrand wrote: > Rename PG_balloon to PG_offline. This is an indicator that the page is > logically offline, the content stale and that it should not be touched > (e.g. a hypervisor would have to allocate backing storage in order for the > guest

Re: [PATCH v7 1/4] gpiolib: Pass bitmaps, not integer arrays, to get/set array

2018-09-02 Thread Matthew Wilcox
> +++ b/drivers/auxdisplay/hd44780.c > @@ -62,17 +62,12 @@ static void hd44780_strobe_gpio(struct hd44780 *hd) > /* write to an LCD panel register in 8 bit GPIO mode */ > static void hd44780_write_gpio8(struct hd44780 *hd, u8 val, unsigned int rs) > { > - int values[10]; /* for DATA[0-7],

Re: [PATCH] staging: lustre: Change return type to vm_fault_t

2018-04-23 Thread Matthew Wilcox
On Mon, Apr 23, 2018 at 11:38:17PM +0530, Souptick Joarder wrote: > On Mon, Apr 23, 2018 at 11:05 PM, Matthew Wilcox <wi...@infradead.org> wrote: > > I think you need to check your setup ... I get this: > > > > drivers/staging/lustre/lustre/llite/llite_mmap.c:277:31: w

Re: [PATCH] staging: lustre: Change return type to vm_fault_t

2018-04-23 Thread Matthew Wilcox
On Mon, Apr 23, 2018 at 10:12:30PM +0530, Souptick Joarder wrote: > On Sun, Apr 22, 2018 at 8:50 AM, Matthew Wilcox <wi...@infradead.org> wrote: > > On Sun, Apr 22, 2018 at 03:47:24AM +0530, Souptick Joarder wrote: > >> @@ -261,7 +261,7 @@ static inline int t

Re: [PATCH] staging: lustre: Change return type to vm_fault_t

2018-04-21 Thread Matthew Wilcox
On Sun, Apr 22, 2018 at 03:47:24AM +0530, Souptick Joarder wrote: > @@ -261,7 +261,7 @@ static inline int to_fault_error(int result) > * \retval VM_FAULT_ERROR on general error > * \retval NOPAGE_OOM not have memory for allocate new page > */ > -static int ll_fault0(struct vm_area_struct

Re: [PATCH net-next 2/2] ncpfs: move net/ncpfs to drivers/staging/ncpfs

2017-11-14 Thread Matthew Wilcox
On Sun, Nov 12, 2017 at 11:22:27AM -0800, Stephen Hemminger wrote: > The Netware Core Protocol is a file system that talks to > Netware clients over IPX. Since IPX has been dead for many years > move the file system into staging for eventual interment. Should probably cc Petr on this ... (added)