Re: [PATCH v2 6/6] staging: exfat: replace kmalloc with kmalloc_array

2019-10-31 Thread Roi Martin
e instead of using the struct field directly seems to improve readability a bit. Otherwise: p_fs->vol_utbl[col_index][get_row_index(index)] = uni; I assume, in cases like this, from a coding style perspective, the following approach is preferred: row_i

Re: [PATCH 6/6] staging: exfat: replace kmalloc with kmalloc_array

2019-10-31 Thread Roi Martin
> This patch failed to apply. Please fix it up and resend it as a new > version. I have rebased the patch against the branch "staging-testing" of the tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git And sent the new version. Thanks,

[PATCH v2 6/6] staging: exfat: replace kmalloc with kmalloc_array

2019-10-31 Thread Roi Martin
Replace expressions of the form: kmalloc(count * size, GFP_KERNEL); With: kmalloc_array(count, size, GFP_KERNEL); Signed-off-by: Roi Martin --- v2 changes: This patch has been rebased against the branch "staging-testing" of the tree: https://git.kernel.org/pub/scm/li

[PATCH 2/6] staging: exfat: make alignment match open parenthesis

2019-10-29 Thread Roi Martin
Fix checkpatch.pl warning: CHECK: Alignment should match open parenthesis Signed-off-by: Roi Martin --- drivers/staging/exfat/exfat_core.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/staging/exfat/exfat_core.c b/drivers/staging/exfat

[PATCH 6/6] staging: exfat: replace kmalloc with kmalloc_array

2019-10-29 Thread Roi Martin
Replace expressions of the form: kmalloc(count * size, GFP_KERNEL); With: kmalloc_array(count, size, GFP_KERNEL); Signed-off-by: Roi Martin --- drivers/staging/exfat/exfat_core.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/exfat

[PATCH 5/6] staging: exfat: avoid multiple assignments

2019-10-29 Thread Roi Martin
Fix checkpatch.pl warning: CHECK: multiple assignments should be avoided Signed-off-by: Roi Martin --- drivers/staging/exfat/exfat_core.c | 3 +- drivers/staging/exfat/exfat_super.c | 90 +++-- 2 files changed, 73 insertions(+), 20 deletions(-) diff --git

[PATCH 1/6] staging: exfat: remove unnecessary parentheses

2019-10-29 Thread Roi Martin
Fix checkpatch.pl warning: CHECK: Unnecessary parentheses around ... Signed-off-by: Roi Martin --- drivers/staging/exfat/exfat_core.c | 24 drivers/staging/exfat/exfat_super.c | 44 ++--- 2 files changed, 34 insertions(+), 34 deletions(-) diff

[PATCH 3/6] staging: exfat: remove unnecessary new line in if condition

2019-10-29 Thread Roi Martin
Fix checkpatch.pl warning: CHECK: Logical continuations should be on the previous line Signed-off-by: Roi Martin --- drivers/staging/exfat/exfat_core.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/exfat/exfat_core.c b/drivers/staging/exfat

[PATCH 0/6] staging: exfat: fix multiple coding-style issues

2019-10-29 Thread Roi Martin
Fix multiple coding-style issues reported by the checkpatch.pl script in the exfat module. Roi Martin (6): staging: exfat: remove unnecessary parentheses staging: exfat: make alignment match open parenthesis staging: exfat: remove unnecessary new line in if condition staging: exfat

[PATCH 4/6] staging: exfat: replace printk(KERN_INFO ...) with pr_info()

2019-10-29 Thread Roi Martin
Fix checkpatch.pl warning: WARNING: Prefer [subsystem eg: netdev]_info([subsystem]dev, ... then dev_info(dev, ... then pr_info(... to printk(KERN_INFO ... Signed-off-by: Roi Martin --- drivers/staging/exfat/exfat_super.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion