Re: [PATCH 13/14] staging: android: ion: Do not sync CPU cache on map/unmap

2019-01-22 Thread Sumit Semwal
Hello everyone, Sincere apologies for chiming in a bit late here, but was off due to some health issues. Also, adding Daniel Vetter to the mix, since he has been one of the core guys who shaped up dma-buf as it is today. On Tue, 22 Jan 2019 at 02:51, Andrew F. Davis wrote: > > On 1/21/19 5:22 A

Re: [PATCH] staging: android: ion: remove duplicate buffer field initializes

2018-04-23 Thread Sumit Semwal
; > Move the initialization of these two fields together with the > statements that initialize the other two fields from the function > parameters, prior to the heap allocate() call, for consistency. > > Signed-off-by: Todd Poynor Acked-by: Sumit Semwal > --- > drivers/staging/

Re: [PATCH 1/2] staging: android: ion: Cleanup ion_page_pool_alloc_pages

2018-02-07 Thread Sumit Semwal
without any judgement. > With patch history comment addressed (same as the other patch you sent), > Signed-off-by: Yisheng Xie Please feel free to add my Acked-by: Sumit Semwal > --- > drivers/staging/android/ion/ion_page_pool.c | 8 ++-- > 1 file changed, 2 insertions(+), 6

Re: [PATCH 2/2] staging: android: ion: Combine cache and uncache pools

2018-02-07 Thread Sumit Semwal
Perhaps you should also put the version history here, to capture the changes from previous versions? > Signed-off-by: Yisheng Xie With that done, please feel free to add Acked-by: Sumit Semwal > --- > drivers/staging/android/ion/ion.c | 5 -- > drivers/staging/android/io

Re: [PATCH 0/3] staging: android: ion: Minor clean ups and fixes

2017-05-17 Thread Sumit Semwal
droid: ion: Remove unused members from ion_buffer > staging: android: ion: Remove ION_FLAG_CACHED_NEEDS_SYNC > staging: android: ion: Avoid calling free_duped_table() twice > Thanks for these patches! Please feel free to add my Reviewed-by: Sumit Semwal > drivers/s

Re: [PATCHv4 00/12] Ion cleanup in preparation for moving out of staging

2017-04-21 Thread Sumit Semwal
is a new version to address that. I also > addressed some minor comments on the patch to collapse header files. For the series, please feel free to apply my Acked-by: Sumit Semwal > > Thanks, > Laura > > Laura Abbott (12): > cma: Store a name in the cma structure >

Re: [Intel-gfx] [PATCH v2] dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro

2017-04-20 Thread Sumit Semwal
--- a/drivers/staging/android/ion/ion.c >>> +++ b/drivers/staging/android/ion/ion.c >>> @@ -1020,10 +1020,10 @@ static const struct dma_buf_ops dma_buf_ops = { >>> .release = ion_dma_buf_release, >>> .begin_cpu_access = ion_dma_buf_begin_cpu_access, >>> .end_cpu_access = ion_dma_buf_end_cpu_access, >>> - .kmap_atomic = ion_dma_buf_kmap, >>> - .kunmap_atomic = ion_dma_buf_kunmap, >>> - .kmap = ion_dma_buf_kmap, >>> - .kunmap = ion_dma_buf_kunmap, >>> + .map_atomic = ion_dma_buf_kmap, >>> + .unmap_atomic = ion_dma_buf_kunmap, >>> + .map = ion_dma_buf_kmap, >>> + .unmap = ion_dma_buf_kunmap, >>> }; >>> >>> struct dma_buf *ion_share_dma_buf(struct ion_client *client, >>> diff --git a/include/linux/dma-buf.h b/include/linux/dma-buf.h >>> index bfb3704..79f27d6 100644 >>> --- a/include/linux/dma-buf.h >>> +++ b/include/linux/dma-buf.h >>> @@ -39,13 +39,13 @@ struct dma_buf_attachment; >>> >>> /** >>>* struct dma_buf_ops - operations possible on struct dma_buf >>> - * @kmap_atomic: maps a page from the buffer into kernel address >>> - * space, users may not block until the subsequent unmap >>> call. >>> - * This callback must not sleep. >>> - * @kunmap_atomic: [optional] unmaps a atomically mapped page from the >>> buffer. >>> - *This Callback must not sleep. >>> - * @kmap: maps a page from the buffer into kernel address space. >>> - * @kunmap: [optional] unmaps a page from the buffer. >>> + * @map_atomic: maps a page from the buffer into kernel address >>> + * space, users may not block until the subsequent unmap >>> call. >>> + * This callback must not sleep. >>> + * @unmap_atomic: [optional] unmaps a atomically mapped page from the >>> buffer. >>> + * This Callback must not sleep. >>> + * @map: maps a page from the buffer into kernel address space. >>> + * @unmap: [optional] unmaps a page from the buffer. >>>* @vmap: [optional] creates a virtual mapping for the buffer into >>> kernel >>>* address space. Same restrictions as for vmap and friends apply. >>>* @vunmap: [optional] unmaps a vmap from the buffer >>> @@ -206,10 +206,10 @@ struct dma_buf_ops { >>> * to be restarted. >>> */ >>> int (*end_cpu_access)(struct dma_buf *, enum dma_data_direction); >>> - void *(*kmap_atomic)(struct dma_buf *, unsigned long); >>> - void (*kunmap_atomic)(struct dma_buf *, unsigned long, void *); >>> - void *(*kmap)(struct dma_buf *, unsigned long); >>> - void (*kunmap)(struct dma_buf *, unsigned long, void *); >>> + void *(*map_atomic)(struct dma_buf *, unsigned long); >>> + void (*unmap_atomic)(struct dma_buf *, unsigned long, void *); >>> + void *(*map)(struct dma_buf *, unsigned long); >>> + void (*unmap)(struct dma_buf *, unsigned long, void *); >>> >>> /** >>> * @mmap: > > > Best regards > -- > Marek Szyprowski, PhD > Samsung R&D Institute Poland > -- Thanks and regards, Sumit Semwal Linaro Mobile Group - Kernel Team Lead Linaro.org │ Open source software for ARM SoCs ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [Intel-gfx] [PATCH v2] dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro

2017-04-20 Thread Sumit Semwal
istency I've renamed all four of kmap* and kunmap* to be >> map* and unmap*. (Even though only kmap_atomic presently conflicts.) >> >> [1] https://www.spinics.net/lists/target-devel/msg15070.html >> >> Signed-off-by: Logan Gunthorpe >> Reviewed-by: Sinclair Y

[PATCH for-4.4 04/19] x86/hyperv: Handle unknown NMIs on one CPU when unknown_nmi_panic

2017-03-25 Thread Sumit Semwal
Cc: de...@linuxdriverproject.org Cc: Haiyang Zhang Link: http://lkml.kernel.org/r/20161202100720.28121-1-vkuzn...@redhat.com Signed-off-by: Thomas Gleixner Signed-off-by: Ingo Molnar Signed-off-by: Sasha Levin Signed-off-by: Greg Kroah-Hartman Signed-off-by: Sumit Semwal --- arch/x86/ke

Re: [RFC PATCH 08/12] cma: Store a name in the cma structure

2017-03-10 Thread Sumit Semwal
Hi Laura, Thanks for the patch. On 3 March 2017 at 03:14, Laura Abbott wrote: > > Frameworks that may want to enumerate CMA heaps (e.g. Ion) will find it > useful to have an explicit name attached to each region. Store the name > in each CMA structure. > > Signed-off-by: Laura Abbott > --- > d

Re: [PATCH] staging: android ion/hisi: fix dependencies

2016-09-15 Thread Sumit Semwal
ext.hi6220_ion_probe+0x5c): undefined reference to >> `ion_parse_dt' >> hi6220_ion.c:(.text.hi6220_ion_probe+0xf8): undefined reference to >> `ion_destroy_platform_data' >> >> This selects the symbol when needed. >> > > Acked-by: Laura Abbott > Reviewed-by:

Re: [PATCH -next] staging: android: ion: Fix return value check in hi6220_ion_probe()

2016-09-15 Thread Sumit Semwal
should be >> replaced with IS_ERR(). >> > > Acked-by: Laura Abbott > Reviewed-by: Sumit Semwal > >> Signed-off-by: Wei Yongjun >> --- >> drivers/staging/android/ion/hisilicon/hi6220_ion.c | 4 ++-- >> 1 file changed, 2 insertions(+), 2 deleti

Re: [PATCH] staging: android: ion: Make ION_OF depend on OF_ADDRESS

2016-09-14 Thread Sumit Semwal
Hi Laura, On 14 September 2016 at 21:03, Laura Abbott wrote: > The Ion platform code uses of_platform_device_create which has > dependencies on OF_ADDRESS. Depending on OF is not sufficient > Thanks for the patch; looks good to me. Please feel free to apply my Reviewed-by: Sumit Semw

Re: [Linaro-mm-sig] [RESEND][PATCH 0/5] Ion cleanup

2016-08-15 Thread Sumit Semwal
s so this is a resend. >> Probably hit the window when everyone was busy/traveling. >> Looks good to me; please feel free to apply my Reviewed-by: Sumit Semwal >> --- >> >> Hi, >> >> This is some clean up of old Ion interfaces and APIs. These are interfaces >&g

Re: [PATCH 00/18] staging/android: clean up SW_SYNC

2016-06-09 Thread Sumit Semwal
ting to catch up on patches, please give me some time, >> staging patches are at the bottom of my priority list, sorry. > > fwiw on the patch series: > > Reviewed-by: Daniel Vetter Likewise, fwiw for this series, Reviewed-by: Sumit Semwal > -- > Daniel Vetter > So

Re: [PATCH] MAINTAINERS: add entry for the Sync File Framework

2016-05-11 Thread Sumit Semwal
Hi Gustavo, On 11 May 2016 at 19:15, Gustavo Padovan wrote: > From: Gustavo Padovan > > Add Gustavo as maintainer for the Sync File Framework. Sumit is > co-maintainer as he maintains drivers/dma-buf/. It also uses Sumit's > tree as base. > > Cc: Sumit Semwal > S

Re: [PATCH] dma-buf: Update docs for SYNC ioctl

2016-03-21 Thread Sumit Semwal
On 21 March 2016 at 13:00, Daniel Vetter wrote: > Just a bit of wording polish plus mentioning that it can fail and must > be restarted. > > Requested by Sumit. > > Cc: Chris Wilson > Cc: Tiago Vignatti > Cc: Stéphane Marchesin > Cc: David Herrmann > Cc: Sum

Re: [PATCH] dma-buf/sync_file: de-stage sync_file

2016-03-21 Thread Sumit Semwal
Thanks for the patch, Gustavo! On 18 March 2016 at 19:49, Gustavo Padovan wrote: > From: Gustavo Padovan > > sync_file is useful to connect one or more fences to the file. The file is > used by userspace to track fences. > I think it is worthwhile to add relevant bits to the Documentation as wel

Re: [PATCH] dma-buf, drm, ion: Propagate error code from dma_buf_start_cpu_access()

2016-03-20 Thread Sumit Semwal
851e >> Author: Daniel Vetter >> Date: Thu Feb 11 20:04:51 2016 -0200 >> >> dma-buf: Add ioctls to allow userspace to flush >> >> Testcase: igt/gem_concurrent_blit/*dmabuf*interruptible >> Testcase: igt/prime_mmap_coherency/ioctl-errors >> S

Re: [PATCHv2 1/1] staging/ion: Add support to get ion handle from dma buf

2016-01-07 Thread Sumit Semwal
* import that fd and return a handle representing it. If a dma-buf from > + * Given an dma-buf fd that was allocated through ion via > ion_share_dma_buf_fd, > + * import that fd and return a handle representing it. If a dma-buf from > * another exporter is passed in this function will ret

[PATCH] staging: android: ion: fix wrong init of dma_buf_export_info

2015-02-24 Thread Sumit Semwal
113 exp_info.flags = O_RDWR; 1114 exp_info.priv = buffer; ^^ And here also. 1115 This patch corrects this stupidity. Reported-by: Dan Carpenter Signed-off-by: Sumit Semwal --- drivers/staging/android/ion/ion.c | 10 +- 1 file

Re: dma-buf: cleanup dma_buf_export() to make it easily extensible

2015-02-20 Thread Sumit Semwal
Hi Dan, On 21 February 2015 at 00:56, Dan Carpenter wrote: > Hello Sumit Semwal, > > The patch 817bd7253291: "dma-buf: cleanup dma_buf_export() to make it > easily extensible" from Jan 23, 2015, leads to the following static > checker warning: > > drivers