>> fail1:
>> class_destroy(internal->class);
>>
>> +fail0:
>
> GW-BASIC sytle label names are an anti-pattern. It's better to name the
> labels after what they do, just like function names describes what the
> function does. Here it would be "goto clear_desc;" or something. It
> doesn't h
On Fri, Jul 13, 2018 at 10:58:02PM -0700, Todd Poynor wrote:
> @@ -376,7 +377,10 @@ int gasket_register_device(const struct
> gasket_driver_desc *driver_desc)
> fail1:
> class_destroy(internal->class);
>
> +fail0:
GW-BASIC sytle label names are an anti-pattern. It's better to name the
l
From: Todd Poynor
Remove device registration on class creation fail.
Hold mutex around device removal updates for proper ordering of
updates.
Signed-off-by: Zhongze Hu
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/gasket_core.c | 8 +++-
1 file changed, 7 insertions(+), 1 deletio