Hi Christoph,
On Mon, Sep 02, 2019 at 05:54:38AM -0700, Christoph Hellwig wrote:
> On Mon, Sep 02, 2019 at 08:39:37PM +0800, Gao Xiang wrote:
> > >
> > > > + if (erofs_inode_version(advise) == EROFS_INODE_LAYOUT_V2) {
> > >
> > > I still need to wade through the old thread - but didn't you
On Mon, Sep 02, 2019 at 08:39:37PM +0800, Gao Xiang wrote:
> >
> > > + if (erofs_inode_version(advise) == EROFS_INODE_LAYOUT_V2) {
> >
> > I still need to wade through the old thread - but didn't you say this
> > wasn't really a new vs old version but a compat vs full inode? Maybe
> > the names
Hi Christoph,
On Mon, Sep 02, 2019 at 05:26:27AM -0700, Christoph Hellwig wrote:
> >
> > - vi->datamode = __inode_data_mapping(advise);
> > + vi->datamode = erofs_inode_data_mapping(advise);
> >
> > if (vi->datamode >= EROFS_INODE_LAYOUT_MAX) {
>
> While you are at it can we aim for s
>
> - vi->datamode = __inode_data_mapping(advise);
> + vi->datamode = erofs_inode_data_mapping(advise);
>
> if (vi->datamode >= EROFS_INODE_LAYOUT_MAX) {
While you are at it can we aim for some naming consistency here? The
inode member is called is called datamode, the helper is
From: Gao Xiang
As Christoph said [1], "
> + vi->datamode = __inode_data_mapping(advise);
What is the deal with these magic underscores here and various
other similar helpers? "
Let avoid magic underscores now...
[1] https://lore.kernel.org/lkml/20190829102426.ge20...@infradead.org/
Reporte