Re: [FFmpeg-devel] avformat/hlsenc: pull request for single file mode

2014-07-11 Thread Nicolas Martyanoff
I updated my pull request, taking the comments of Anssi Hannula into account, and splitting patches as much as possible. Contact me if there is any trouble. -- Nicolas Martyanoff http://wandrian.net khae...@gmail.com ___ ffmpeg-devel mailing list ffmpe

[FFmpeg-devel] [Updated PATCH 2/4] armv6: Accelerate ff_fft_calc for general case (nbits != 4)

2014-07-11 Thread Ben Avison
The previous implementation targeted DTS Coherent Acoustics, which only requires nbits == 4 (fft16()). This case was (and still is) linked directly rather than being indirected through ff_fft_calc_vfp(), but now the full range from radix-4 up to radix-65536 is available. This benefits other codecs

Re: [FFmpeg-devel] [PATCH] AVFormat: LRC demuxer and muxer

2014-07-11 Thread Star Brilliant
On 2014-07-09 23:09, Derek Buitenhuis wrote: +*start = -(mm*6LL + ss*1000LL + cs*10LL); // just in case negative pts That said, there is still a bug. %d will read negative integers already, you do not need to check for '-'. I forgot to mention it in the previous mail. It is not a

Re: [FFmpeg-devel] [PATCH 1/6] lavf: add directory listing API

2014-07-11 Thread wm4
On Fri, 11 Jul 2014 03:03:53 +0200 Lukasz Marek wrote: > On 10.07.2014 01:36, Lukasz Marek wrote: > > On 08.07.2014 14:49, Lukasz Marek wrote: > >> On 7 July 2014 23:59, wm4 >> All symbols in public headers should have the AV prefix. (I guess > >> this > >> is why you wanted to use void*

[FFmpeg-devel] [PATCH] avformat/movenc: do not use alternate group 0

2014-07-11 Thread Michael Niedermayer
alternate group 0 is special, and not an alternate group Testing very welcome! Signed-off-by: Michael Niedermayer --- libavformat/movenc.c |4 ++-- tests/ref/acodec/alac|2 +- tests/ref/acodec/pcm-s16be |2 +- tests/ref/acodec/pcm-s24be

Re: [FFmpeg-devel] [PATCH 1/6] lavf: add directory listing API

2014-07-11 Thread Lukasz Marek
On 11 July 2014 14:01, wm4 wrote: > On Fri, 11 Jul 2014 03:03:53 +0200 > Lukasz Marek wrote: > > > On 10.07.2014 01:36, Lukasz Marek wrote: > > > On 08.07.2014 14:49, Lukasz Marek wrote: > > >> On 7 July 2014 23:59, wm4 > >> All symbols in public headers should have the AV prefix. (I guess

Re: [FFmpeg-devel] [PATCH v2] drawtext: Add basic text shaping using libfribidi - Fixes ticket #3758

2014-07-11 Thread Andrey Utkin
2014-07-10 13:47 GMT+03:00 Marc Jeffreys : > Changes since last time: > I've made the changes to configure, and squashed the patches together. > Option changed from fribidi=1 (default 0) to text_shaping=1 (default 1). > (Ideas for better names are definitely welcome.) > Hopefully I've made the docu

Re: [FFmpeg-devel] [PATCH 1/6] lavf: add directory listing API

2014-07-11 Thread Nicolas George
Le tridi 23 messidor, an CCXXII, Lukasz Marek a écrit : > Hi, any comments, if not I will sent pull request tomorrow including > libssh and ftp implementations (with minor changes) Sorry, I did not follow the thread carefully enough. Could you resend the updated series as a coherent whole once aga

[FFmpeg-devel] [PATCH] Blackframe video filter now sets frame metadata accordingly.

2014-07-11 Thread Stepan Bujnak
the libavfilter/vf_blackframe.c filter now not only logs detected values, but also sets frame metadata. The metadata have prefix 'lavfi.blackframe.*'. Signed-off-by: Stepan Bujnak --- libavfilter/vf_blackframe.c | 29 + 1 file changed, 25 insertions(+), 4 deletions(-)

Re: [FFmpeg-devel] [PATCH] Blackframe video filter now sets frame metadata accordingly.

2014-07-11 Thread wm4
On Fri, 11 Jul 2014 22:13:54 +0200 Stepan Bujnak wrote: > the libavfilter/vf_blackframe.c filter now not only logs detected > values, but also sets frame metadata. The metadata have prefix > 'lavfi.blackframe.*'. > > Signed-off-by: Stepan Bujnak > --- > libavfilter/vf_blackframe.c | 29 +++

Re: [FFmpeg-devel] [PATCH] Blackframe video filter now sets frame metadata accordingly.

2014-07-11 Thread Stepan Bujnak
On 11.07.2014 22:25, wm4 wrote: On Fri, 11 Jul 2014 22:13:54 +0200 Stepan Bujnak wrote: the libavfilter/vf_blackframe.c filter now not only logs detected values, but also sets frame metadata. The metadata have prefix 'lavfi.blackframe.*'. Signed-off-by: Stepan Bujnak --- libavfilter/vf_bl

Re: [FFmpeg-devel] [PATCH] Blackframe video filter now sets frame metadata accordingly.

2014-07-11 Thread wm4
On Fri, 11 Jul 2014 22:33:59 +0200 Stepan Bujnak wrote: > > On 11.07.2014 22:25, wm4 wrote: > > On Fri, 11 Jul 2014 22:13:54 +0200 > > Stepan Bujnak wrote: > > > >> the libavfilter/vf_blackframe.c filter now not only logs detected > >> values, but also sets frame metadata. The metadata have pre

[FFmpeg-devel] [PATCH v2] Blackframe video filter now sets metadata accordingly.

2014-07-11 Thread Stepan Bujnak
the libavfilter/vf_blackframe.c filter now not only logs detected values, but also sets frame metadata. Currently, only `pblack` value is set but `SET_META` macro has been introduced to ease development in the future. Signed-off-by: Stepan Bujnak --- Updated version that removes redundant values

[FFmpeg-devel] [PATCH] ffplay: increase subtitle que size

2014-07-11 Thread Michael Niedermayer
Fixes part of Ticket2516 with ffplay Signed-off-by: Michael Niedermayer --- ffplay.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/ffplay.c b/ffplay.c index 6572c42..c07e359 100644 --- a/ffplay.c +++ b/ffplay.c @@ -120,7 +120,7 @@ typedef struct PacketQueue { } PacketQu

[FFmpeg-devel] [PATCH] ffplay: remove empty subtitles from que head

2014-07-11 Thread Michael Niedermayer
Signed-off-by: Michael Niedermayer --- ffplay.c |1 + 1 file changed, 1 insertion(+) diff --git a/ffplay.c b/ffplay.c index 7e954fd..6572c42 100644 --- a/ffplay.c +++ b/ffplay.c @@ -1446,6 +1446,7 @@ retry: sp2 = NULL; if (sp->serial !=

[FFmpeg-devel] [PATCH] x86/dsputilenc: remove some empty if statements

2014-07-11 Thread James Almer
Signed-off-by: James Almer --- libavcodec/x86/dsputilenc_mmx.c | 8 1 file changed, 8 deletions(-) diff --git a/libavcodec/x86/dsputilenc_mmx.c b/libavcodec/x86/dsputilenc_mmx.c index 86858e8..7b787dc 100644 --- a/libavcodec/x86/dsputilenc_mmx.c +++ b/libavcodec/x86/dsputilenc_mmx.c @@

Re: [FFmpeg-devel] [PATCH 1/6] lavf: add directory listing API

2014-07-11 Thread Lukasz Marek
On 11.07.2014 20:34, Nicolas George wrote: Le tridi 23 messidor, an CCXXII, Lukasz Marek a écrit : Hi, any comments, if not I will sent pull request tomorrow including libssh and ftp implementations (with minor changes) Sorry, I did not follow the thread carefully enough. Could you resend the

[FFmpeg-devel] [PATCH 4/4] doc/examples: add directory listing example

2014-07-11 Thread Lukasz Marek
--- .gitignore | 1 + configure| 2 + doc/Makefile | 1 + doc/examples/Makefile| 3 +- doc/examples/avio_list_dir.c | 100 +++ 5 files changed, 106 insertions(+), 1 deletion(-) create mod

[FFmpeg-devel] [PATCH 1/4] lavf: add directory listing API

2014-07-11 Thread Lukasz Marek
TODO: bump minor, update doc/APIchanges API allows protocol implementations to provide API that allows to list directory content. API is similar to POSIX opendir/readdir/closedir. Signed-off-by: Lukasz Marek --- libavformat/avio.c | 76 +- libavformat

[FFmpeg-devel] [PATCH 3/4] lavf/ftp: implement directory listing callbacks

2014-07-11 Thread Lukasz Marek
Signed-off-by: Lukasz Marek --- libavformat/ftp.c | 197 -- 1 file changed, 190 insertions(+), 7 deletions(-) diff --git a/libavformat/ftp.c b/libavformat/ftp.c index 66c0665..7f6a916 100644 --- a/libavformat/ftp.c +++ b/libavformat/ftp.c @@ -1

[FFmpeg-devel] [PATCH 2/4] lavf/libssh: implement directory listing callbacks

2014-07-11 Thread Lukasz Marek
Signed-off-by: Lukasz Marek --- libavformat/libssh.c | 116 --- 1 file changed, 111 insertions(+), 5 deletions(-) diff --git a/libavformat/libssh.c b/libavformat/libssh.c index 87a2a7f..85a6cc4 100644 --- a/libavformat/libssh.c +++ b/libavformat/li

[FFmpeg-devel] [PATCH 1/2] [WIP/RFC] Add a release note for 2.3

2014-07-11 Thread Timothy Gu
Based on a patch by Clément Bœsch . Signed-off-by: Timothy Gu --- So, I rebased Clément's original patch and added (a lot) more stuff to make it a real official modern-looking release note. Some stuff I am not sure about: - Should we use Clément's format with all kinds of Unicode characters or

[FFmpeg-devel] [PATCH 2/2] [RFC] Move old Changelog entries to doc/Changelog.old

2014-07-11 Thread Timothy Gu
Signed-off-by: Timothy Gu --- Changelog => doc/Changelog.old | 33 - 1 file changed, 33 deletions(-) rename Changelog => doc/Changelog.old (97%) diff --git a/Changelog b/doc/Changelog.old similarity index 97% rename from Changelog rename to doc/Changelog.old inde