Re: [FFmpeg-devel] [PATCH] lavfi: Port mp=pp7 to libavfilter

2014-12-27 Thread arwa arif
...] +static int query_formats(AVFilterContext *ctx) +{ +static const enum PixelFormat pix_fmts[] = { +AV_PIX_FMT_YUV444P, AV_PIX_FMT_YUV422P, +AV_PIX_FMT_YUV420P, AV_PIX_FMT_YUV411P, +AV_PIX_FMT_YUV410P, AV_PIX_FMT_YUV440P, +

Re: [FFmpeg-devel] [PATCH] lavfi: Port mp=pp7 to libavfilter

2014-12-27 Thread Michael Niedermayer
On Sat, Dec 27, 2014 at 06:07:53PM +0530, arwa arif wrote: [...] +#define OFFSET(x) offsetof(PP7Context, x) +#define FLAGS AV_OPT_FLAG_FILTERING_PARAM|AV_OPT_FLAG_VIDEO_PARAM +static const AVOption pp7_options[] = { +{ qp, force a constant quantizer parameter, OFFSET(qp),

Re: [FFmpeg-devel] [PATCH] lavfi: add tblend filter

2014-12-27 Thread Stefano Sabatini
On date Friday 2014-12-26 11:39:09 +0100, Stefano Sabatini encoded: On date Wednesday 2014-12-10 19:03:10 +0100, Clément Bœsch encoded: [...] From 3310ce2542545e45204337b25651cdf624f1e9b8 Mon Sep 17 00:00:00 2001 From: Stefano Sabatini stefa...@gmail.com Date: Thu, 4 Dec 2014 12:27:53 +0100

Re: [FFmpeg-devel] [PATCH] lavfi: Port mp=pp7 to libavfilter

2014-12-27 Thread Stefano Sabatini
On date Saturday 2014-12-27 18:07:53 +0530, arwa arif encoded: ...] +static int query_formats(AVFilterContext *ctx) +{ +static const enum PixelFormat pix_fmts[] = { +AV_PIX_FMT_YUV444P, AV_PIX_FMT_YUV422P, +AV_PIX_FMT_YUV420P, AV_PIX_FMT_YUV411P,

Re: [FFmpeg-devel] [PATCH] libavformat/mxfdec.c: support demuxing opatom audio without index

2014-12-27 Thread Tomas Härdin
On Sun, 2014-12-21 at 17:46 -0800, Mark Reid wrote: hi, Media Composer generates audio OPAtom mxf files that don't have index segments. All the uncompressed pcm audio essence data contained in a single KLV packet. This is my initial attempt to get demuxing working, I'm not too familiar

Re: [FFmpeg-devel] [PATCH]Do not store more than 30 bit for r10k

2014-12-27 Thread Reimar Döffinger
On Sat, Dec 27, 2014 at 12:41:12AM +0100, Carl-Eugen Hoyos wrote: diff --git a/libavcodec/r210enc.c b/libavcodec/r210enc.c index d61cd75..4cbebd7 100644 --- a/libavcodec/r210enc.c +++ b/libavcodec/r210enc.c @@ -62,7 +62,7 @@ static int encode_frame(AVCodecContext *avctx, AVPacket *pkt,

[FFmpeg-devel] [PATCH 01/15] vp9/x86: save one register in loopfilter surface coverage.

2014-12-27 Thread Ronald S. Bultje
--- libavcodec/x86/vp9lpf.asm | 56 +++ 1 file changed, 28 insertions(+), 28 deletions(-) diff --git a/libavcodec/x86/vp9lpf.asm b/libavcodec/x86/vp9lpf.asm index 416f08f..e0f7386 100644 --- a/libavcodec/x86/vp9lpf.asm +++ b/libavcodec/x86/vp9lpf.asm

[FFmpeg-devel] [PATCH 02/15] vp9/x86: make cglobal statement more conservative in register allocation.

2014-12-27 Thread Ronald S. Bultje
--- libavcodec/x86/vp9lpf.asm | 21 - 1 file changed, 16 insertions(+), 5 deletions(-) diff --git a/libavcodec/x86/vp9lpf.asm b/libavcodec/x86/vp9lpf.asm index e0f7386..c62ac46 100644 --- a/libavcodec/x86/vp9lpf.asm +++ b/libavcodec/x86/vp9lpf.asm @@ -307,7 +307,20 @@ SECTION

[FFmpeg-devel] [PATCH 04/15] vp8/x86: remove unused register from ABSSUB_CMP macro.

2014-12-27 Thread Ronald S. Bultje
--- libavcodec/x86/vp9lpf.asm | 42 +- 1 file changed, 21 insertions(+), 21 deletions(-) diff --git a/libavcodec/x86/vp9lpf.asm b/libavcodec/x86/vp9lpf.asm index 64d3b26..44db472 100644 --- a/libavcodec/x86/vp9lpf.asm +++ b/libavcodec/x86/vp9lpf.asm @@

[FFmpeg-devel] [PATCH 03/15] vp9/x86: slightly simplify 44/48/84/88 h stores.

2014-12-27 Thread Ronald S. Bultje
--- libavcodec/x86/vp9lpf.asm | 88 +-- 1 file changed, 40 insertions(+), 48 deletions(-) diff --git a/libavcodec/x86/vp9lpf.asm b/libavcodec/x86/vp9lpf.asm index c62ac46..64d3b26 100644 --- a/libavcodec/x86/vp9lpf.asm +++ b/libavcodec/x86/vp9lpf.asm

[FFmpeg-devel] [PATCH 05/15] vp9/x86: simplify ABSSUM_CMP by inverting the comparison meaning.

2014-12-27 Thread Ronald S. Bultje
--- libavcodec/x86/vp9lpf.asm | 103 +++--- 1 file changed, 52 insertions(+), 51 deletions(-) diff --git a/libavcodec/x86/vp9lpf.asm b/libavcodec/x86/vp9lpf.asm index 44db472..613a104 100644 --- a/libavcodec/x86/vp9lpf.asm +++ b/libavcodec/x86/vp9lpf.asm

[FFmpeg-devel] [PATCH 06/15] vp9/x86: store unpacked intermediates for filter6/14 on stack.

2014-12-27 Thread Ronald S. Bultje
filter16 goes from 508 to 482 (h) or 346 to 314 (v) cycles; filter88 goes from 240 to 238 (h) or 174 to 165 (v) cycles, measured on TOS. --- libavcodec/x86/vp9lpf.asm | 151 -- 1 file changed, 79 insertions(+), 72 deletions(-) diff --git

[FFmpeg-devel] [PATCH 07/15] vp8/x86: move variable assigned inside macro branch.

2014-12-27 Thread Ronald S. Bultje
The value is not used outside the branch. --- libavcodec/x86/vp9lpf.asm | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavcodec/x86/vp9lpf.asm b/libavcodec/x86/vp9lpf.asm index e117798..15d4159 100644 --- a/libavcodec/x86/vp9lpf.asm +++ b/libavcodec/x86/vp9lpf.asm @@ -469,8

[FFmpeg-devel] [PATCH 09/15] vp9/x86: make filter_44_v work on 32-bit.

2014-12-27 Thread Ronald S. Bultje
--- libavcodec/x86/vp9dsp_init.c | 4 +- libavcodec/x86/vp9lpf.asm| 152 +++ 2 files changed, 98 insertions(+), 58 deletions(-) diff --git a/libavcodec/x86/vp9dsp_init.c b/libavcodec/x86/vp9dsp_init.c index 7acf4f7..d89843e 100644 ---

[FFmpeg-devel] [PATCH 11/15] vp9/x86: make filter_48/84_v work on 32-bit.

2014-12-27 Thread Ronald S. Bultje
--- libavcodec/x86/vp9dsp_init.c | 8 ++-- libavcodec/x86/vp9lpf.asm| 8 +++- 2 files changed, 9 insertions(+), 7 deletions(-) diff --git a/libavcodec/x86/vp9dsp_init.c b/libavcodec/x86/vp9dsp_init.c index 6c58c6c..79cae38 100644 --- a/libavcodec/x86/vp9dsp_init.c +++

[FFmpeg-devel] [PATCH 12/15] vp9/x86: make filter_16_v work on 32-bit.

2014-12-27 Thread Ronald S. Bultje
--- libavcodec/x86/vp9dsp_init.c | 4 +- libavcodec/x86/vp9lpf.asm| 135 ++- 2 files changed, 99 insertions(+), 40 deletions(-) diff --git a/libavcodec/x86/vp9dsp_init.c b/libavcodec/x86/vp9dsp_init.c index 79cae38..40e51a0 100644 ---

Re: [FFmpeg-devel] libavutil: added camellia block cipher

2014-12-27 Thread Giorgio Vazzana
Hi, 2014-12-24 23:41 GMT+01:00 supraja reddy supraja0...@gmail.com: Hello, Thank you for your reviews. I have attached the updated patch . You are using a single array K for all the keys, without distinguishing between kw, k and ke as in the rfc. This makes code harder to read/maintain

Re: [FFmpeg-devel] [PATCH 01/15] vp9/x86: save one register in loopfilter surface coverage.

2014-12-27 Thread Clément Bœsch
On Sat, Dec 27, 2014 at 11:02:36AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9lpf.asm | 56 +++ 1 file changed, 28 insertions(+), 28 deletions(-) diff --git a/libavcodec/x86/vp9lpf.asm b/libavcodec/x86/vp9lpf.asm index

Re: [FFmpeg-devel] [PATCH 01/15] vp9/x86: save one register in loopfilter surface coverage.

2014-12-27 Thread Hendrik Leppkes
On Sat, Dec 27, 2014 at 5:24 PM, Clément Bœsch u...@pkh.me wrote: On Sat, Dec 27, 2014 at 11:02:36AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9lpf.asm | 56 +++ 1 file changed, 28 insertions(+), 28 deletions(-) diff --git

Re: [FFmpeg-devel] [PATCH 1/2] avfilter/vf_cropdetect: Factorize duplicated code using a macro

2014-12-27 Thread Michael Niedermayer
On Sat, Dec 27, 2014 at 04:48:44PM +0100, Benoit Fouet wrote: Hi, Le 27/12/2014 04:35, Michael Niedermayer a écrit : This simplifies subsequent changes Signed-off-by: Michael Niedermayer michae...@gmx.at --- libavfilter/vf_cropdetect.c | 34 ++ 1

Re: [FFmpeg-devel] [PATCH]Do not store more than 30 bit for r10k

2014-12-27 Thread Carl Eugen Hoyos
Reimar Döffinger Reimar.Doeffinger at gmx.de writes: -uint16_t b = *src++ 4; +uint16_t b = *src++ 6; if (avctx-codec_id == AV_CODEC_ID_R210) -pixel = (r 20) | (g 10) | b 2; +pixel = (r 20) | (g 10) | b;

Re: [FFmpeg-devel] [PATCH 07/15] vp8/x86: move variable assigned inside macro branch.

2014-12-27 Thread Timothy Gu
On Saturday, December 27, 2014, Ronald S. Bultje rsbul...@gmail.com wrote: The value is not used outside the branch. --- libavcodec/x86/vp9lpf.asm | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) Is this the right patch? Timothy ___

Re: [FFmpeg-devel] [PATCH 03/15] vp9/x86: slightly simplify 44/48/84/88 h stores.

2014-12-27 Thread Clément Bœsch
On Sat, Dec 27, 2014 at 11:02:38AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9lpf.asm | 88 +-- 1 file changed, 40 insertions(+), 48 deletions(-) diff --git a/libavcodec/x86/vp9lpf.asm b/libavcodec/x86/vp9lpf.asm index

Re: [FFmpeg-devel] libavutil: added camellia block cipher

2014-12-27 Thread Giorgio Vazzana
2014-12-26 20:01 GMT+01:00 Michael Niedermayer michae...@gmx.at: [...] +static uint64_t F(uint64_t F_IN, uint64_t KE) +{ +uint32_t Zl, Zr; +Zl = (F_IN 32) ^ (KE 32); +Zr = (F_IN MASK32) ^ (KE MASK32); KE ^= F_IN; Zl = KE 32; Zr = KE MASK32; +Zl = ((SBOX1[(Zl

Re: [FFmpeg-devel] [PATCH 04/15] vp8/x86: remove unused register from ABSSUB_CMP macro.

2014-12-27 Thread Clément Bœsch
On Sat, Dec 27, 2014 at 11:02:39AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9lpf.asm | 42 +- 1 file changed, 21 insertions(+), 21 deletions(-) diff --git a/libavcodec/x86/vp9lpf.asm b/libavcodec/x86/vp9lpf.asm index 64d3b26..44db472

Re: [FFmpeg-devel] [PATCH 08/15] vp8/x86: save one register in SIGN_ADD/SUB.

2014-12-27 Thread Clément Bœsch
On Sat, Dec 27, 2014 at 11:02:43AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9lpf.asm | 28 ++-- 1 file changed, 14 insertions(+), 14 deletions(-) diff --git a/libavcodec/x86/vp9lpf.asm b/libavcodec/x86/vp9lpf.asm index 15d4159..a1c8ddd 100644 ---

Re: [FFmpeg-devel] [PATCH 2/4] ffplay: remove unused no_background from videostate

2014-12-27 Thread Michael Niedermayer
On Thu, Dec 25, 2014 at 07:57:03PM +0100, Marton Balint wrote: Signed-off-by: Marton Balint c...@passwd.hu --- ffplay.c | 1 - 1 file changed, 1 deletion(-) LGTM [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB No human being will ever know the Truth, for

Re: [FFmpeg-devel] [PATCH 06/15] vp9/x86: store unpacked intermediates for filter6/14 on stack.

2014-12-27 Thread Clément Bœsch
On Sat, Dec 27, 2014 at 11:02:41AM -0500, Ronald S. Bultje wrote: filter16 goes from 508 to 482 (h) or 346 to 314 (v) cycles; filter88 goes from 240 to 238 (h) or 174 to 165 (v) cycles, measured on TOS. --- libavcodec/x86/vp9lpf.asm | 151 -- 1

Re: [FFmpeg-devel] [PATCH 07/15] vp8/x86: move variable assigned inside macro branch.

2014-12-27 Thread Clément Bœsch
On Sat, Dec 27, 2014 at 11:02:42AM -0500, Ronald S. Bultje wrote: The value is not used outside the branch. --- libavcodec/x86/vp9lpf.asm | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavcodec/x86/vp9lpf.asm b/libavcodec/x86/vp9lpf.asm index e117798..15d4159 100644

Re: [FFmpeg-devel] [PATCH 08/15] vp8/x86: save one register in SIGN_ADD/SUB.

2014-12-27 Thread Ronald S. Bultje
Hi, On Sat, Dec 27, 2014 at 1:00 PM, Clément Bœsch u...@pkh.me wrote: +SIGN_ADDm8, m11, m4, m5 ; m8 = p0 + f2%if %2 != 44 fingers fart in the comment? %if %2 != 44 Lol, I did actually lose that line at some point, now I know what happened to it. Removed

Re: [FFmpeg-devel] [PATCH 06/15] vp9/x86: store unpacked intermediates for filter6/14 on stack.

2014-12-27 Thread Ronald S. Bultje
Hi, On Sat, Dec 27, 2014 at 12:54 PM, Clément Bœsch u...@pkh.me wrote: On Sat, Dec 27, 2014 at 11:02:41AM -0500, Ronald S. Bultje wrote: filter16 goes from 508 to 482 (h) or 346 to 314 (v) cycles; filter88 goes from 240 to 238 (h) or 174 to 165 (v) cycles, measured on TOS. ---

Re: [FFmpeg-devel] [PATCH 15/15] vp9/x86: make filter_16_h work on 32-bit.

2014-12-27 Thread Ronald S. Bultje
Hi, On Sat, Dec 27, 2014 at 1:35 PM, Clément Bœsch u...@pkh.me wrote: On Sat, Dec 27, 2014 at 11:02:50AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9dsp_init.c | 4 +- libavcodec/x86/vp9lpf.asm| 191 ++- 2 files changed, 154

Re: [FFmpeg-devel] [PATCH 09/15] vp9/x86: make filter_44_v work on 32-bit.

2014-12-27 Thread Ronald S. Bultje
Hi, On Sat, Dec 27, 2014 at 1:15 PM, Clément Bœsch u...@pkh.me wrote: ; (m0: hev, [m1: flat8out], [m2: flat8in], m3: fm, m7..m8: q0' p0', m10..13: p1 p0 q0 q1, m14: pb_10, m15: q0-p0) ; filter4() Is this still accurate? No, comments all fixed as pointed out. Ronald

Re: [FFmpeg-devel] [PATCH 11/15] vp9/x86: make filter_48/84_v work on 32-bit.

2014-12-27 Thread Clément Bœsch
On Sat, Dec 27, 2014 at 11:02:46AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9dsp_init.c | 8 ++-- libavcodec/x86/vp9lpf.asm| 8 +++- 2 files changed, 9 insertions(+), 7 deletions(-) diff --git a/libavcodec/x86/vp9dsp_init.c b/libavcodec/x86/vp9dsp_init.c index

Re: [FFmpeg-devel] [PATCH 10/15] vp9/x86: make filter_88_v work on 32-bit.

2014-12-27 Thread Ronald S. Bultje
Hi, On Sat, Dec 27, 2014 at 1:23 PM, Clément Bœsch u...@pkh.me wrote: On Sat, Dec 27, 2014 at 11:02:45AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9dsp_init.c | 2 +- libavcodec/x86/vp9lpf.asm| 153 ++- 2 files changed, 107

Re: [FFmpeg-devel] [PATCH 11/15] vp9/x86: make filter_48/84_v work on 32-bit.

2014-12-27 Thread Ronald S. Bultje
Hi, On Sat, Dec 27, 2014 at 1:24 PM, Clément Bœsch u...@pkh.me wrote: On Sat, Dec 27, 2014 at 11:02:46AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9dsp_init.c | 8 ++-- libavcodec/x86/vp9lpf.asm| 8 +++- 2 files changed, 9 insertions(+), 7 deletions(-) diff

Re: [FFmpeg-devel] [PATCH 13/15] vp9/x86: make filter_44_h work on 32-bit.

2014-12-27 Thread Clément Bœsch
On Sat, Dec 27, 2014 at 11:02:48AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9dsp_init.c | 4 +- libavcodec/x86/vp9lpf.asm| 140 --- 2 files changed, 78 insertions(+), 66 deletions(-) diff --git a/libavcodec/x86/vp9dsp_init.c

Re: [FFmpeg-devel] [PATCH 14/15] vp9/x86: make filter_48/84/88_h work on 32-bit.

2014-12-27 Thread Clément Bœsch
On Sat, Dec 27, 2014 at 11:02:49AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9dsp_init.c | 12 +++-- libavcodec/x86/vp9lpf.asm| 62 2 files changed, 48 insertions(+), 26 deletions(-) diff --git a/libavcodec/x86/vp9dsp_init.c

Re: [FFmpeg-devel] [PATCH 13/15] vp9/x86: make filter_44_h work on 32-bit.

2014-12-27 Thread Ronald S. Bultje
Hi, On Sat, Dec 27, 2014 at 1:30 PM, Clément Bœsch u...@pkh.me wrote: On Sat, Dec 27, 2014 at 11:02:48AM -0500, Ronald S. Bultje wrote: --- libavcodec/x86/vp9dsp_init.c | 4 +- libavcodec/x86/vp9lpf.asm| 140 --- 2 files changed, 78

Re: [FFmpeg-devel] [PATCH 2/2] avutil/atomic: reuse ret to avoid dereferencing twice the same value.

2014-12-27 Thread Clément Bœsch
On Tue, May 27, 2014 at 04:18:30AM +0200, Michael Niedermayer wrote: On Mon, May 26, 2014 at 09:18:59PM +0200, Clément Bœsch wrote: --- Shouldn't change anything since ptr access is locked with the mutex, but code looks more obvious that way to me. Maybe I'm wrong... ---

Re: [FFmpeg-devel] [PATCH 1/2] avutil/buffer: always fetch the pool atomically.

2014-12-27 Thread Clément Bœsch
On Mon, May 26, 2014 at 09:18:58PM +0200, Clément Bœsch wrote: --- So, after the recent threads patches, valgrind DRD (helgrind and tsan didn't went through yet) went from 1199 to 1215 passing tests (on a total of 1937) after the thread changes. It's better but it's far from being perfect. I

[FFmpeg-devel] [PATCH]Fix r10kdec output

2014-12-27 Thread Carl Eugen Hoyos
Hi! Attached patch allows to use -f framecrc to check r10k - gbrp10 ffv1 - r10k roundtrips: The decoder currently writes incorrect lsb for blue that are different for the input and output files. This does not affect the 10 significant bits and therefore the ffv1 files are not affected, only

Re: [FFmpeg-devel] [PATCH]Only enable xcb-shm if error fields are?available in the header

2014-12-27 Thread Clément Bœsch
On Thu, Dec 25, 2014 at 11:56:55PM +, Carl Eugen Hoyos wrote: Clément Bœsch u at pkh.me writes: -check_pkg_config xcb-shm xcb/shm.h xcb_shm_attach || { +check_pkg_config xcb-shm = 1.4 xcb/shm.h xcb_shm_attach || { No objections from me: I cannot test atm but I suspect this

Re: [FFmpeg-devel] [PATCH]Only enable xcb-shm if error fields are available in the header

2014-12-27 Thread Carl Eugen Hoyos
Clément Bœsch u at pkh.me writes: No objections from me: I cannot test atm but I suspect this should work. I won't push an untested patch like this. Does compilation with xcb-shm work for you with the patch applied? If yes, please apply. (libxcb is ancient on my current system.) Carl

Re: [FFmpeg-devel] [PATCH]Do not store more than 30 bit for r10k

2014-12-27 Thread Reimar Döffinger
On Sat, Dec 27, 2014 at 05:02:39PM +, Carl Eugen Hoyos wrote: Reimar Döffinger Reimar.Doeffinger at gmx.de writes: -uint16_t b = *src++ 4; +uint16_t b = *src++ 6; if (avctx-codec_id == AV_CODEC_ID_R210) -pixel = (r 20) | (g

Re: [FFmpeg-devel] [PATCH]Do not store more than 30 bit for r10k

2014-12-27 Thread Carl Eugen Hoyos
Reimar Döffinger Reimar.Doeffinger at gmx.de writes: Though as noted in the commit message I am not sure that for better compatibility the extra bits shouldn't be 1 instead... I am not against, but I wonder what you want to be compatible with? Or to say it differently: If something reads

Re: [FFmpeg-devel] Branchpoint tags

2014-12-27 Thread Michael Niedermayer
On Wed, Dec 03, 2014 at 05:45:01AM +0100, Michael Niedermayer wrote: On Sun, Sep 14, 2014 at 07:12:56PM +0200, Michael Niedermayer wrote: Hi Should we add git tags to the revissions where releases are branched off ? that way a git describe on master would look like:

Re: [FFmpeg-devel] [PATCH] ffmpeg: add sdp_file option

2014-12-27 Thread Michael Niedermayer
On Thu, Dec 25, 2014 at 10:56:06PM +0100, Simon Thelen wrote: Allow printing of sdp information to a file specified by -sdp_file This allows users to print sdp information when at least one of the outputs isn't an rtp stream. Signed-off-by: Simon Thelen ffmpeg-...@c-14.de --- ffmpeg.c

[FFmpeg-devel] Parallelization of FFmpeg

2014-12-27 Thread David Ison
It was necessary to change the email subscription, because I had used to subscribe was an alias. The vc1 decoder could need frame parallelization. That being said, what normally happens is that you decide on which part of FFmpeg you would like to work on and start sending patches. In theory,

Re: [FFmpeg-devel] [PATCH]Do not store more than 30 bit for r10k

2014-12-27 Thread Reimar Döffinger
On 28.12.2014, at 00:58, Carl Eugen Hoyos ceho...@ag.or.at wrote: Reimar Döffinger Reimar.Doeffinger at gmx.de writes: Though as noted in the commit message I am not sure that for better compatibility the extra bits shouldn't be 1 instead... I am not against, but I wonder what you want