Re: [FFmpeg-devel] [PATCH] vp9: add profile names

2015-05-03 Thread James Almer
On 03/05/15 3:55 AM, Ronald S. Bultje wrote: > Hi, > > On Sun, May 3, 2015 at 2:15 AM, James Almer wrote: > >> Signed-off-by: James Almer >> --- >> libavcodec/avcodec.h | 3 +++ >> libavcodec/version.h | 4 ++-- >> libavcodec/vp9.c | 22 ++ >> 3 files changed, 19 inse

Re: [FFmpeg-devel] [PATCH] matroskadec: use uint64_t instead of int for index_scale

2015-05-03 Thread Michael Niedermayer
On Sun, May 03, 2015 at 11:07:20PM +0200, Andreas Cadhalpun wrote: > index_scale is set to matroska->time_scale of type uint64_t. > > When index_scale is int, the assignment can overflow and e.g. result > in index_scale = 0. This causes a floating point exception due to the > division by index_sca

[FFmpeg-devel] [PATCH] matroskadec: check s->streams[k] before using it

2015-05-03 Thread Andreas Cadhalpun
This fixes a segmentation fault. Signed-off-by: Andreas Cadhalpun --- libavformat/matroskadec.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavformat/matroskadec.c b/libavformat/matroskadec.c index 27d184e..31723b3 100644 --- a/libavformat/matroskadec.c +++ b/libavforma

Re: [FFmpeg-devel] Test case for Closed caption decoder.

2015-05-03 Thread Michael Niedermayer
On Sun, May 03, 2015 at 08:53:14PM +0200, Clément Bœsch wrote: > On Sun, May 03, 2015 at 06:46:15PM +0530, Anshul wrote: > > > > > > On 05/02/2015 08:24 PM, Clément Bœsch wrote: > > >On Tue, Apr 28, 2015 at 07:50:15PM +0530, Anshul wrote: > > >> > > >>On 04/28/2015 02:14 PM, Clément Bœsch wrote:

[FFmpeg-devel] [PATCH] matroskadec: use uint64_t instead of int for index_scale

2015-05-03 Thread Andreas Cadhalpun
index_scale is set to matroska->time_scale of type uint64_t. When index_scale is int, the assignment can overflow and e.g. result in index_scale = 0. This causes a floating point exception due to the division by index_scale. Signed-off-by: Andreas Cadhalpun --- libavformat/matroskadec.c | 2 +-

Re: [FFmpeg-devel] [PATCH 1/2] ffplay: unify displaymatrix based rotation code

2015-05-03 Thread Michael Niedermayer
On Sun, May 03, 2015 at 09:16:55PM +0200, Marton Balint wrote: > > On Sun, 3 May 2015, Michael Niedermayer wrote: > > >Signed-off-by: Michael Niedermayer > >--- > >ffplay.c | 45 +++-- > >1 file changed, 23 insertions(+), 22 deletions(-) > > > >diff --git

Re: [FFmpeg-devel] [PATCH 2/2] ffplay: support snap to 90degree autorotation

2015-05-03 Thread Marton Balint
On Sun, 3 May 2015, Michael Niedermayer wrote: On Sun, May 03, 2015 at 08:04:52PM +0200, wm4 wrote: On Sun, 3 May 2015 03:10:05 +0200 Michael Niedermayer wrote: do people prefer this to be enabled or disabled by default ? Signed-off-by: Michael Niedermayer --- ffplay.c |5 + 1

Re: [FFmpeg-devel] [PATCH] pngdec: abort if x_offset * bpp >= image_linesize

2015-05-03 Thread Michael Niedermayer
On Sun, May 03, 2015 at 08:41:35PM +0200, Andreas Cadhalpun wrote: > On 03.05.2015 20:09, Michael Niedermayer wrote: > > On Sun, May 03, 2015 at 05:11:17PM +0200, Andreas Cadhalpun wrote: > >> In this case ptr could be set to a position outside the image_buf in > >> png_handle_row, leading to memor

Re: [FFmpeg-devel] [PATCH 1/2] ffplay: unify displaymatrix based rotation code

2015-05-03 Thread Marton Balint
On Sun, 3 May 2015, Michael Niedermayer wrote: Signed-off-by: Michael Niedermayer --- ffplay.c | 45 +++-- 1 file changed, 23 insertions(+), 22 deletions(-) diff --git a/ffplay.c b/ffplay.c index 826a473..eea00e6 100644 --- a/ffplay.c +++ b/ffplay.c @@

Re: [FFmpeg-devel] Test case for Closed caption decoder.

2015-05-03 Thread Clément Bœsch
On Sun, May 03, 2015 at 06:46:15PM +0530, Anshul wrote: > > > On 05/02/2015 08:24 PM, Clément Bœsch wrote: > >On Tue, Apr 28, 2015 at 07:50:15PM +0530, Anshul wrote: > >> > >>On 04/28/2015 02:14 PM, Clément Bœsch wrote: > >>>Then FATE test patch should be applied after the CC patch. > >>> > >>New

[FFmpeg-devel] Re: [PATCH] pngdec: abort if x_offset * bpp >= image_linesize

2015-05-03 Thread Andreas Cadhalpun
On 03.05.2015 20:09, Michael Niedermayer wrote: > On Sun, May 03, 2015 at 05:11:17PM +0200, Andreas Cadhalpun wrote: >> In this case ptr could be set to a position outside the image_buf in >> png_handle_row, leading to memory corruption and thus crashes. >> >> Signed-off-by: Andreas Cadhalpun >> -

Re: [FFmpeg-devel] [PATCH] pngdec: return correct error code from decode_frame_common

2015-05-03 Thread Michael Niedermayer
On Sun, May 03, 2015 at 05:50:26PM +0200, Andreas Cadhalpun wrote: > During the loop ret can get changed. Since it is not set on all failure > paths, decode_frame_common can return 0 even though an error occurred. > > Signed-off-by: Andreas Cadhalpun > --- > libavcodec/pngdec.c | 15 ++--

Re: [FFmpeg-devel] [PATCH 2/2] ffplay: support snap to 90degree autorotation

2015-05-03 Thread Michael Niedermayer
On Sun, May 03, 2015 at 08:04:52PM +0200, wm4 wrote: > On Sun, 3 May 2015 03:10:05 +0200 > Michael Niedermayer wrote: > > > do people prefer this to be enabled or disabled by default ? > > > > Signed-off-by: Michael Niedermayer > > --- > > ffplay.c |5 + > > 1 file changed, 5 insertio

Re: [FFmpeg-devel] [PATCH] pngdec: abort if x_offset * bpp >= image_linesize

2015-05-03 Thread Michael Niedermayer
On Sun, May 03, 2015 at 05:11:17PM +0200, Andreas Cadhalpun wrote: > In this case ptr could be set to a position outside the image_buf in > png_handle_row, leading to memory corruption and thus crashes. > > Signed-off-by: Andreas Cadhalpun > --- > libavcodec/pngdec.c | 6 ++ > 1 file changed

Re: [FFmpeg-devel] [PATCH 2/2] ffplay: support snap to 90degree autorotation

2015-05-03 Thread wm4
On Sun, 3 May 2015 03:10:05 +0200 Michael Niedermayer wrote: > do people prefer this to be enabled or disabled by default ? > > Signed-off-by: Michael Niedermayer > --- > ffplay.c |5 + > 1 file changed, 5 insertions(+) > > diff --git a/ffplay.c b/ffplay.c > index eea00e6..48b09ee 10

Re: [FFmpeg-devel] [PATCH]Fix cropdetect for >8 bit

2015-05-03 Thread Michael Niedermayer
On Sun, May 03, 2015 at 02:05:44PM +0200, Carl Eugen Hoyos wrote: > Hi! > > Attached patch fixes cropdetect here for yuv422p10le (no > other formats tested), I don't know if the change to > diff makes sense or not. > > Please comment, Carl Eugen LGTM i think the div change is not needed but i m

Re: [FFmpeg-devel] [PATCH] FFV1 specification: Reduce redundancy in the description of xxPlane() and xxLine()

2015-05-03 Thread Michael Niedermayer
On Sun, May 03, 2015 at 02:59:59PM +0200, Jerome Martinez wrote: > Le 03/05/2015 13:55, Michael Niedermayer a écrit : > >On Sun, May 03, 2015 at 12:31:05PM +0200, Jerome Martinez wrote: > >>- plane_count which is the count of planes > >thats a bad name for packed formats > > Good point, but this i

[FFmpeg-devel] [PATCH] pngdec: return correct error code from decode_frame_common

2015-05-03 Thread Andreas Cadhalpun
During the loop ret can get changed. Since it is not set on all failure paths, decode_frame_common can return 0 even though an error occurred. Signed-off-by: Andreas Cadhalpun --- libavcodec/pngdec.c | 15 ++- 1 file changed, 10 insertions(+), 5 deletions(-) diff --git a/libavcodec/

Re: [FFmpeg-devel] [PATCH] pngdec: check s->last_picture.f->data[0] before using it

2015-05-03 Thread Michael Niedermayer
On Sun, May 03, 2015 at 04:21:39PM +0200, Andreas Cadhalpun wrote: > This check was removed in commit 08aec6f6, but > s->last_picture.f->data[0] is still used in handle_p_frame_apng > unconditionally. > > This fixes a segmentation fault. > > Signed-off-by: Andreas Cadhalpun applied thanks [..

[FFmpeg-devel] [PATCH] pngdec: abort if x_offset * bpp >= image_linesize

2015-05-03 Thread Andreas Cadhalpun
In this case ptr could be set to a position outside the image_buf in png_handle_row, leading to memory corruption and thus crashes. Signed-off-by: Andreas Cadhalpun --- libavcodec/pngdec.c | 6 ++ 1 file changed, 6 insertions(+) diff --git a/libavcodec/pngdec.c b/libavcodec/pngdec.c index 2

[FFmpeg-devel] [PATCH] libavformat/keyframes: output keyframe indexes

2015-05-03 Thread Jonathan Viney
Hi, First patch here. I wrote this format to be able to get the keyframe indexes faster than seemed possible with ffprobe, and also to get more familiar with ffmpeg. ffmpeg -i input.mkv -c copy -f keyframes -keyframes_filename keyframes.txt /dev/null Could something like this be included in ffmp

[FFmpeg-devel] [PATCH] pngdec: check s->last_picture.f->data[0] before using it

2015-05-03 Thread Andreas Cadhalpun
This check was removed in commit 08aec6f6, but s->last_picture.f->data[0] is still used in handle_p_frame_apng unconditionally. This fixes a segmentation fault. Signed-off-by: Andreas Cadhalpun --- libavcodec/pngdec.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavcode

Re: [FFmpeg-devel] Test case for Closed caption decoder.

2015-05-03 Thread Anshul
On 05/02/2015 08:24 PM, Clément Bœsch wrote: On Tue, Apr 28, 2015 at 07:50:15PM +0530, Anshul wrote: On 04/28/2015 02:14 PM, Clément Bœsch wrote: Then FATE test patch should be applied after the CC patch. New patch attached. I have used other ass api. +fate-sub-cc: CMD = fmtstdout ass -f

Re: [FFmpeg-devel] [PATCH] FFV1 specification: Reduce redundancy in the description of xxPlane() and xxLine()

2015-05-03 Thread Jerome Martinez
Le 03/05/2015 13:55, Michael Niedermayer a écrit : On Sun, May 03, 2015 at 12:31:05PM +0200, Jerome Martinez wrote: - plane_count which is the count of planes thats a bad name for packed formats Good point, but this is not worse than the previous name used ;-). and actually you use "alpha_pla

[FFmpeg-devel] [PATCH]Fix cropdetect for >8 bit

2015-05-03 Thread Carl Eugen Hoyos
Hi! Attached patch fixes cropdetect here for yuv422p10le (no other formats tested), I don't know if the change to diff makes sense or not. Please comment, Carl Eugendiff --git a/libavfilter/vf_cropdetect.c b/libavfilter/vf_cropdetect.c index 485ae69..6d0081e 100644 --- a/libavfilter/vf_cropdetec

Re: [FFmpeg-devel] [PATCH] FFV1 specification: Reduce redundancy in the description of xxPlane() and xxLine()

2015-05-03 Thread Michael Niedermayer
On Sun, May 03, 2015 at 12:31:05PM +0200, Jerome Martinez wrote: > Le 03/05/2015 04:57, Michael Niedermayer a écrit : > >i dont think its a good idea to replace a named variable in a > >for () statement by a construct so long that it needs a linebreak > >in the text output [...] > > I hesitated an

Re: [FFmpeg-devel] [PATCH] FFV1 specification: Reduce redundancy in the description of xxPlane() and xxLine()

2015-05-03 Thread Jerome Martinez
Le 03/05/2015 04:57, Michael Niedermayer a écrit : i dont think its a good idea to replace a named variable in a for () statement by a construct so long that it needs a linebreak in the text output [...] I hesitated and this is a very good point, so I replaced by 2 named variables: - plane_co

Re: [FFmpeg-devel] [PATCH] avfilter/avf_showcqt: optimize gamma

2015-05-03 Thread Michael Niedermayer
On Sat, May 02, 2015 at 10:13:30AM -0700, Muhammad Faiz wrote: > > From c79989a2069966331ec65f9734554e4a2de065b9 Mon Sep 17 00:00:00 2001 > From: Muhammad Faiz > Date: Fri, 1 May 2015 16:44:59 +0700 > Subject: [PATCH] avfilter/avf_showcqt: optimize gamma calculation applied thanks [] --