[FFmpeg-devel] [PATCH v2 2/2] avformat/dashdec: rename variable name for more readable

2021-01-17 Thread liuqi05
Rename is_init_section_common_audio to is_init_section_common_subtitle for is_common_init_section_exist(c->subtitles, c->n_subtitles). Because it is checked to subtitles, not audio. Signed-off-by: liuqi05 --- libavformat/dashdec.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff

[FFmpeg-devel] [PATCH v2 1/2] avformat/dashdec: check init_section before use it.

2021-01-17 Thread liuqi05
because there have no Initialization in SegmentTemplate, so it will have no init_section for init segment file. but in the is_common_init_section_exist function it will be used for check to url, url_offset and size, so check init_section before use init_section. And fix code style in

Re: [FFmpeg-devel] [PATCH V3 3/3] dnn/openvino: support model input resize

2021-01-17 Thread Guo, Yejun
> -Original Message- > From: ffmpeg-devel On Behalf Of Ting Fu > Sent: 2021年1月18日 11:42 > To: ffmpeg-devel@ffmpeg.org > Subject: [FFmpeg-devel] [PATCH V3 3/3] dnn/openvino: support model input > resize > > OpenVINO APIs require specify input size to run the model, while some > OpenVINO

Re: [FFmpeg-devel] [PATCH V2 2/3] dnn/openvino: refine code for better model initialization

2021-01-17 Thread Fu, Ting
> -Original Message- > From: ffmpeg-devel On Behalf Of Guo, > Yejun > Sent: Monday, January 18, 2021 08:50 AM > To: FFmpeg development discussions and patches > Subject: Re: [FFmpeg-devel] [PATCH V2 2/3] dnn/openvino: refine code for > better model initialization > > > > >

[FFmpeg-devel] [PATCH V3 3/3] dnn/openvino: support model input resize

2021-01-17 Thread Ting Fu
OpenVINO APIs require specify input size to run the model, while some OpenVINO model does accept different input size. To enable this feature adding input_resizable option here for easier use. Setting bool variable input_resizable to specify if the input can be resizable or not. input_resizable =

[FFmpeg-devel] [PATCH V3 2/3] dnn/openvino: refine code for better model initialization

2021-01-17 Thread Ting Fu
Move openvino model/inference request creation and initialization steps from ff_dnn_load_model_ov to new function init_model_ov, for later input resize support. Signed-off-by: Ting Fu --- libavfilter/dnn/dnn_backend_openvino.c | 203 ++--- 1 file changed, 118 insertions(+),

[FFmpeg-devel] [PATCH V3 1/3] dnn/openvino: remove unnecessary code

2021-01-17 Thread Ting Fu
Signed-off-by: Ting Fu --- libavfilter/dnn/dnn_backend_openvino.c | 8 1 file changed, 8 deletions(-) diff --git a/libavfilter/dnn/dnn_backend_openvino.c b/libavfilter/dnn/dnn_backend_openvino.c index 5271d1caa5..8476f4fb38 100644 --- a/libavfilter/dnn/dnn_backend_openvino.c +++

Re: [FFmpeg-devel] [PATCH] avformat/rtsp: don't overwrite session control uri

2021-01-17 Thread Andriy Gelman
On Sun, 17. Jan 19:55, Andriy Gelman wrote: > On Mon, 18. Jan 00:49, Carl Eugen Hoyos wrote: > > Am So., 11. Okt. 2020 um 01:54 Uhr schrieb Andriy Gelman > > : > > > > > > From: Andriy Gelman > > > > > > Fixes #1941 > > > > > > Currently the session control uri gets overwritten by the media's uri

Re: [FFmpeg-devel] [PATCH] avformat/rtsp: don't overwrite session control uri

2021-01-17 Thread Andriy Gelman
On Mon, 18. Jan 00:49, Carl Eugen Hoyos wrote: > Am So., 11. Okt. 2020 um 01:54 Uhr schrieb Andriy Gelman > : > > > > From: Andriy Gelman > > > > Fixes #1941 > > > > Currently the session control uri gets overwritten by the media's uri > > when mpegts is signalled in the media description. This

Re: [FFmpeg-devel] [PATCH V2 2/3] dnn/openvino: refine code for better model initialization

2021-01-17 Thread Guo, Yejun
> -Original Message- > From: ffmpeg-devel On Behalf Of Ting Fu > Sent: 2021年1月15日 16:43 > To: ffmpeg-devel@ffmpeg.org > Subject: [FFmpeg-devel] [PATCH V2 2/3] dnn/openvino: refine code for better > model initialization > > Move openvino model/inference request creation and

Re: [FFmpeg-devel] [PATCH] avformat/rtsp: don't overwrite session control uri

2021-01-17 Thread Carl Eugen Hoyos
Am So., 11. Okt. 2020 um 01:54 Uhr schrieb Andriy Gelman : > > From: Andriy Gelman > > Fixes #1941 > > Currently the session control uri gets overwritten by the media's uri > when mpegts is signalled in the media description. This happens because > s->nb_streams doesn't count mpegts which is

Re: [FFmpeg-devel] [PATCH] avformat/rtsp: don't overwrite session control uri

2021-01-17 Thread Andriy Gelman
On Sat, 31. Oct 10:16, Andriy Gelman wrote: > On Wed, 21. Oct 13:39, Andriy Gelman wrote: > > On Sat, 10. Oct 19:22, Andriy Gelman wrote: > > > From: Andriy Gelman > > > > > > Fixes #1941 > > > > > > Currently the session control uri gets overwritten by the media's uri > > > when mpegts is

[FFmpeg-devel] [PATCH 2/5] avformat/smacker: Check for too small pts_inc

2021-01-17 Thread Michael Niedermayer
Fixes: negation of -2147483648 cannot be represented in type 'int'; cast to an unsigned type to negate this value to itself Fixes: 26910/clusterfuzz-testcase-minimized-ffmpeg_dem_SMACKER_fuzzer-6705429132476416 Found-by: continuous fuzzing process

[FFmpeg-devel] [PATCH 1/5] avformat/sccdec: Use larger intermediate for ts/next_ts computation

2021-01-17 Thread Michael Niedermayer
Fixes: signed integer overflow: 92237203 * 33 cannot be represented in type 'int' Fixes: 26910/clusterfuzz-testcase-minimized-ffmpeg_dem_SCC_fuzzer-6603769487949824 Found-by: continuous fuzzing process https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg Signed-off-by: Michael

[FFmpeg-devel] [PATCH 5/5] avformat/wavdec: Check block_align vs. channels before combining them

2021-01-17 Thread Michael Niedermayer
Fixes: signed integer overflow: 65535 * 65312 cannot be represented in type 'int' Fixes: 26910/clusterfuzz-testcase-minimized-ffmpeg_dem_WAV_fuzzer-6606935226974208 Found-by: continuous fuzzing process https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg Signed-off-by: Michael

[FFmpeg-devel] [PATCH 4/5] avformat/tta: Use 64bit intermediate for index

2021-01-17 Thread Michael Niedermayer
Fixes: signed integer overflow: 42032 * 51092 cannot be represented in type 'int' Fixes: 26910/clusterfuzz-testcase-minimized-ffmpeg_dem_TTA_fuzzer-6679539648430080 Found-by: continuous fuzzing process https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg Signed-off-by: Michael

[FFmpeg-devel] [PATCH 3/5] avformat/soxdec: Check channels to be positive

2021-01-17 Thread Michael Niedermayer
Fixes: signed integer overflow: 32 * -1795162112 cannot be represented in type 'int' Fixes: 26910/clusterfuzz-testcase-minimized-ffmpeg_dem_SOX_fuzzer-6724151473340416 Found-by: continuous fuzzing process https://github.com/google/oss-fuzz/tree/master/projects/ffmpeg Signed-off-by: Michael

Re: [FFmpeg-devel] [PATCH] Populate field order returned by avs script, Trac Ticket 8757

2021-01-17 Thread emcodem
On 2021-01-17 09:02, wrote Stephen Hutchinson: Going into detail about GetParity wouldn't be necessary if it's not used (and there aren't any other invoke-parsed functions aside from checking with Import() whether the script actually returns a clip), so the comment could be shortened. Also,

Re: [FFmpeg-devel] [PATCH 16/16] avfilter/vsrc_testsrc: Deduplicate options

2021-01-17 Thread Anton Khirnov
Quoting James Almer (2021-01-04 20:35:30) > On 1/4/2021 4:29 PM, Nicolas George wrote: > > Andreas Rheinhardt (12021-01-04): > >> What enumerating code? It is actually commonplace that options are > >> shared (you can find examples in libavfilter by using 'git grep -e > >> define --and -e

Re: [FFmpeg-devel] [PATCH 7/7] avformat/sbgdec: Reduce the amount of floating point in str_to_time()

2021-01-17 Thread Nicolas George
Michael Niedermayer (12021-01-17): > Fixes: 1e+75 is outside the range of representable values of type 'long' > Fixes: > 26910/clusterfuzz-testcase-minimized-ffmpeg_dem_SBG_fuzzer-6626834808700928 > > Found-by: continuous fuzzing process >

Re: [FFmpeg-devel] [PATCH 2/2 v3] avcodec/librav1e: Pass through timestamps as opaque user data

2021-01-17 Thread Derek Buitenhuis
On 17/01/2021 13:40, James Almer wrote: > LGTM. Pushed. - Derek ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, visit link above, or email ffmpeg-devel-requ...@ffmpeg.org with

Re: [FFmpeg-devel] [PATCH 1/2] avfilter/vsrc_testsrc: add planar support to rgbtestsrc

2021-01-17 Thread James Almer
On 1/16/2021 11:55 AM, Paul B Mahol wrote: Signed-off-by: Paul B Mahol --- libavfilter/vsrc_testsrc.c | 33 ++--- 1 file changed, 30 insertions(+), 3 deletions(-) diff --git a/libavfilter/vsrc_testsrc.c b/libavfilter/vsrc_testsrc.c index 7001f9ba16..c047fe8e86

Re: [FFmpeg-devel] [PATCH 2/2 v3] avcodec/librav1e: Pass through timestamps as opaque user data

2021-01-17 Thread James Almer
On 1/17/2021 9:43 AM, Derek Buitenhuis wrote: avcodec has no facilities to generate timestamps properly from output frame numbers (and it would be wrong for VFR anyway), so pass through the timestamps using rav1e's opaque user data feature, which was added in v0.4.0. This bumps the minimum

[FFmpeg-devel] [PATCH 2/2 v2] avcodec/librav1e: Pass through timestamps as opaque user data

2021-01-17 Thread Derek Buitenhuis
avcodec has no facilities to generate timestamps properly from output frame numbers (and it would be wrong for VFR anyway), so pass through the timestamps using rav1e's opaque user data feature, which was added in v0.4.0. This bumps the minimum librav1e version to 0.4.0. Signed-off-by: Derek

Re: [FFmpeg-devel] [PATCH 2/2 v2] avcodec/librav1e: Pass through timestamps as opaque user data

2021-01-17 Thread Derek Buitenhuis
On 17/01/2021 12:38, Derek Buitenhuis wrote: > --- a/libavcodec/av1dec.c > +++ b/libavcodec/av1dec.c > @@ -929,7 +929,7 @@ static int av1_decode_frame(AVCodecContext *avctx, void > *frame, > > s->operating_point_idc = > s->raw_seq->operating_point_idc[s->operating_point]; > > -

[FFmpeg-devel] [PATCH 2/2 v3] avcodec/librav1e: Pass through timestamps as opaque user data

2021-01-17 Thread Derek Buitenhuis
avcodec has no facilities to generate timestamps properly from output frame numbers (and it would be wrong for VFR anyway), so pass through the timestamps using rav1e's opaque user data feature, which was added in v0.4.0. This bumps the minimum librav1e version to 0.4.0. Signed-off-by: Derek

Re: [FFmpeg-devel] [PATCH 2/2] avcodec/librav1e: Pass through timestamps as opaque user data

2021-01-17 Thread Derek Buitenhuis
On 16/01/2021 16:53, James Almer wrote: > pts was declared inside the if (frame->buf[0]) block, so compilation > fails. You need to move this line inside that block. Guess who forgot to git commit --amend before sending his patch? This guy. Woops - I had already fixed this locally before sending

Re: [FFmpeg-devel] [PATCH] Revert "avutil/timecode: fix sscanf format string with garbage at the end"

2021-01-17 Thread lance . lmwang
On Sun, Jan 17, 2021 at 03:30:15AM +0100, Marton Balint wrote: > > On Sun, 17 Jan 2021, lance.lmw...@gmail.com wrote: > > > On Sat, Jan 16, 2021 at 09:49:42AM +0100, Marton Balint wrote: > > > This reverts commit 6696a07ac62bfec49dd488510a719367918b9f7a. > > > > > > It is wrong to restrict

Re: [FFmpeg-devel] [PATCH] Populate field order returned by avs script, Trac Ticket 8757

2021-01-17 Thread Stephen Hutchinson
On 1/16/21 7:26 PM, emco...@ffastrans.com wrote: The purpose of this is to tell ffmpeg which field order the returned clip of the avisynth .avs script decided to finally deliver, which is handy in an automated environment. Interlacing is generally a very hard topic in avisynth, the huge comment

Re: [FFmpeg-devel] [PATCH] avisynth: more intelligent RGB flipping

2021-01-17 Thread Stephen Hutchinson
On 6/9/20 7:56 PM, Stephen Hutchinson wrote: avs_is_color_space provides a generic way of checking whether the video is RGB, and has been available since 2.6. This means that GetProcAddress doesn't have to run on every frame. --- Also should probably be applied to the 4.3 branch as well.