[FFmpeg-devel] [PATCH v2 2/2] avcodec/v4l2_context: resume the decoding process after source change event received.

2021-07-21 Thread Ming Qian
client need to resume the decoding process after it dequeues the source change event. no matter what's the return value of v4l2_resolution_changed(). if the client doesn't resume the decoding process, the decoder may keep waiting in documentation of v4l2 stateful decoder, we can see the following

[FFmpeg-devel] [PATCH v2 1/2] avcodec/v4l2_context: don't reinit output queue when dynamic resolution change

2021-07-21 Thread Ming Qian
in the v4l2 stateful video document, we can see the following description: During the resolution change sequence, the OUTPUT queue must remain streaming. Calling VIDIOC_STREAMOFF() on the OUTPUT queue would abort the sequence and initiate a seek. In principle, the OUTPUT queue

Re: [FFmpeg-devel] [PATCH V4] lavf/vf_ocr: add subregion support

2021-07-21 Thread Lingjiang Fang
On Wed, 21 Jul 2021 09:38:51 +0800 Steven Liu wrote: > > > > 2021??7??12?? 1:14??Lingjiang Fang > > ?? > > > > follow comments from Steven Liu > > --- > > doc/filters.texi | 8 > > libavfilter/vf_ocr.c | 45 > > +++- 2 files

[FFmpeg-devel] [PATCH] avformat/yuv4mpegdec: Use table instead of repeated "else if"

2021-07-21 Thread Andreas Rheinhardt
The code savings more than offset the size of the table (1936B vs 768B with GCC 10.3 at -O3). Signed-off-by: Andreas Rheinhardt --- libavformat/yuv4mpegdec.c | 183 +- 1 file changed, 80 insertions(+), 103 deletions(-) diff --git a/libavformat/yuv4mpegdec.c

Re: [FFmpeg-devel] [PATCH] libavcodec/mpeg12dec.c: Switch to init_get_bits8 and checks return value

2021-07-21 Thread Andreas Rheinhardt
Thierry Foucu: > --- > libavcodec/mpeg12dec.c | 5 - > 1 file changed, 4 insertions(+), 1 deletion(-) > > diff --git a/libavcodec/mpeg12dec.c b/libavcodec/mpeg12dec.c > index b27ed5bd6d..a786e48054 100644 > --- a/libavcodec/mpeg12dec.c > +++ b/libavcodec/mpeg12dec.c > @@ -1341,8 +1341,11 @@

Re: [FFmpeg-devel] [PATCH v1 2/2] avfilter/vf_subtitles: Added shift option for subtitles/ass filters.

2021-07-21 Thread Manolis Stamatogiannakis
Would it be possible to have a quick review for this patch? It is pretty straightforward. Plus, this is its second submission. It already includes the requested changes from the first time (~1y ago). Thanks in advance, Manolis On Sun, 4 Jul 2021 at 18:13, Manolis Stamatogiannakis wrote: >

Re: [FFmpeg-devel] [PATCH] avformat/mov: parse 3gpp titl from media or track udta

2021-07-21 Thread Jan Ekström
On Wed, Jul 21, 2021 at 8:28 PM Jan Ekström wrote: > > Seems to be: > * Utilized by Handbrake for track titling > * Actually defined as "title for the media" > > Definition from 3GPP TS 26.244 follows: > > Field TypeDetails > Value >

[FFmpeg-devel] [PATCH] Fix for bug #9231: B-frames parameter is ignored in videotoolboxenc

2021-07-21 Thread Anselm Busse
This commit fixes the bug as report in https://trac.ffmpeg.org/ticket/9231 by removing the line that overwrites the user settings for max_b_frames. Signed-off-by: Anselm Busse --- libavcodec/videotoolboxenc.c | 1 - 1 file changed, 1 deletion(-) diff --git a/libavcodec/videotoolboxenc.c

[FFmpeg-devel] [PATCH] avformat/mov: parse 3gpp titl from media or track udta

2021-07-21 Thread Jan Ekström
Seems to be: * Utilized by Handbrake for track titling * Actually defined as "title for the media" Definition from 3GPP TS 26.244 follows: Field TypeDetails Value BoxHeader.Size Unsigned int(32)

[FFmpeg-devel] [PATCH] ffmpeg: fix order between field order autodetection and override

2021-07-21 Thread Jan Ekström
Somehow I missed this in fbb44bc51a647862eb05ae3f9d7d49a0be9bed57 , even though the lines were within the context. Probably the code originally being after the this logic had something to do with it, but previously it only touched the avformat context's codecpar, which did not affect the encoder

[FFmpeg-devel] [PATCH] avformat/mov: parse 3gpp titl from media or track udta

2021-07-21 Thread Jan Ekström
Seems to be utilized by Handbrake for track titling and is actually defined as "title for the media" as per the specification. Definition from 3GPP TS 26.244 follows: Field TypeDetails Value BoxHeader.Size Unsigned int(32)

Re: [FFmpeg-devel] libavcodec/mpeg12dec.c: Check return value of init_get_bits

2021-07-21 Thread Thierry Foucu
On Mon, Jul 19, 2021 at 3:50 PM Andreas Rheinhardt < andreas.rheinha...@outlook.com> wrote: > Thierry Foucu: > > --- > > libavcodec/mpeg12dec.c | 5 - > > 1 file changed, 4 insertions(+), 1 deletion(-) > > > > diff --git a/libavcodec/mpeg12dec.c b/libavcodec/mpeg12dec.c > > index

[FFmpeg-devel] Patch JPEG2000 Parser: Fix parsing of tile-part header

2021-07-21 Thread Shaun Simpson
Please find my patch attached. libavcodec/jpeg2000_parser: Fix parsing of tile-part header, and frames where the end of frame marker is at the end of the buffer. Fixes playback of Sol Levante MXF JPEG2000 file: VIDEO_e4da5fcd-5ffc-4713-bcdd-95ea579d790b.mxf

[FFmpeg-devel] Patch libavcodec/jpeg2000_parser: Fix skipping of JP2 info markers...

2021-07-21 Thread Shaun Simpson
libavcodec/jpeg2000_parser: Fix skipping of JP2 info markers by correctly reading marker size. This fixes playback of some JPEG2000 files that fail with a frame not found error. When reading the JP2 info markers, the parser can be triggered into incorrectly calculating the number of bytes to

Re: [FFmpeg-devel] Gitweb broken

2021-07-21 Thread Michael Niedermayer
On Wed, Jul 21, 2021 at 06:05:49PM +0530, Gyan Doshi wrote: > > > On 2021-07-21 17:09, Michael Niedermayer wrote: > > On Wed, Jul 21, 2021 at 11:01:53AM +0530, Gyan Doshi wrote: > > > > > > On 2021-07-20 14:04, Nicolas George wrote: > > > > Hi. > > > > > > > > Not sure if there is somebody to

[FFmpeg-devel] [PATCH] libavcodec/mpeg12dec.c: Switch to init_get_bits8 and checks return value

2021-07-21 Thread Thierry Foucu
--- libavcodec/mpeg12dec.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/libavcodec/mpeg12dec.c b/libavcodec/mpeg12dec.c index b27ed5bd6d..a786e48054 100644 --- a/libavcodec/mpeg12dec.c +++ b/libavcodec/mpeg12dec.c @@ -1341,8 +1341,11 @@ static int

[FFmpeg-devel] Task for beginner : lossless JPEG transformations

2021-07-21 Thread Nicolas George
Hi. In case somebody is looking for a task to begin working on FFmpeg, I have the following suggestion. The program jpegtran, from libjpeg / libjpeg-turbo, can do lossless or almost-lossless crop and rotate on JPEG, and even overlay with the most recent versions. I think this would be welcome

Re: [FFmpeg-devel] [PATCH v2 2/2] avformat/movenc: add support for TTML muxing

2021-07-21 Thread Andreas Rheinhardt
Jan Ekström: > From: Jan Ekström > > Includes basic support for both the ISMV ('dfxp') and MP4 ('stpp') > methods. This initial version also foregoes fragmentation support > in case the built-in sample squashing is to be utilized, as this > eases the initial review. > > Additionally, add basic

[FFmpeg-devel] [PATCH] avcodec/utils: don't return negative values in av_get_audio_frame_duration()

2021-07-21 Thread James Almer
In some extrme cases, like with adpcm_ms samples with an extremely high channel count, get_audio_frame_duration() may return a negative frame duration value. Don't propagate it, and instead return 0, signaling that a duration could not be determined. Fixes ticket #9312 Signed-off-by: James Almer

Re: [FFmpeg-devel] Gitweb broken

2021-07-21 Thread Nicolas George
Michael Niedermayer (12021-07-20): > hmm, i guess in this case as it required root mailing root at ffmpeg > directly would work I will keep it mind. > fixed Thanks. Regards, -- Nicolas George ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org

Re: [FFmpeg-devel] [PATCH 2/2] lavfi/dnn_backend_ov: Rename RequestItem to OVRequestItem

2021-07-21 Thread Guo, Yejun
> -Original Message- > From: ffmpeg-devel On Behalf Of > Shubhanshu Saxena > Sent: 2021年7月12日 0:15 > To: ffmpeg-devel@ffmpeg.org > Cc: Shubhanshu Saxena > Subject: [FFmpeg-devel] [PATCH 2/2] lavfi/dnn_backend_ov: Rename > RequestItem to OVRequestItem > > Rename RequestItem to

Re: [FFmpeg-devel] Gitweb broken

2021-07-21 Thread Gyan Doshi
On 2021-07-21 17:09, Michael Niedermayer wrote: On Wed, Jul 21, 2021 at 11:01:53AM +0530, Gyan Doshi wrote: On 2021-07-20 14:04, Nicolas George wrote: Hi. Not sure if there is somebody to contact directly: We need to have a list of the various services + resources that ffmpeg.org

Re: [FFmpeg-devel] [PATCH v2 2/2] avformat/movenc: add support for TTML muxing

2021-07-21 Thread Jan Ekström
On Mon, Jul 19, 2021 at 2:40 PM Jan Ekström wrote: > +int ret = AVERROR_BUG; > +int64_t start_ts = track->start_dts == AV_NOPTS_VALUE ? > + 0 : (track->start_dts + track->track_duration);; The trailing second semicolon which I missed is the cause of the new warning

Re: [FFmpeg-devel] [PATCH 2/2] libswscale: Adds ff_hscale8to15_4_avx2 and ff_hscale8to15_X4_avx2 for all filter sizes.

2021-07-21 Thread Alan Kelly
On Fri, Jul 16, 2021 at 3:48 PM Alan Kelly wrote: > These functions replace all ff_hscale8to15_*_ssse3 when avx2 is available. > --- > EXTERNAL_AVX2_FAST is now used instead of EXTERNAL_AVX2_FAST_GATHER as > discussed in the email thread for part 1 of this patch. > > Benchmark results on Skylake

Re: [FFmpeg-devel] [PATCH V4] lavf/vf_ocr: add subregion support

2021-07-21 Thread Steven Liu
> 2021年7月12日 下午1:14,Lingjiang Fang 写道: > > follow comments from Steven Liu > --- > doc/filters.texi | 8 > libavfilter/vf_ocr.c | 45 +++- > 2 files changed, 52 insertions(+), 1 deletion(-) > > diff --git a/doc/filters.texi

Re: [FFmpeg-devel] Gitweb broken

2021-07-21 Thread Michael Niedermayer
On Wed, Jul 21, 2021 at 11:01:53AM +0530, Gyan Doshi wrote: > > > On 2021-07-20 14:04, Nicolas George wrote: > > Hi. > > > > Not sure if there is somebody to contact directly: > > We need to have a list of the various services + resources that ffmpeg.org > operates, and the responsible people

Re: [FFmpeg-devel] Gitweb broken

2021-07-21 Thread Gyan Doshi
On 2021-07-20 14:04, Nicolas George wrote: Hi. Not sure if there is somebody to contact directly: We need to have a list of the various services + resources that ffmpeg.org operates, and the responsible people + basic technical details, and distribute that among the devs. Right now, it

Re: [FFmpeg-devel] [PATCH] avformat/mov: parse 3gpp titl from media or track udta

2021-07-21 Thread Jan Ekström
On Wed, Jul 21, 2021 at 12:10 AM Jan Ekström wrote: > > Seems to be: > * Utilized by Handbrake for track titling > * Actually defined as "title for the media" > > Definition from 3GPP TS 26.244 follows: > > Field TypeDetails > Value >

Re: [FFmpeg-devel] [PATCH 01/17] avcodec/avcodec: Stop including bsf.h in avcodec.h

2021-07-21 Thread Andreas Rheinhardt
Andreas Rheinhardt: > Also include bsf.h directly wherever it is used. > > Signed-off-by: Andreas Rheinhardt > --- > Following the example of e67e02d15672a87da1b0566e197a1e19dc7e1e33 > I have neither added an APIchanges entry nor a version bump for > anything in this set. > Will apply this

Re: [FFmpeg-devel] [PATCH 24/41] avcodec/adpcmenc: Use smaller scope for some variables

2021-07-21 Thread Andreas Rheinhardt
Andreas Rheinhardt: > This is to avoid unused variables warnings if the code for disabled > encoders is #if'ed away which will happen in a subsequent commit. > In case of buf it also avoids shadowing. > > Signed-off-by: Andreas Rheinhardt > --- > libavcodec/adpcmenc.c | 105

Re: [FFmpeg-devel] [PATCH] Revert "libavcodec/mips: Fix specification of instruction name"

2021-07-21 Thread Andreas Rheinhardt
Jiaxun Yang: > This reverts commit ebedd26eefe2ff4bbf5a358907c4e8e4b0d62eae. > > The original commit states that "gcc supports both of them, > clang only supports the second type", it's obviousely not ture. > > Error: opcode not supported on this processor: loongson3a(mips64r2) `pxor >

Re: [FFmpeg-devel] Gitweb broken

2021-07-21 Thread Michael Niedermayer
On Tue, Jul 20, 2021 at 10:34:39AM +0200, Nicolas George wrote: > Hi. > > Not sure if there is somebody to contact directly: hmm, i guess in this case as it required root mailing root at ffmpeg directly would work > > Our source view with Gitweb is currently partially broken. For example, >

[FFmpeg-devel] [PATCH v2 4/5] avutil/mips: Use $at as MMI macro temporary register

2021-07-21 Thread Jiaxun Yang
Some function had exceed 30 inline assembly register oprands limiation when using LOONGSON2 version of MMI macros. We can avoid that by take $at, which is register reserved for assembler, as temporary register. As none of instructions used in these macros is pseudo, it is safe to utilize $at

[FFmpeg-devel] [PATCH v2 1/5] avutil/mips: Use MMI_{L, S}QC1 macro in {SAVE, RECOVER}_REG

2021-07-21 Thread Jiaxun Yang
{SAVE,RECOVER}_REG will be avilable for Loongson2 again, also comment about the magic. Signed-off-by: Jiaxun Yang --- libavutil/mips/mmiutils.h | 32 +--- 1 file changed, 17 insertions(+), 15 deletions(-) diff --git a/libavutil/mips/mmiutils.h

[FFmpeg-devel] [PATCH v2 3/5] avcodec/mips: Use MMI marcos to replace Loongson3 instructions

2021-07-21 Thread Jiaxun Yang
Loongson3's extention instructions (prefixed with gs) are widely used in our MMI codebase. However, these instructions are not avilable on Loongson-2E/F while MMI code should work on these processors. Previously we introduced mmiutils marcos to provide backward compactbility but newly commited

[FFmpeg-devel] [PATCH v2 0/5] avcodec Loongson-2 MMI fixes

2021-07-21 Thread Jiaxun Yang
Get MMI optimizations build for Loongson-2 again. Tested on Loongson-2 and Loongson-3A. --- v2: Rebase and add patch v6 --- Cc: yinshiyou...@loongson.cn Jiaxun Yang (5): avutil/mips: Use MMI_{L,S}QC1 macro in {SAVE,RECOVER}_REG avutil/mips: Extract load store with shift C1 pair marco

[FFmpeg-devel] [PATCH v2 2/5] avutil/mips: Extract load store with shift C1 pair marco

2021-07-21 Thread Jiaxun Yang
We're doing some fancy hacks with load store with shift C1 beside unaligned load store. Create a marco for l/r pair to allow us use it in these places. Signed-off-by: Jiaxun Yang --- libavutil/mips/mmiutils.h | 49 --- 1 file changed, 30 insertions(+), 19

[FFmpeg-devel] [PATCH v2 5/5] avcodec/mips: cabac.h provide fallback for wsbh instruction

2021-07-21 Thread Jiaxun Yang
wsbh is only avilable for MIPS R2+. Provide a fallback for older processors. Signed-off-by: Jiaxun Yang --- libavcodec/mips/cabac.h | 24 1 file changed, 24 insertions(+) diff --git a/libavcodec/mips/cabac.h b/libavcodec/mips/cabac.h index f1e953dabe..39c308c7e0 100644