Re: [flashrom] wiki output

2011-08-14 Thread Stefan Tauner
another thing: id like to output the maximum decode size for programmers (there are so many ppl that got bitten by the "oh... 3com nics do only support 128 kB, sorry"-"bug" - including me). most of the pci devices seem to have a fixed maximum anyway, but it is only set at init to the global variabl

[flashrom] [PATCH 1/3] layout: change return type and name of find_next_included_romentry

2011-08-14 Thread Stefan Tauner
- rename from find_next_included_romentry to get_next_included_romentry - return a pointer to a rom_entry instead of just its index Signed-off-by: Stefan Tauner --- layout.c | 38 +++--- 1 files changed, 19 insertions(+), 19 deletions(-) diff --git a/layout.c

[flashrom] [PATCH 3/3] an obvious but dubios refactor opportunity

2011-08-14 Thread Stefan Tauner
it probably makes sense, even if the code savings are minimal, because of readability. i split it out so that you can decide. as i explained in the previous patch i hope it wont stay long anyway ;) Signed-off-by: Stefan Tauner --- layout.c | 50 +++-

[flashrom] [PATCH 0/3] Make read before write configurable (infrastructure part)

2011-08-14 Thread Stefan Tauner
This is a rebased and enhanced version of carl-daniel's patch: http://www.flashrom.org/pipermail/flashrom/2010-October/005202.html Stefan Tauner (3): layout: change return type and name of find_next_included_romentry Make read before write configurable (infrastructure part) an obvious but du

[flashrom] [PATCH 2/3] Make read before write configurable (infrastructure part)

2011-08-14 Thread Stefan Tauner
- Introduce a variable in doit() that allows to influence read-before-write and its consequences. - Rename handle_romentries to build_new_image and a description of its purpose. - Modify build_new_image so that it still works even if the old content is not read before. Signed-off-by: S

Re: [flashrom] flashrom on PowerPC (002-lh28f008bjt.patch)

2011-08-14 Thread Carl-Daniel Hailfinger
Am 14.08.2011 04:12 schrieb Stefan Tauner: > On Wed, 27 Jul 2011 18:20:19 +0200 > Mattias Mattsson wrote: > > >> Index: 82802ab.c >> === >> --- 82802ab.c(revision 1396) >> +++ 82802ab.c(working copy) >> Stefan

Re: [flashrom] Initial version of autotools support for Flashrom

2011-08-14 Thread Carl-Daniel Hailfinger
Am 14.08.2011 09:58 schrieb Peter Lemenkov: > 2011/8/14 Carl-Daniel Hailfinger : > >> Hi Peter, >> >> thanks for your patch. >> I think your code looks clean. >> It does not work, though: >> > Yes, I forgot to add bootstrap script, which regenerates all necessary > files. You may invoke the

Re: [flashrom] [PATCH] [1/n] SPI FAST READ infrastructure

2011-08-14 Thread Stefan Tauner
> SPI FAST READ infrastructure. > Add feature bits to allow annotation of SPI flash chips with possible > read methods. > This includes the not-yet-supported Dual and Quad I/O read operations > just in case we ever encounter programmer hardware which can use that > feature. > > An alternative desi

Re: [flashrom] Initial version of autotools support for Flashrom

2011-08-14 Thread Peter Lemenkov
2011/8/14 Carl-Daniel Hailfinger : > Hi Peter, > > thanks for your patch. > I think your code looks clean. > It does not work, though: Yes, I forgot to add bootstrap script, which regenerates all necessary files. You may invoke the following sequence of commands or simply run autoreconf -ivf : ac

[flashrom] [PATCH 6/6] Add ich_descriptor_tool to decode all flash descriptors stored in a flash dump file

2011-08-14 Thread Stefan Tauner
additionally to what is available via FDOC/FDOD this allows to access: - the softstraps which are used to configure the chipset by flash content without the need for BIOS routines. on ICH8 it is possible to read those with FDOC/FDOC too, but this was removed in later chipsets. - the ME VS

[flashrom] [PATCH 5/6] ichspi: add support for Intel Hardware Sequencing

2011-08-14 Thread Stefan Tauner
todo: - revise hwseq activation: when should hwseq be used, when swseq? in the current version i have added a programmer parameter to tell flashrom when one wants to use hwseq _if it is available_ (i.e. descriptor valid), example: flashrom -p internal:laptop=force_I_want_a_brick,hwseq=yes -

[flashrom] [PATCH 4/6] ichspi: improve prettyprint_opcodes

2011-08-14 Thread Stefan Tauner
add headers for the columns and some decoding into human readable format. --- before: […] Reading OPCODES... done preop0=0x06, preop1=0x50 op[0]=0x02, 3, 0 op[1]=0x03, 2, 0 op[2]=0x20, 3, 0 op[3]=0x05, 0, 0 op[4]=0x9f, 0, 1 op[5]=0x20, 1, 2 op[6]=0x01, 1, 0 op[7]=0x06, 0, 0 SPI Read Configuration

[flashrom] [PATCH 3/6] ichspi: don't touch the nonexistent(?) BBAR register on ICH8

2011-08-14 Thread Stefan Tauner
There is no sign of BBAR (BIOS Base Address Configuration Register) in the public datasheet (or specification update) of the ICH8. Also, the offset of that register has changed between ICH7 (SPIBAR + 50h) and ICH9 (SPIBAR + A0h), so we have no clue if or where it is on ICH8. Better don't try to tou

[flashrom] [PATCH 2/6] ichspi: disable writes when locked or read-only regions are detected

2011-08-14 Thread Stefan Tauner
Until we are able to unlock regions or at least understand better what consequences writing single regions have, disable writing completely whenever a non-writeable region is detected. NB: the registers might not always reflect the real access status. http://www.flashrom.org/pipermail/flashrom/201

[flashrom] [PATCH 1/6] ichspi: add ICH/PCH flash descriptor decoding via FDOC/FDOD

2011-08-14 Thread Stefan Tauner
based on the work of Matthias 'mazzoo' Wenzel this patch adds pretty printing of those ICH/PCH flash descriptor sections that are cached/mapped by the chipset (and which are therefore reachable via FDOC/FDOD registers). this includes the following: - content section: describes the image and so

[flashrom] [PATCH 0/6] ichspi 8.0

2011-08-14 Thread Stefan Tauner
this is based on my makefile patch "Makefile: fix and simplify test program compilations" not sure if it applies without that. 2/6 and 3/6 are new; 4/6 and 5/6 are ~unchanged iirc 1/6 was modified based on carldani's review 6/6 got also a few improvements Stefan Tauner (6): ichspi: add ICH/PCH